Jump to content
Sign in to follow this  
ralf2007

Cisco1600 Probleme mit der Metrik, Ersatzroute

Recommended Posts

Hallo Zusammen,

 

habe ein Problem mit einem Cisco 1600.

 

Ich möchte den Router als zentralen Router für mein Netzwerk einsetzen. Die Hauptaufgabe soll die Sicherstellung des Internetzugang sein. Aus diesem Grund habe ich zwei Internetzugänge über zwei verschiedene DSL-Router. DSL-Router 1 hat die IP 10.10.10.2/24 der zweite 10.10.10.3/24 Der Cisco hat zwei IP-Adressen auf dem ETH0 Konfiguriert. 193.28.62.99/24 für das LAN in dem sich die USER befinden und eine secondary IP-Adresse 10.10.10.1/24 für die Verbindung zu den DSL-Routern.

Jetzt habe ich zwei Routen eingerichtet. Die erste 0.0.0.0 0.0.0.0 10.10.10.2 100 und 0.0.0.0 0.0.0.0 10.10.10.3 200. Der letzte Wert soll eigentlich die Priorität der Metrik bestimmen. Leider funktioniert das nicht. Jede Route einzeln funktioniert einwandfrei, habe ich beide eingetragen, funktioniert nur die Route mit dem kleineren Wert.

 

Routerkonf:

 

test#s run

Building configuration...

 

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname test

!

enable secret 5 $1$cmh.$trz1g3kscwaVUnUD9jYO

enable password bier1

!

ip subnet-zero

!

!

!

interface Ethernet0

ip address 10.10.10.1 255.255.255.0 secondary

ip address 193.28.62.99 255.255.255.0

no ip directed-broadcast

!

interface BRI0

no ip address

no ip directed-broadcast

shutdown

!

no ip classless

ip route 0.0.0.0 0.0.0.0 10.10.10.2 100

ip route 0.0.0.0 0.0.0.0 10.10.10.3 200

!

dialer-list 1 protocol ip permit

dialer-list 1 protocol ipx permit

!

line con 0

transport input none

line vty 0 4

password bier

login

!

end

 

Kann mir jemand helfen ????

 

Über eine Antwort würde ich mich sehr freuen.

 

Ich habe noch eine kleine Skizze im Anhang beigelegt.

 

Gruß

Ralf2007

post-40527-13567389419614_thumb.jpg

Share this post


Link to post
Share on other sites

Ich wiederhole hier nochmal kurz, da ich auf dieses Problem ja schon geantwortet habe, allerdings in einem anderen Forum.

 

Ich bin der Meinung, dass dieses Szenario nicht mit statischem Routing zu lösen ist. Damit der 1600er feststellen kann, ob eine Route verfügbar ist oder nicht, gibt es zwei Möglichkeiten:

 

1. Die Nachbarrouter sind unmittelbar am 1600er angeschlossen, so dass das Interface physikalisch down geht. Damit verschwindet dann auch die Route aus der Routingtabelle.

2. Die Nachbarrouter (und der 1600er) verwenden ein dynamisches Routingprotokoll wie z.B. OSPF. Dadurch, dass die Router nun gegenseitig HELLO-Pakete austauschen, kann der Ausfall eines der beiden Router auch dann festgestellt werden, wenn sie nicht direkt am 1600er angeschlossen sind.

 

Eine weitere Möglichkeit, die gewünschte Redundanz zu realisieren, wäre die Verwendung eines Hot-Standby-Protokolls wie z.B. VRRP gewesen, welches aber von den beiden DSL-Routern, wie du schon sagtest, leider nicht unterstützt wird.

 

Die Lösung mit Floating Static Routing, wie auch schon vorgeschlagen wurde, wird hier auch nicht funktionieren, weil keine der beiden statischen Routen verschwinden wird (vom oben angeführten ersten Fall abgesehen, dann wäre das möglich), der Router sich also entsprechend IMMER für die Route mit der geringeren administrativen Distanz entscheidet, unabhängig davon, ob der Router tatsächlich erreichbar ist oder nicht.

 

Was mir auch auffällt: Gibt es gute Gründe, für die Client-PCs im LAN offizielle IP-Adressen zu verwenden?

 

Gruß,

Martin

Share this post


Link to post
Share on other sites

Rack1R3(config)#ip route 0.0.0.0 0.0.0.0 162.1.1.1 ?

<1-255> Distance metric for this route

name Specify name of the next hop

permanent permanent route

tag Set tag for this route

track Install route depending on tracked item

<cr>

 

Rack1R3(config)#ip route 0.0.0.0 0.0.0.0 162.1.1.1

 

Du kannst ein Track Objekt definieren. Ich kann dir aber jetzt nicht sagen ob der 1600'er das auch kann. Musste mal nachsehen. Dann geht eine Route down, wenn das Objekt den Status aendert. Tracken kann man auch ip reachability.

 

Rack1R3(config)#track 1 ip route ?

A.B.C.D {/nn || A.B.C.D} Prefix and mask

 

Rack1R3(config)#track 1 ip route

 

Reliable Static Routing Backup Using Object Tracking

 

Das muesste eigentlich gehen.

 

Fu

Share this post


Link to post
Share on other sites

Wooow, das sieht sehr vielversprechend aus! Der Beschreibung nach macht das ja genau das, was er sucht... eingesetzt hab ich das allerdings noch nie - wusste nicht mal, dass es so ein cooles Feature gibt!

 

Hab grad mal im Feature Navigator geschaut, laut Cisco können das erst die 1700er oder die 830er bzw. 870er, die 1600er allerdings nicht. Aber probieren kann man's ja trotzdem mal...

Share this post


Link to post
Share on other sites

Hallo,

 

Vielen Dank für Eure Ideen !!!

 

Ich habe das alles verstanden, ich kenne das von anderen Routern, hier nennt man so etwas eine Nachbars***aftsüberwachung. Es wird eine IP-Adresse überwacht (manchmal auch über ein bestimmtes Gatway). Sollte diese nicht mehr erreichbar sein wird die Ersatzroute aktiv. Es wird aber ständig die erste IP überprüft und ist diese wieder erreichbar werden die Pakete wieder zu diesem Ziel geroutet.

 

Leider habe ich erst vor einer Woche angefangen einen Cisco-Router zu konfigurieren. Deshalb kann ich aus den Informationen nicht ganz erkennen mit welchen Befehlen ich das umsetzen kann.

Ist es möglich das mir jemand eine Beispielkonfiguration zusammen stellt.

Ich würde mich darüber sehr freuen.

 

Gruß

Ralf2007

Share this post


Link to post
Share on other sites

Hi,

 

das wuerde so aussehen:

 

ip sla monitor 1

type echo protocol ipIcmpEcho 145.1.36.6

timeout 1000

threshold 2

frequency 3

ip sla monitor schedule 1 life forever start-time now

 

 

ip route 0.0.0.0 0.0.0.0 145.1.36.7 252 track 1

ip route 0.0.0.0 0.0.0.0 145.1.36.8 253

 

Im Test:

 

Rack1R3#sh track 1

Track 1

Response Time Reporter 1 reachability

Reachability is Up

9 changes, last change 00:00:06

Latest operation return code: OK

Latest RTT (millisecs) 1

Tracked by:

STATIC-IP-ROUTING 0

Rack1R3#sh ip route static

S* 0.0.0.0/0 [252/0] via 145.1.36.7

 

 

Dann nehme ich das Interface 145.1.36.6 raus.

 

Rack1R3#sh track 1

Track 1

Response Time Reporter 1 reachability

Reachability is Down

10 changes, last change 00:00:07

Latest operation return code: Timeout

Tracked by:

STATIC-IP-ROUTING 0

Rack1R3#sh ip route static

S* 0.0.0.0/0 [253/0] via 145.1.36.8

Rack1R3#

 

Vielleicht baust du dir dann noch einen delay in das track object, weil sonst unter Umstaenden staendig deine Routen hin und her wechseln. Und eventuell noch den Ping etwas hoeher.

 

Fu

Share this post


Link to post
Share on other sites

Hallo,

 

danke :) :) :) :)

 

werde die Config am Monatg bei mir testen.

 

Möchte mich nochmal bei Euch bedanken, es freut mich sehr das es so ein Forum gibt.

Melde mich dann wieder.

 

Gruß

Ralf2007

 

......habe viel in dieser Woche über die Konfiguration eines Cisco-Routers gelernt, Danke.

Share this post


Link to post
Share on other sites

Hi,

 

ich hab gerade noch mal nachgeschaut. In der Liste steht es ab 1700 aufwaerts. Und dann wieder auf 2610XM. Das ist ja auch das neuere 2610'er Modell. Ich selber hab das Beispiel auf einem 3640 konfiguriert. Die 800'er mit einem advipservices stehen aber auch in der Liste.

 

 

Fu

Share this post


Link to post
Share on other sites

Hola,

 

just for Info: in dieser Konstellation sollte OER auch hot sein! (geht jedoch auch erst ab 1700).

 

 

sample:

 

key chain key1

key 1

key-string oer

 

oer master

logging

mode route control

max prefix total 100

backoff 90 3000 300

border 10.10.10.1 key-chain key1

interface Ethernet1/0 internal

interface Ethernet2/0 external --> Provider 1

max-xmit-utilization absolute 1000 --> wie viel Traffic hier

interface Ethernet3/0 external --> Provider 2

max-xmit-utilization absolute 300 --> wie viel Traffic da

learn

throughput

delay

monitor-period 1

periodic-interval 0

 

oer border

logging

local Ethernet1/0

master 10.1.100.1 key-chain key1 --> der lokale Router

 

interface Ethernet1/0

desc LAN

ip address 10.1.100.1 255.255.255.0

 

interface Ethernet 2/0

desc Provider A

load-interval 30

 

 

interface Ethernet 3/0

desc Provider B

load-interval 30

 

 

==> so sollte das in der Theorie klappen (;-)

 

Ciao

Share this post


Link to post
Share on other sites

Hallo Zusammen,

 

habe mir einen 2603 besorgt und versucht zu konfigurieren.

Leider habe ich es nich geschaft.

 

Da ich mit der Konfiguration von Cisco-Routern gerade erst angefangen habe, habe ich auch vieles nicht verstanden.

 

Ok, dann habe ich es mit OSPF versucht, soll ja ganz einfach zu konfigurieren sein.

Das normale Routing hat nach der Konfiguration auch funktioniert, leider genau die Funktion die ich realisieren wollte nicht. Das was nicht funktioniert ist die Priorisierung der Ziele. Ich kann ein System abschalten und dann über das andere ins Internet, das funktioniert sehr gut. Schalte ich das Gerät aber wieder ein, geht er weiter über den zweiten Router, ich möchte aber das er wieder über den ersten geht.

 

hier meine Config:

stuhr1:>#

stuhr1:>#

stuhr1:>#s run

Building configuration...

 

Current configuration : 736 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname stuhr1:>

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

ip cef

!

!

!

no ftp-server write-enable

!

!

!

!

interface Ethernet0/0

ip address 193.28.62.99 255.255.255.0 secondary

ip address 10.10.10.1 255.255.255.248

half-duplex

!

interface Serial0/0

no ip address

shutdown

no fair-queue

!

interface BRI0/0

no ip address

shutdown

!

router ospf 100

log-adjacency-changes

redistribute static subnets

network 10.10.10.0 0.0.0.7 area 0.0.0.0

network 193.28.62.0 0.0.0.255 area 0.0.0.0

!

no ip classless

ip http server

!

!

line con 0

line aux 0

line vty 0 4

login

!

!

!

end

 

stuhr1:>

 

 

 

 

 

stuhr1:>#s ip route

Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2

i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2

ia - IS-IS inter area, * - candidate default, U - per-user static route

o - ODR, P - periodic downloaded static route

 

Gateway of last resort is not set

 

C 193.28.62.0/24 is directly connected, Ethernet0/0

1.0.0.0/29 is subnetted, 1 subnets

O 1.1.1.0 [110/20] via 10.10.10.2, 00:06:33, Ethernet0/0

2.0.0.0/29 is subnetted, 1 subnets

O 2.1.1.0 [110/20] via 10.10.10.3, 00:06:33, Ethernet0/0

10.0.0.0/29 is subnetted, 2 subnets

O 10.10.10.8 [110/30] via 10.10.10.2, 00:06:33, Ethernet0/0

[110/30] via 10.10.10.3, 00:06:33, Ethernet0/0

C 10.10.10.0 is directly connected, Ethernet0/0

O 193.28.53.0/24 [110/40] via 10.10.10.2, 00:06:35, Ethernet0/0

[110/40] via 10.10.10.3, 00:06:35, Ethernet0/0

stuhr1:>#

 

unter "s ip route" sehe ich beide routen, nach meinem Verständnis müßte man hier auch eine unterschiedliche Metrik sehen, habe aber beide den gleichen Wert in den Klammern.

 

Wer kann mir helfen ???

 

Gruß

Ralf2007

Share this post


Link to post
Share on other sites

Hallo,

 

es läuft.......

 

die Konfiguration der Cisco-Router ist OK.

Ich habe in den Routern für den Internetzugang Kosten vergeben. Das funktioniert !!!!!

 

Danke für Eure Hilfe.

 

Ralf2007

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...