Jump to content

scnugg

Members
  • Posts

    31
  • Joined

  • Last visited

Everything posted by scnugg

  1. Ich hatte meinen ursprünglichen Text auch schon entsprechend editiert, aber das war wohl für Deine Antwort zu spät. Danke auf jeden Fall für Deine Klarstellung Also die RDP-CAL ist dann in der VDA-CAL enthalten, so verstehe ich es. Und ist das Gerät Enterprise+SA-lizenziert müßte dann die RDP-CAL zusätzlich gekauft werden bei Zuriff auf den virtuellen Desktop.
  2. Ich glaube ich habe es jetzt verstanden. Also Benutzer, die über VPN/RDP auf VMs zugreifen, benötigen eine RDP-CAL unabhängig davon wie die Bereitstellung der VM ist (also ob als VDI oder nicht...). Und der Admin an der Konsole nicht, denn er verwaltet ja die VMs.
  3. Also auch die "einfache Sitzung"? Die hat ja im Gegensatz zur "Erweiterten Sitzung" keine RDP-Funktionalitäten....
  4. Danke für die Info. Gilt das auch wenn ich direkt an der Konsole arbeite und über den Hyper-V Manager auf die Desktop-VMs zugreife?
  5. Für alle Fälle kann das aber nicht gelten, denn davon ausgenommen sollte aber zumindest sein wenn man direkt an der Konsole sitzt. Und dass eine RDP-CAL auch nötig ist wenn am Host keine RDS-Rolle installiert ist, wundert mich jetzt etwas, da ich mehrfach das Gegenteil gelesen habe. Hast Du dafür vielleicht eine Quelle? Vielen Dank! Vielen Dank für Deine Mühe und Deine Infos.
  6. Vielen Dank für die vielen konstruktiven informativen Beiträge Vielleicht kann noch jemand was zu dem zweiten Teil meiner Frage sagen, also zu der Office-Lizenzierung in VMs, wenn auf diese über RDP zugegriffen wird, jedoch keine VDI-Rolle installiert und die VMs dann ohne VDI-Bereitstellung auf dem Hyper-V laufen? Also die Frage ob auch in diesem Fall eine Office-Volumenlizenz oder O365 mit shared activation lizenzrechtlich zwingend nötig ist oder nicht. Denn ich hatte auch von Meinungen gehört, dass 1.) wenn z.B. in der VM ein Office Professional installiert und aktiviert ist, aufgrund der Geräte-Lizenzierung von Office für den zugreifenden client ebenfalls eine Office Professional-Lizenz gekauft werden müßte. 2.) genausogut in diesem Szenario ein O365 ohne shared activation (also z.B. ein O365 business-Plan) eingesetzt werden kann, in welchem dann sowohl die VM als auch der zugreifende client aktiviert werden Von meinem Verstädnis her sind Nr. 1.) und 2.) richtig, da für die Verbindung zur VM zwar RDP als Dienst, aber keine am Host installierte RDS-Rolle beansprucht wird. Ich bin mir aber nicht sicher. Danke!
  7. Und das Windows in den VMs, auf die zugegriffen wird, muss dann unbedingt mit diesem ISO installiert und mit diesem Schlüssel aktiviert worden sein? Oder ist das optional? Danke.
  8. Aber was genau bekomme ich denn nun mit einer VDA-Lizenz? Nehmen wir an ich kaufe die Lizenz für ein Gerät. Bekomme ich zugleich einen Lizenzschlüssel und einen Downloadlink um Windows Enterprise in einer VM zu installieren, zu aktivieren und diese dann über VDI bereitstellen zu können? Denn es heißt ja, das Windows in der VM wäre "lizenzfrei" - andererseits "schreit" doch auch jedes frisch installierte Windows in einer VM nach einer Aktivierung...Du scheinst ja den Durchblick zu haben und das war ja auch eine meine Fragen
  9. Danke für die Infos, muss ich mir aber alles nochmal in Ruhe anschauen. Sorry, ich hätte vielleicht von Anfang an schreiben sollen, dass dies alles aus Sicht eines kleineren Unternehmens mit Win 10 PRO-clients und Office Professional ist. Ich habe das jetzt im Anfang des Threads ergänzt. Aufgrund unseres relativ geringen Kohlevorkommens wollen wir möglichst auf Abos verzichten. Aber im Fall von VDI gehts ja nicht ohne Abo
  10. Die Frage habe ich mir auch schon des öfteren gestellt Dennoch versuche ich mich im "Lizenzdschungel" zurechtzufinden und bestmöglich umzusetzen. Und die VDA-Lizenz finde ich nun wirklich....(naja, reden wir lieber nicht darüber...)
  11. Da fehlt mir wohl Basiswissen denn ich verstehe nicht was Du meinst. Könntest Du bitte kurz erklären wie Du das meinst? Danke.
  12. Du bist doch aber auch hier im VDI-Szenario, oder? Davon gehe ich einmal aus, da Du ja von FQDN/IP-Zugriff sprichst. Ich hatte die Lizenzbedingungen jetzt so verstanden, dass bereits dann wenn VDI als Rolle implementiert ist, RDS-CALs benötigt werden. Ich lasse mich gern eines besseren belehren.
  13. @NorbertFe und @cj_berlin Vielen Dank für Eure Einschätzungen Evgenij, Du hast mit Nr. 2 eine Problematik genannt, die mir bisher nicht klar war, nämlich die zwingende Office-Lizenzierung per User wenn der Zugriff von außerhalb erfolgt. Hast Du dazu zufällig einen Link? Wenn die Zahl der RDS-CALs derjenigen der Office Standard-Lizenzen entspricht, sollte die Problematik damit doch behoben sein, oder?
  14. @Nobbyaushb Das ist nett, danke Ich habe eigentlich auch ganz gute Erfahrungen mit RDS-Server. Virtualisierte Desktops haben dann ja aber auch gewisse Vorteile in Bezug auf Kompatibilität von Desktopsoftware-Installationen und Lizenzierung von Anwendersoftware (z.B. Acrobat Pro), die auf virtuelle Desktops verteilt werden kann. Aber scheint wohl eine ziemlich teure Angelegenheit zu sein
  15. Hallo, zum Thema Desktopvirtualisierung und dessen Lizenzierung habe ich schon etliche Beiträge in diesem und anderen Foren gelesen, aber es bleibt noch Klärungsbedarf Es soll Windows 10 virtualisiert werden und über VPN mit RDP auf die VMs zugegriffen werden können. Eine Mehrfachnutzung wie bei WVD ist nicht nötig, also 1 User pro VM zur Zeit. 1.) VDI-Szenario Soweit ich es richtig verstanden habe, ist es so dass wenn VDI eingesetzt wird, zu den VDA-Lizenzen (und den Server-CALs, die ohnehin benötigt werden) noch RDS-Lizenzen benötigt werden, da VDI wie RDSH eine Remotedesktopserver-Rolle ist was wiederum Microsoft-lizenzrechtlich den Bedarf an RDS-Lizenzen begründet. Wenn zugreifende Geräte bereits Windows Enterprise mit SA-lizenziert sind, benötigten sie keine zusätzliche VDA-Lizenz. Um die VDA-Lizenzen zu sparen, wird wohl auch öfter mal statt Windows Desktop hier Server Datacenter als Host genommen und dann in den VMs installiert. Ich möchte aber in diesem Szenario gern mal bei Windows Desktop bleiben In Bezug auf Office wäre dies dann als Volumen (Office Standard) bzw. Microsoft 365 Apps For Enterprise (als Nachfolger von Office 365 ProPlus), Enterprise E3 oder E5 zu lizenzieren. Aber welche Windows Desktop OS-Version wird dann in den VMs installiert? Einerseits heißt es, das OS in den VMs ist lizenzfrei bzw. über die VDA-Lizenz abgedeckt. Es gibt wohl auch eine Version "Windows 10 Enterprise VDA". Muss dann die "Windows 10 Enterprise VDA" zur Installation in den VMs genommen werden (bekommt man also mit der VDA-Lizenz einen Lizenzkey?) oder kann alternativ auch z.B. ein Windows 8.1 PRO, 10 PRO Systembuilder in den VMs installiert und aktiviert werden? Dann wiederum wäre ja das OS in der VM nicht lizenzfrei... 2.) Hyper-V Host ohne VDI-Rolle als mögliche Alternative Wird die VDI-Rolle nicht installiert, wäre der Erwerb von RDS-CALs eingespart. Die VDA-Lizenzen (bzw. Windows Enterprise+SA) an den auf die virtuellen Desktops zugreifenden Clients würden aber auch in diesem Szenario benötigt. Hier wäre für mich die gleiche Frage nach der zu installierenden Windows Desktop-Version in den VMs wie in dem VDI-Szenario. Außerdem die Frage in Bezug auf Office, ob auch hier wie in dem VDI-Szenario unbedingt die Office Volumenversion (Office Standard) oder alternativ die Office 365-Abos mit RDS-Server Support nötig sind oder ob auch z.B. ein Office Home & Business oder Professional lizenzrechtlich in den VMs eingesetzt werden darf. Denn da hier ja keine RDS-Rolle beim Zugriff auf die VMs beansprucht wird, habe ich es so verstanden, dass z.B. wenn Office Professional in einer VM installiert und aktiviert ist, der zugreifende PC ebenfalls eine Lizenz von Office Professional erwerben muss, aber dass es nicht zwingend nötig ist Office Volumen bzw. Office 365 mit RDS-Support (shared activation) zu erwerben und zu installieren. Daher müßte doch auch der Einsatz der Office 365 business-Abos ohne shared activation lizenzrechtlich zulässig sein. Ergänzung: Dies ist alles aus Sicht eines kleinen Domainnetzwerkes mit Windows 10 PRO-clients und Office 2019 Professional, d.h. mit Windows Enterprise, KMS, MAK habe ich noch keine praktische Erfahrung. Vielen Dank für Input!
  16. Hallo, wir möchten Hardware für einen Server kaufen, auf welchem dann Windows Server 2019 standard installiert wird. Der Server bekommt die Rolle Hyper-V und auf ihm werden dann 2 VMs mit Server Standard in Betrieb genommen werden. Mir ist klar, dass lizenzrechtlich gesehen leider auf dem physischen Server dann keine weiteren Rollen installiert werden dürfen, sondern nur in den beiden VMs. Nun möchte ich gern möglichst beide VMs auf einen zweiten Server, auf welchem Server 2019 Essentials installiert werden soll, per Hyper-V Replica replizieren lassen. Wie sieht das Ganze dann lizenzmäßig aus? Ich habe es jetzt nach Internetrecherchen so verstanden, dass dafür der Replikationsserver ebenfalls für Server 2019 Standard lizenziert werden müßte außer man hat Software Assurance. Ist das wirklich so? Denn solange das Replikat nicht in Betrieb ist, wäre es ja nicht ganz fair, dafür zu bezahlen. Gruss
  17. Hallo, ich habe weitere Tests gemacht. Ergebnis: Mit dem Bonding-Modus "balance-tlb" in der NAS und einem ganz "normalen" unmanaged switch bekomme ich das, was ich ursprünglich wollte. Der Mode LACP ist für mich ein totales "Geschwindigkeitsdurcheinander" mit der Folge, dass die 2 GBit/s Bandbreite oft nicht optimal ausgenutzt wurden. Problem also gelöst. Danke für Eure Anregungen. :)
  18. @monstermania Festplatten sind 2x Seagate 3,5 Zoll NAS HDD ST4000VN000 im RAID1-Verbund. Dein Hinweis mit der Schreibgeschwindigkeit ist interessant, das hatte ich nämlich noch gar nicht geprüft. Und jetzt wirds interessant: Lesend bekam ich gerade von einem einzigen "datenziehenden" client 55 MB/s und schreibend 110 MB/s. Paradoxer geht es nun wirklich nicht mehr. Wie gesagt: Deaktiviere ich am client in der Windows Systemsteuerung den Netzwerkadapter und aktiviere ihn erneut, bekomme ich auch lesend die 110 MB/s. Das soll mal einer verstehen... Wie hast Du den "exklusiven" Zugriff konfiguriert? Ich verstehe nicht, was Du damit meinst. :)
  19. Hallo, Ja, windows updates oder backups kann ich ganz klar ausschließen. Das mit dem "Algo" könnte hinkommen. Nur kann ich das irgendwie herausfinden oder beeinflussen? Mir würde es sehr helfen, wenn jemand auch dengleichen Switch oder diegleiche NAS hat, hier zu schreiben, ob damit Bonding problemlos bei ihm funktioniert. Dann könnte ich das Problem weiter eingrenzen. Gruss :)
  20. Hi magheinz, ja, die NAS kann das, hat 2 Netzwerkports und man kann dort Bonding konfigurieren. Siehe auch meinen zweiten Beitrag: Ziehen client A und client B zugleich Daten von der NAS, haben sie beide 110 MB/s (wie gewünscht) => es wird 2 GBit/s ausgenutzt Ziehen client A und client C zugleich Daten von der NAS, haben sie beide 110 MB/s (wie gewünscht) => es wird 2 GBit/s ausgenutzt Ziehen client B und client C zugleich Daten von der NAS, haben sie beide 55 MB/s (unerwünscht!!) => es wird nur 1 GBit/s ausgenutzt Das Ganze ist bei mir verwirrend, denn in einem Netzwerk aus mehreren PCs kann ich nicht wissen, welcher PC welche Leistung bezieht. Je nachdem, welche PCs gerade eingeschaltet sind, verschiebt sich auch die "Berechtigung" dieser Computer hinsichtlich der zu verteilenden Bandbreite. Immer wieder habe ich auch den Fall, dass wenn nur ein einziger PC Daten von der NAS zieht, dieser nur 55 MB/s statt 110 MB/s bekommt. Lasse ich dann zusätzlich den "Chef-PC" Daten ziehen, bekommt dieser 110 MB/s und der erste PC, der vorher 55 MB/s hatte, bekommt auf einmal auch die 110 MB/s. Auf einmal ist also die volle 2 GBit/s Bandbreite wieder da. Vorher allerdings, als nur 1 Computer gezogen hat, wurde nur 0,5 GBit/s Bandbreite genutzt. Total unlogisch. Irgendwie merkwürdig das Ganze und völlig unberechenbar. Irgendetwas läuft das schief. :)
  21. Hi, Komponenten habe ich doch schon genannt: Netgear Switch GS108T (FW 5.4.2.22) und eine QNAP NAS TS-253A (FW 4.2.1), 3 client-PCs mit Windows 10 PRO 64Bit. Aufbau: Die Komponenten sind mit 1 GBit/s-Ethernetkabel verbunden. In der NAS ist an zwei Ports LAG mit LACP (802.3ad) konfiguriert. LAG-Config Im Switch: Link trap=disable, admin mode=enable, STP mode=disable, LACP=enable. Messverfahren: Ganz einfach Dateien von der Freigabe der NAS auf den client kopieren, der Windows Explorer zeigt die Geschwindigkeit an. Die NAS zeigt auf der Weboberfläche während des Transfers diegleiche Geschwindigkeit an. Ich habe es gerade schon wieder festgestellt: Wenn ich nur von client B allein die Daten von der NAS runterlade, bekomme ich zunächst konstant 110 MB/s. Breche ich den Vorgang ab und warte ich einige Minuten und wiederhole den Datentransfer mit nur diesem einen client, bekomme ich plötzlich nur noch 55 MB/s. Das ist mit Sicherheit nicht im Sinne des Erfinders. :)
  22. Aber wie kommt es, dass, wenn nur client B als einziger PC Daten von der NAS überträgt, die Geschwindigkeit zwar meistens 110 MB/s ist, manchmal aber auch nur 55 MB/s? Das ist ja dann sogar noch schlechter als wenn das Bonding gar nicht konfiguriert wäre. Spätestens das scheint eine Fehlfunktion zu sein.
  23. Hast Du dazu vielleicht nähere Infos? Wie kann ich am einfachsten steuern, welcher PC einen Member exklusiv erhält? Ich habe nur herausgefunden, dass ich das über die IP-Adresse einstellen kann. Aber so richtig verstanden und zufriedenstellend ist das irgendwie nicht. Ich habe dazu auch im Internet nichts weiter gefunden. Irgendwelche Tipps oder Tools? Danke. :)
  24. Hallo, danke für Deine Antwort. Mir ist schon klar, dass ein Paar nicht mehr als 1 GBit/s nutzen kann. Mehr erwarte ich auch gar nicht. Das Problem ist ein anderes. Nochmal zur Verdeutlichung: Ziehen client A und client B zugleich Daten von der NAS, haben sie beide 110 MB/s (wie gewünscht) => es wird 2 GBit/s ausgenutzt Ziehen client A und client C zugleich Daten von der NAS, haben sie beide 110 MB/s (wie gewünscht) => es wird 2 GBit/s ausgenutzt Ziehen client B und client C zugleich Daten von der NAS, haben sie beide 55 MB/s (unerwünscht!!) => es wird nur 1 GBit/s ausgenutzt Es sollten doch dem Switch und der NAS völlig egal sein, welche zwei clients zugleich Daten ziehen, so dass immer, wenn zwei beliebige clients die Daten von der NAS übertragen, die maximale Bandbreite von 2 GBit/s zur Verfügung gestellt werden sollte. Das ist bei mir aber eben nicht so, denn wenn client B und client C die Daten bekommen, wird nur 1 GBit/s statt 2 GBit/s ausgenutzt. Oder anders ausgedrückt: Für client A ist eine Bandbreite von 1 Gbit/s (110 MB/s) reserviert und alle anderen clients müssen sich das zweite 1 GBit/s (110 MB/s) teilen. Das ändert sich auch nicht, wenn noch ein vierter client D dazukommt. "Round-Robin" ist es bei mir insoweit nicht, denn die Verteilung erfolgt offensichtlich aufgrund von IP-Adressen. Oder habe ich Dich vielleicht nicht richtig verstanden? Dann sage ich "sorry" :cool: . Wenn die LAG-Funktionalität bei mir so, wie ich beschrieben habe, richtig ist, wäre für mich alles in Ordnung. Ich bin nur etwas verwundert, weil mal jemand gepostet hat, dass die gesamte LAG-Bandbreite immer GLEICHMÄSSIG auf alle clients verteilt wird... Wäre nur nett, wenn das jemand bestätigen könnte, der LAG im Einsatz hat, denn ich bin auf diesem Gebiet Newbie. :)
  25. Hallo, ich habe einen Netgear Switch GS108T (FW 5.4.2.22) und eine QNAP NAS TS-253A (FW 4.2.1). Netzwerkadapter und Kabel im Standard 1 GBit/s. Im Switch an zwei Ports und in der NAS ist LAG nach LACP (802.3ad) konfiguriert. Alle Clientrechner haben Windows 10 PRO 64Bit. Jetzt finde ich eine Sache etwas merkwürdig, die ich festgestellt habe: Nehmen wir an, ich habe drei Computer als clients wie folgt: client A IP=192.168.0.11 client B IP=192.168.0.12 client C IP=192.168.0.13. Wenn ich jetzt Daten von der NAS auf die drei clients zugleich übertrage, ist client B sozusagen der "Chef" und hat eine "garantierte" Übertraungsgeschwindigkeit von 1 GBit/s. das übrige 1 GBit/s aus dem LAG wird auf die clients A und C gleichmäßig verteilt, also ca. 110 MB/s bei clientB und ca. 55 MB/s jeweils bei clients A und C. Wenn allerdings z.B. nur die beiden clients A und C zugleich Daten von der NAS runterladen, haben beide nur 55 MB/s anstatt 110 M/s und das übrige 1 GBit/s, das dem client B "reserviert" ist, liegt ungenutzt brach. Auch wenn ich einen vierten client D in das Netzwerk integriere, bleiben bei clientB die 110 MB/s und die anderen drei Clients teilen sich entsprechend anteilig das übrige 1 GBit/s. Dieses ganze "Konstrukt" hat zwar den Vorteil, dass dem client B die Geschwindigkeit von 1 GBit/s "garantiert" ist, also privilegiert ist, egal, wieviele anderen clients zugleich Daten ziehen. Allerdings hat es ja auch den Nachteil, dass, wenn client B einmal nicht besetzt ist, die anderen clients auf 1 GBit/s des LAG verzichten müssen. Ich habe festgestellt, dass man über die Vergabe der IP-Adresse steuern kann, welcher client mit 1 GBit/s privilegiert ist und welche anderen clients die Bandbreite von 1 GBit/s teilen müssen, wenn client B einmal nicht besetzt ist. Dann ist mir noch aufgefallen, dass client B manchmal auch nur 55 MB/s hat, selbst wenn er als einziger PC Daten von der NAS zieht. Das weist dann für mich eher doch darauf hin, dass hier irgendetwas grottenfalsch läuft und die von mir vermutete "Privilegierung" eher ein Fehler statt Absicht ist. Wenn ich dann den Netzwerkadapter von client B deaktiviere und anschließend neuaktiviere, hat er wieder 110 MB/s. Kennt jemand diese Problematik und weiß, wie man es einstellen kann, dass, egal, welche clients Daten von der NAS ziehen, immer insgesamt 2 GBit/s zur Verfügung stehen und diese 2 GBit/s dann gleichmäßig auf alle clients verteilt werden? So hätte nämlich das LAG von der Funktionsfähigkeit auch eigentlich erwartet. Jedenfalls habe ich schon andere Netzwerkadapter, Windows Betriebssysteme, Netzwerkkabel und Einstellungen ausprobiert und komme an diesem Punkt einfach nicht weiter, bin daher für jeden Hinweis dankbar. Gruß :)
×
×
  • Create New...