Jump to content

zachy

Members
  • Content Count

    20
  • Joined

  • Last visited

Community Reputation

10 Neutral

About zachy

  • Rank
    Newbie
  1. Ok, das heißt, es gibt keine andere Möglichkeit, als alle IP-Adressen in der Firewall einzutragen?
  2. Hallo ins Forum, ich möchte mit Azure SQL eine Datenbank aufsetzen, auf die Personen von außen zugreifen sollen. Es handelt sich um eine Demo-Datenbank. Die Personen, die auf die Datenbank zugreifen sollen, sind immer andere. Das Problem ist, dass ich für jeden Zugriff die IP-Adresse in der Firewall eintragen muss. Kann man das evtl. vereinfachen? Da keine schützenswerten Daten in der Datenbank liegen, wäre es hilfreich, wenn ich den Firewall-Schutz quasi ausschalten können. Danke und Grüße zachy
  3. Komisch, wenn ich das Management Studio komplett schließe und mich dann noch mal anmelde, dann klappt es. Irgendwie scheint er also die Anmeldedaten der vorherigen Sitzung beim "normalen" Abmelden (über die Schaltfläche Trennen) zwischen zu speichern und wiederzuverwenden, auch wenn man sich mit anderem Namen anmeldet. Das ist doch sehr kurios. Ist evtl. noch irgendwo ein Haken gesetzt, den ich rausnehmen muss?
  4. Hallo NilsK, ich werd bekloppt. Du hast Recht! suser_name() sagt mir, dass ich mit der Windows-Anmeldung angemeldet sein, user_name() gibt mir dbo zurück. Ich versteh bloß nicht warum! Ich habe doch im Anmeldedialog auf SQL-Server-Authentifizierung umgeschaltet und Benutzername und Passwort eingegeben. Was habe ich denn da falsch gemacht??!! :confused:
  5. Hallo zahni, danke für deine Antwort. Ich habe mal folgendes probiert: DENY INSERT, UPDATE, DELETE, SELECT ON tbl_Artikel TO public; Dann habe ich mich wieder mit Test123 angemeldet, konnte aber trotzdem noch alles tun. Selbst wenn ich mit Windows-Authentifizierung folgenden Code ausführe DENY INSERT, UPDATE, DELETE, SELECT ON tbl_Artikel TO Test123; kann der User immer noch auf die Tabelle zugreifen. Wo kommen die Berechtigungen denn bloß her?
  6. Hallo Community, ich habe mich mit der Windows-Authentifizerung am SQL Server 2014 angemeldet und mit folgendem Code einen Login und einen User für meine Datenbank erstellt: CREATE LOGIN Test123 WITH PASSWORD = 'Passw0rd'; GO CREATE USER Test123; Wenn ich mich nun mit diesem User am Server anmelde, kann ich im Objekt-Explorer in meiner Datenbank keine Tabellen mehr sehen – so hatte ich es auch erwartet. Allerdings kann ich ein SELECT ausführen, um mir die Tabellen samt Inhalt anzeigen zu lassen. Selbst INSERT, UPDATE und DELETE sind möglich!! Wo liegt mein Fehler? Eigentlich dür
  7. Hallo, leider komme ich noch immer nicht weiter. Die Anleitungen habe ich befolgt, aber es geht nach wie vor nicht. Weiß jemand ob und wie ich den SQL-Code aus meinem ersten Beitrag über die GUI erledigen kann? Vielen Dank und Gruß zachy
  8. Hallo Expert Member, danke für deine schnelle Antwort. Ich sehe nicht, wo das Komma fehlen soll. Hast du zufällig eine Anleitung für mich, wie man die FILESTREAM-Dateigruppe über die GUI einfügt?
  9. Hallo Community, ich nutze die SQL Server 2014 Express-Edition und möchte einer vorhandenen Datenbank eine FILESTREAM-Dateigruppe hinzufügen. FILESTREAM auf Serverebene ist bereits aktiviert. Hier mein Code: alter database [DBName] add filegroup fgDOCS contains filestream ( name = fgDOCS, filename = 'C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLSERVER\MSSQL\DATA\fgDOCS' ) log on ( name = DOCSlog, filename = 'C:\Program Files\Microsoft SQL Server\MSSQL12.MSSQLSERVER\MSSQL\DATA\DOCSlog.ldf' ) with filestream ( non_transacted_access = full, directory_name = 'DOCS_Verzeichnis
  10. Hallo Forumsmitglieder, ich versuche über Access 2013 eine Gespeicherte Prozedur auf einem SQL Server 2014 auszuführen. Ich kenne mich zwar gut mit VBA aus und verstehe auch ein wenig von Transact SQL, aber das Zusammenspiel von Access und SQL Server ist für mich noch Neuland. Hier erst mal die SP: Create procedure [dbo].[Firmen_Und_Ort_Abfragen] as select [FrmID], [FrmNr], [FrmName], [OrtBezeichnung] from [dbo].[tblFirmen] left join [dbo].[tblOrte] on [OrtID] = [FrmOrt] order by [FrmName] Sie führt fragt einfach nur die Daten aus zwei Tabellen ab. Klappt auch hervorragend.
  11. Ich verwende zum verknüpfen der Tabellen immer das Tool ODBC-Datenbanken von Access. Ich bin davon ausgegangen, dass Access dann den PK kennt. Allerdings werde ich jetzt auch versuchen, alles über SPs zu lösen. Das scheint mir der vernünftigste Weg zu sein. Dazu habe ich dann aber auch schon wieder ein Problem, welches ich aber in einem anderen Thread beschreiben werde. Vielen Dank erst mal für Eure Hilfe! Beste Grüße zachy
  12. Hi, danke für eure Antworten. Ja natürlich, die Tabellen müssen natürlich in Access 2013 verknüpft werden. Da hätte ich auch drauf kommen können. :P Ich habe die Tabellen jetzt verknüpft und verwende nun diese als Datenquelle für mein Formular. Trotzdem dauert das Laden dieser Daten unfassbar lange. Ist das bei euch auch so?
  13. Hallo Forumsmitglieder, ich nutzte seit längerer Zeit Access 2013 als Datenbank und Frontend. Aus bestimmten Gründen habe ich mich dazu entschlossen, die Datenbanklogik auf SQL Server 2014 zu verschieben und Access nur noch als Frontend zu benutzen. Gesagt getan. Zunächst einmal habe mit Hilfe des Migration Wizzard alle meine Access-Tabellen auf den SQL-Server kopiert (ich habe die Link-Funktion des Wizzards nicht verwendet). In Access hatte ich mehrere Formulare erstellt, u.a. eines welches als Datenquelle eine Abfrage auf vier Access-Tabellen benutzt. Das Formular läuft schnell
  14. In der lokalen Sicherheitsrichtlinie unter secpol.msc >> Lokale Richtlinien >> Zuweisen von Benutzerrechten >> Lokal anmelden zulassenauf dem DC ist folgendes eingetragen: •Administratoren •Druck-Operatoren •Konten-Operatoren •Server-Operatoren •Sicherungs-Operatoren Logisch dass sich auf dem DC keine Benutzer anmelden sollen, die haben hier ja nichts zu suchen... Auf dem Windows 7-Client ist folgendes eingetragen: •Administratoren •Sicherungs-Operatoren •Authentifizierte Benutzer •außerdem 3 SIDs mit *S-1-5-32-... Der Windows 7-Client befindet sich nat
  15. Ich habe nun versucht, mich mit dem Benutzer am Windows Server anzumelden. Auch das funktioniert nicht, mit der gleichen Fehlermeldung. Der Benutzer ist Mitglied in folgenden Gruppen: -Benutzer -Domänenbenutzer -Remotedesktopbenutzer Ich habe danach einen anderen Benutzer angelegt, ihm die gleichen Gruppen zugewiesen, doch ebenfalls ohne Erfolg. Ich kann mich weder am Windows Server noch am Windows 7-Rechner anmelden. Nur wenn ich den Benutzer in die Gruppe der Administratoren verschiebe, kann er sich anmelden. Mir ist nun klar, dass der Fehler an mir liegt, ich muss irgend eine Ein
×
×
  • Create New...