Jump to content

Tron

Members
  • Posts

    171
  • Joined

  • Last visited

Everything posted by Tron

  1. Hi, ich möchte auf einer HTA Seite nach einer WMI-Abfrage (wenn Sie erfolgreich ist z.B. ein "OK") als Textausgabe zentriert auf der HTA-Seite angezeigt bekommen. Damit der Benutzer sieht das etwas passiert. ;-) Gruß Tron
  2. Hallo blub, dank dir. Hab das ganze jetzt in einem VBS-Skript erledigt. Gruß Tron
  3. Hi, ich möchte aus dem Zertifikatsstore eines Windows XP Clients ein Zertifikat auslesen, dies geht ohne Problem per certutil jetzt möchte ich das ganze per VBS-Skript / WMI-Abfrage lösen. Mit certutil bekomme ich ja keinen Rückgabewert... dies benötige ich aber um danach weitere Schritte einzuleiten. Hat vielleicht einer von euch sich mit diesem Thema schon beschäftigt und kann mir ein paar Tipps geben. Viele Grüße Tron
  4. Hi, bei unseren Lagerarbeitern gibts mal wieder Problem. Diese haben einen Tablet PC und sind ganz normal per Netzwerkkabel mit dem Netzwerk verbunden. Jetzt laufen/rennen diese Lagerarbeiter sehr oft hin und her und reißen sich die Netzwerkkabel raus. Danach ist natürlich die Netzwerkverbindung weg (und die Daten gehen verloren, wenn Sie auf Save klicken und keine Verbindung haben) von daher soll jetzt eine Wlanverbindung per klick auf einen Button aktiviert werden. Dies würde ich sehr gerne per VBS-Skript / WMI-Abfrage lösen. Hat vielleicht einer von euch sich mit diesem Thema schon beschäftigt und kann mir ein paar Tipps geben. Viele Grüße Tron
  5. Hi, @ killtux mit Pathman.exe: Path Manager aus dem Windows Server 2003 Resource Kit Tools kannst du leider nicht die Umgebungsvariablen auslesen, aber später löschen und oder setzen. @ Sunny61 mit setx kann man zwar Variablen setzen, aber der ganze Umgebungsvariablen Path würde überschrieben und von daher gibt's von MS auch Pathman... damit funktionierts immer ;-) Viele Grüße Tron
  6. @ phoenixcp Richtig, wird nur benötigt für eine Testumgebung. Durch die HTA-Seite muss nur noch auf dem Button geklickt werden um ein Programm zu installieren. Die Silent-Installation und die Einstellungen der Programme werden automatisch vorgenommen. Dadurch wird der Aufwand für mehrere Installationen gedrückt. Viele Grüße Tron
  7. Hallo zusammen, das kleine Problem hab ich gelöst mit (, 1, true). Function checkwmioffice2003() Set sh = createobject("wscript.shell") sh.run "Installations.vbs", 1, true Trotzdem Danke für Eure Antworten. :D Viele Grüße Tron
  8. Hallo zusammen, leider hab ich immer noch das gleiche Problem... der Button wird leider nur ab und zu deaktiviert (ausgegraut). :confused: Ich glaube das liegt an dem Zeitintervall... wenn die WMI-Abfrage erfolgt, ist das Programm noch nicht eingetragen um es abzufragen. Vielleicht kann mir noch einer Helfen? Gruß Tron
  9. Hi Nils, danke für deine Antwort. Hab gerade noch was geändert. Schau mal Nils... Jetzt funktioniert es... bin mir aber nicht sicher, ob das Skripte jetzt wirklich noch WMI prüft oder vorher den Button deaktiviert (ausgraut). Jetzt wäre natürlich noch ein Button super Klasse, der insgesamt prüft welche Software installiert ist und vorher die Button deaktiviert (ausgraut), hast du damit vielleicht schon Erfahrungen gesammelt. <html> <head> <title>Installation</title> <HTA:APPLICATION APPLICATIONNAME="Installation" ID="Installation" VERSION="1.0"/> </head> <script language="VBScript"> Sub Window_OnLoad Dim width,height width=500 height=500 self.ResizeTo width,height 'This method will be called when the application loads 'Add your code here End Sub Function checkwmioffice2003() Set sh = createobject("wscript.shell") sh.run "Installations.vbs" Const wbemFlagReturnImmediately = &h10 Const wbemFlagForwardOnly = &h20 Set sh = createobject("wscript.shell") Set objWMIService = GetObject("winmgmts:\\.\root\CIMV2") Set colItems = objWMIService.ExecQuery("SELECT * FROM Win32_Product where Name = 'Office2003'", "WQL") If colItems.count > 0 Then If InstallOffice2003.disabled="true" Then InstallOffice2003.disabled="false" Else InstallOffice2003.disabled="true" End If End If Set sh = Nothing End Function </script> <body bgcolor="white"> <!--Add your controls here--> <input type="button" name="InstallOffice2003" id="InstallOffice2003" value="Install Office2003" style="position: absolute; top: 150px; width: 180px; height: 40px; left: 30px" onclick="OnClickButtonInstallOffice2003"> <!--{{InsertControlsHere}}-Do not remove this line--> </body> </html> Gruß Tron
  10. Hallo zusammen, ich bau gerade ein Installationsskript über eine HTA Seite. Auf dieser HTA Seite hab ich mehrere Button für die Installation. Nach der Installation der jeweiligen Software soll der Button sofort deaktiviert (ausgegraut) werden. Die Installation einer Software funktioniert einwandfrei nur leider wird der Button nach der Installation nicht deaktiviert (ausgegraut). Um den Button zu deaktivieren nach der Installation, benutze ich eine WMI-Abfrage. Diese WMI-Abfrage funktioniert einwandfrei. Klick ich jetzt nochmals auf den Button des Installationsskripts, wird dieser auch deaktiviert (ausgegraut). Wieso deaktiviert sich der Button nicht beim ersten Klick? Hier mein Code-Beispiel: <html> <head> <title>Installation</title> <HTA:APPLICATION APPLICATIONNAME="Installation" ID="Installation" VERSION="1.0"/> </head> <script language="VBScript"> Sub Window_OnLoad Dim width,height width=500 height=500 self.ResizeTo width,height 'This method will be called when the application loads 'Add your code here End Sub Function checkwmioffice2003() On Error Goto 0 Const wbemFlagReturnImmediately = &h10 Const wbemFlagForwardOnly = &h20 Set sh = createobject("wscript.shell") Set objWMIService = GetObject("winmgmts:\\.\root\CIMV2") Set colItems = objWMIService.ExecQuery("SELECT * FROM Win32_Product where Name = 'Office2003'", "WQL") If colItems.count > 0 Then If InstallOffice2003.disabled="true" Then InstallOffice2003.disabled="false" Else InstallOffice2003.disabled="true" End If End If On Error Resume Next Set sh = Nothing End Function Function OnClickButtonInstallOffice2003() return=checkwmioffice2003 set sh = createobject("wscript.shell") sh.run "C:\Installationsskript" set sh = nothing End Function </script> <body bgcolor="white"> <!--Add your controls here--> <input type="button" name="InstallOffice2003" id="InstallOffice2003" value="Install Office2003" style="position: absolute; top: 150px; width: 180px; height: 40px; left: 30px" onclick="OnClickButtonInstallOffice2003"> <!--{{InsertControlsHere}}-Do not remove this line--> </body> </html>
  11. Teil Nr.:2/2 setspn -A HTTP/srvsp01.demo.de demo\sspadmin setspn -A HTTP/srvsp01 demo\sspadmin setspn -A HTTP/srvsp01.demo.de demo\sspadminapppool setspn -A HTTP/srvsp01 demo\sspadminapppool setspn -A HTTP/srvsp01.demo.de demo\portalapppool setspn -A HTTP/srvsp01 demo\portalapppool setspn -A HTTP/srvsp01.demo.de demo\mysiteapppool setspn -A HTTP/srvsp01 demo\mysiteapppool setspn -A HTTP/srvsp01.demo.de demo\sspsearch setspn -A HTTP/srvsp01 demo\sspsearch setspn -A HTTP/srvsp01.demo.de demo\wsssearch setspn -A HTTP/srvsp01 demo\wsssearch setspn -A HTTP/srvsp01.demo.de demo\wsscrawl setspn -A HTTP/srvsp01 demo\wsscrawl Diese Domain Service Accounts findet ihr auch in Blog-Link: Part 1 - Base Configuration for SharePoint ganz oben. Zusätzlich habe dann noch in Delegierungseinstellungen für die Domain Service Accounts vorgenommen (Active Directory-Benutzer und -Computer > Eigenschaften eines Domain Service Accounts > Konto unter den Kontooptionen > Konto wird für Delegierungszwecke vertraut). Nachdem der SPN erfolgreich gesetzt wurde, kann das Authentifizierungsprotokoll nun auf der Web Applikation geändert werden. Diese Einstellung kann in der Zentraladministration > Anwendungsverwaltung > Authentifizierungsanbieter geändert werden. Im Punkt IIS-Authentifizierungseinstellungen: Von "NTLM" auf "Integrierte Windows-Authentifizierung" > Aushandeln (Kerberos). Die mit der integrierten Windows-Authentifizierung empfohlene Sicherheitskonfiguration ist Kerberos. Kerberos erfordert, dass das Anwendungspoolkonto 'Netzwerkdienst' ist oder speziell vom Domänenadministrator konfiguriert wurde. Die NTLM-Authentifizierung funktioniert hingegen mit einem beliebigen Anwendungspoolkonto und der Standarddomänenkonfiguration. Nach diesen Änderungen hab ich ein "iisreset" durchgeführt um alles neu zu initialisieren. Jetzt muss noch Kerberos auf dem SSP ermöglicht werden. Hier die Befehl dazu. C:\Programme\Gemeinsame Dateien\Microsoft Shared\web server extensions\12\BIN STSADM.exe -o SetSharedWebServiceAuthn -negotiate Als letzer Schritt müssen jetzt eigentlich noch im Komponentendienste > der Server auf Default Impersonation Level = Delegate gesetzt werden und IIS WAMREG Admin Service > Launch and Activate Permissions > alle Domain Service Accounts hinterlegt werden mit den Berechtigungen 'Local Activation'. Jetzt stellt sich der Eine oder Andere sicherlich die Frage, wie ich denn sicher testen kann, ob der Benutzer sich tatsächlich über Kerberos an der Web Applikation authentifizieren kann. Eine sehr gute Möglichkeit liefert das IIS Ressouce Kit Tool WFETCH, dass kostenlosten heruntergeladen werden kann. IIS Ressouce Kit Tool: WFetch 1.4 Ist der AUTHORIZATION-String länger als 1000 Zeichen, kann man sicher gehen, dass die Authentifizierung über Kerberos durchgeführt wurde. Der NTLM Authorization-String ist in der Regel kürzer als 300 Zeichen. Leider wurde mir bis jetzt immer noch NTLM und nicht Kerberos als primäres Authentifizierungsprotokoll angezeigt. :confused: Also was hab ich falsch gemacht??? Ich bin für jede Antwort dankbar. ;) Viele Grüße, Tron
  12. Hallo zusammen, nach langer Zeit, hab ich mal wieder etwas Zeit einen Beitrag in das MCSEboard zu schreiben. Teil Nr.:1/2 Thema: Probleme Kerberos in einer MOSS 2007 Farm einrichten mit SQL Server 2005 Also, ich habe vor einer Woche eine MOSS 2007 Farm mit SP1 mit einem SQL Server 2005 mit SP2 installiert. Die Installation des ganzen war nicht das Problem, nur leider ist es mir bis heute nicht möglich die MOSS 2007 Farm von dem Authentifizierungsprotokoll NTLM auf Kerberos als primäres Authentifizierungsprotokoll umzustellen. Ich hab jetzt schon alle wichtigen Blogs durchgelesen und weis nicht mehr weiter. Hier z.B. ein Blog: Part 1 - Base Configuration for SharePoint Kerberos zur Datenbank aktivieren Bevor Kerberos auf den Web Applikationen der Frontend Server aktiviert wird, sollte es auch auf Ebene der Datenbank eingerichtet werden. Beim SQL Server 2005 ist das nicht all zu kompliziert. Die Voraussetzung für die Verwendung von Kerberos ist, dass der Datenbankdienst über einen Active Directory Account ausgeführt wird. Ist das der Fall, kann für diesen Service Account ein Service Principal Name (SPN) registriert werden. Die Erstellung des SPNs wird über das Kommandozeilenwerkzeug SETSPN unterstützt. SETSPN ist Bestandteil der Windows Server Ressouce Kit Tools und kann von der Installations-CD oder dieser Website bezogen werden. Konfigurieren eines virtuellen Windows SharePoint Services-Servers zur Verwendung von Kerberos-Authentifizierung und Wechseln von Kerberos-Authentifizierung zurück zur NTLM-Authentifizierung Direkt Link: Windows 2000/2003 Ressouce Kit Tool: Setspn.exe Hier meine einzelnen Einträge dazu. setspn -A MSSQLSvc/srvsp01.demo.de:1433 demo\administrator setspn -A HTTP/srvsp01.demo.de demo\administrator setspn -A HTTP/srvsp01 demo\administrator Die Service Principal Names wurden von mir ohne ein Problem registriert. Mit dem schönen "ldifde" kann man diese abfragen. Hier der Befehl dazu: ldifde -f check_HTTP_MSSQLSvc_SPN.txt -t 3268 -d "" -l servicePrincipalName -r "(servicePrincipalName=HTTP/srvsp01.demo.de*)" -p subtree Nachdem ich die Service Principal Names für den Administrator erstellt und diese zusätzlich überprüft habe. Wurden die SQL Server Dienst neu gestartet. In dem SQL Server Management Studio hab ich dann direkt mit dem Befehl: select auth_scheme, * from sys.dm_exec_connections die Authentifizierung abgefragt, leider wurde mir hier immer noch NTLM und nicht Kerberos als primäres Authentifizierungsprotokoll angezeigt. Wieso ist das so.... Was hab ich falsch gemacht... :confused: Also habe ich dann versucht Kerberos für die SharePoint Applikationen zu aktivieren. Um auf einer SharePoint Web Applikation Kerberos zu aktiviern, müssen die identischen Voraussetzungen wie beim SQL Server gegeben sein. Dass heißt, der Anwendungspool muss über die Identität eines Domain Service Accounts ausgeführt werden. Hier meine Domain Service Accounts und die einzelnen Service Principal Names: Weiter gehts im Teil Nr.:2/2
  13. Hat sicher erledigt! Problem gelöst. Aber Danke... Gruß Tron
  14. Hallo zusammen, wer kennst sich hier super gut mit EFS = Encrypting File System auf Netzwerkfreigaben (unter Windows 2003 Server SP1) aus!?! Leider Frag ich mich die ganze Zeit, wo ich die einzelnen Zertifikate der Benutzer (die Zugriff auf die Netzwerkfreigabe haben sollen) hinterlegen muss. Die Client-System sind alle mit Windows XP SP2 ausgestattet. Des Weiteren möchte ich nachher die CA-Zertifikate der einzelnen Benutzer auf RSA-Token ablegen. Damit die Benutzer direkten Zugriffe (nach der Anmeldung) auf die Netzwerkfreigabe bekommen können. :wink2: Vielleicht hat sich schon einer von Euch mit diesem Thema beschäftigt. Für jede Information bin ich dankbar. Gruß Tron
  15. Hallo, @ chäfer, Hier die Antwort: Zitat "Es ging darum das ich einen Server Installieren soll und ich hab eine USV" Ich glaube du meinst dann auch UPS (uninterruptible power supply (UPS)) Antwort muss sein: C. Deinstallieren (abklemmen) UPS (USV) bevor die Installation des Windows Small Business Server 2003 stattfindet. Weil sonst Problem bei der Installation bestehen. Die gleiche Frage hatte ich auch. Da ich meine Prüfung in Englisch gemacht habe, muss die Antwort in Englisch so heißen: C. Disconnect the UPS before the installation of Windows Small Business Server 2003 Gruß Tron
  16. Hallo, @ chäfer, hier alle Infos: :) Unterschied zwischen SBS2000 nach SBS2003 Standard & Premium Edition, Unterschied zwischen SBS2003 Standard & Premium Edition, Sehr Gute Kenntnisse zu Exchange 2003: OWA etc., Sehr Gute Kenntnisse zu SharePoint Team Services: Managment Files etc., Routing & RAS PPTP etc., Universal Plug and Play (UPnP) basiert auf einer Reihe von standardisierten Netzwerkprotokollen und Datenformaten., SQL-Server 2000: Datenbanken und Sicherungsverfahren etc., Datensicherung unter SBS2003 Standard & Premium Edition etc., DNS - DNS und nochmals DNS, USV und Installation unter SBS2003 Standard & Premium Edition etc. und natürlich Netzwerkplanung mit SBS2003 Standard & Premium Edition. Ich hoffe ich konnte dir (euch) helfen. :D Hab leider nur 925 Punkte gemacht. ;) Gruß Tron
  17. Hallo zusammen, @ Tobi72, 1 Tag Schulung vom Microsoft - Partner Programm und wusste da schon mehr als unser lustiger Trainer… Danach hab ich mir die blaue Schulungsunterlage durchgelesen und am nächsten Tag die Prüfung gemacht. SBS-Microsoft-Partner Persönlich: Mehr als 10 Jahre Praxis im Umfeld professioneller Systemtechnologie ;) Gruß Tron
  18. Hallo zusammen, ich weis zwar nicht was hier ab geht, aber unter 3000 € Brutto würde ich nicht mal vom Sofa zum Rechnersystem gehen. Na ja ist aber auch egal... :D Gruß Tron
  19. Hallo, @ Microdemis, hier alle Infos: ;) Unterschied zwischen SBS2000 nach SBS2003 Standard & Premium Edition, Unterschied zwischen SBS2003 Standard & Premium Edition, Sehr Gute Kenntnisse zu Exchange 2003: OWA etc., Sehr Gute Kenntnisse zu SharePoint Team Services: Managment Files etc., Routing & RAS PPTP etc., Universal Plug and Play (UPnP) basiert auf einer Reihe von standardisierten Netzwerkprotokollen und Datenformaten., SQL-Server 2000: Datenbanken und Sicherungsverfahren etc., Datensicherung unter SBS2003 Standard & Premium Edition etc., DNS - DNS und nochmals DNS, USV und Installation unter SBS2003 Standard & Premium Edition etc. und natürlich Netzwerkplanung mit SBS2003 Standard & Premium Edition. Ich hoffe ich konnte dir (euch) helfen. :D Gruß Tron
  20. Hallo zusammen, wollt mich nach langer Zeit auch mal wieder melden. Am letzten Freitag hab ich die 70-282 Exam Designing, Deploying, and Managing a Network Solution for a Small- and Medium-Sized Business gemacht. Hab leider nur 925 Punkte gemacht. ;) Fand die Prüfung nicht wirklich schwer. Man sollte die Unterschiede von SBS2000 zu SBS2003 wissen. Sonst sollte man sich noch sehr gut mit SharePoint Team Services auskennen. Gruß Tron
  21. Hi triebwerk, wie sieht es den mit den Büchern von Nicole Laue aus: http://www.amazon.de/exec/obidos/ASIN/393723909X/qid=1125563863/sr=1-4/ref=sr_1_11_4/028-1337683-9160512 http://www.amazon.de/exec/obidos/ASIN/3833004401/qid=1125563939/sr=1-3/ref=sr_1_2_3/028-1337683-9160512 Gruß Tron
  22. Hallo zusammen, hab die 70-292 bestanden mit 880 Punkten. Wie schon oft im Forum geschrieben wurden die Neuheiten von DNS & SUS etc. abgefragt. Die 70-292 ist zu schaffen. Die 70-296 fand ich persönlich schwieriger. Hatte bei der 70-292 keine Simulation wie in der 70-296. Bei 70-296 stand nachher das auch Simulationsfragen abprüft wurden, die zu Testzwecken hinzugefügt wurden. Bei der 70-292 stand nur bestanden. Die Punktzahl war nachher ohne Balken auf dem Ausdruck. Ein Dank an alle. ;) Muss mich jetzt wieder ums Projektgeschäft kümmern. Vielleicht werden die nächsten Prüfungen für den ISA-Server anfallen. Vielleicht könnt mir noch ein paar gute Bücher zum ISA-Server empfehlen ;) . Jetzt MCSE 2000 & 2003. Danke an alle, Gruß Tron
  23. Hallo zusammen, gestern habe ich die 70-296 erfolgreich mit 800 Punkten bestanden und jetzt kommt der Kracher. Ich hatte statt den normalen 50 Fragen „75 Fragen“. Kleines Prüfungsprotokoll: Meine Prüfung bestand auch wie normal aus zwei Teilbereichen: Erster Teil: 35 Fragen Zweiter Teil: 40 Fragen In dem zweiten Teil hatte ich aber Simulationsfragen, ja Simulationsfragen!!! Nicht ich zieh das Bild von rechts nach links etc. Das sind keine Simulationsfragen. Ich musste einen SUS-Server konfigurieren und dazu GPOs anlegen. Dann hatte ich zwei Simulationsfragen zur Loopbackverarbeitungsmodus (Terminalserver). Eine Simulationsfragen GPOs anlegen für Softwareverteilung und eine einfache Simulationsfragen zum anlegen von GCs und das zwischenspeichern der universellen Gruppenmitgliedschaften. Zum Abschluss kommt dann noch die 20 bis 25 Fragen lange Umfrage. Also was kam dran: PKI -> Parameter “certutil” mit der Option “- backup“ & “- restore EFS -> automatische Speicherung von persönlichen Zertifikaten Smartcard Login -> Administratorenkonten GPOs -> z.B. Loopbackverarbeitungsmodus, Desktopeinstellung, Reihenfolge in der Abarbeitung GPOs und natürlich Filtern der GPOs etc. IPSec, SMB etc. also Datenverkehr zwischen verschiedensten Clientversion -XP-W2K-NT-98-95 Unterschiede zwischen WEB - Standard - Enterprise Edition Cluster Fragen zum Thema Quorum - Festplatten-Platz Anbindung Natürlich -> Parameter for dcpromo & ntdsutil Vertrauensstellungen und ein paar DNS Fragen. GCs etc. Halt die Neuerungen, aber Nichts was einem das Genick brechen könnte. Ich hoffe ich konnte helfen. Viel Erfolg bei Eurer 70-296 Prüfung. :wink2: Gruß Tron
  24. Hallo zusammen, "Von ckcoach: hmm, das problem ist ja das ich nicht an den ran komme. also kann ich nichts eingeben... vielleicht hift eine Reperaturinstallation weiter?" @ ckcoach, du must nicht an den defekten Dc um die FSMOs zu übertragen!!! Des Weiteren solltest du wissen, wer der erste DC im Unternehmen ist und welcher der Zweite. Einfach auf den neuen Server dos-console starten und losss geht's. Natürlich solltest du vorher das Schema erweitert haben (w2k auf w2k3)!! Schema-Nr 30 ok ntdsutil roles connections connect to server "srvdc01" Immer zum neuen Server ("Der Name ist wie immer beliebig") q transfer domain naming master etc die restlichen 4 dann noch Bei Fragen Fragen. Wenn du nicht weis, was du tust könnte dies sehr schlimme Folgen haben. Gruß Tron
  25. Moin Fantafisch, hat alles super geklappt!! Ich hab immer die neusten Treiber aus dem I-Net benutzt und wie du schon geschrieben hast, diese funktionieren nicht!! Über die Smart Start CD super Einfach!! Danke nochmals, hätte ich aber auch selbst drauf kommen müssen!! Man, so mülll. Gruß Tron
×
×
  • Create New...