Jump to content

jpanse

Newbie
  • Content Count

    33
  • Joined

  • Last visited

Community Reputation

10 Neutral

About jpanse

  • Rank
    Newbie
  • Birthday 05/17/1978
  1. Ich seh schon. Das wird nicht damit gelöst sein indem ein paar Mausmeter zurücklegt. Danke für den Input.
  2. Die Kuh ist lustig... Ich vergebe bei Freigaben immer Jedem Vollzugriff und regel den Rest über NTFS Berechtigungen auf dem Fileserver wo die Freigabe herkommt. Funktioniert erstklassig. Wenn der User laut Freigabeberechtigung Vollzugriff hat und NTFS aber nur Lesen, dann darf der nur Lesen...wenn du jetzt dem User die NTFS Rechte auf dem Ordner entziehst / den Zugriff verweigerst dann darf er da auch nichts mehr machen... Die Grafik mit der Kuh sieht doch gut aus...der "User" darf halt nur in "GRUPPE" Mitglied sein... Ah: Die Vererbung....
  3. Leider lassen sich die Geräte die wir herstellen so schlecht virtualisieren... anyway...Feierabend Danke
  4. Die sind lokale Admins... :thumb2: :schreck: Die IP Adressen werden für verschiedene Kundensysteme verwendet welche wir im Haus haben wenn etwas daran geändert werden muss oder etwas neu eingerichtet wird erledigt man das mit IPs aus dem Subnetz der Kunden. Es soll wohl schon vergekommen sein das Systeme ausgeliefert wurden und man sich gewundert hat warum das beim Kunden nicht läuft...Falsche IP versorgt...um sowas zu umgehen passt man die IP vom eigenen Computer an... Ich seh schon...alles nicht so einfach...Das muss wohl ein anderes Netzwerkdesign her... Danke für die vielen Antworten.
  5. Hallo Wir betreiben ein AD mit 3 DCs mit Server 2012 R2 und drei DNS Servern. Es funktioniert alles gut, lediglich das DNS bereitet mir Kopfzerbrechen. Ich habe mich auch schon durch alte Einträge gelesen, aber mein "Problem" finde ich nirgendwo so richtig. Vielleicht suche ich auch an der falschen Stelle? Ich habe ein paar Spezis welche ihrem Client mehrere IP Adressen auf einer NIC geben. Das hat sich allmählich zu einer gängigen Praxis entwickelt. :nene: Natürlich registriert sich der Client mit all diesen IPs am DNS und der generiert fröhlich die A-Records. Jetzt habe ich den Hosteintrag PC-XYZ-01 172.16.0.1, PC-XYZ-01 192.168.12.1 usw. Am liebsten würde ich denen das verbieten, aber die Abteilung generiert Gewinn und da sind so ein Paar DNS Probleme ja wohl mein Problem... Kann ich dem DNS beibringen, dass er nur zulässt, dass sich die Clients nur mit der IP aus unserem lokalen Subnetz registrieren? Ist das eher eine Einstellung am Client oder am DNS Server? Ich habe schon gesucht, aber eine Lösung habe ich jetzt noch nicht. Der Hintergrund ist eigentlich der, wenn ich jetzt über Powershell oder sonstige Konsolen mit dem PC-Name irgendein Kommando absetzen will funktionierte das hin und wieder nicht, kein Wunder, ein Ping auf den PC-Name löste natürlich irgendeine IP auf welche nicht zu unserem Subnetz gehörte. Das ist wirklich lästig. Ich bin auch gerade nicht so motiviert das ganze Netz umzustricken, zumal ich da stellenweise gegen Windmühlen kämpfe...Ich träumte von einer Unterteilung der Netze und meheren NICs pro PC, VLAN...usw...vielleicht eines Tages. Danke für den ein oder anderen Input :)
  6. Die GPP habe ich mir auch schon angeschaut. Ich denke ich werde es darüber Lösen. Den Artikel habe ich schon gelesen, ausserdem ist es recht selbsterklärend. Die Ursprüngliche Frage war lediglich: Worin der Unterschied liegen könnte das dass Script bei einem User die Gruppen in denen er Mitglied ist ausliest und bei dem Anderen nicht. Im AD gleichen sie sich, ich muss wohl mal mit LDAP da ran...irgendwo ist da noch ein Fehler drin und der ist über die GUI nicht zu sehen. Jetzt könnte man der Thread eigentlich schliessen...
  7. @NilsK Genau das soll das skript aber machen. Mir ist jetzt lediglich aufgefallen das es bei einigen Usern funktioniert und bei anderen nicht. Obwohl die User im AD gleich konfiguiert sind, jedenfalls augenscheinlich. Gruss, Thmas
  8. :confused: Na wenigstens konnte ich dazu beitragen scheinbar einen Fehler im Forum zu finden.
  9. Hallo, hallo Ich habe ein Problem welches ich nicht nachvollziehen kann und ich möchte gern wissen warum das Problem auftritt. Unser LogonScript ist ein VBS und liest per Rekursion die Gruppen unserer User aus. Jetzt habe ich unsere Drucker umgezogen und das Script angepasst, dabei ist mir aufgefallen das einige User die Drucker verbunden und richtig zugewiesen bekommen, andere nicht. Also das "'On Error Resume Next" wieder auskommentiert und das "WScript.Echo("Gruppen: " & strGroups)" wieder aktiviert und das Script laufen lassen. Ernüchterung machte sich breit als die Fehlermeldung kam "Active Directory" : Die Verzeichniseigenschaft wurden nicht im Cache gefunden. Danach poppt das Fenster auf mit "Gruppen:" und es steht nichts drin. Jetzt habe ich das mit einem anderen User probiert, da läuft das Script sauber durch und er zeigt die Gruppen an. Also habe ich die User verglichen und keinen Unterschied festellen können, auch das OS spielt keine Rolle. Wenn es bei einem User nicht funktioniert geht es bei XP und auch bei Win7 nicht. Meine DC's sind Server 2008 R2 und ein Server 2003 32 Bit. Ich wundere mich halt warum es bei manchen geht und bei anderen nicht, wo könnte der Fehler liegen? Hier mal noch der Codeschnipsel: 'Setzt das Script bei Fehlern fort 'On Error Resume Next Const E_ADS_PROPERTY_NOT_FOUND = &h8000500D 'Trennen der vorhandenen Netzlaufwerke Set wshNetwork = CreateObject("WScript.Network") Set shell = CreateObject("WScript.Shell") shell.run "net use * /d /y",0 'Wartezeit des Scripts vor Ausführung (5 sek) WScript.sleep 5000 'Auslesen des AnzeigeName des Users. Set objSysInfo = CreateObject("ADSystemInfo") strUserDN = objSysInfo.UserName ' Bind to user object. Set objUser = GetObject("LDAP://" & strUserDN) ' Display user NT name (sAMAccountName), Distinguished Name, ' Common Name, Display Name, first name, and last name. ' The last three might not have values. 'Wscript.Echo "sAMAccountName: " & objUser.sAMAccountName 'Wscript.Echo "Distinguished Name: " & objUser.distinguishedName 'Wscript.Echo "Common Name: " & objUser.cn 'Wscript.Echo "Display Name: " & objUser.displayName 'Wscript.Echo "First Name: " & objUser.givenName 'Wscript.Echo "Last Name: " & objUser.sn 'Festlegen div. Variablen Dim WshNetwork Set WshNetwork = WScript.CreateObject("WScript.Network") Set ObjNetwork = CreateObject("WScript.Network") Set ADSysInfo = CreateObject("ADSystemInfo") Set CurrentUser = GetObject("LDAP://" & ADSysInfo.UserName) Dim objWshNet Set objWshNet = CreateObject("Wscript.Network") Set objWshNet = Nothing Dim drv, drvpath, drvname 'Ermittlung der Gruppe mit Hilfe einer Rekursion objGroups = CurrentUser.GetEx("memberOf") Dim strGroups Call GetGroupsOfUser(objGroups, strGroups) Private Sub GetGroupsOfUser(ByVal objGroups, ByRef strGroups) For Each strGroup in objGroups Set objCurrentGroup = GetObject("LDAP://" & strGroup) strGroups = strGroups + strGroup + " " On Error Resume Next objCurrentGroups = objCurrentGroup.GetEx("memberOf") If Err.Number <> E_ADS_PROPERTY_NOT_FOUND Then Call GetGroupsOfUser(objCurrentGroups, strGroups) End if Next End Sub 'Umwandlung in Kleinbuchstaben strGroups = lcase(strGroups) WScript.Echo("Gruppen: " & strGroups) Danke und Gruss Thomas
  10. Hallo Helfende. Wie nutzen Outlook 2003 und hosted Exchange 2007. Es gibt einige freigegebene öffentliche Kalender und die Kalender der MA. Unsere "Teppichabteilung" kann nun Termine, z.B. Servicesitzungen, in die Kalender der MA eintragen. Nachdem nun einer der MA diesen Termin geändert hat und behauptet der wäre aber so eingetragen wurden fragt mein Personalverantwortlicher nach einer Änderungshistorie. In dem Kalenderprogramm welches wir vorher hatten gab es so etwas. Dort war zu sehen wer den Termin zuletzt geöffnet und geändert. Das der MA den Termin in seinem Kalender selber geändert hat, steht außer Frage. Jedoch kam durch diesen Vorfall die Frage nach einer Änderungsprotokollierung auf. In diesem Tool ist soetwas integriert Add-In-World - SmartTools TeamOutlook 2.0 - Startpaket mit 1 Gratislizenz Gibt es eine Möglichkeit diese Funktion mit Boardmitteln zu erreichen oder kennt jemand Tools die eine solche Funktion zur verfügung stellen? Kosten soll es natürlich wie immer nichts ;) Danke schonmal :)
  11. Nein ich erwarte nicht das mir jemand auf Grund der Meldung "schlägt fehl" jemand hilft. Ich wollte das nur angemerkt habe, ich versuche mir eigentlich immer zuerst selber zu helfen. ADSIEdit habe ich auch schon ins Auge gefasst. Backup ist natürlich vorhanden. Ich bin ja nicht wahnsinnig ;)
  12. 2 DC's sind schon vorhanden. RemoveOrg schlägt fehl, irgendwie habe ich nichts anderes erwartet. :o
  13. Hmm Meinst du es reicht wenn der Server Member ist? ICh belese mich erstmal über Removeorg.
  14. Ok, jetzt nochmal nachfragen. Was entfernt er da genau? Der Exchange war auf einem spepparaten Rechner. Klär mich mal bitte auf. Ich habe bedenken das er mein bestehendes AD zerhackstückelt...ich habe zwar ein Backup aber den Aufwand es wieder geradezubiegen möchte ich mir dann doch sparen.
  15. Hallo Gemeinde. Ich bin gerade dabei einen EXCH 2k10 aufzusetzen. Allerdings hat mein Vorgängster irgendwann mal versucht testweise einen Exchange 2k3 in der gleichen Umgebung aufzusetzen. Jetzt meint das Setup es existiere ein EXCH 2k3 in meiner Umgebung und den solle ich mit dem entsprechenden SP versehen. Leider geht das nicht da der Server nicht mehr existiert. Die Schemaerweiterungen sind noch vorhanden, allerdings habe ich so meine Bedenken die einfach so zu entfernen. Was kann ich tun? Zur Infrastruktur: Server 2k3 32 Bit SP2 als GC Server 2k3 32 Bit SP2 als DC Server 2k8 64 Bit als DC (Da soll EXCH drauf) Server 2k8 64 Bit als Member Setupüberprüfung ist soweit ok, er meint aber die Exchange-Organisation sei nicht im Einheitlichen Modus. Was so als Lösung des Problems vorgeschlagen wird ist leider nicht machbar, weil der Server den Setup gefunden hat nicht existiert. Was nun :confused:
×
×
  • Create New...