Jump to content

j.c.v.

Members
  • Content Count

    51
  • Joined

  • Last visited

Community Reputation

10 Neutral

About j.c.v.

  • Rank
    Newbie

Recent Profile Visitors

The recent visitors block is disabled and is not being shown to other users.

  1. Hallo zusammen, ich habe hier ein sehr seltsames Phänomen: Bei einem Kunden werden diverse Server W2K8R2, W2K12, W2K12R2, W2K16, W2K19 (alles VMs) per WBADMIN auf einen zentralen Backup-Server (Blech) gesichert. Dieser Server wurde vor Kurzem ersetzt (altes Gerät W2K8R2, neues Gerät W2K12R2). Nun habe ich folgendes Problem: Die Windows 2008 R2-VMs sichern nur noch extrem langsam auf die Netzwerkfreigabe des Server 2019. Vorher war die Performance ca. 8x so hoch (z.B. alte Sicherungszeit 30 Minuten, neue Sicherungszeit 4 Stunden). Alle anderen VMs (mit neueren Betriebssystemen / wbadmin-Versionen) sichern "ganz normal zügig". Auch der direkte Zugriff aus den W2K8R2-VMs auf die Freigabe des 2019er funktioniert mit normaler Performance. Nur die wbadmin-Sicherung dauert extrem lange... Kann sich hier jemand einen Reim darauf machen oder hat Tipps? Danke und schöne Grüße, Jan
  2. Moin Dunkelmann, eine wichtige Info... hab ich leider bei einem schnellen Google-Versuch selbst nicht gefunden. Beim o.g. Thread geht es zwar um einen RV180W (der ohne W hat etwas andere, leistungsfähigere Hardware) und AUSgehenden Clientverbindungen, bei mir geht es um einen ohne "W" und EINgehenden Site-Verbindungen - eine gewisse Vergleichbarkeit ist aber sicher da. Die Lösung aus dem o.g. Forum (QOS einschalten) hat aber leider nicht funktioniert. Daher lasse ich den Thread hier mal offen - vielleicht hat ja noch jemand eine Idee...
  3. Hallo Zusammen, ich habe ein Problem mit einer "alten" ISA-2006-Struktur. Aufbau: 1 Zentrale, 6 Remote-Standorte ISA 2006 an allen 7 Standorten. Jeder Remote-Standort ist mit der Zentrale per S2S-VPN (PPTP) verbunden. Weiterhin ist Client-VPN (auch PPTP) an jedem Standort eingerichtet. Jeder Standort hat ein LAN (mit ISA als Gateway) und ein Transfernetz (mit dem externen ISA-Interface und einem xDSL-Router). Bisher hat alles gut funktioniert.... :-) An einem Remote-Standort wurde der bisherige Router ausgetauscht gegen einen Cisco SB RV180. Weiterleitung Port 1723 auf ISA und VPN-Passthrough für PPTP ist eingeschaltet. Einwahl am Standort per Client-VPN ist möglich. Und nun das Problem: Die Standortverbindung zur Zentrale geht an diesem Standort NICHT mehr. Bei Herstellung aus der Zentrale läuft die Verbindungsherstellung unendlich. Bei Herstellung aus dem Remote-Standort kommt nach 2-3 Minuten "Die Verbindung wurde vom Remotecomputer getrennt, bevor sie hergestellt werden konnte". Die Verbindung Zentrale -> andere 5 Remote-Standorte funktioniert einwandfrei (Fehler bei Zentrale unwahrscheinlich). Die Verbindung Client -> Remotestandort funktioniert (wie o.g.) auch einwandfrei, daher müsste die Router-Config okay sein. (Der ISA wurde auch schon testweise in die DMZ des Routers gesetzt, leider ohne Änderung) Daher meine Frage: Kennt einer dies Problem bzw. kann weiterhelfen? Ist denn bei S2S-PPTP irgendetwas anders als bei C2S-PPTP? (dass der Router nachher doch Schuld ist?) Danke & Schöne Grüße, JCV
  4. Hallo zusammen, ich arbeite gerade an einer Testumgebung mit einem Failover-Cluster unter Windows 2012. Nun geht es um die Sicherung, die Server-Sicherung / wbadmin bringt unter 2012 ja einige Neuerungen mit sich. Hierbei stellen sich mir einige Fragen, bei denen ihr mir vielleicht weiterhelfen könnt. Szenario: Failover-Cluster (2012) mit zwei Nodes, derzeit wird auf dem Cluster als Rolle nur Hyper-V ausgeführt (4VMs), was sich aber ggf. ändern kann (evtl. noch Fileserver, DHCP, etc. geplant). Die VMs liegen auf einem CSV auf einer QNAP-NAS(Pro) mit iSCSI. Ziel ist es, den kompletten Cluster zu sichern, ohne Ausfall der VMs und unabhängig davon, wo sich die VMs gerade befinden. Hierzu soll das integrierte wbadmin genutzt werden, DPM kommt aktuell nicht in Frage. Sicherungsziel ist eine Freigabe auf einem dedizierten Backup-Server, wo die Sicherungen quasi "online" liegen sollen und regelmäßig auf ein lokal angeschlossenes RDX oder LTO gezogen werden (mit Backup-Exec, unabhängig von der Laufzeit der "primären" Sicherung). Wenn ich nun den wbadmin-Assistent auf einem Node starte (zum Testen, später wird gescripted), sehe ich nun zwei Möglichkeiten: 1.) Ich kann den Server selbst, inkl. der gerade auf dem Server laufenden(!) VMs und das Quorum sichern. Das CSV selbst kann ich nicht mit wählen (was ja bezüglich der VMs auch "doppelt gemoppelt" wäre, später (s.o.) aber sinnvoller sein könnte). Prinzipiell wäre dies zunächst ja hinreichend, wenn dies auf beiden Nodes konfiguriert wäre. Fraglich ist nur, ob die VMs in der Sicherung dann auch immer entsprechend berücksichtigt werden, wenn diese zwischen den Knoten verschoben werden (?). Eher problematisch sehe ich jedoch zwei Punkte: - Was ist, wenn das CSV mal mehr Daten als die VMs enthält (z.B. Fileserver, etc.) - die werden dann nicht gesichert... (?) - Wenn die VMs zwischen den Knoten verschoben werden, werden diese mal mit dem einem, mal mit dem anderen Knoten gesichert (hoffentlich - siehe oben). Dadurch "blähen" sich die Sicherungsdateien ziemlich auf und belegen mehr Speicher auf dem Backup-Server als nötig (wie ja auch schon mit wbadmin unter 2008 R2) 2.) Alternativ kann ich nur das CSV selber sichern. Dabei werden die VMs in den Status "Sicherung wird ausgeführt" versetzt. Dies erscheint zunächst sinnvoller, da dann ja alle Daten des CSVs mitgenommen werden und die VMs nicht evtl. doppelt agelegt werden. Man könnte also als Job dies auf einem Node durchführen und auf jedem Node dann nochmal den "Rest" (also den jeweiligen Server, ohne Hyper-V und CSV) - dann sollte man doch alles haben, oder? Fraglich ist für mich hier, ob die VMs auch korrekt gesichert werden (so "sicher" wie per Child-Snapshot in der o.g. Lösung), es ist auch Exchange und SQL auf den VMs im Einsatz... Ebenso fraglich sind für mich die Recovery-Optionen (dich ich wegen des doch hohen Aufwands noch nicht getestet habe). Desaster-Fall (kompletter Cluster ist zerstört): Kann ich mit dieser Sicherung die VMs auch lauffähig wiederherstellen ohne den kompletten Cluster zu rekonstruieren? (Ist ja meistens so: Server bereit stellen, Sicherung liegt dateibasiert vor, Einlesen der Sicherung und Starten der VMs sollte auf diesem Einzelgerät, ohne Cluster etc. möglich sein!) Vielleicht gibt es ja jemanden, der hiermit schon Erfahrung hat und ein paar Tipps geben kann. Schöne Grüße, Jan Okay - Update in dieser Sache (ich war eben etwas voreilig - sorry): Nachdem ich nun schon einiges getestet habe, fällt Option 1.) weg, da die Hyper-V Maschinen nicht gesichert werden können, wenn sie auf einem CSV liegen. Dies gibt Microsoft auch so an, habe ich erst nur falsch verstanden: http://technet.microsoft.com/en-us/library/jj614621.aspx 1. Virtual machines hosted on CSV’s cannot be added as part of backup configuration 2. Windows Server Backup has to be configured on all nodes to ensure that backup and recovery will be available in the event of a failure on one of the nodes in the cluster. 3. Volumes recovery not supported 4. Security access control lists are not applicable on CSV file service root. Therefore, file recovery to the root of CSV volume is not supported. Bleibt also nur die Sicherung des CSVs. Hier treten nun wieder folgende Fragen auf: - zu 2.: "on all nodes" ?! Das würde ja bedeuten, dass alle VMs doppelt gesichert würden?!!! - Wie ist das dann mit dem Recovery (s.o.) - hat da jemand schon (Test-) Erfahrungen? Das nächste Problem bleibt dann die Sicherung der Nods selber. Wie oben gesagt, könne keine lokalen UND CSV-Daten in einer Sicherung enthalten sein. Wenn ich einen Node mit "Bare-Metal" sichern will, wählt er C: komplett aus (was ja das CSV "logisch" enthalten würde) und bricht ab, da CSVFS-Daten nicht mitgesichert werden können (an sich logisch). Entferne ich C:\ClusterStorage, geht Bare-Metal nicht mehr. Wähle ich Bare-Metal ab, kommt die Meldung "Einer für die Sicherung angegebenen Dateipfade befindet sich unterhalb eines Analysepunktes...") geht also auch nicht.... Jetzt bin ich etwas fraglos...
  5. (PUSH) Niemand hier, der DPM 2012 (ggf. auch mit anderen disk-basierten Wechselmedien) im Einsatz hat? Danke, Jan
  6. Hallo zusammen, ich plane derzeit ein neues Projekt (mit Windows 2012 Failover-Cluster, Hyper-V und weiteren Rollen im Cluster). Für die Sicherung des Clusters und anderer Dienste (Exchange etc. vorhanden) bietet sich ja immer der DPM an. Der Kunde wird einen dedizierten Backup-Server (mit GROßEM lokalem Storage) verwenden. Aus diversen Gründen wird aber RDX als externer Speicher verwendet werden (LTO etc. ist nicht gewünscht, bitte fragt nicht). Meine Frage ist daher, ob DPM 2012 nun auch RDX unterstützt (ohne Filestreamer, etc.) oder nicht (wie in den bisherigen Versionen). Ich habe dazu bisher keine klaren Aussagen gefunden. Ansonsten müsste wieder BackupExec zum Einsatz kommen... Danke und schöne Grüße, Jan
  7. Ja, für Profuktionsumgebungen wird davon abgeraten, aus diversen Gründen solls in diesem Test trotzdem so sein... Die in dem Link erwähnten Leistungsapsekte sind kein Thema, die Server sind schnell genug, RAM ist reichlich da und die Hyper-V Sachen liegen ja auf ganz anderen Laufwerken, kommen mit der Mini-ADS also nicht ins Gerangel. Der eventuelle Sicherheritsapsekt bleibt natürlich, ist aber Stöhnen auf hohem Niveau (ich denke, jeder, der schonmal einen SBS produktiv genutzt hat, kommt nichtmal auf diese Gedanken :-) ) Alle DCs zu virtualisieren ist ja auch keine empfohlene Vorgehensweise (wie oben auch von NilsK nochmal erwähnt/verlinkt). Da kein dritter physikalischer Server als reiner DC arbeiten soll, kann man jetzt entweder die ADS-Rolle mitlaufen lassen oder alle DCs virtualisieren. Wie von beiden Seiten beschrieben ist beides keine Lehrbuch-Lösung, ich habe mich letzten Endes für die zusätzliche Rolle auf der Hardware entschieden :-) ....
  8. Jupp - und genau das hat es nicht :-). Ich habe mir jetzt für den Test eine 459 Pro Plus organisieren können (Intel Modell MIT SPC-3). Dann wollen wir mal sehen :-)... Nur´noch zur Sicherheit: Die beiden Server sollen bei diesem Test (trotz allem) DCs werden. Ich installiere die beiden Server also soweit fertig (als DC), auf der NAS ist ein Target bereit und leer. Dann installiere ich die Hyper-V Rolle auf den Servern, dann den Failovercluster und richte dort das Target dann als CSV ein - korrekt? Schöne Grüße, Jan
  9. Erst einmal vielen Dank für eure Antworten! Ich werde mich bei hyper-v-server.de nochmal durchwühlen. Ich vermute aber (@NECRON), meine QNAP (419er) unterstützt eben keine mehreren Initiatoren pro Target. Zumindest steht bei QNAP in den allgemeinen iSCSI How-Tos: "Nicht mit mehreren Clients verbinden". Ich habe mal aus Spaß ein Target von zwei PCs aus angesprochen, hat direkt zu Datenverlust geführt... Wenn bei einem CSV die Nodes die Verbindung aufbauen ist das ja letzten Endes nichts anderes (?!)... Schöne Grüße, Jan
  10. Hallo Dukel, wie konfiguriere ich denn in einem Failover-Cluster das iSCSI als shared Storage? (bei meinen Tests war dies (mit einem iSCSI-Target) NICHT möglich).... Die iSCSI-Verbindungen seitens der Server habe ich NICHT geteamt (s.o.) sondern per MCS eingerichtet. MPIO bringt mir doch keinen Vorteil beim Zugriff EINES Servers auf ein Target (dafür ist doch MCS da) - oder? Zum Fileserver: Wie beschrieben ist das NAS/SAN NICHT (!) aus dem LAN erreichbar. Die Freigabe muss daher durch einen Server oder durch einen ADS-zentralen Freigabepunkt erfolgen. Zum DC: Laut MS-WP muss zumindest ein DC physikalisch sein. Zumindest dies möchte ich (aus dem Bauchgefühl) so umsetzen.... Schöne Grüße, Jan
  11. Hallo zusammen, ich hoffe, mein Post ist hier richtig. Es geht um ein Gedankenspiel zu einer (etwas) ausfallsicheren und komfortablen Hyper-V Lösung mit Windows Server 2012. Kurze Beschreibung der Eckdaten: In einer Testumgebung habe ich im Moment zwei W2K8R2-Server mit Hyper-V Rolle (hardware-unterschiedlich) sowie eine NAS-Box (QNAP 419 II Plus, 4 Enterprise HDD als RAID10), auf der nur der iSCSI-Dienst mit zwei Targets läuft. Auf jedem Target liegen die VMs für je einen Server. Für die Verbindung zwischen den Servern und der NAS (bzw. eher SAN in dieser Einstellung) besteht ein eigenes VLAN, zusätzlich zum regulären LAN. In diesem VLAN haben die Server jeweils eine Intel DualPort Server-NIC (1000TX), die NAS nutzt ihre beiden onboard NIC (ist also nur mit dem VLAN verbunden). Die NAS "teamt" ihre beiden NICs zum Switch (LAG). Jeder Server vebindet sich mit jeweils einem der iSCSI-Targets und nutzt dabei MCS im iSCSI-Initiator um über zwei Verbindungen zum Target (NIC1+2) die beste Leistung herauszuholen. (Performance ist also eine relevante Frage, daher auch iSCSI, eigenes VLAN und jeweils zwei NICs) Failovercluster o.ä. ist NICHT konfiguriert. Soweit zu den Eckdaten. Problematisch an dieser Lösung sind zwei Dinge: 1.) Da ja nur ein Initiator exklusiv auf ein Target zugreifen kann, ist das iSCSI-Storage nicht für beide Server verfügbar. Sprich: möchte man eine Maschine zwischen den beiden Hyper-V Hosts verschieben, muss man auf einem Server alle Maschinen beenden, das iSCSI trennen, auf dem anderen neu verbinden, die Maschine kopieren und den ganzen weg wieder zurück... Gleiches gilt bei Ausfall eine Maschine: iSCSI manuell umlegen, Maschinen einbinden uns starten, etc... 2.) Die Verwaltung ist nicht zentralisiert, schnelle Migration, etc. ist auch von daher nicht möglich Mit dem Server 2012 wurde ja angekündigt, dass sich im Bereich Hyper-V und shared-Storage Einiges getan hat. Ich muss zugeben, mich hier noch nicht 1000%ig eingearbeitet zu haben, erste Versuche mit StorageSpace und ClusterSharedVolumes waren aber leider nicht positiv, daher hier die Frage an die Community. Ich plane also, diese Umgebung zu aktualisieren. Hierfür stehen zunächst zwei neue, baugleiche Server mit Windows 2012 Standard und je drei NICs (1x LAN, 2x iSCSI-VLAN) bereit. Falls benötigt, steht Systems Centre 2012 ebenfalls zur Verfügung. Das iSCSI- Subsystem (NAS, VLAN, etc.) soll weiter genutzt werden. Zielsetzung ist es, eine Hyper-V-Konfiguration umzusetzen, in der auf den beiden Servern mehrere VMs ausgeführt werden. Die VMs sollen auf dem iSCSI-Target liegen und von beiden Servern zugriffsfähig sein. Die VMs sollen zentral verwaltet und einfach von einem Server auf den anderen verschoben weren können (ja nach Ressourcenbedarf). Ein automatisches Failover wäre gut, ist aber kein KO-Kriterium. Meine Fragen sind daher: - Hat hier jemand bereits Erfahrungen mit der Materie und kann mir sagen, ob dies überhaupt so möglich ist? - Wenn ja - freue ich mich über jeden Hinweis der für die korrekte Einrichtung hilfreich ist (insbesondere auch zum System Centre)... Abschließend noch ein Hinweis: Die Server sollen nicht nur die Hyper-V Rolle ausführen. Zusätzlich werden beide Server Domaincontroller sein (ich weiß - ist niocht empfohlen, wird in dieser Umgebung aber tolleriert). Weiterhin wird noch ein Fileserver fürs LAN benötigt, dessen Daten aber auch auf dem iSCSI liegen sollen. Wenn diese Freigaben ebenfalls ausfallsicher (gegen Ausfall eines Servers) wären, so wäre das ein nettes Addon. Danke für eure Hilfe und schöne Grüße, Jan
  12. Hallo Zusammen, ich habe eine Frage zur Konfiguration des Remotedesktopgateway. Folgende Situation: Mittelgroßes AD-Netz (alle Server W2K8R2) u.a. zwei Hyper-V Server. Internetanbindung BK (100/5MBit, eine externe IP, leider nur dynamisch) an Securepoint UTM-Firewall. Externe IP über intranet.firma.de erreichbar. Es soll (zunächst nur zur Eprobungszwecken) der Remotedesktopgateway eingeführt werden. Hierfür wurde ein virtueller W2K8R2 exklusiv zur Verfügung gestellt. Mein erster Ansatz ist nun: Remotedesktopdienste und -Gateway installieren, durchkonfigurieren, und gut. Die erste Frage anbei: Sitzunghost und Gateway auf gleichem Server möglich? (Sicherheitsfrage ist bei der Erprobung erst noch sekundär) Jetzt kommt aber das Problem: Im Unternehmen wird bereits Exchange mit OWA, etc. eingesetzt. Die Firewall leitet Port 443 hierfür an den Exchange weiter. (https://intranet.firma.de/OWA funktioniert ganz normal) Da nur eine externe IP verfügbar ist, ist demnach auch nur ein externer 443 verfügbar, der ist aber belegt. Für diese Eprobung darf die aktuelle Konfiguration nicht geändert werden. (RDP-Gateway mit auf dem Exchange oder ein ISA davor der per Header weiterleitet ist also nicht möglich) Der RDP-Gateway muss also irgendwie "extern" von 443 runter. Meine Überlegungen wären A: Das gesamte RDP-Gateway-System auf einen anderen, freien Port legen. B: Nur extern einen anderen Port nehmen und intern durch die Firewall auf 443 des neuen Servers umleiten lassen. Hat hier jemand Erfahrungen oder Tipps? (Man müsste ja mindestens den Port im RDP-Client eintragen - geht das?) Vielen Dank und schöne Grüße, Jan P.S.: Was ich bisher gegoogelt habe deutet darauf hin, dass zumindest A nicht geht, direkt einen anderen Port für RDP-Gateway einstellen soll wohl erst in Server 8 kommen...
  13. Hallo Norbert, ja - theoretisch ist die Verquickung von DC und Hyper-V nicht optimal. Aber in der Praxis sieht es bei kleineren Unternehmen ja nun wohl leider anders aus :suspect: . Und mit dieser Lösung hat man wenigstens zwei DCs, kann die anderen Dienste schnell mal umschalten und zumindest ist kein virtueller DC dabei ;) (auch schon alles gesehen). Dies aber nur am Rande. Zur Migration: HAbe ich mir fast schon gedacht (also in eine Gruppe packen, dann alles einzeln replizieren - öffentliche DB, Postfächer, etc. ?). Hast du eine gute Quelle für eine Step-by-Step Anleitung oder eine übersichtliche Checkliste? Oder gibt es da sogar Assistenten oder Scripts für 2010-to-2010? Schöne Grüße, Jan
  14. Hallo zusammen, ich habe eigentlich ein einfaches Problem, eine schnelle Lösung dafür habe ich aber leider nicht gefunden - vielleicht könnt ihr mir weiterhelfen. Folgende Situation: Kleines Netz (2K8R2 AD) mit aktuell nur einem Server, hier ist alles drauf (2K8R2DC, Exchange 2010, und noch viel mehr). Um die Leistung und Sicherheit zu erhöhen, kommt nun ein zweiter Server dazu (W2K8R2 STD mit Hyper-V). Physikalisch DC und Fileserver, virtuell alle anderen Dienste als jeweils eigene VMs. Anschließend wird der alte Server neu installiert und läuft als zweiter DC und Cold-Standby für die VMs. Meine Aufgabe ist es nun, von dem aktuellen Server die Exchange-Installation in eine VM des neuen Servers sauber, restlos und fehlerfrei zu übertragen. Das MUSS nicht online passieren, kleinere Ausfallzeiten wären kein Problem. Eine neue VM wurde bereits mit W2K8R2 STD installiert, Exchange 2010 Prereq. sind auch installiert - die Frage ist nun, wie macht man am geschicktesten weiter? Ein normales Wiederherstellungs-Setup käme ja wohl nicht in Frage, da die VM einen anderen Namen, IP, etc. haben wird und ja im eigentlichen Sinne auch nicht mehr der alte Server ist (auf dem ja diverse andere Sachen liefen). Über eure Ideen und Vorschläge würde ich mich sehr freuen! Schöne Grüße, Jan
  15. Und in diesem Moment - wo ich den letzten Post schrieb - kam eine Idee: Netzwerklistendienst und NLA! Ersterer ist von Zweiterem anhängig. Also: Den Start des NLA-Dienstes auf "verzögert" eingestellt und siehe da: LÄUFT! Genauere Tests natürlich erst einmal vorbehalten, aber hier scheint es erstmal zu klappen. Schöne Grüße, Jan
×
×
  • Create New...