Jump to content
Sign in to follow this  
volvo

Cisco801 Internet und Einwahl

Recommended Posts

Hallo zusammen ich muss einmal nerven.

 

Nachdem ich hier tausende Beiträge gelesen habe habe ich leider noch nichts gefunden was mir weiterhilft.

 

Ich benutze einen Cisco 801 welche sich wunderbar in das Internet einwählt (danke eurer Hilfe).

 

Soweit so gut....

 

.. nun soll dieser Cisco aber auch von aussen per ISDN-Einwahl von einer ISDN-Karte aus erreichbar sein.

 

Ich weiß bis dato das beides einzeln problemlos umsetztbar ist doch beides zusammen soll wohl schwierigkeiten geben und ich muss ehrlich gestehen ich habe es noch nicht hinbekommen.

 

Hat jemand für mich vielleicht ein Konfigurationbeispiel als hilfestellung o.ä. ???

 

Wäre super.

 

LG Euer Volvo

Share this post


Link to post

Hallo hier meine derzeit laufende Konfig die ist nur für internetzugang ausgelegt den rest habe ich nach dem nichts ging wieder verworfen :(

 

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco801

!

logging buffered 8192 debugging

enable secret blablabla

!

username blablabla password blablabla

!

!

!

!

ip subnet-zero

no ip source-route

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

interface Ethernet0

ip address 192.168.0.50 255.255.255.0

ip access-group 121 in

no ip proxy-arp

ip nat inside

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn answer1 99999999

ppp authentication chap pap callin

!

interface Dialer1

description ISP

ip address negotiated

ip access-group 121 in

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name Cisco1

dialer idle-timeout 30

dialer string 0191011 class DialClass

dialer hold-queue 10

dialer-group 1

pulse-time 0

ppp authentication chap pap callin

ppp chap hostname blablabla@t-online.de

ppp chap password blablabla

ppp pap sent-username blablabla@t-online.de password blablabla

!

ip nat inside source list 101 interface Dialer1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

map-class dialer DialClass

access-list 101 permit tcp any any eq www log

access-list 101 permit udp any any eq domain log

access-list 101 permit tcp any any eq smtp log

access-list 101 permit tcp any any eq pop3 log

access-list 101 deny udp any eq 53 any log

access-list 102 deny udp any eq netbios-dgm any

access-list 102 deny udp any eq netbios-ns any

access-list 102 deny udp any eq netbios-ss any

access-list 102 deny udp any range snmp snmptrap any

access-list 102 deny udp any range bootps bootpc any

access-list 102 deny tcp any eq 137 any

access-list 102 deny tcp any eq 138 any

access-list 102 deny tcp any eq 139 any

access-list 102 permit ip any any log

access-list 102 deny tcp any eq 445 any

access-list 102 deny tcp any eq 135 any

access-list 102 deny tcp any eq 123 any

access-list 102 deny tcp any eq 1433 any

 

dialer-list 1 protocol ip list 102

!

logging 192.168.0.51

logging trap

logging loopback 0

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

!

time-range TIME

periodic daily 0:00 to 23:59

!

end

 

 

Ich hoffe ihr könnt mir helfen bzw mir is noch zu helfen. :(

 

so long euer volvo

Share this post


Link to post

hi volvo,

 

 

du stellst erstmal das bri am besten auf ppp authentication ms-chap ohne callin, für die interneteinwahl sollte der router immer noch pap einseitig machen, wenn das ios keine macke hat. dann legst du einen zweiten dialer an, hier auch die ppp authentication auf ms-chap stellen, dieler remote-name wird der username für den pc, dann noch einen user auf dem router anlegen mit entsprechendem passwort:

 

 

Dialer 2

description PC Einwahl

ip address x.x.x.x netmask 255.255.255.0

no ip proxy-arp

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name <pcusername>

dialer idle-timeout 30

dialer hold-queue 10

dialer-group 1

peer default ip address y.y.y.y

ppp authentication ms-chap

 

 

wenn der pc ins internet soll, noch ip nat inside berücksichtigen. die ip y.y.y.y bekommt der pc zugewiesen und es wird bei erfolgreicher einwahl eine route auf dem router installiert. dann solltest du deine acl 102 nochmal überdenken, da steht ein permit ip any any vor denys, d.h. permit ip any any sollte ganz untern stehen und alle denys davor. auf dem dialer 1 hast du eine acl 121, die gibt es nicht! das riecht nach einer config maker config, ein supertolles cisco tool :cry:

 

gruss

 

rob

Share this post


Link to post

also nur die authentifizzierung in meiner bisherigen config ändern ???

 

Dann den dialer 2 hinzufügen ???

 

Das wars ??

 

Ach ja wie lege ich einen User auf dem teil an :( sry bin was cisco angeht nicht die leuchte es ist mein erster :(

 

Ins internet muss der PC der sich einwählt nicht zugreifen klnnen aber er sollte eine IP zugewiesen bekommen. :(

 

Noch eins was ich nicht verstehe: "dieler remote-name wird der username für den pc"

 

Das heißt der Pc der sich einwählen will MUSS so heißen und der dialer und ethernet sollte also statt 121 da 102 stehen habe richtig ??

 

Was besagt ip address x.x.x.x muss da die normale IP des routers rein die auch schon beim ethernet steht ?

 

Danke erstmal für die hilfe.

 

LG Volvo

Share this post


Link to post

Ach ja so siehts nun aus....

 

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Cisco801

!

logging buffered 8192 debugging

enable secret ***

!

username *** password ***

!

!

!

!

ip subnet-zero

no ip source-route

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

interface Ethernet0

ip address 192.168.0.50 255.255.255.0

ip access-group 102 in

no ip proxy-arp

ip nat inside

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn answer1 nraufdererantwortensoll

ppp authentication ms-chap

!

interface Dialer1

description ISP

ip address negotiated

ip access-group 102 in

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name Cisco1

dialer idle-timeout 30

dialer string 0191011 class DialClass

dialer hold-queue 10

dialer-group 1

pulse-time 0

ppp authentication ms-chap

ppp chap hostname ***

ppp chap password ***

ppp pap sent-username ***

!

interface Dialer 2

description PC Einwahl

ip address 192.168.0.50 netmask 255.255.255.0

no ip proxy-arp

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name <pcusername>

dialer idle-timeout 30

dialer hold-queue 10

dialer-group 1

peer default ip address 192.168.0.199

ppp authentication ms-chap

!

ip nat inside source list 101 interface Dialer1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

map-class dialer DialClass

access-list 101 permit tcp any any eq www log

access-list 101 permit udp any any eq domain log

access-list 101 permit tcp any any eq smtp log

access-list 101 permit tcp any any eq pop3 log

access-list 101 deny udp any eq 53 any log

access-list 102 deny udp any eq netbios-dgm any

access-list 102 deny udp any eq netbios-ns any

access-list 102 deny udp any eq netbios-ss any

access-list 102 deny udp any range snmp snmptrap any

access-list 102 deny udp any range bootps bootpc any

access-list 102 deny tcp any eq 137 any

access-list 102 deny tcp any eq 138 any

access-list 102 deny tcp any eq 139 any

access-list 102 deny tcp any eq 445 any

access-list 102 deny tcp any eq 135 any

access-list 102 deny tcp any eq 123 any

access-list 102 deny tcp any eq 1433 any

access-list 102 permit ip any any log

 

dialer-list 1 protocol ip list 102

!

logging 192.168.0.51

logging trap

logging loopback 0

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

!

time-range TIME

periodic daily 0:00 to 23:59

!

end

 

Ich hoffe soweit richtig verstanden ?? *hoff*

Share this post


Link to post
also nur die authentifizzierung in meiner bisherigen config ändern ???

 

Dann den dialer 2 hinzufügen ???

 

Das wars ??

 

Ach ja wie lege ich einen User auf dem teil an :( sry bin was cisco angeht nicht die leuchte es ist mein erster :(

 

Ins internet muss der PC der sich einwählt nicht zugreifen klnnen aber er sollte eine IP zugewiesen bekommen. :(

 

Noch eins was ich nicht verstehe: "dieler remote-name wird der username für den pc"

 

Das heißt der Pc der sich einwählen will MUSS so heißen und der dialer und ethernet sollte also statt 121 da 102 stehen habe richtig ??

 

Was besagt ip address x.x.x.x muss da die normale IP des routers rein die auch schon beim ethernet steht ?

 

Danke erstmal für die hilfe.

 

LG Volvo

 

 

DIe config sieht schonmal nicht schlecht aus, den user legst du so an:

 

 

enable mode( erkennst du an raute #)

 

config t<enter>

user <pcusername> pass <passwort><enter>

 

exit<enter>

 

wr<enter>

 

die access-l 102 würde ich nicht auf den dialer setzen... ursprünglich gabes da sicher mal eine andere vom configmaker...

 

die ip adresse sollte nicht die vom lan interface des router sein, dass ist ok, wenn diese im lan nicht benutzt wird. der pc bekommt jetzt die 192.168.0.199 zugeweisen,

 

 

dann versuch mal dein glück, hoffentlich spielt das ios mit, da gibts diverse bugs...

 

 

 

am besten noch auf dem router debug isdn q931, debug ppp authentication und debug ppp negotiation anschalten + terminal monitoring und mal mit dem pc anklingeln... und natürlich auch internet noch einmal prüfen...

 

gruss

 

rob

Share this post


Link to post

vom config maker ?? mag sein k.a. :(

 

Der hat ja nie gescheit funktioniert :( der maker mein ich

 

also lass ich die accesslist auf 121 beim dialer ???

 

die ip adresse sollte nicht die vom lan interface des router sein ???

 

also eine zweite hernehmen meintewegen die 192.168.0.53 o.ä. ??

 

die 199 is für den externen pc korrekt die wird im netzwerk nicht genutzt.

Share this post


Link to post

Hi,

 

du kannst das zwar lassen mit der acl 121, aber die müsstest du erstmal anlegen, die gibts im moment gar nicht... ansonsten ist das ok mit der ip.

 

 

gruss

 

rob

Share this post


Link to post

Nun meine letzte frage was sollte denn dann in der 121 drin stehen ?? und wozu dann die 101 und 102 ??

 

Ich probiere es jetzt mal aus :)

hab tausend dank im vorraus

Share this post


Link to post

Das mit dem mschap geht leider nicht also ich muss das mit der authentifizierung leider mit dem callin lassen.

 

Wenn ich mich nun in der router einwählen will (internet funzt super) kommt folgendes...

 

TCP/IP Cp gemeldeter fehler 733 ein unbekannter fehler ist aufgetreten.

Share this post


Link to post

Fehler gefunden

 

IP unnumbered Eth0

 

wenn man:

 

interface Dialer 2

description PC Einwahl

----> ip address 192.168.0.50 netmask 255.255.255.0 gegen oben genanntes austauscht funzt es super.

no ip proxy-arp

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name <pcusername>

dialer idle-timeout 30

dialer hold-queue 10

dialer-group 1

peer default ip address 192.168.0.199

ppp authentication ms-chap

 

Hab tausend dank

Share this post


Link to post

Ein letztes Problem ich bin eingewählt aber kann auf keinen der Rechner im Netzwerk zugreifen. :( hast du noch nen letzte idee ???

 

Schaut mir so nach routing o.ä. aus :( bin einfach hilflos :( erreiche den router per pings auf seiner eth addi aber keinen einzigen rechner der da dran hängt :(

 

Hier die config die so weit funzt

 

!

version 12.1

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname ***

!

logging buffered 8192 debugging

enable ***

!

username *** password ***

username *** password ***

!

!

!

!

ip subnet-zero

no ip source-route

!

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

interface Ethernet0

ip address 192.168.20.50 255.255.255.0

ip access-group 121 in

no ip proxy-arp

ip nat inside

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

isdn answer1 ***

isdn answer2 ***

ppp authentication chap pap callin

!

interface Dialer1

description ISP

ip address negotiated

ip access-group 121 in

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name Cisco1

dialer idle-timeout 30

dialer string 00191011 class DialClass

dialer hold-queue 10

dialer-group 1

pulse-time 0

ppp authentication chap pap callin

ppp chap hostname ***

ppp chap password ***

ppp pap sent-username *** password ***

!

ip nat inside source list 101 interface Dialer1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

interface Dialer 2

description PC Einwahl

IP unnumbered Eth0

no ip proxy-arp

encapsulation ppp

no ip split-horizon

dialer pool 1

dialer remote-name einwahl

dialer idle-timeout 60

dialer hold-queue 10

dialer-group 1

peer default ip address 192.168.20.199

ppp authentication ms-chap

!

!

map-class dialer DialClass

access-list 101 permit tcp any any eq www

access-list 101 permit udp any any eq domain

access-list 101 permit tcp any any eq smtp

access-list 101 permit tcp any any eq pop3

access-list 101 deny udp any eq domain any

access-list 102 deny udp any eq netbios-dgm any

access-list 102 deny udp any eq netbios-ns any

access-list 102 deny udp any eq netbios-ss any

access-list 102 deny udp any range snmp snmptrap any

access-list 102 deny udp any range bootps bootpc any

access-list 102 deny tcp any eq 137 any

access-list 102 deny tcp any eq 138 any

access-list 102 deny tcp any eq 139 any

access-list 102 deny tcp any eq 445 any

access-list 102 deny tcp any eq 135 any

access-list 102 deny tcp any eq 123 any

access-list 102 deny tcp any eq 1433 any

access-list 102 permit ip any any log

access-list 121 deny udp any eq netbios-ss any

access-list 121 deny tcp any eq 137 any

access-list 121 deny tcp any eq 138 any

access-list 121 deny tcp any eq 139 any

access-list 121 permit ip any any time-range TIME

dialer-list 1 protocol ip list 102

!

line con 0

exec-timeout 120 0

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

!

time-range TIME

periodic daily 0:00 to 23:59

!

end

Share this post


Link to post

Hi,

 

 

mit arp -a siehst du auf nem xp rechner, welche ip adressen im gleichen netzwerk arp mässig auf gelöst werden, du könntest natürlich auf dem router auch eine ip aus einem anderen netz zuweisen und routen... arp müsste in deinem fall auf jeden fall gehen, da die ip aus dem gleichen netz ist...

 

 

gruss

 

 

rob

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...