Jump to content
Sign in to follow this  
weg5st0

IIS6.0 CGI Cookie Header

Recommended Posts

Hallo Board,

 

ich hab mal wieder was kniffliges:

 

Win2003 aktuelles Patchlevel (kein SR2). Englische Version mit deutscher Benutzeroberfläche.

 

Hier läuft eine CGI-Applikation die Daten verschlüsselt (Sonderzeichen) in einem Cookie ablegt.

 

Ruft man die Seite auf (Cookie gelöscht) geht alles wie gewünscht. Das Cookie wird dann lokal abgelegt.

 

Ruft man die Seite erneut auf (mit vorhandenem Cookie), dann bringt der Webserver einen 400 - Bad request (Die Applikation wird gar nicht erst angefasst - Der Fehler kommt vom IIS).

 

Meine Analyse hat ergeben: Der GET vom Client wird dann mit 400 beantwortet, wenn in dem Cookie-Headerfield des HTTP-Get-Pakets Werte mit Sonderzeichen (ist ja verschlüsselt) stehen.

 

Dann habe ich den Artikel gefunden:

http://support.microsoft.com/kb/824446/en-us

Leider ist das Patch schon drauf (gehört zu SP1) und das Workaround hilft auch nicht weiter.

 

Hat sonst jemand eine Idee?

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...