Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
darktemplar

Cisco ISDN Router Konfig Hilfe !

Empfohlene Beiträge

ok danke , dann hab ich das mal verstanden...

Ihr merkt ich bin noch nicht solange dabei, umsomehr bin ich für Eure Hilfe dankbar.

Ich melde mich gleich wieder nach Versuch NR. 123

 

PS: Der Dialer wurde schon immer angesprochen, hab ich vielleicht im 1 Post nicht genau gesagt. Ich seh aber beim debuggen, dass in jedem Fall der richtige Dialer ausgwählt wurde, dann aber ein Fehler à la: "no dialer-group defined" oder "no free dialer - starting idle fast timer" kommt.

Nun gibts ja so ein schönes Troubleshooting Guide von Cisco, wo genaus diese Fälle beschrieben sind. Das hab ich auch alles probiert, bevor ich hier gepostet habe - ohne Erfolg.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Also die Troubleshooting Reihenfolge sollte jetzt so aussehen:

1) wird der richtige Dialer ausgewählt (ping + debug ppp dialer)

2) wählt der B-Kanal die Gegenstelle korrekt an (Layer 2/3 -> debug isdn q933)

3) schafft PPP den Verbindungsaufbau über die ISDN Leitung

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi darktemplar,

 

ios version ist auch nicht das beste, was ich mir vorstellen kann, wie gesagt normalerweise gibt es entweder in-band oder dialer pool aber nicht beides zusammen in einer config, da sich die befehle gegenseitig ausschließen, und das ios warnt

 

hier ein beispiel, der dialer ist in einem pool und ich will diesen zu einer in-band configuration ändern (ios 12.3.10 cisco 3660):

 

router(config)#in dia 1

router(config-if)#dialer in-band

%Remove dialer profile config first

 

umgedreht sollte es genauso sein, kann ich nur nicht testen, da ich keine laufende config mit rotary-group habe...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@rob67

also "dialer in-band" - benutzt man das nicht nur wenn man analoge Gegenstellen von einem ISDN BRI oder PRI aus anwählt? Was hat der "dialer pool" damit zu tun? Also Rotary-Group und Dialer-Pool sollte man alternativ benutzen ...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@wursti:

 

sage ich doch dauernd, er hat beides in seinem dialer drin! du kannst den dialer ganz normal auch mit rotary group benutzen hast allerdings nur einen dialer und müsstest mit maps arbeiten

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@rob: stimmt - hat mich auch gewundert.

Sind wir mal gespannt was uns darktempla gleich berichten wird ...

 

@darktemplar:

Also ich denke sinnvoll wäre eine aktuelle konfig und die Fehlermeldung aus dem debug die sich reproduzieren läßt. Damit die konfig nicht so lang wird, es reichen ja Routingtabelle, BRI, Dialer und die dialer-lists und ACL - kann man ja ein bisschen zusammenstreichen. Irgendwie kriegen wir ja nichtmal raus woran ungefähr es liegen könnte - Authentifizierung käme ja auch noch in Frage. Die Konfiguration der Gegenstelle wäre dafür ja auch wichtig - und genau dieses Router zu Router wählen klappt ja nicht ...

 

Bisher haben wir ja nur auf Deine erste Konfig geguckt und so vermutet, und geschaut was etwas ungewöhnlich aussieht ...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

ok eine aktuelle konfig folgt....

 

nochmals klar zu sagen: die verbindung zur Aussenstelle klappt einwandfrei, aber eben nur solange der 2. Dialer nicht in der konfig steht.

 

Mein Vorgehen: Ich passe die Konfig an, lade sie in die startup-config des Routers --> reload.

 

Eine aktuelle Konfig folgt.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

... ein reload musst Du nicht jedesmal machen - die Änderungen werden eigentlich sofort wirksam.

 

Mach das Debugging lieber über Telnet - ist weniger CPU intensiv (einloggen per telnet: terminal monitor)

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Anebi die aktuelle Konfig (gekürzt):

 

 

!

interface Dialer 1

description connected to xxxxxxx

ip address 172.16.4.1 255.255.255.0

no ip directed-broadcast

no ip split-horizon

encapsulation ppp

dialer idle-timeout 60

dialer hold-queue 10

dialer map ip 172.16.4.13 name xxxxx xxxxxxxxxxxx

dialer caller xxxxxxxxxxxxx

!

dialer-group 1

dialer pool 1

!

ppp authentication chap

ppp chap hostname xxxxxxxxx

no ppp multilink

no cdp enable

!

!

interface dialer 2

description connected to Internet

ip address negotiated

ip nat outside

no ip split-horizon

encapsulation ppp

dialer idle-timeout 120

dialer string xxxxxxxxxxxx

dialer hold-queue 10

dialer remote-name xxxxxxxx

!

dialer-group 2

dialer pool 1

!

ppp authentication chap pap callin

ppp chap hostname xxxxxxx

ppp chap password xxxxxxxxxxx

ppp pap sent-username xxxxxxx password xxxxxxxx

no ppp multilink

no cdp enable

!

!

interface BRI 0

!

no shutdown

description connected to xxxxxxx,Internet

no ip address

encapsulation ppp

ppp authentication chap

dialer pool-member 1

!

!

!Dialer Control List 1

access-list 101 permit ip any any

access-list 102 permit ip any any

!

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

!

! IP Static Routes

ip route 172.16.13.0 255.255.255.0 172.16.4.13

ip route 0.0.0.0 0.0.0.0 dialer 2

 

 

Nun die Fehlermeldungen:

 

Wenn ich mit reload die config ins startup schreiben will, kommt erstmal das:

%Configure a "dialer in-band", or "dialer pool" first

%Configure a "dialer in-band", or "dialer pool" first

%Configure a "dialer in-band", or "dialer pool" first

 

 

Ping geht jetzt weder ins Internet noch zur Filiale. z.B. mach ich ping 212.40.5.50 (öffentlicher DNS)

erhalte als Debug Info folgendes:

Mar 1 00:03:21.052: Di2 DDR: ip (s=172.16.8.1, d=212.40.5.50), 100 bytes, outg

oing interesting (list 102).

 

--> D.h. für mich: er hat den richtigen Dialer gewählt (Di2)

nach ein paar Sekunden folgt dies:

 

*Mar 1 00:03:36.340: BR0 DDR: cdp, 296 bytes, outgoing uninteresting (no dialer

-group defined)

*Mar 1 00:03:36.344: BR0 DDR: Packet sent directly to pool or rotary group memb

er : dropping packet.

 

 

Dasselbe mit der Filialenverbindung, nur wird dort (ebenfals richtig) Dialer 1 ausgwählt:

Mar 1 00:06:33.680: Di1 DDR: ip (s=172.16.4.1, d=172.16.13.1), 100 bytes, outg

oing interesting (list 101).

*Mar 1 00:06:35.676: Di1 DDR: ip (s=172.16.4.1, d=172.16.13.1), 100 bytes, outg

oing interesting (list 101)

*Mar 1 00:06:36.340: BR0 DDR: cdp, 296 bytes, outgoing uninteresting (no dialer

-group defined)

*Mar 1 00:06:36.340: BR0 DDR: Packet sent directly to pool or rotary group memb

er : dropping packet..

 

Was ich nicht ganz verstanden habe: Mann sollte Pool-Member und Group nicht mixen ?! aber ich brauch doch die group für die Access lists....

Ich hab auch schon sämtliche group Befehle weggelassen - nix gebracht..

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

gib doch noch einmal neu dialer pool auf den dialern ein, möglicherweise hast du eine alte config verwendet und der dialer pool steht an der falschen Stelle, deine dialer hängen in der luft, nein vergiss es , aber deine config ist merkwürdig dargestellt... die dialer maps solltest du aber nicht konfigurieren, die sind doch normalerweise auch nur bei in-band verfügbar... :confused: die dialer group bleibt natürlich drauf, damit definierst du den traffic fürs wählen und leitung offenhalten!

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ok dialer map ist draussen. Auch die Konfig hab ich über den Mittag komplett neu gemacht.

Dazwischen hab ich es auch mit neuen Nummern für die Pools und Dialers versucht.

 

Mich irritiert aber schon die erste Fehlermeldung beim "Reload" Befehl ?!

 

Warum verlangt er nach einem dialer in-band oder einem Pool ? Der Pool existiert doch, warum merkt er's nicht. Sehrwahrscheinlich hab ich irgendwo einen ganz trivialen Fehler drin...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Wenn Du eh in deinen ACL 101 + 102 permit ip any any benutzt könntest Du die dialer-list auch einfacher schreiben und stattdessen "dialer-list 1 protocol ip permit" schreiben.

 

eigentlich würde ich als nächstes "debug ppp negotiation" ausprobieren. Mit der Fehlermeldung beim Abspeichern kann ich garnichts anfangen. Die dialer pool konfiguration ist eigentlich tadellos ???

 

Ohne dialer-group X Befehl wird die Verbindung nie aufgebaut werden. Das ist allenfalls für einen Dialer denkbar der nur eingehende Anrufe annimmt ... "Mischen" kann man die schon - was auch immer das heißen soll - die Befehle haben eben nichts miteinander zu tun.

 

Also ich sehe jetzt wenig Ansatzpunkte - soll die Fehlermeldung bedeuten dass die Konfiguration garnicht anzuspeichern ist?? Das hieße nichts weiter als das die KOnfiguration die die debug-meldungen nicht die ist die wir zu sehen kriegen oder?

Ich habe jetzt echt Schwierigkeiten den Änderungen zu folgen. Wir bräuchten mal eine Konfig, die wenigstens halb geht - und von da aus müssen wir weiter. Dann muss man entscheiden z.B. "no ip split-horizon" ist ein nutzloser Befehl - wie kommt der da rein? Und wenn man sich über so ein Problem klar ist, nächster punkt ...

 

Der debug zeigt ja cdp-Packete an obwohl die auf dem dialer eigentlich disabled sind? vielleicht kann man das auchmal mit "no cdp run" im globalen-config abschalten.

 

Gruss

Robert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@darktemplar: ich hab den Eindruck das da irgenwie immer mit textfiles hantiert wird. Die Ausrufezeichen sind wirklich an komischen Stellen - Wer hat denn Dialer Control List 1 da rein geschrieben - die kämen doch erst 4 Zeilen später. Ist da irgend so ein komischer automatischer Konfig-Maker zugange??

 

Gruss

Robert

 

PS: ist das echt die "show running-config" die wir da sehen?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×