Jump to content

Relaunch 2018: Willkommen im neuen Forum - Das MCSEboard.de wurde runderneuert. Wir wünschen Euch viel Spaß an Board.

Melde dich an, um diesem Inhalt zu folgen  
darktemplar

Cisco ISDN Router Konfig Hilfe !

Empfohlene Beiträge

Hallo zusammen,

 

Nach x-Stunden probieren muss ich nun Eure Hilfe beanspruchen. Es geht um einen Cisco 803 ISDN Router.

 

Ich möchte gerne 2 verschiedene Verbindungen Einrichten:

 

Dialer 1:

Verbindung zu einem anderen Cisco Router

 

Dialer 2:

Verbindung mit einem Internet Provider

 

Nun habe ich beide Verbindungen konfiguriert und einzeln verwendet (jeweils den anderen Dialer mit ! auskommentiert)- funktionieren beide. Sobald ich aber beide in einem File zusammenfüge geht jeweils nur 1 Dialer ! Nun mein ich alles richitg gemacht zu haben mein Konfig sieht so aus (nur die wichtigen Passagen):

 

interface dialer 1 (Anbindung Cisco)

...

dialer group 1

dialer pool 1

....

 

 

 

interface dialer 2 (Internetanbindung)

..

dialer group 1

dialer pool 2

...

 

 

 

interface BRI O

...

dialer pool-member 1

dialer pool-member 2

...

 

 

--> Ist die Konfig so wie oben beschrieben geht NUR die Einwahl ins Internet

Ersetzte ich den Eintrag "dialer pool-meber 1" durch *dialer rotary-group 1" so funktioniert die Einwahl ins Internet nicht mehr, dafür klappt mit der Einwahlverbindung auf den anderen Cisco !

 

Ich hab aus Verzweiflung schon alle möglichen (und unsinnigen) Kombinationen ausprobiert - ohne Erfolg !

 

Hat jemand eine Idee ? Bin sehr dankbar für Eure Hilfe,

 

Gruess

 

Marc

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Anbei meine aktuelle Konfig:

So wie sie hieer steht klappts mit dem Internet...

 

Gruss

 

 

!*************************************************

!

! SYSTEM-KONFIGURATION - xxxxxxxx.cfg

!

! Serverkonfiguration für xxxxxxxx

!

! xxxxxxxx

!

!--------------------------------------------------

!

! Hostname : xxxxxxxx

! Modell : Cisco 803

!

!****************************************xxxxxxxx

! Änderungen:

! --------------------------------

! xxxxxxxx

!

!

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

no service tcp-small-servers

no service udp-small-servers

!

hostname xxxxxxxx

!

enable password xxxxxxxx

username xxxxxxxx password xxxxxxxx

!

no ip name-server

!

isdn switch-type basic-net3

no pots country

!

!

ip subnet-zero

no ip domain-lookup

ip routing

!

interface Dialer 1

description connected to xxxxxxx

ip address 172.16.4.1 255.255.255.0

no ip directed-broadcast

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 60

dialer hold-queue 10

dialer map ip 172.16.4.13 name xxxxxxxx xxxxxxxx

dialer caller xxxxxxxx

dialer-group 1

dialer pool 1

 

 

!

!

ppp authentication chap

ppp chap hostname xxxxxxxx

!

no ppp multilink

no cdp enable

!

!

interface dialer 2

description connected to Internet

ip address negotiated

ip nat outside

no ip split-horizon

encapsulation ppp

dialer in-band

dialer idle-timeout 120

dialer string xxxxxxxx

dialer hold-queue 10

dialer remote-name xxxxxxxx

dialer-group 1

dialer pool 2

 

ppp authentication chap pap callin

ppp chap hostname xxxxxxxx

ppp chap password xxxxxxxx

ppp pap sent-username xxxxxxxx password xxxxxxxx

no ppp multilink

no cdp enable

!

!

interface Ethernet 0

no shutdown

ip address 172.16.8.1 255.255.255.0

no ip directed-broadcast

keepalive 10

!

interface BRI 0

 

no shutdown

description connected to xxxxxx,Internet

no ip address

encapsulation ppp

ppp authentication chap

dialer pool-member 1

dialer pool-member 2

 

!

!

!Dialer Control List 1

access-list 101 permit ip any any

 

!

dialer-list 1 protocol ip list 101

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

Dynamic NAT

ip nat translation timeout 86400

ip nat translation tcp-timeout 86400

ip nat translation udp-timeout 300

ip nat translation dns-timeout 60

ip nat translation finrst-timeout 60

ip nat inside source list 2 interface dialer 2 overload

!

ip nat inside source list 1 interface dialer 1 overload

 

ip classless

!

! IP Static Routes

ip route 172.16.13.0 255.255.255.0 172.16.4.13

ip route 0.0.0.0 0.0.0.0 dialer 2

 

 

!

no ip http server

no snmp-server location

 

 

 

 

no snmp-server contact

banner motd #xxxxxxxx#

!

line console 0

exec-timeout 0 0

password test

 

login

transport input none

!

line vty 0 4

password test

login

!

!

no service pad

no rcapi server

!

end

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

du hast immer noch beide Konfigurationen gemischt, die dialer hängen nicht im pool, mach mal auf den dialer no dialer in-band und dann noch mal dialer pool 1 und schau, ob es dann geht

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Rob,

 

Erstmals Danke für die schnelle Antwort. Ich bin hier am verzweifeln....

Ich habe nun beim Dialer 1 den Eintrag "no dialer in-band" vor den "dialer-group 1 " Eintrag eingefügt - ohne Erfolg.

 

wie gesagt, Dialer 2 (Internet) funktioniert so. Dialer 1 nicht. Das debugging meldet aber, dass das IP Routing richtig funktioniert. D.H. wenn ich ne IP aus dem 172.16.X.X Netz pinge, dann wird der Dialer 1 aufgerufen aber es steht: no dialer group defined.

 

weitere Idee ?

 

Merci und Gruss

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

das dialer in-band muss auf jedenfall raus, das kommt noch von der rotary-group, sonst lösch doch nochmal die dialer und leg sie nochmal neu an! die in-band Konfiguration hat nur einen dialer, normalerweise dürfte das gar nicht zusammen auf einem dialer stehen, möglicherweise liegt es an deinem ios, steht jetzt immer noch dialer in-band in der config drin?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Die Konfig ist gleich wie vorher, nur steht anstatt "dialer in-band" jetzt "no dialer in-band".

Ausserdem meldet er beim "reload" Befehl:

 

configure a "dialer in-band" or "dialer-pool" first

 

Das hab ich doch schon , oder ?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

sehr merkwürdig, der router scheint ein problem mit deiner config zu haben, der router zeigts zwar an, machts aber nicht, no dialer in-band dürfte gar nicht dastehen sondern nur dialer pool, kopier doch mal beide dialer, lösch sie komplett und leg sie am besten mit einer neuen Nummer neu an ohne diesen in-band befehl! oder du schreibst eine neue startup-config ohne diesen in-band befehl, welche ios version hast du?

 

Grüsse

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@darktemplar:

folgende drei Befehle müssen bei Dir mal "sortiert" werden

dialer-group 1

dialer-list 1 protocol ip ...

access-list ...

 

Du hast beide Dialer über dieselbe dialer-list angesprochen. Der im Befehl dialer-list definierte traffic bestimmt welcher traffic den Dialer auslösen soll. Du musst also schon mal mind. 2 verschiedene dialer-lists referenzieren. Also unter

 

Dialer 1 kommt > dialer-group 1

Dialer 2 kommt > dialer-group 2

 

jetzt werden 2 verschiedene dialer-list erstellt

 

dialer-list 1 protocol ip list 101

dialer-list 2 protocol ip list 102

 

in einer entsprechenden ACL definiert man jetzt den genauen traffic

 

access-list 101 permit ip 172.16.8.0 0.0.0.255 172.16.4.0 0.0.0.255

(oder access-list 102 permit ip any 172.16.4.0 0.0.0.255)

eure Zweigstelle

access-list 102 permit ip 172.16.8.0 0.0.0.255 0.0.0.0 0.0.0.0

ISP (besser über die einzelnen Ports ausarbeiten)

 

Also mach die die Regeln klar "dialer-group 1" bezieht sich auf "dialer-list 1 protocol ip list 101". Diese bezieht sich auf die ACL 101 ...

 

Etwas anderes: Du brauchst nicht mit mehreren Dialer-Pools zu arbeiten, Du hast ja nur eine BRI Schnittstelle. Beide Dialer können mit Dialer Pool 1 denselben Pool benutzen. unter BRI0 reicht dann dialer pool-member 1.

 

Gruss

Robert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@wursti

 

Hallo Robert, es ist durchaus legitim, verschiedene dialer mit der gleichen dialer list anzusprechen, solange der traffic der gleiche typ ist, der zur anwahl führt. die nutzung der dialer selbst steuert das routing!

 

Gruss

 

Rob

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@rob

ja, mmhh, könnte sein - bin mir selbst da nicht sicher.

 

darktemplar schreibt aber das die Dialer einzeln gehen wenn er den jeweils anderen auskommentiert. Deshalb vermute ich den Fehler in der Auswahl der Dialer. In Beitrag 5 schreibt er "no dialer-group defined" ... Die Dialer selbst laufen ja erstmal ...

 

@darktemplar

Bitte "debug ppp dialer" benutzen etc.

 

Gruss

Robert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

kleiner Nachtrag/Frage:

gibt es nicht noch ein drittes Subnetz? Dein LAN am Fa0 hat 172.16.8.0/24, dein Dialer zwischen den CISCO Routern hat 172.16.4.0/24 - dann sollte es doch ein drittes IP Subnetz geben, an der LAN Schnittstelle dieses anderen Routers ... ist das 172.16.13.0/24?

 

.. dann müsste meine ACL 101 die ich vorhin gepostet habe natürlich entsprechend korrigiert werden - sorry - (also dann .13 statt .4)

 

Gruss

Robert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstmal danke @all

 

Die IOS Version ist: 12.3(5d)

 

Wenn ich nun die beschriebenen Gruppen bilde

 

dialer 1 --> dialer-group 1

dialer 2 --> dialer-group 2 (das war in meiner Urpsrungskonfig auch auf dialer-group 1)

 

was muss beim BRI 0 stehen ?

 

dialer pool-member 1 (klar)

Muss hier kein Verweis auf die beiden dialer groups gemacht werden ?

 

Ich erstelle in der Zwischenzeit ne neue Konfig - wie empfohlen....

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

@ robert:

 

richtig erkannt mit den Subnetzen, hab die access list entsprechend angepasst.

 

Wie gesagt, es wird beim pingen der jeweils richtige dialer ausgwählt (das seh ich beim debuggen). Auch ist der Traffic als interesting eingestuft.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

1. mit "dialer pool-member 1" mit BRI0 dem Pool 1 zugeordnet - fertig.

2. mit "dialer pool 1" wird Dialer X gesagt: benutze ein BRI/B-Kanal aus dem Pool 1 - fertig.

 

dialer-list und dialer-group haben mit dem BRI nichts mehr zu tun.

dialer-group X sagt: benutze dialer-list X (dort steht dann weiteres)

 

Gruss

Robert

 

PS: dein Beitrag 14:

heißt das der Dialer wird nun angesprochen - anders als im Beitrag 1 Ist das ne Verbesserung?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesem Inhalt zu folgen  

×