Jump to content

Router wählt sich nicht ein (ISDN)


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hi, sorry das ich schon mit dem nächsten Problem nerve,

 

Ich habe einen alten 1603 Cisco (IOS 11.2) bekommen und

wollte die Einwahl über ISDN mal ausprobieren. Ich hab mir schon

eine Konfig zusammen gebaut. Da Problem ist das Dialer1 und Bri0 Interface sind zwar up , aber die Beiden ISDN Kanäle

bleiben down .

 

Wäre super wenn mir jemand einen Tip geben könnte :

 

Danke im Voraus :-)

 

 

Hier mal meine Konfig, hab ich mir aus einigen Beiträgen

zusammen gebaut:

 

 

Building configuration...

 

Current configuration:

!

version 11.2

service timestamps debug uptime

service timestamps log uptime

service password-encryption

no service udp-small-servers

no service tcp-small-servers

!

hostname router

!

enable secret 5 xxxxxxxxxxxxxxxxx.

enable password 7 xxxxxxxxxxxxxxxx

!

ip subnet-zero

no ip source-route

no ip domain-lookup

isdn switch-type basic-net3

clock timezone CET 1

clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 1:00

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

no ip directed-broadcast

no ip proxy-arp

load-interval 30

no cdp enable

!

interface BRI0

description isdn-Interface

no ip address

ip access-group Internet in

encapsulation ppp

load-interval 30

dialer pool-member 1

no fair-queue

no cdp enable

ppp authentication chap pap callin

!

interface Dialer1

description Internet

no ip address

no ip directed-broadcast

no ip proxy-arp

encapsulation ppp

no ip split-horizon

bandwidth 64

load-interval 30

dialer remote-name Cisco1

dialer idle-timeout 30

dialer string xxxxxxxxx

dialer hold-queue 10

dialer load-threshold 255 outbound

dialer pool 1

dialer-group 1

no fair-queue

no cdp enable

ppp authentication chap pap callin

ppp chap hostname xxxxxxxxxx

ppp chap password 7 xxxxxxxxxxxxxx

ppp multilink

pulse-time 0

!

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

map-class dialer DialClass

access-list 101 deny udp any eq ntp any

access-list 101 permit ip any any

no cdp run

dialer-list 1 protocol ip list 101

!

line con 0

line vty 0 4

password 7 xxxxxxxxx

login

!

end

Link to comment

Hi quenton

 

Habe gerade nicht viel Zeit ! Habe deshalb nur schnell überflogen,

aber warum verwendest Du keine IP am dialer interface ?

Zumindest ip unnumbered to eth wäre hier denkbar !

Jedoch sollte es der Router gegenüber auch tun !

Oder bekommst Du vom Router gegenüber eine IP ?

Dann ip address negotiated !

Als nächtes "ppp authentication chap pap callin"

hiermit auth. der Router nur eingehende Anrufe !

Welcher Router macht den die Einwahl ? Oder müssen sich beide

Router zueinander einwählen dürfen ? Dann solltest Du das callin wieder entfernen.

Und ppp multilink ! Warum multilink, wenn Du em Interface dialer 1 den Bandbreiten-command 64 mitgibst ?

 

Tip !

Debuggen !

 

Router#terminal monitor

Router#debug isdn events

Router#debug isdn q921

Router#debug isdn q931

Router#debug ppp authentication

 

Damit siehst Du schon mal wenigstens, ob der Router überhaupt

versucht das Interface anzuheben.

Was ich aufgrund der IP Konfiguration im Moment bezweifel.

 

Info: Schau makl nach der Konfiguration des Router gegenüber,

und richte die Konfiguration daraufhin aus !

 

 

Gruß

 

Mr. Oiso

Link to comment

Hi Mr._oiso,

 

da hab ich ja noch arge Schnitzer drin,

 

ich möchte mich eigentlich ganz normal

über einen ISP einwählen.

Ich bin mir gerade ich sicher (bin auf der Arbeit )aber

wegen der alten IOS Version hatte ich einige

Befehle nicht zur Verfügung.

 

Also ich sollte:

 

ip address negotiated

 

und das callin entfernen ?

 

Ist das korrekt ?

Kannst Du mir sonst noch einen Tipp geben

 

Danke und Gruss

Link to comment

hi quenton

 

Hier mal ein Beispiel von Cisco

Diese Konfiguration ist für eine ISDN Einwahl zu einem ISP

dialer 1 = ISP

 

Wichtig wäre aber mal eben zu prüfen, ob Deine Router Software

auch IP-Nat unterstützt.

Bin mir im Moment nicht sicher !

 

Teste mal "ip nat outside" am dialer 1 !

 

isdn switch-type basic-net3

!

!

interface Ethernet0

ip address 10.1.0.1 255.255.255.0

ip nat inside

 

! --- Ethernet 0 is an inside NAT interface.

! --- All traffic from this network will be translated.

 

no cdp enable

!

interface BRI0

 

! --- If you have additional BRIs, copy this BRI 0 configuration to the other BRIs.

 

no ip address

encapsulation ppp

dialer pool-member 1

 

!--- Assign BRI0 as member of dialer pool 1.

!--- Dialer pool 1 is specified in interface Dialer 1.

 

isdn switch-type basic-net3

 

! --- This depends on the country.

 

no cdp enable

ppp authentication chap pap callin

 

! --- Permit one-way CHAP and PAP authentication.

! --- Configure authentication on both the physical and dialer interface.

 

!

interface Dialer1

 

! --- Create a dialer interface for every device you need to connect to.

 

description CONNECTION TO INTERNET

ip address negotiated

 

! --- IP address obtained from ISP. If the ISP permits a static address,

! --- configure that instead.

 

ip nat outside

 

! --- The Outside NAT interface. Since this interface only has one IP address,

! --- all traffic from inside network will be Port Address Translated (PAT).

 

encapsulation ppp

dialer pool 1

 

! --- Dialer profile 1. Remember that interface BRI 0 is a member of this profile.

 

dialer remote-name ISP

dialer idle-timeout 180

dialer string 6122

 

! --- Number used to dial the ISP.

 

dialer-group 1

 

! --- Apply interesting traffic definition from dialer-list 1.

 

no cdp enable

ppp authentication chap pap callin

ppp chap hostname XXXXX

 

! --- XXXXX is the username the ISP expects in order to authenticate this router.

! --- For more information, refer to the document on ppp chap hostname.

 

ppp chap password YYYYY

 

! --- YYYYY is the password the ISP expects in order to authenticate this router.

 

ppp pap sent-username XXXXX password YYYYY

 

! --- PAP username and password.

! --- This is only needed if the ISP does not support CHAP.

 

 

MfG

 

Mr. Oiso

Link to comment

hi quenton

 

11.2 None Nat Support in Base Image

NAT in plus image

None in easy ip image

supported Hardware

Cisco 1000, 2500, 4x00, AS5200, 7200, RSP7000, 7500

 

11.2P None Nat Support in Base Image

NAT in plus image

None in easy ip image

supported Hardware

Cisco 1000, 1600, 2500, 3620, 3640, 4x00, AS5200, AS5300, Cat5000 RSM, 7200, RSP7000, 7500

 

11.3 PAT only Support in Base Image

NAT in plus image

Phase 1 in easy ip image

supported Hardware

Cisco 1000, 1600, 2500, 3620, 3640, 4x00, AS5200, 7200, RSP7000, 7500

 

11.3T PAT only Support in Base Image

NAT in plus image

Phase 1 in easy ip image

supported Hardware

Cisco 1000, 1600, 2500, 2600, 3620, 3640, 4x00, AS5200, AS5300, Cat5000 RSM, 7200, RSP7000, 7500

 

12.0 NAT Support in Base Image

NAT in plus image

Phase 1 in easy ip image

supported Hardware

Cisco 1600, 2500, 2600, 3620, 3640, 4000, 4500, 4700, AS5x00, Cat5000 RSM, 7200, RSP7000, 7500

 

Schau doch bitte mal nach,

 

Router#show version

 

welches IOS genau Du auf dem Router hast !

Könnte von Bedeutung sein !

 

MfG

 

Mr. Oiso

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...