Jump to content

VPN Client to Cisco 836


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich versuche mit meinem Laptop per VPN-Client in mein privates Netzwerk zu kommen. Das Heimnetz ist durch einen Cisco 836 ans WWW angebunden.

 

Die Authentifizierung auf dem Router funktioniert einwandfrei, jedoch kann ich das Netz hinter dem Router nicht erreichen. Ich habe etlich Techdocs von Cisco gelesen, jedoch helfen die nicht wirklich weiter. Ich nehme an, das es sich bei mir um ein NAT Problem handelt. Aber vielleicht kann mir ja jemand weiterhelfen.

 

Die Config ist in der folgenden Antwort, da ich hier auf 4000 Zeichen begrenzt werde.

 

Danke vorab!!!

Link to comment

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname xxx

!

boot-start-marker

boot-end-marker

!

memory-size iomem 5

enable secret 0 xxx

!

!

username xxx privilege 15 password 0 xxx

aaa new-model

!

!

aaa authentication login default local

aaa authentication login VPN-Client local

aaa authorization network default local

aaa authorization network VPN-Client local

aaa session-id common

ip subnet-zero

!

ip domain name xxx

ip name-server xxx

ip cef

ip ips po max-events 100

ip ssh version 2

ip ddns update method dyndns

HTTP

add http://xxx:xxx@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 1 0 0 0

!

vpdn enable

!

vpdn-group T-Online

request-dialin

protocol pppoe

ip mtu adjust

!

no ftp-server write-enable

isdn switch-type basic-net3

!

!

!

!

!

crypto isakmp policy 10

encr 3des

authentication pre-share

group 2

!

crypto isakmp client configuration group xxx

key xxx

dns xxx

pool DHCP-VPN

!

!

crypto ipsec transform-set Strong esp-3des esp-sha-hmac

!

crypto dynamic-map VPN-Client 10

set transform-set Strong

!

!

crypto map VPN client authentication list VPN-Client

crypto map VPN isakmp authorization list VPN-Client

crypto map VPN client configuration address respond

crypto map VPN 500 ipsec-isakmp dynamic VPN-Client

!

!

!

interface Ethernet0

description Inside

bandwidth 100000

ip address 192.168.1.254 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

no cdp enable

no shutdown

!

interface Ethernet2

no ip address

shutdown

!

interface BRI0

no ip address

shutdown

isdn switch-type basic-net3

!

interface ATM0

no ip address

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

no atm ilmi-keepalive

dsl operating-mode auto

pvc 1/32

pppoe-client dial-pool-number 1

no shutdown

!

interface FastEthernet1

no ip address

duplex auto

speed auto

!

interface FastEthernet2

no ip address

speed auto

full-duplex

shutdown

!

interface FastEthernet3

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet4

no ip address

duplex auto

speed auto

!

interface Dialer1

ip ddns update hostname xxx

ip ddns update dyndns

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

no ip mroute-cache

dialer pool 1

dialer idle-timeout 180

dialer-group 1

no cdp enable

ppp pap sent-username xxx password 0 xxx

crypto map VPN

!

ip local pool DHCP-VPN 192.168.1.1 192.168.1.5

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

ip route 192.168.1.0 255.255.255.0 Ethernet 0

!

no ip http server

no ip http secure-server

!

ip dns server

ip nat inside source list 1 interface Dialer1 overload

!

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 100 deny udp any eq netbios-dgm any

access-list 100 deny udp any eq netbios-ns any

access-list 100 deny udp any eq netbios-ss any

access-list 100 deny udp any range snmp snmptrap any

access-list 100 deny udp any range bootps bootpc any

access-list 100 deny tcp any eq 137 any

access-list 100 deny tcp any eq 138 any

access-list 100 deny tcp any eq 139 any

access-list 100 deny tcp any eq 23 any eq 23

access-list 100 permit ip any any

dialer-list 1 protocol ip list 100

!

!

control-plane

!

!

line con 0

login local

no modem enable

transport preferred all

transport output all

line aux 0

login local

transport preferred all

transport output all

line vty 0 4

login local

transport preferred ssh

transport input ssh

transport output telnet ssh

!

scheduler max-task-time 5000

no rcapi server

!

!

end

Link to comment

Hallo,

du musste deine NAT Access-Liste abändern. Die Pakete die vom Client an den PC im LAN gehen, treffen diesen, werden zurückgeschickt und laufen dann ins NAT. Somit werden sie nicht mehr in den VPN Tunnel gesteckt.

Ändere das mal fondendermaßen ab:

 

access-list 120 remark VPN-Client nicht natten

access-list 120 deny ip 192.168.1.0 0.0.0.255 192.168.1.0 0.0.0.255

access-list 120 rem alles was ins Internet geht ok

access-list 120 permit ip 192.168.1.0 0.0.0.255 any

 

ip nat inside source list 120 interface Dialer1 overload

 

Wenn Du dann noch Probleme hast, dann wähle mal ein anderes Netz für den IP-Pool ( DHCP-VPN z.B. 192.168.2.0/24).

 

Grüße

Christian

Link to comment
  • 3 weeks later...
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...