Jump to content

Cisco 803 bleibt online


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich habe folgendes Problem:

 

Cisco 803 legt nicht auf, trotz der Beendung von Opera und ICQ.

 

Im gleichen Takt wie die TX/RX aufblinken, so blinkt auch die LED TXD fürs LAN.

Hab hier im Forum ein paar Dinge gefunden mit denen ich es ausprobiert habe. Leider ohne Erfolg....

 

Hier auch noch meine Conf.:

 

Current configuration:

!

version 12.0

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname landsberg

!

enable secret 5 ***

!

username landsberg password 7 ***

!

!

!

!

!

ip subnet-zero

no ip source-route

!

ip dhcp pool DHCPPoolLAN_0

network 192.168.10.0 255.255.255.0

dns-server 145.253.2.11 145.253.2.75

default-router 192.168.10.1

!

ip name-server 145.253.2.11

ip name-server 145.253.2.75

isdn switch-type basic-net3

isdn voice-call-failure 0

cns event-service server

!

!

!

!

!

interface Ethernet0

ip address 192.168.10.1 255.255.255.0

ip access-group 121 in

no ip directed-broadcast

no ip proxy-arp

ip nat inside

!

interface BRI0

no ip address

no ip directed-broadcast

encapsulation ppp

dialer pool-member 1

isdn switch-type basic-net3

!

interface Dialer1

description ISP

ip address negotiated

ip access-group 121 in

no ip directed-broadcast

no ip proxy-arp

ip nat outside

encapsulation ppp

no ip split-horizon

dialer remote-name Cisco1

dialer pool 1

dialer idle-timeout 30

dialer string 0192070 class DialClass

dialer hold-queue 10

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname ar0344587193

ppp chap password 7 071C28425B1A4B56

ppp pap sent-username *** password 7 ***

!

ip nat inside source list 18 interface Dialer1 overload

no ip http server

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

map-class dialer DialClass

dialer isdn short-hold 120

access-list 18 permit 192.168.10.0 0.0.0.255

access-list 121 deny udp any eq netbios-dgm any

access-list 121 deny udp any eq netbios-ns any

access-list 121 deny udp any eq netbios-ss any

access-list 121 deny tcp any eq 137 any

access-list 121 deny tcp any eq 138 any

access-list 121 deny tcp any eq 139 any

access-list 121 permit ip any any time-range TIME

dialer-list 1 protocol ip list 1

!

line con 0

exec-timeout 120 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 0 0

login local

!

time-range TIME

periodic daily 0:00 to 23:59

!

end

 

Jemand einen Tip wie ich herausfinde was die Verbindung aufrecht hält?

 

 

Danke und schönes WE

Link to comment

Hallo firescout,

 

also ich bin jetzt nicht der Cisco-Guru, aber mich wundert fast, daß du überhaupt online kommst. In der Config ist steht folgendes:

dialer-list 1 protocol ip list 1

 

Dieser Eintrag "korrespondiert" mit dem Eintrag

dialer-group 1

unter dem Dialer1 und bezieht sich auf auf eine access-list 1 (~ list 1).

 

Mit dieser dialer-list wird angegeben, welches der "interested traffic" ist, also der Verkehr, der den Dialer aktivieren und aufrecht erhalten soll/darf.

 

Dadurch, daß du keine access-list 1 angegen hast, wundert es mich, daß überhaupt eine Verbindung zustande kommt. Aber ich muß zugeben, ich habe diesen Fall noch nie ausprobiert.

 

Der interested traffic muß also eingeschränkt werden!

Du mußt dir also überlegen, welcher Verkehr den Dialer aufbauen UND aufrecht erhalten darf!

Beispiel: Surf-Verkehr (Port 80, 443) , dein ICQ (5190) und Mail (Port 110).

 

Tja, und daraus ne access-list erstellt dürfte dann in etwa so ausschauen:

 

access-list 199 permit tcp any any eq 80

access-list 199 permit tcp any any eq 110

access-list 199 permit tcp any any eq 443

access-list 199 permit tcp any any eq 5190

access-list 199 deny tcp any any log

 

Du mußt natürlich dann den Eintrag:

dialer-list 1 protocol ip list 1

auf

dialer-list 1 protocol ip list 199

abändern:

folgende zwei Zeilen im global configuration mode (conf t) reinkopieren:

no dialer-list 1 protocol ip list 1

dialer-list 1 protocol ip list 199

 

Weiterhin habe ich grad überlegt, ob es zusätzlich noch sinnvoll wäre, den idle-timeout nur auf den ausgehenden Verkehr triggern zu lassen:

"dialer idle-timeout 30 outbound" statt "dialer idle-timeout 30" unterm Dialer1. -> Vielleicht einfach zusätzlich probieren.

 

Eine kurze Erklärung: Ich habe gerade keinen Cisco vor mir. Deshalb ist alles hier gesagte recht theoretisch! -> Bitte einfach ausprobieren!

 

Das "log" am Ende des letzten Eintrags der acces-list gibt den Traffic aus, der den Dialer NICHT aufbauen oder aufrecht erhalten darf!

Vielleicht kannst du damit ja herausfinden, welcher traffic noch interessant für dich ist.

 

Rumspielen solltest du vielleicht auch mit dem Debugging:

debug dialer packet

und

debug dialer events

beides im enable-mode (sog. privileged exec mode).

Solltest du dich per telnet auf den Router connected haben, dann vorher noch "term mon" ausführen!

 

Wichtig auf jeden Fall: Die access-list an die dialer-list gebunden schränkt KEINEN Verkehr ein! Sie dient lediglich der Definition, welcher Verkehr den Dialer aufbauen und aufrecht erhalten darf oder soll!!!

 

Stöber vielleicht noch ein wenig auf den Cisco-Seiten rum. Mit ein wenig Muße und Suchgeschick kannst du da alle Infos finden.

Nun gut, ich hoffe, es hat geholfen und daß meine Tipps korrekt waren. ;o)

 

Viel Erfolg und schreib mal bitte, ob es geklappt hat.

 

Grüße aus Potsdam

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...