Jump to content

Getrennten Speicherbereich deaktivieren


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

vielleicht kann mir jemand einen Tip geben, ich komme alleine nicht mehr weiter.

 

Folgendes Problem:

 

Ich möchte DOS Programme unter W2K NICHT im getrennten Speicherbereich ausführen. Die Dos-Exe wird über ein Konfigurations-Batch aufgerufen (net use lpt1 \\Server.... etc.)

 

Es geht um ein spezielles Kassenprogramm, das sich mit der Option "Getrennter Speicherbereich" mehrmals starten lässt, das darf aber auf keinen Fall sein.

 

Mit den Gruppenrichtlinien (ADM auf OU) habe ich für alle User die Richlinienschlüssel:

 

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\MemCheckBoxInRunDlg = 1

 

und

 

HKEY_LOCAL_MACHINE\ System\ CurrentControlSet\ Control\ WOW\DefaultSeparateVDM = NO

 

verteilt.

 

Dies funktionieren auch, bzw, die Einträge sind in der Registry richtig gesetzt worden. (Geprüft mit Regedit)

 

Die Checkbox "Getrennter Speicherbereich" wird mir in allen Verknüpfungen zwar angezeigt, ich kann das Häkchen aber nicht entfernen, es wird nur schattiert angezeigt.

 

Welche Einstellung muss ich ändern um die Checkbox bearbeiten zu können.

 

Alle Versuche bisher und alles Suchen, sei es hier im Forum, bei gruppenrichtlinien. de, sonstwo im Internet und in den eigenen ADMs wie auch im RegistrySystemWizard sind bisher im Sande verlaufen. Ich finde einfach keine Lösung.

 

Vielleicht hatte ja jemand schonmal das gleiche Problem und weiß, wie ich das anstellen kann.

 

Vielleicht gibt es ja auch ein Tool, mit dem man das doppelte Starten verhindern kann, da ich aber vom Dau ausgehen muss, brauche ich eine wasserdichte Lösung, die beim doppelten Aufruf einfach den Focus auf das bereits laufende Programm setzt ohne Fragen zu stellen :-) Mit dem Erstellen einer Datei und dem Abfragen per Exist im Startbatch habe ich schon probiert, das Dumme ist nur, das ich beim Schliesen des Dosfensters nichts habe wo ich einen Abschlussbatch einhaken kann, der mir die Datei vor dem nächsten reellen Start wieder löscht.

 

Bin für jeden Tip dankbar

 

Grüssle

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...