Jump to content
Sign in to follow this  
Wallenreiter

Callback mit ISDN?

Recommended Posts

HAllo Leute!

 

endlich mal ein Forum, das sich mit CISCO beschaftigt :)

 

Ich habe ein Riesenproblem! Mein Chef hat mich am freitag beauftragt diesen Montag zum Kunden zu fahren und auf einem CISCO-Router ein CALLBACK mit ISDN einzurichten.

Ich habe soetwas noch nie gemacht und habe insgesamt erst die ersten beiden semester des CCNA 1-Kurses besucht und keine Praxiserfahrung mit Routern.

 

Client: WIN_NT-PC per DFÜ

 

Gegenstelle: Cisco Router 800er serie

 

Hat jemand eine verständliche anleitung auf deutsch dazu? Ich verzweifele mittlerweile mit diesen englischen Informationsschnipseln im Netz. In der Fachbücherei gibts auch nicht zu Callback mit cisco. :-(

 

 

Ich habe das Prizip jetzt so ungefähr auf dem schirm und habe mir folgende Strategie zurechtgelegt:

 

1. Legacy-Lösung

 

isdn switch-type basic-net3 !! Oder ein anderer ISDN-Switch!

dialer-list 1 protocol ip permit !! Eine Art ACL, die IP erlaubt | Muss weiter unten an das

 

Interface gebunden werden

map-class dialer dial1 !! Muss eingerichtet werden, keinen Plan warum |

 

Wahrscheinlich username vom peer

dialer callback-server username

 

 

interface BRI0

ip address .... .... !! Ist schon eingestellt

encapsulation ppp !! Standardeintrag dass PPP benutzt wird

dialer map ip Peer-IP name Peer-Name Tele-NR-des-Peers !! Ordnet der ausgehenden IP eine Tele-Nr. zu | Diesen Eintag

 

für jeden Peer wiederholen |

 

Tele-NR-des-Peers-Eventuell-mit-Führender_Null

dialer idle-timeout 200 !! Bestimmt wahrscheinlich die Zeit, ab wie lange die

 

Verbindung ohne Verkehr gehalten wird

dialer enable-timeout 2 !! ?? Nochmal nachschlagen

isdn caller Tele-NR-des-eingehenden-Peer !! Überprüfung der ankommenden Rurnummern | wird für jeden

 

peer gemacht und muss einen entsprechenden dialer-map-eintrag

 

weiter oben haben

isdn answer1 Tele-NR-des-Routers !! ISDN-NR auf die der Router abnimmt

isdn calling-number Tele-NR-des-Routers !! Abgehende Rufnummer des Routers

dialer-group 1 !! Bindet die dialer-list (oden definiert) an das interface

dialer callback-secure !! Callback-eintrag

ppp callback accept !! Callback-eintrag

ppp authentication chap !! Es wird CHAP benutzt

 

 

 

 

 

Eventuell:

 

interface bri0

ppp chap password Geheim !!!! Falls CHAP nicht funktioniert. PW das Gleiche wie bei ISDN-Peer.

 

interface bri0

isdn caller Tele-Nr-des-peers callback !!!! ISDN-Callback

 

Einen broadcast-Eintrag in die Dialer-Map -- Siehe DECUS-Symposium

 

Eventuell ISDN-SPID-Eintrag machen

 

dialer callback-server username ÄNDERN

 

------------------------------------------------------------------------

 

Könnte das funzen?

 

Habe folgende Fragen darüber hinaus:

 

1. was ist eine Map-Class?

2. was ist ein Dialer Callback-secure?

3. was was ist ein dialer in-band?

 

 

 

Hoffe, das mir jemand helfen kann.

 

 

MFG,

 

Dominik Wallenreiter!

Share this post


Link to post

Hi Wallenreiter

 

Ja das sieht doch schon mal gut aus !

Jedoch hast Du wahrscheinlich ein paar optionen zuviel

aufgelistet !

Lösung 1 und 2 :

Damit erklärt sich auch die dialer map !

 

dialer callback-secure

 

Syntax Description

 

This command has no arguments or keywords.

Default

 

Disabled

Command Mode

 

Interface configuration

Usage Guidelines

 

This command affects those users that are not authorized to be called back with the dialer callback-server command. If the username (hostname in the dialer map command) is not authorized for callback, the call will be disconnected if the dialer callback-secure command is configured. If the dialer callback-secure command is not configured, the call will not be disconnected. In either case, callback has not occurred.

Example

 

The following partial example configures BRI0 with the commands required to make it function as the callback server on the shared network. Callback security is enabled on BRI0, such that any user other than atlanta will be disconnected and not called back.

 

interface BRI0

ip address 171.1.1.9 255.255.255.0

encapsulation ppp

dialer callback-secure

dialer enable-timeout 2

dialer map ip 171.1.1.8 name atlanta class dial1 81012345678901

dialer-group 1

ppp callback accept

ppp authentication chap

!

map-class dialer dial1

dialer callback-server username

 

Lösung zu 3 :

 

Mit dialer in-band wird DDR (Dial on Demand) eingerichtet !

Deswegen meinte ich eben auch ein paar Optionen zu viel.

Was möchtest DU konfigurieren ?

Statische Zugänge oder dynamisch ! Wieviele ?

 

 

Werde Montag morgen mal ein Beispiel pasten ! (Für statisch)

 

Bei Fragen, ruhig melden !

 

Gruß, nice weekend

 

Mr. Oiso

Share this post


Link to post

erstmal vielen dank für deine antwort.

 

Es sollen sich 4 Leute einwählen können. Keinen Plan ob gleichzeitig. Es steht aber nur ein Physikalisches ISDN-Interface zur verfügung. Ich habe die Vermutung, dass dann auch nur eine Verbindung funzt. Mir egal, ich will nur meinen Kopf aus der Schlinge ziehen :-) Ich kanns eh nur unter Testbedingungen testen.

 

 

>> map-class dialer dial1

>> dialer callback-server username

 

Also sagt dieses Kommando, aus, dass nur ein Callback gestartet wird, wenn der Username genau übereinstimmt. Muss der Username in der dialer map UND im Username-eintrag stehen?

 

Ich habe viele Konfigs gesehen, die den in-band-eintrag nicht hatten und trotzdem DDR Legacy-Konfigs sind. Muss der auch beim

 

Configuring ISDN Caller ID Callback

 

rein?

 

Ich habe gemerkt, das ich in meiner letzten Konfig "Configuring ISDN Caller ID Callback " und "PPP Callback Over ISDN" gemixt habe.

 

Ich habe jetzt nochmal eine reinrassige "Configuring ISDN Caller ID Callback" gemacht. die muss morgen funzen.

Share this post


Link to post

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>> 1. ISDN Caller-ID mit Legacy-DDR-Lösung <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

 

Vorraussetzungen:

 

- ISDN ID-Screening (Einkommende rufnumemr checken) muss aktiviert sein auf dem ISDN-Switch der Firma.

- Dialer Map Commando muss aktiv sein.

- Der Peer (Client oder caller) braucht das: dialer enable-timeout seconds --- Configure the time to wait before initiating callback.

- Auch dialer-lists eintragen

- auch username-Profiles eintragen

 

-----------------------------------------------------------------------------------------------------------------------------------------------------------

 

!! Oder ein anderer ISDN-Switch!

isdn switch-type basic-net3

 

 

!! Eine Art ACL, die IP erlaubt | Muss weiter unten an das Interface gebunden werden

dialer-list 1 protocol ip permit

 

!! Einrichtung des Userkontos

username clemens password 0 cctest

 

interface BRI0

 

!! Ist schon eingestellt

ip address .... ....

 

!! Standardeintrag dass PPP benutzt wird

encapsulation ppp

 

!! Nimmt CHAP als PPP-Authentifikation

ppp authentication chap

 

!! Ordnet der ausgehenden IP eine Tele-Nr. zu | Diesen Eintag für jeden Peer wiederholen | Tele-NR-des-Peers-Eventuell-mit-Führender_Null |

 

!! diesen Eintrag eventuell auch ohne Benutzername | Eventuell broadcast statt "name Peer-Name" oder beides

dialer map ip Peer-IP name Peer-Name Tele-NR-des-Peers

 

!! Bestimmt wahrscheinlich die Zeit, ab wie lange die Verbindung ohne Verkehr gehalten wird

dialer idle-timeout 200

 

!! Wartezeit zwischen Peer-anruf und Server-Rückruf | wenns nicht klappt, damit experimentieren

dialer enable-timeout 2

 

!! welche eingehende Nummer wird beachtet und zurückgerufen (callback-Eintrag) | Für jede Nummer einzeln | Rufnummer stimmt mit

 

!! dialer-Map-Eintrag überein | Führende 0 ??!!

isdn caller Tele-NR-des-eingehenden-Peer callback

 

 

 

!! ISDN-NR auf die der Router abnimmt | Im Beispiel ohne Vorwahl

isdn answer1 Tele-NR-des-Routers

 

 

!! Abgehende Rufnummer des Routers | Im Beispiel ohne Vorwahl

isdn calling-number Tele-NR-des-Routers

 

!! Bindet die dialer-list (oden definiert) an das interface

dialer-group 1

 

 

 

Optional:

 

no ip mroute-cache

 

dialer in-band !! Damit wird DDR (Dial on Demand) eingerichtet !

 

-------------------------------------------------------------------------------------

Share this post


Link to post

Hi Wallenreiter

 

Hier erstmal eine Beispiel Konfiguration von einem Cisco 800.

 

version 12.0

no service pad

service timestamps debug datetime msec localtime

service timestamps log datetime msec localtime

service password-encryption

!

hostname xxxxxxx

!

logging console informational

enable secret 5 xxxxxxxxxxxxxxxxxxxx

enable password 7 xxxxxxxxxxxxxx

!

username gatebonn callback-dialstring 02284225000 password 7 xx

username gatetrier callback-dialstring 06518261300 password 7 xx

username osmgate callback-dialstring 02018955800 password 7 xxx

username SNMP-MHO callback-dialstring 05401831247 password 7 xxx

username ciscotac password 7 xxx

username Administrator privilege 15 password 7 xxx

username manager privilege 15 password 7 xxx

username gateklagespartner callback-dialstring 05407808574 password 7 xxx

username gateete password 7 xxx

username etegate callback-dialstring 05401831245 password 7 xxx

!

!

!

!

clock timezone MET 1

clock summer-time MET date Mar 28 2004 2:00 Oct 31 2004 3:00

ip subnet-zero

!

ip name-server 172.18.30.1

ip name-server 172.18.30.2

isdn switch-type basic-net3

isdn voice-call-failure 0

!

!

!

interface Ethernet0

description connected to Vlan 186

ip address 192.168.186.203 255.255.255.0

no ip directed-broadcast

!

interface BRI0

bandwidth 128

no ip address

ip directed-broadcast

encapsulation ppp

dialer rotary-group 1

dialer-group 2

isdn switch-type basic-net3

isdn send-alerting

isdn sending-complete

isdn static-tei 0

fair-queue 64 16 0

compress mppc

!

interface Dialer1

bandwidth 128

ip address 10.93.78.153 255.255.255.0

no ip directed-broadcast

encapsulation ppp

no keepalive

dialer in-band

dialer enable-timeout 3

dialer map ip 193.101.76.222 name osmgate class osm 02018955800

dialer map ip 200.1.2.10 name gatetrier class gwi broadcast 06518261300

dialer map ip 192.168.186.194 name gateklagespartner broadcast 05407808574

dialer map ip 192.168.186.209 name ciscotac class gwi broadcast

dialer map ip 10.93.77.1 name gatebonn class gwi 02284225000

dialer hold-queue 10

dialer-group 1

fair-queue 64 16 0

compress mppc

ppp callback accept

ppp authentication chap

ppp multilink

!

interface Dialer2

bandwidth 64

ip address 10.93.78.155 255.255.255.0

no ip directed-broadcast

encapsulation ppp

dialer in-band

dialer enable-timeout 10

dialer map ip 192.168.186.201 name gateete class ete

dialer map ip 192.168.186.202 name etegate class ete

dialer map ip 172.25.0.111 name SNMP-MHO class ete 05401831247

dialer hold-queue 50

dialer-group 2

no fair-queue

compress mppc

ppp callback accept

ppp authentication chap

ppp multilink

!

router rip

redistribute static metric 10

passive-interface Dialer1

passive-interface Dialer2

network 192.168.186.0

!

ip default-gateway 192.168.186.113

ip http server

ip http port 17303

ip http access-class 99

ip http authentication local

ip classless

ip route 10.136.78.0 255.255.255.192 10.93.77.1

ip route 192.168.1.0 255.255.255.0 Dialer1

ip route 193.101.76.222 255.255.255.255 Dialer1

ip route 200.1.2.10 255.255.255.255 Dialer1

ip route 200.2.1.0 255.255.255.0 200.1.2.10

!

!

map-class dialer gwi

dialer callback-server username

!

map-class dialer osm

dialer callback-server username

!

map-class dialer ete

dialer callback-server username

logging 172.25.0.111

access-list 99 permit 172.18.30.96

access-list 99 permit 172.25.0.111

access-list 99 permit 172.18.20.116

access-list 99 deny any

access-list 101 permit tcp any any

access-list 101 permit udp any any

access-list 101 deny 53 any any

access-list 101 deny 55 any any

access-list 101 deny 77 any any

access-list 101 deny pim any any

access-list 101 permit ip any any

access-list 104 permit tcp any any

access-list 104 permit udp any any

access-list 104 deny 53 any any

access-list 104 deny 55 any any

access-list 104 deny 77 any any

access-list 104 deny pim any any

access-list 104 permit ip any any

access-list 107 permit tcp any any

access-list 107 permit udp any any

access-list 107 deny 53 any any

access-list 107 deny 55 any any

access-list 107 deny 77 any any

access-list 107 deny pim any any

access-list 107 permit icmp 200.2.1.0 0.0.0.255 172.18.16.0 0.0.15.255 log

access-list 107 permit icmp any 200.2.1.0 0.0.0.255 log

access-list 107 permit icmp 10.136.78.0 0.0.0.255 172.18.16.0 0.0.15.255 log

access-list 107 permit icmp any 10.136.78.0 0.0.0.255 log

access-list 107 deny icmp any any log

access-list 107 permit ip any 172.18.16.0 0.0.15.255

access-list 108 permit tcp any any

access-list 108 permit udp any any

access-list 108 deny 53 any any

access-list 108 deny 55 any any

access-list 108 deny 77 any any

access-list 108 deny pim any any

access-list 108 permit icmp 200.2.1.0 0.0.0.255 172.18.16.0 0.0.15.255 log

access-list 108 permit icmp any 200.2.1.0 0.0.0.255 log

access-list 108 permit icmp 10.136.78.0 0.0.0.255 172.18.16.0 0.0.15.255 log

access-list 108 permit icmp any 10.136.78.0 0.0.0.255 log

access-list 108 deny icmp any any log

access-list 108 permit ip any 172.18.16.0 0.0.15.255

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip list 104

snmp-server engineID local 000000090200000217663BCC

snmp-server community pulverfass RO

snmp-server community lunte RW

snmp-server enable traps snmp

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server host 172.25.0.111 lunte tty isdn snmp

banner login C

!

line con 0

exec-timeout 3600 0

transport input none

stopbits 1

line vty 0 4

exec-timeout 3600 0

password 7 xxxx

login local

!

rcapi server port 2578

!

!

end

 

 

Dazu eine Info:

 

Bei einer Dialer Caller Konfiguration lässt Du das dialer in-band weg ! Das funktioniert damit in der Regel nicht !

 

Der Switch Type ist soweit richtig !

 

>> map-class dialer dial1

>> dialer callback-server username

 

Hiermit bestimmt der Router anhand des user-Eintrages ob zurückgerufen wird, und wenn ja, welche NR.

 

Dieses brauchst Du nicht, wenn Du mit dialer caller ID arbeitest,

da Du mit dialer caller ID callback die Nr. identifizierst, welche ausschließlich anrufen darf, und über dialer string ID dann zurückgerufen wird.

Share this post


Link to post

Hi Wallenreiter

 

Hier ein zweites Beispiel für die Callbackfunktion mittels Caller ID

 

 

version 12.1

service timestamps debug datetime msec

service timestamps log datetime msec

!

hostname Router1

!

isdn switch-type basic-net3

!

interface Loopback0

ip address 10.0.0.1 255.255.255.0

!

interface BRI0

no ip address

dialer pool-member 1

!

isdn switch-type basic-net3

!

interface Dialer1

description for Router2

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer enable-timeout 2

dialer string 6121

dialer caller 6121 callback

dialer-group 1

!

interface Dialer2

description for Router3

ip unnumbered Loopback0

encapsulation ppp

dialer pool 1

dialer caller 6101

dialer-group 1

!

dialer-list 1 protocol ip permit

 

!--- Define ip as interesting traffic.

 

Bei der Konfiguration mittels Caller ID benötigst Du keine User und auch kein dialer in-band management, weil hier die authentication via Tel. Nr. abläuft.

 

Hier wird zum Beispiel an dialer interface 1 der Anrufer mittels Nr. 6121 identifiziert und auch auf der selben Nr. zurückgerufen.

 

An dialer int 2 wird nur die Nr. identifiziert, jedoch kein callback durchgeführt.

 

Wichtig: Bei dieser Konfiguration wurde auch ip unnumbered to ...

konfiguriert, was bei der vorigen statisch war, wo mit

dialer map command die IP Adr. festgelegt wurden.

Deshalb auch keine echt DDR Konfiguration ist.

 

Gruß

 

Mr. Oiso

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...