Jump to content

ip nat inside mit vrf


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Empfohlene Beiträge

Hallo Zusammen,

 

ich habe einen Kunden mit mehreren Büros welche sich einen DSL-Anschluss teilen.

 

Via VRF habe ich jedem sein eigenes LAN eingerichtet.

Jetzt möchte ich via "ip nat inside" Portforwardings einrichten.

 

Allerdings bietet mir die CLI die VRF-Option nur an wenn ich es auf eine IP, nicht aber auf mein Dialer Interface beziehen möchte.

 

Bin Ratlos.

 

Jemand ne Idee?

Link zu diesem Kommentar

Hola,

 

vielleicht hilft das:

 

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28

ip nat inside source list 1 pool net-208

!

interface ethernet 0

ip address 171.69.232.182 255.255.255.240

ip nat outside

!

interface ethernet 1

ip address 192.168.1.94 255.255.255.0

ip nat inside

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 192.168.2.0 0.0.0.255

The following example translates only traffic local to the provider edge device running NAT (NAT-PE):

ip nat inside source list 1 interface e 0 vrf shop overload

ip nat inside source list 1 interface e 0 vrf bank overload

!

ip route vrf shop 0.0.0.0 0.0.0.0 192.1.1.1

ip route vrf bank 0.0.0.0 0.0.0.0 192.1.1.1

!

access-list 1 permit 10.1.1.1.0 0.0.0.255

!

Configuring NAT for IP Address Conservation

Configuration Examples for Configuring NAT for IP Address Conservation

43

ip nat inside source list 1 interface e 1 vrf shop overload

ip nat inside source list 1 interface e 1 vrf bank overload

!

ip route vrf shop 0.0.0.0 0.0.0.0 172.1.1.1 global

ip route vrf bank 0.0.0.0 0.0.0.0 172.1.1.1 global

access-list 1 permit 10.1.1.0 0.0.0.255

 

 

Configuring NAT for IP Address Conservation  [Cisco IOS Software] - Cisco Systems

ciao

Link zu diesem Kommentar

Hmmm,

 

leider hilfts nich so richtig.

Ich muss ja irgendwo angeben welcher externe Port auf welchen internen Port gemapt werden soll.

 

Anbei mal die Config.

 

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Internetgate

!

boot-start-marker

boot-end-marker

!

enable secret

enable password

!

no aaa new-model

!

resource policy

!

no network-clock-participate slot 1

no network-clock-participate wic 0

ip subnet-zero

ip cef

!

!

ip dhcp use vrf connected

!

ip dhcp pool Raum-A

vrf Raum-A

network 192.168.1.0 255.255.255.0

default-router 192.168.1.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-B1

vrf Raum-B1

network 192.168.2.0 255.255.255.0

default-router 192.168.2.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-B2

vrf Raum-B2

network 192.168.3.0 255.255.255.0

default-router 192.168.3.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-B3

vrf Raum-B3

network 192.168.4.0 255.255.255.0

default-router 192.168.4.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-B4

vrf Raum-B4

network 192.168.5.0 255.255.255.0

default-router 192.168.5.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-C

vrf Raum-C

network 192.168.6.0 255.255.255.0

default-router 192.168.6.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-D

vrf Raum-D

network 192.168.7.0 255.255.255.0

default-router 192.168.7.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-F

vrf Raum-F

network 192.168.8.0 255.255.255.0

default-router 192.168.8.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-G

vrf Raum-G

network 192.168.9.0 255.255.255.0

default-router 192.168.9.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Sekretariat

vrf Sekretariat

network 192.168.10.0 255.255.255.0

default-router 192.168.10.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

ip dhcp pool Raum-E

vrf Raum-E

network 192.168.11.0 255.255.255.0

default-router 192.168.11.1 255.255.255.0

dns-server 145.253.2.11 84.23.254.1

!

!

ip vrf Raum-A

rd 192.168.1.0:2

!

ip vrf Raum-B1

rd 192.168.2.0:2

!

ip vrf Raum-B2

rd 192.168.3.0:2

!

ip vrf Raum-B3

rd 192.168.4.0:2

!

ip vrf Raum-B4

rd 192.168.5.0:2

!

ip vrf Raum-C

rd 192.168.6.0:2

!

ip vrf Raum-D

rd 192.168.7.0:2

!

ip vrf Raum-E

rd 192.168.11.0:2

!

ip vrf Raum-F

rd 192.168.8.0:2

!

ip vrf Raum-G

rd 192.168.9.0:2

!

ip vrf Sekretariat

rd 192.168.10.0:2

!

ip ddns update method dyndns

HTTP

add http://@members.dyndns.org/nic/update?system=dyndns&hostname=<h>&myip=<a>

interval maximum 1 0 0 0

Link zu diesem Kommentar

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

description zum LAN

ip address 10.10.10.10 255.255.255.0

no ip mroute-cache

duplex auto

speed auto

!

interface FastEthernet0/0.1

description Raum-A

encapsulation dot1Q 100

ip vrf forwarding Raum-A

ip address 192.168.1.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.2

description Raum-B1

encapsulation dot1Q 101

ip vrf forwarding Raum-B1

ip address 192.168.2.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.3

description Raum-B2

encapsulation dot1Q 102

ip vrf forwarding Raum-B2

ip address 192.168.3.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.4

description Raum-B3

encapsulation dot1Q 103

ip vrf forwarding Raum-B3

ip address 192.168.4.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.5

description Raum-B4

encapsulation dot1Q 104

ip vrf forwarding Raum-B4

ip address 192.168.5.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.6

description Raum-C

encapsulation dot1Q 105

ip vrf forwarding Raum-C

ip address 192.168.6.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.7

description Raum-D

encapsulation dot1Q 106

ip vrf forwarding Raum-D

ip address 192.168.7.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.8

description Raum-F

encapsulation dot1Q 107

ip vrf forwarding Raum-F

ip address 192.168.8.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.9

description Raum-G

encapsulation dot1Q 108

ip vrf forwarding Raum-G

ip address 192.168.9.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.10

description Sekretariat

encapsulation dot1Q 109

ip vrf forwarding Sekretariat

ip address 192.168.10.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface FastEthernet0/0.11

description Raum-E

encapsulation dot1Q 110

ip vrf forwarding Raum-E

ip address 192.168.11.1 255.255.255.0

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip virtual-reassembly

no snmp trap link-status

!

interface Serial0/0

no ip address

shutdown

!

interface FastEthernet0/1

description zum internet

no ip address

no ip mroute-cache

duplex auto

speed auto

pppoe enable

pppoe-client dial-pool-number 1

!

interface Serial0/1

no ip address

shutdown

!

interface Dialer1

description zu T-Online

ip ddns update hostname

ip ddns update dyndns

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 2

ppp authentication chap pap callin

ppp chap hostname

ppp chap password 0

ppp pap sent-username

password 0

Link zu diesem Kommentar
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Schreibe einen Kommentar

Du kannst jetzt antworten und Dich später registrieren. Falls Du bereits ein Mitglied bist, logge Dich jetzt ein.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Editor-Fenster leeren

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

×
×
  • Neu erstellen...