Jump to content
Sign in to follow this  
Thimax

PPTP Verbindung auf C876

Recommended Posts

Hallo,

 

Ich versuche ein PPTP Remote access auf meinem C876 ADSL Router einzurichten. Allerdings antwortet der Router meinem dial-in request nicht (Error 678: The remote computer did not respond).

 

Hier sind mal die relevanten Teile meiner Config:

 

...

vpdn enable

!

vpdn-group 1

!

Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

interface Virtual-Template1

ip unnumbered Vlan1

peer default ip address pool PPTP_USERS

ppp encrypt mppe auto required

ppp authentication ms-chap-v2

ppp chap hostname xxxxxx

ppp chap password 0 yyyyyyy

!

interface Vlan1

ip address 192.168.1.253 255.255.255.0

ip nat inside

ip virtual-reassembly

!

ip local pool PPTP_USERS 192.168.1.100 192.168.1.105

...

 

Im Windows XP-GUI habe ich dann eine PPTP Verbindung hergestellt mit den obigen Usernamen und Passwort. Ums vorweg z sagen: Pingen kann ich den Router von meinem PC aus, beide Internetanschlüsse sind ok. VLAN 1 ist auch up/up, es muss also wohl an meiner Config liegen, aber was fehlt ? Kennt jemand sich besser damit aus?

 

Danke im voraus,

Thimax

Share this post


Link to post

Anbei meine Konfigvorlage die ich immer verwende. Die Einwahl funktioniert von allen Interfaces aus, vorausgesetzt die Firewall lästs zu...

 

maccros

 

-----------------------------------------------------------------------------------------------

!

aaa new-model

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

vpdn enable

!

vpdn-group 1

accept-dialin

protocol pptp

virtual-template 1

!

username pptpuser password 0 geheim

!

interface Virtual-Template1

ip address 192.168.250.251 255.255.255.0

peer default ip address pool myPPTPPool

no keepalive

ppp encrypt mppe auto required

ppp authentication ms-chap ms-chap-v2

!

ip local pool myPPTPPool 192.168.250.1 192.168.250.250

!

 

-----------------------------------------------------------------------------------------------

Share this post


Link to post

Ich habe jetzt anstelle des ip unnumbered auf VLAN1 wie in maccros' Besispiel eine feste IP adresse auf meine Virtual-template konfiguriert. Das Problem ist weiterhin das gleiche:

The remote computer did not respond. Ein Telnet auf den Router funktionniert aber vom Internet aus :confused:

Share this post


Link to post

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname demolab

!

boot-start-marker

boot-end-marker

!

enable password cisco

!

aaa new-model

!

!

aaa authentication login default local

aaa authorization exec default local

!

aaa session-id common

!

resource policy

!

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool LAN

network 192.168.1.0 255.255.255.0

default-router 192.168.1.253

dns-server 194.154.192.101 194.154.192.102

!

!

no ip domain lookup

vpdn enable

!

vpdn-group 1

!

Default PPTP VPDN group

accept-dialin

protocol pptp

virtual-template 1

!

!

!

!

username xxxxx password 0 xxxxx

!

!

!

!

!

!

interface BRI0

no ip address

encapsulation hdlc

shutdown

!

interface ATM0

no ip address

ip accounting output-packets

no atm ilmi-keepalive

pvc 8/35

encapsulation aal5snap

pppoe-client dial-pool-number 1

!

dsl operating-mode auto

!

interface FastEthernet0

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface Virtual-Template1

ip address 10.1.1.254 255.255.255.0

peer default ip address pool pptp

no keepalive

ppp encrypt mppe auto required

ppp authentication ms-chap-v2

!

interface Vlan1

ip address 192.168.1.253 255.255.255.0

ip nat inside

ip virtual-reassembly

!

interface Dialer1

ip address negotiated

ip accounting output-packets

ip nat outside

no ip virtual-reassembly

encapsulation ppp

ip tcp adjust-mss 1452

dialer pool 1

dialer-group 1

ppp chap hostname xxxxx

ppp chap password 0 xxxxx

!

ip local pool pptp 10.1.1.1 10.1.1.253

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.1.0 0.0.0.255

access-list 1 permit 10.1.1.0 0.0.0.255

dialer-list 1 protocol ip permit

!

!

!

!

control-plane

!

!

line con 0

no modem enable

transport output all

line aux 0

transport output all

line vty 0 4

transport input all

transport output all

!

scheduler max-task-time 5000

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...