Jump to content
Sign in to follow this  
jussi

pppoe über dummy interface (1721)

Recommended Posts

Hallo,

 

ich habe eine 1721 mit 2 SHDSL Wics (für gebündelte Wan Leitung) und 1x ETH fürs LAN!

 

 

das eth IF habe ich auf einen hub gelegt, um gleichzeitig pppoe für eine adsl backup leitung zu machen.

 

woran muss ich nun den dialer binden, bzw was für ein "virtuelles" interface muss ich nun konfigurieren?

 

danke für mögliche vorschläge?

Share this post


Link to post
Share on other sites

Hi,

 

 

des ethernet interface bekommt eine normale ip adresse und zusätzlich die pppoe Kommandos und den dialer bindest du ebenfalls mittels pool an dieses Interface, der Router macht dann beides PPPOE und normales LAN Routing... Hab es selbst so auf nem 2600er gehabt...

 

 

Gruss

 

 

rob

Share this post


Link to post
Share on other sites

danke sehr, stelle gerade fest, ich muss erst mal ios upgraden (kein vpdn), leider ist das gerät schon produktiv. sobald ich deine lösung anwenden kann gebe ich nochmal bescheid.

Share this post


Link to post
Share on other sites

ich habe heute die config aktiviert. grundsätzlich geht es, aber es gibt irgendwie ein MTU problem wenn der dialer oben ist aber wegen vorhandener shdsl leitung alle pakete über die atm interfaces fliessen werden besteht ein MTU Problem (zB google.de wird nicht geladen das ist der mtu klassiker) sobald ich den dialer auf shutdown setze (siehe config) geht alle flink. Nur das ist ja als backupleitung ziemlich nutzlos. hat jemand ne idee?

 

Current configuration : 2584 bytes
!
version 12.4
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname xxxxxxxxxxxxxx
!
boot-start-marker
boot system flash c1700-k9o3sy7-mz.124-12c.bin
boot-end-marker
!
enable password 7 XXXXXXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
clock timezone MET 1
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
ip cef
no ip domain lookup
!
vpdn enable
!
password encryption aes
!
!
!
!
!
controller DSL 0
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto
!
controller DSL 1
mode atm
line-term cpe
line-mode 2-wire line-zero
dsl-mode shdsl symmetric annex B
line-rate auto
! 
!
!
!         
interface Loopback0
no ip address
!
interface ATM0
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
ip unnumbered FastEthernet0
no ip redirects
no ip unreachables
ip load-sharing per-packet
no ip route-cache
no snmp trap link-status
pvc b-dsl2 1/51 
 ubr 2300
 encapsulation aal5snap
!
!
interface ATM0.2 point-to-point
no ip route-cache
no snmp trap link-status
pvc noc 0/51 
 ubr 32
 encapsulation aal5snap
!
!
interface ATM1
no ip address
no ip route-cache cef
no ip route-cache
no atm ilmi-keepalive
!
interface ATM1.1 point-to-point
ip unnumbered FastEthernet0
no ip redirects
no ip unreachables
ip load-sharing per-packet
no ip route-cache
no snmp trap link-status
pvc b-dsl2 1/51 
 ubr 2300
 encapsulation aal5snap
!
!
interface ATM1.2 point-to-point
no ip route-cache
no snmp trap link-status
pvc no 0/51 
 ubr 32
 encapsulation aal5snap
!
!
interface FastEthernet0
ip address x.y.z.33 255.255.255.192
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
no cdp enable
!
interface Dialer0
description pppoe nach tdsl
ip address negotiated
no ip redirects
no ip unreachables
ip mtu 1412
encapsulation ppp
no ip mroute-cache
shutdown
dialer pool 1
dialer idle-timeout 15
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxxxxxxxxxxxxxxxxx password 7 xxxxxxxxxxxxxxx
!
ip route 0.0.0.0 0.0.0.0 ATM0.1
ip route 0.0.0.0 0.0.0.0 ATM1.1
ip route 0.0.0.0 0.0.0.0 Dialer0 150
no ip http server
no ip http secure-server
!
!
!
logging history size 20
logging facility local2
logging a.b.c.d
access-list 50 permit a.b.c.d n.n.n.m
access-list 50 deny   any
no cdp run
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
access-class 50 in
password 7 xxxxxxxxxxxxxxxxxx
login
!
end       

Share this post


Link to post
Share on other sites

hi wordo,

 

sobald der dialer oben ist hab ich ein massives mtu problem. die route war testweise mal runter, aber ich war mir vorher schon sicher, dass darüber im falle von mindestens einer ATM Leitung vorhanden, kein traffic fließt.

 

könnte die eingesetzte hardware ein problem sein?

der cisco hat ja nur ein (fa)eth interface dieses ist nun mit einem switch/hub (ich weiss nicht mal was der kunde da benutzt hat) verbunden und darein gehen das adsl modem und das LAN.

ich habe das hier geändert/zusätzlich eingetragen:

 

ip mtu 1492

ip tcp adjust-mss 1452

 

scheint die wende zu bringen

update:

Nein, das war es nicht. :-(

 

muss die MTU des Fastethernet Interfaces (welches ja das physikalische interface des Dialer ist) die gleiche MTU und MSS haben wie der Dialer?

 

Hier wird kein Nat gemacht oder ähnliches. Das geschiet hinter dem Router an der Kunden FW.

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...