Jump to content
Sign in to follow this  
Klettermaxx

LNS für QoS, Load Balancing

Recommended Posts

Servus zusammen,

 

vielleicht ist ja doch ein Kenner unter uns. Für die Terminierung von PPP-Sessions benötige ich einen als LNS konfigurierten Cisco Router. Der LNS selber steht und funktioniert top.

 

Ich benötige allerdings einen Denkanstoß zur Konfiguration von Load Balancing mit QoS. Die Cisco Website ist schon tagelang von mir durchforstet worden, genauso die Seiten von Juniper Networks.

 

Das QoS an sich ist weniger das Problem, denn ich kann per AVPair sowie direkt auf dem Virtual Template, wo die L2TP Tunnel terminieren, die QoS-Config mitgeben. Arge Magengeschwüre bereitet jedoch das Load Balancing. Die CPEs sprechen BGP mit dem LNS, allerdings, muss für Load Sharing auf jedem Outgoing Interface das IP Load Sharing aktiviert werden, was bei Virtuellen Interfacen nicht konfigurierbar ist. Die Loopback kann man dazu auch net nutzen. Ich tippe mal das ich um MLPPP nicht drum rum komme. Sofern jemand auf gleichem Niveau wie ich arbeitet und Erfahrung hat, würde mir ein Denkanstoß aus dessen Erfahrung sehr viel weiter helfen. Vielen Dank erstmal vorraus.

Share this post


Link to post
Share on other sites

Ich kann zum konkreten Problem leider nicht helfen, aber mein letzter Stand war, dass vernuenftiges QoS mit AVPairs bei nem L2TP LNS mit VTemplates nicht funktioniert.

 

Hast du das richtig durchgetestet?

Share this post


Link to post
Share on other sites

Zum einen gebe ich Dir auf jeden Fall recht vernünftiges QoS ist das auf jeden Fall nicht. Nur Du kannst mitlerweile kaum noch Kunden vom DSL abhalten. Sie wollen alles genauso über DSL bzw. SDSL machen, wie auch über Ihre alten Carrier Festverbindungen, nur muss alles günstig sein.

 

Komplett getestet haben wir es zur Zeit noch nicht, aber wir werden es garantiert in einem Labortest aufbauen. Trotzdem erstmal danke!

Share this post


Link to post
Share on other sites

Hallo,

 

was hat nun QOS mit [L3] Loadbalancing zu tun? Aus QOS sicht gibt es phy oder virt interface mit einer bestimmten Bandbreite. Falls du mehrere Subscriber via PPPOE oder vielleicht L2TP terminiren willst und dort an dieser Stelle (BRAS) QOS in Richtung Kunde realisieren willst geht es hauptsächlich um die Deklaration der Richtigen Hardware für diesen Zweck. Ich kenne leider deine Konstellation nicht genau. Im Normalfall (mehrere Kunde via PPPOE / L2TP) sollte hier H-QOS (im Cisco Syntax) oder Subsciber Based QOS (Juniper) interessant sein. Hier handelt es sich hauptsächlich um Provider HW. Welche HW benutzt ihr als LNS.

Die Grenzen ältere HW sind eng geschnürt.. QOS in HW und nicht anderen Pfaden ist teilweise also nicht möglich..

 

ciao

Share this post


Link to post
Share on other sites

Hi,

 

also du hast zum Kunden 2 PPPoE sessions, über beide machst du BGP. Dazu möchtest du QoS machen und Load-Balancing ??

 

Zu Qos:

Per-Session Qos ist das Stichwort. Unterstützt von 7200,7300, 10000 Routern (IOS 12.2SB) soviel ich weiss. Ich habs auf 7200ern getestet. Du kannst über Radius die Service-Policy zuweisen (Diese muss lokal konfiguriert sein).

Am besten das "Parent - Child konzept". Also ein traffic-shape auf der default-lass, darin ein LLQ oder CBWFQ.

bsp:

 

class-map PREC5

match ip precedence 5

 

policy-map MAP_PREC5

class PREC5

priority percent 20

 

policy-map SHAPE_2048

class-class default

shape average 2048000

service-policy MAP_PREC5

 

 

Zo Load-Balancing:

Lass das von CEF erledigen. Dein Problem wird vermutlich sein, dass BGP per default nur dei beste Route in die Routingtable aufnimmt. Somit auch nur 1 CEF Eintrag.

 

Unter dem BGP Prozess "maximum-paths 2" lässt 2 gleichwertige Einträge zu.

 

Wernn du in der Rrouting Table 2 gleichwertige Routen hast, und CEF aktiv ist, sollte per-destination Load Balancing (default; per-packet konfigurierbar) gemacht werden.

 

Kann das funktionieren??!

 

Grüsse,

Thomas

Share this post


Link to post
Share on other sites

Servus,

 

hier ist ein Beispiel für Loadbalancing mit OER (und CLNS):

version 12.4

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

!

resource policy

!

ip subnet-zero

!

!

!

!

ip cef

vpdn enable

!

!

clns routing

!

!

!

key chain cisco0

key 1

key-string 7 *******

!

!

!

!

!

!

!

!

!

!

!

!

oer master

policy-rules OER

max-range-utilization percent 10

keepalive 1

!

border 192.168.20.1 key-chain cisco0

interface FastEthernet0/0.21 internal

interface FastEthernet0/0.22 internal

interface Ethernet1/0 external

interface Ethernet1/1 external

!

learn

throughput

delay

periodic-interval 1

monitor-period 2

prefixes 200

expire after time 1

aggregation-type prefix-length 32

max prefix total 2500

backoff 180 360

mode route control

mode select-exit best

periodic 180

resolve loss priority 1 variance 1

resolve delay priority 2 variance 1

resolve utilization priority 3 variance 1

resolve range priority 5

!

oer border

local Loopback0

active-probe address source interface Ethernet1/0

master 192.168.20.1 key-chain cisco0

!

!

!

!

!

!

!

bba-group pppoe global

!

!

interface Loopback0

description OER Master Controller

ip address 192.168.20.1 255.255.255.255

!

interface FastEthernet0/0

description To L2 Switch port 15

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

description Native VLAN Trunking

encapsulation dot1Q 1 native

ip address 192.168.205.1 255.255.255.248

!

interface FastEthernet0/0.21

description To Switch A port 10

encapsulation dot1Q 21

ip address 192.168.21.1 255.255.255.252

ip nat inside

ip virtual-reassembly

!

interface FastEthernet0/0.22

description To Switch B port 2

encapsulation dot1Q 22

ip address 192.168.22.1 255.255.255.252

ip nat inside

ip virtual-reassembly

!

!

interface Ethernet1/0

description To NAT box of ISP #1

ip address 172.16.0.2 255.255.255.252

full-duplex

!

interface Ethernet1/1

description To NAT box of ISP #2

ip address 172.16.0.6 255.255.255.252

ip virtual-reassembly

full-duplex

!

interface Ethernet1/2

no ip address

shutdown

half-duplex

!

interface Ethernet1/3

no ip address

shutdown

half-duplex

!

!

!

!

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.1

ip route 0.0.0.0 0.0.0.0 172.16.0.5

!

!

no ip http server

no ip http secure-server

!

ip prefix-list OER seq 10 permit 0.0.0.0/0

!

access-list 20 remark Approved IP addresses

access-list 20 permit 10.0.0.0 0.255.255.255

access-list 20 permit 172.16.0.0 0.15.255.255

access-list 20 permit 192.168.0.0 0.0.255.255

dialer-list 2 protocol ip permit

no cdp run

!

!

!

oer-map OER 10

match ip address prefix-list OER

!

control-plane

!

!

!

line con 0

line aux 0

line vty 0 4

access-class 20 in

password 7 ******

login

!

!

end

 

 

Vielleicht hilft Dir das ja weiter.

 

Gruss,

 

theMatrix

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...