Jump to content
Sign in to follow this  
xyCruiseryx

HSRP Konfiguration: Frage zum Status

Recommended Posts

Hi alle,

 

hier mal ein HSRP Beispiel. Unten wären dann die Fragen.

 

HSRP configuration for DLS1:

DLS1# config t

Enter configuration commands, one per line. End with CNTL/Z.

DLS1(config)# ip routing

DLS1(config)# interface vlan 1

DLS1(config-if)# standby 1 ip 172.16.1.1

DLS1(config-if)# standby 1 preempt

DLS1(config-if)# standby 1 priority 150

DLS1(config-if)# exit

DLS1(config)# interface vlan 10

DLS1(config-if)# ip address 172.16.10.3 255.255.255.0

DLS1(config-if)# standby 1 ip 172.16.10.1

DLS1(config-if)# standby 1 preempt

DLS1(config-if)# standby 1 priority 150

DLS1(config-if)# no shutdown

DLS1(config-if)# exit

DLS1(config)# interface vlan 20

DLS1(config-if)# ip address 172.16.20.3 255.255.255.0

DLS1(config-if)# standby 1 ip 172.16.20.1

DLS1(config-if)# standby 1 preempt

DLS1(config-if)# standby 1 priority 150

DLS1(config-if)# exit

DLS1(config)# interface vlan 30

DLS1(config-if)# ip address 172.16.30.3 255.255.255.0

DLS1(config-if)# standby 1 ip 172.16.30.1

DLS1(config-if)# standby 1 preempt

DLS1(config-if)# standby 1 priority 100

DLS1(config-if)# exit

DLS1(config)# interface vlan 40

DLS1(config-if)# ip address 172.16.40.3 255.255.255.0

DLS1(config-if)# standby 1 ip 172.16.40.1

DLS1(config-if)# standby 1 preempt

DLS1(config-if)# standby 1 priority 100

DLS1(config-if)# end

 

 

HSRP configuration for DLS2:

DLS2# config t

Enter configuration commands, one per line. End with CNTL/Z.

DLS2(config)# ip routing

DLS2(config)# interface vlan 1

DLS2(config-if)# standby 1 ip 172.16.1.1

DLS2(config-if)# standby 1 preempt

DLS2(config-if)# standby 1 priority 150

DLS2(config-if)# exit

DLS2(config)# interface vlan 10

DLS2(config-if)# ip address 172.16.10.4 255.255.255.0

DLS2(config-if)# standby 1 ip 172.16.10.1

DLS2(config-if)# standby 1 preempt

DLS2(config-if)# standby 1 priority 150

DLS2(config-if)# no shutdown

DLS2(config-if)# exit

DLS2(config)# interface vlan 20

DLS2(config-if)# ip address 172.16.20.4 255.255.255.0

DLS2(config-if)# standby 1 ip 172.16.20.1

DLS2(config-if)# standby 1 preempt

DLS2(config-if)# standby 1 priority 150

DLS2(config-if)# exit

DLS2(config)# interface vlan 30

DLS2(config-if)# ip address 172.16.30.4 255.255.255.0

DLS2(config-if)# standby 1 ip 172.16.30.1

DLS2(config-if)# standby 1 preempt

DLS2(config-if)# standby 1 priority 100

DLS2(config-if)# exit

DLS2(config)# interface vlan 40

DLS2(config-if)# ip address 172.16.40.4 255.255.255.0

DLS2(config-if)# standby 1 ip 172.16.40.1

DLS2(config-if)# standby 1 preempt

DLS2(config-if)# standby 1 priority 100

DLS2(config-if)# end

Share this post


Link to post
Share on other sites

Step 8

Issue the show standby command on both DLS1 and DLS2.

DLS1# show standby

Vlan1 - Group 1

State is Active

5 state changes, last state change 00:02:48

Virtual IP address is 172.16.1.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.228 secs

Preemption enabled

Active router is local

Standby router is 172.16.1.4, priority 100 (expires in 7.207 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Vl1-1" (default)

 

Vlan10 - Group 1

State is Active

5 state changes, last state change 00:02:50

Virtual IP address is 172.16.10.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.113 secs

Preemption enabled

Active router is local

Standby router is 172.16.10.4, priority 100 (expires in 9.807 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Vl10-1" (default)

 

Vlan20 - Group 1

State is Active

5 state changes, last state change 00:02:55

Virtual IP address is 172.16.20.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.884 secs

Preemption enabled

Active router is local

Standby router is 172.16.20.4, priority 100 (expires in 9.220 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Vl20-1" (default)

 

Vlan30 - Group 1

State is Standby

4 state changes, last state change 00:02:45

Virtual IP address is 172.16.30.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.413 secs

Preemption enabled

Active router is 172.16.30.4, priority 150 (expires in 8.415 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl30-1" (default)

 

Vlan40 - Group 1

State is Standby

11 - 18 CCNP: Building Multilayer Switched Networks v5.0 - Lab 5-1 Copyright © 2006, Cisco Systems, Inc

4 state changes, last state change 00:02:51

Virtual IP address is 172.16.40.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.826 secs

Preemption enabled

Active router is 172.16.40.4, priority 150 (expires in 7.828 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl40-1" (default)

Share this post


Link to post
Share on other sites

DLS2# show standby

Vlan1 - Group 1

State is Standby

3 state changes, last state change 00:02:33

Virtual IP address is 172.16.1.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.950 secs

Preemption enabled

Active router is 172.16.1.3, priority 150 (expires in 8.960 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl1-1" (default)

 

Vlan10 - Group 1

State is Standby

3 state changes, last state change 00:02:34

Virtual IP address is 172.16.10.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.759 secs

Preemption enabled

Active router is 172.16.10.3, priority 150 (expires in 7.844 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl10-1" (default)

 

Vlan20 - Group 1

State is Standby

3 state changes, last state change 00:02:42

Virtual IP address is 172.16.20.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.790 secs

Preemption enabled

Active router is 172.16.20.3, priority 150 (expires in 8.289 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl20-1" (default)

 

Vlan30 - Group 1

State is Active

2 state changes, last state change 00:02:52

Virtual IP address is 172.16.30.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 1.549 secs

Preemption enabled

12 - 18 CCNP: Building Multilayer Switched Networks v5.0 - Lab 5-1 Copyright © 2006, Cisco Systems, Inc

Active router is local

Standby router is 172.16.30.3, priority 100 (expires in 9.538 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Vl30-1" (default)

 

Vlan40 - Group 1

State is Active

2 state changes, last state change 00:02:58

Virtual IP address is 172.16.40.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 0.962 secs

Preemption enabled

Active router is local

Standby router is 172.16.40.3, priority 100 (expires in 8.960 sec)

Priority 150 (configured 150)

IP redundancy name is "hsrp-Vl40-1" (default)

 

 

Frage: Warum sind nicht alle Vlans vom DLS2 im HSRP Activ Mode? VLan 30 und 40 sind activ. Warum:? Weil auf DSL2 die größte IP-Adresse ist?

 

Beide DSLs haben die gleiche Prio jedoch unterschiedlihe activ states.

 

 

Kann mir das wer erklären.????

Share this post


Link to post
Share on other sites

hm, hab ich Tomaten auf den Augen, ich seh kurz zusammengefasst:

 

DLS1:physikalische IP immer 172.16.VID.3

DLS2:physikalische IP immer 172.16.VID.4

 

 

virtuelle immer 172.16.VID.1,priority immer gleich. meine Tipps wären:

 

wer zuerst kommt mahlt zuerst

Fehler in der Aufgabenstellung/SIM und es sollten unterschiedliche prios da sein. Die Konfig so wie angegeben macht mir Kopfzerbrechen

 

Zum überfliegen wäre es einfacher wenn man nur die Config teile hätte

Share this post


Link to post
Share on other sites

Moin,

 

Frage: Warum sind nicht alle Vlans vom DLS2 im HSRP Activ Mode? VLan 30 und 40 sind activ. Warum:? Weil auf DSL2 die größte IP-Adresse ist?

 

So wie ich die Konfig überfliege, sollten auf'm DSL2 alle Vlans im "active" sein.

Bei gleicher Priority, wird der Active, der die höchste IP in dem VLAN hat.

 

Allerdings, im show vom DSL2 steht folgendes:

 

DLS2# show standby

Vlan1 - Group 1

State is Standby

3 state changes, last state change 00:02:33

Virtual IP address is 172.16.1.1

Active virtual MAC address is 0000.0c07.ac01

Local virtual MAC address is 0000.0c07.ac01 (v1 default)

Hello time 3 sec, hold time 10 sec

Next hello sent in 2.950 secs

Preemption enabled

Active router is 172.16.1.3, priority 150 (expires in 8.960 sec)

Standby router is local

Priority 100 (default 100)

IP redundancy name is "hsrp-Vl1-1" (default)

 

Sicher das Du auch wirklich Priority 150 eingeben hast? So wie ich das sehe, ist es nicht so, da er die Default-Priotity 100 nimmt.

 

Thomas

Share this post


Link to post
Share on other sites

Am besten du setzt auf dem Switch der active sein soll die Priority auf 110. Die priorty auf den Switch der Standby sein soll lässt du auf den default Wert (100). Dann sieht man gleich wer active sein soll.

 

 

lg Franz

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...