Jump to content

Fehler beim Replizieren des AD


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen,

 

ich habe hier im Forum schon sehr viel gelesen, jedoch bei meinem jetzigen Problem bin ich nicht fündig geworden.

Sollte es hier doch schon einmal beschrieben sein, so bitte ich vorab schonmal um Entschuldigung. :cool:

 

Ich beschreibe mal mein Problem.

 

Ich habe einen w3K installiert und dieser wurde der PDC. Ich habe ihn heraufgestuft auf 2003. Auch hier ist ein DNS Server installiert.

 

Jetzt wollte ich einen zweiten w3K in der Domaine hinein hängen, welcher Repliziert. Ich weiß man nennt ihn zwar nicht mehr BDC, soll aber der Sicherungsserver werden.

 

Also den zweiten Server soweit installiert ok, danach dcpromo aufgerufen und als vorhanden Server in die Domaine einbinden. Soweit noch alles ok. Jetzt muss ich ja die Verzechnisse auswählen etc. Ich habe extra alles identisch zum "PDC" aufgebaut, da identische Hardware. Dann fängt er an zu Replizieren und hört bei "Die Schemaverzeichnispartition wird repliziert" mit folgender Fehlermeldung auf.

 

Der Vorgang ist fehlgeschlagen. Fehler:

 

Active Directory konnte die Verzeichnispartition CN=Schema,CN=Configuration,DC=Blablub,DC=de des

Remotedomänencontroller pdc nicht replizieren.

 

"Die Syntax für den Dateinamen, Verzeichnisnamen oder die Datenträgerbezeichnung ist falsch."

 

Ich habe schon sehr viel gegoogelt usw. aber leider keine passende Lösung gefunden. Vielleicht habt Ihr ja einen Tipp für mich! Wäre sehr schön :)

 

Grüße

 

Ralf

Link to comment

Hola,

 

Jetzt wollte ich einen zweiten w3K in der Domaine hinein hängen, welcher Repliziert. Ich weiß man nennt ihn zwar nicht mehr BDC, soll aber der Sicherungsserver werden.

 

trotzdem gibt es die Bezeichnungen PDC und BDC so nicht mehr. Es sind alles DCs.

 

 

Jetzt muss ich ja die Verzechnisse auswählen etc.

 

Nein, musst du nicht.

Normalerweise fügst du den Server als zusätzlichen DC deiner bestehenden Domäne hinzu und wartest lediglich die AD-Replikation ab.

An keinem Punkt musst du angeben, welche Verzeichnispartitionen repliziert werden sollen.

 

Siehe:

Yusuf`s Directory - Blog - Einen zusätzlichen DC in die Domäne hinzufügen

 

 

Schildere deine Vorgehensweise genauer.

Link to comment

@Daim

 

Danke für Deine Antwort.

 

trotzdem gibt es die Bezeichnungen PDC und BDC so nicht mehr. Es sind alles DCs.

Ok werde mich bemühen dies einzuhalten :D

 

Nein, musst du nicht.

Normalerweise fügst du den Server als zusätzlichen DC deiner bestehenden Domäne hinzu und wartest lediglich die AD-Replikation ab.

An keinem Punkt musst du angeben, welche Verzeichnispartitionen repliziert werden sollen.

Das verwundert mich ein bissel.

 

Ich mache folgendes:

 

Am zweiten Server starte ich dcpromo.

Dann kommt eine Betriebssystemkompatibilitäts Abfrage, welche ich mit weiter bestätige.

Dann folgt die Frage welchen Typ es sein soll. Ich gebe an "Zusätzlicher Domänencontroller für eine bestehende Domäne."

Danach muss ich Benutzernamen und Kennwort eintragen + die vorhandene Domaine.

Wenn ich auf weiter drücke muss ich die vorhandene Domäne "xxx" bestätigen.

Jetzt fragt er mich nach Datenbank und Protokollordner.

Ich soll ihm mitteilen wo was gespeichert werden soll.

Nach deiner Aussage dürfte dies ja jetzt gar nicht kommen richtig?

 

Was mache ich Falsch?

Link to comment
Jetzt fragt er mich nach Datenbank und Protokollordner.

Ich soll ihm mitteilen wo was gespeichert werden soll.

Nach deiner Aussage dürfte dies ja jetzt gar nicht kommen richtig?

 

Ahaa... einer von uns beiden unterliegt (wie so oft) dem "Begrifflichkeits-Problem" ;) .

Das ist alles richtig. Der Assistent fragt dich, wo die Active Directory-Datenbank (NTDS.dit) sowie die Protokoll-Dateien gespeichert werden sollen.

 

Er fragt dich aber nirgends, welche Verzeichnispartitionen repliziert werden sollen.

Denn es werden automatisch alle Verzeichnispartitionen die der andere DC hält, auf den neuen repliziert.

Der neue DC erhält automatisch die folgenden Verzeichnispartitionen:

 

- Schema-Partition

- Konfigurations-Partition

- Domänen-Partition

- Anwendungsverzeichnispartition (wie z.B. die DomainDNSZone sowie die ForestDNSZone)

 

 

Was mache ich Falsch?

 

Du wirfst die Begrifflichkeiten durch die Gegend ;) .

Überprüfe dein Vorgehen mit dem o.g. Artikel, evtl. fällt dir ein Fehler auf.

Link to comment

@Daim

 

Danke

 

Folgendes:

1. Auf dem neuen Server, muss in seinen TCP/IP-Einstellungen ein bereits bestehender DC/DNS (auf dem idealerweise das DNS AD-integriert installiert ist und "Nur sichere" Updates zulässt) als "Bevorzugter DNS-Server" eingetragen sein.

Habe ich, ist mein erster Server, feste IP.

 

2. Danach ruft man auf dem neuen Server den Active Directory-Assistenten "DCPROMO" auf und wählt an entsprechender Stelle den Punkt

"zusätzlichen Domänencontroller für eine bestehende Domäne" aus.

Habe ich auch, wie ich ja eben erklärt habe.

 

3. Wenn der DCPROMO-Assistent abgeschlossen und der neue DC neu gestartet wurde, sollte anschließend (oder vorher) das DNS nur installiert und nicht konfiguriert werden. Denn das DNS ist (auf dem ersten DC) schon konfiguriert. Die DNS-Konfiguration gilt es abzubrechen.

Danach wartet man die Replikation ab und somit sollte der neue DC alle Informationen mitlerweile repliziert bekommen haben.

Der Assistent kann gar nicht abgeschlossen werden, da vorher eben die Fehlermeldung kommt.

Ich teste mal eben wenn ich vorher den DNS installiere, was dann passiert.

Leider keine Veränderung, der "Assistent zum installieren von Active Diretcory" fängt an und bleibt dann wie oben beschrieben irgendwann hängen. Genau an der Stelle "Die Schemaverzeichnispartition wird repliziert" mit eben o.g. Fehlermeldung.

 

Also bis jetzt denke ich habe ich doch alles richtig gemacht oder?

Muss man evtl. auf etwas anderes Rücksichtnehmen?

 

Frage?! Darf der neue Server, welcher auch DC werden soll in der Domaine reingehangen werden oder nicht? Sprich unter System-->Computername-->Domäne(Server1 (PDC))

Link to comment
Ich teste mal eben wenn ich vorher den DNS installiere, was dann passiert.

Leider keine Veränderung, der "Assistent zum installieren von Active Diretcory" fängt an und bleibt dann wie oben beschrieben irgendwann hängen. Genau an der Stelle "Die Schemaverzeichnispartition wird repliziert" mit eben o.g. Fehlermeldung.

 

Das hat an dieser Stelle mit der Installation des DNS auch nichts zu tun.

 

 

Also bis jetzt denke ich habe ich doch alles richtig gemacht oder?

 

Das sieht zumindest von hier aus richtig aus.

 

 

Muss man evtl. auf etwas anderes Rücksichtnehmen?

 

Der Link beschreibt das was es zu tun gilt, mehr gibt es nicht zu beachten.

Das Benutzerkonto das du im Assistenten angibst ist der Domänen-Admin ?

 

Frage?! Darf der neue Server, welcher auch DC werden soll in der Domaine reingehangen werden oder nicht? Sprich unter System-->Computername-->Domäne(Server1 (PDC))

 

Du meinst, ob der Server vor dem promoten zum DC Mitglied der Domäne sein darf, also ein Memberserver ?

Das ist "Jacke wie Hose", spielt keine Rolle.

 

Dann kontrolliere doch mal das DCPROMOUI.LOG, welche Meldungen dort protokolliert wurden.

Evtl. stehen dort weitere Hinweise.

 

Yusuf`s Directory - Blog - Debug Protokollierung

Link to comment
Das Benutzerkonto das du im Assistenten angibst ist der Domänen-Admin ?

Ja, bin Admin.

 

Dann kontrolliere doch mal das DCPROMOUI.LOG, welche Meldungen dort protokolliert wurden.

Evtl. stehen dort weitere Hinweise.

Also ich habe mir die Log Dateien mal genauer angeschaut. Also etwas gravierendes ist mir persönlich nicht aufgefallen, bin aber auch nicht soooooo fit wie Ihr hier.

Das einzige ist er konnte die Zeit nicht synchronisieren.

Evtl guckt Ihr mal rein?! Danke

 

Beide Logs habe ich als Anhang dran gepackt.

dcpromo.txt

dcpromoui2.txt

Link to comment

So Deine Aussage mit

Du meinst, ob der Server vor dem promoten zum DC Mitglied der Domäne sein darf, also ein Memberserver ?

Das ist "Jacke wie Hose", spielt keine Rolle.

hat mir keine ruhe gelassen.

Ich habe den zweiten Server jetzt nicht mehr als Mitglied der Domäne und siehe da ich habe auch noch ein anderes Problem.

Das Problem wurde hier im Forum zwar schon angesprochen aber nicht gelöst.

Siehe Post http://www.mcseboard.de/windows-forum-ms-backoffice-31/weiterer-dc-w2k3-ad-assistent-haengt-15442.html

Genau das gleiche "Problem" habe ich auch. Nehme ich den zweiten Server jedoch in die Domäne auf verschwindet das Problem und ich habe mein "altes" Problem.

 

Irgendwie verstehe ich jetzt gar nichts mehr!

 

Um evtl. Fragen vor ab zu klären, ich habe den AD auf dem erster Server installiert und er hat automatisch den DNS mit installiert. Und auch die HOST Einträge für den 2. Server sind im DNS eingetragen.

 

Eine Namensauflösung mit nslookup funktioniert auch einwandfrei. Ping etc. funktioniert auch.

 

Es kann doch nicht so schwer sein einen DC Server zu replizieren? Oder vielleicht doch?

Ich bin für jede Hilfe dankbar!

Link to comment
Ich habe den zweiten Server jetzt nicht mehr als Mitglied der Domäne und siehe da ich habe auch noch ein anderes Problem.

 

Das ist dann aber auch ein "lokales" Problem der nicht standardmäßig auftritt.

Weder das eine, noch das andere Problem von dir, habe ich jemals - mit sicherlich über 1.000 DC-Installationen (Produktiv+Testumgebung+VMs) - noch nie gehabt.

 

 

Nehme ich den zweiten Server jedoch in die Domäne auf verschwindet das Problem und ich habe mein "altes" Problem.

 

Da liegt dann irgendwo der Hase im Pfeffer begraben.

Das ist aber kein Normalzustand und ich kann mich nur wiederholen, es ist egal ob der Server vorher Mitglied der Domäne ist oder nicht.

 

 

Um evtl. Fragen vor ab zu klären, ich habe den AD auf dem erster Server installiert und er hat automatisch den DNS mit installiert.

 

Völlig korrekt.

 

 

Es kann doch nicht so schwer sein einen DC Server zu replizieren? Oder vielleicht doch?

 

Nein, ist es natürlich nicht. Nur gilt es eben die Fehlerquelle herauszufinden.

Deine Logs wurden zwar noch nicht freigeschaltet, aber führe auf dem ersten DC sicherheitshalber das DCPROMO /v aus. DCPROMO findest du in den Windows Support Tools.

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...