Jump to content
Sign in to follow this  
voyager1111

cisco 1802 dialer gateway problem

Recommended Posts

hallo liebes forum,

 

ich habe folgende cisco konfiguration vor:

mein firewall gateway hat die ip adresse 192.168.20.5.

 

ein client(cl1) pingt über die fw den rechter mit der ip adresse 192.168.21.1 an, daraufhin wählt der cisco das gewünschte netz an.

ein anderer client(cl2) ruft zb ip die adresse 192.168.22.2 an.

 

ich möchte also, über verschiedene netzwerke unterschiedliche nummer anwählen und eine verbindung aufbauen.

 

nun habe ich das problem, dass die verbindung auf den cisco angepingt werden kann, nur dem cl1 und cl2 sind diese adressen nicht erreichbar.

ich vermute, dass ihr noch irgendeine router fehlt.

 

ich dachte eigentlich, dass ich mit dem default-gateway das problem lösen könnte.

jedoch ohne erfolg.

 

nun frage ich hier einmal nach.

hat jemand eine lösung?

 

cya

marco

 

nun der cisco code:

 

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname cisco1802

!

boot-start-marker

boot-end-marker

!

enable secret 5 test

!

no aaa new-model

!

resource policy

!

!

!

ip cef

!

!

no ip domain lookup

vpdn enable

!

!

isdn switch-type basic-net3

!

!

username test password 0 test

username dial password 0 dial

username einwahl password 0 einwahl

!

!

!

!

!

!

interface FastEthernet0

description Netzwerk mit Firewall Gateway 192.168.20.5

ip address 192.168.20.1 255.255.255.0

duplex auto

speed auto

!

interface BRI0

no ip address

encapsulation ppp

dialer pool-member 1

dialer pool-member 2

isdn switch-type basic-net3

isdn point-to-point-setup

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

interface Vlan1

no ip address

shutdown

!

interface Dialer2

description Einwahl in PC 2 Windows-Client xp mit dialin interne ip 192.168.21.1

ip address 192.168.21.2 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name dial2

dialer string 123456789

dialer-group 1

ppp authentication ms-chap-v2 callin

ppp chap hostname dial

ppp chap password 0 dial

!

interface Dialer3

description Einwahl in PC 3

ip address 192.168.23.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name dial3

dialer string 12345

dialer-group 1

ppp callback request

ppp authentication ms-chap-v2 callin

ppp chap hostname dial

ppp chap password 0 dial

!

interface Dialer99

description Einwahl einwahl

ip address 1.1.1.1 255.255.255.252

encapsulation ppp

dialer pool 2

dialer remote-name test

dialer caller 12345678

dialer-group 1

ppp authentication chap

!

interface Dialer1

description Einwahl PC 1 interne ip adresse 192.168.22.2

ip address 192.168.22.1 255.255.255.0

encapsulation ppp

dialer pool 1

dialer remote-name dial

dialer string 1234

dialer-group 1

ppp authentication ms-chap-v2 callin

ppp chap hostname dial

ppp chap password 0 dial

!

interface Dialer100

description Pinakothek-Einwahl

ip address 192.168.24.1 255.255.255.0

encapsulation ppp

dialer pool 2

dialer remote-name einwahl

dialer caller 12345678

dialer-group 1

ppp authentication chap

!

!

!

ip route 0.0.0.0 0.0.0.0 192.168.20.5

!

!

no ip http server

no ip http secure-server

!

dialer-list 1 protocol ip permit

!

!

!

!

!

!

control-plane

!

!

line con 0

line aux 0

line vty 0 4

password test

login

!

!

webvpn context Default_context

ssl authenticate verify all

!

no inservice

!

end

forum_einwahl1.txt

Share this post


Link to post
Share on other sites

ja die fw macht ein NAT in diese dailer netze.

die dialer ip adressen kann ich von den clients anpingen.

 

nur das aufgebautes netz kann nicht erreicht werden.

 

normalerweise sollte doch eigentlich das default-gateway alles routen, oder ?

Share this post


Link to post
Share on other sites

Hi, ist vielleicht ein Problem mit dem Rückrouting von den Rechnern, bei die Rechner brauchen dann 192.168.21.2 bzw. 192.168.23.1 als Gateway für das Netz 192.168.20.0 / 24. Vorsicht, die Leitung würde ich, wenn keine ISDN flat vorhanden ist, erstmal Monitoren und mittels dialer list einschränken, damit es nicht mit der ersten Telefonrechnung ein böses Erwachen gibt.

 

Gruss

 

rob

Share this post


Link to post
Share on other sites

okay, die fehlende rückroute leuchtet mir jetzt auch ein.

 

 

nun ist es leider so, dass ich vor-ort eine isdn einwahl via windows realistiert habe.

dort kann ich leider keine route eintragen, normalerweiser bekomme ich i.d.r immer eine 255.255.255.255 maske.

 

ich habe das gefühlt, ich muss jedes dialer interface eine rückroute eintragen.

doch wie und was soll ich eintragen ?

 

ps. isdn-flat ist natürlich auch vorhanden.

post-43897-13567389466107_thumb.jpg

Share this post


Link to post
Share on other sites

Hi,

 

 

wenn du eine isdn einwahl hast, solltest du eventuell den rechnern die ips zuweisen oder hast du die ips jetzt statisch drin? die brauchen auf jeden fall die ips auf den dialern als gateway (egal ob fest eingetragen oder zugwiesen). und wenn dieser gateway nicht default gateway ist dann noch eine route :

 

PC1:

 

route -p add 192.168.20.0 mask 255.255.255.0 192.168.22.1

 

 

gruss

 

 

rob

Share this post


Link to post
Share on other sites
Hi,

 

 

wenn du eine isdn einwahl hast, solltest du eventuell den rechnern die ips zuweisen oder hast du die ips jetzt statisch drin? die brauchen auf jeden fall die ips auf den dialern als gateway (egal ob fest eingetragen oder zugwiesen). und wenn dieser gateway nicht default gateway ist dann noch eine route :

 

ah verstehe, dass heisst, die rechner auf denen ich mich eingewählt habe, würde ich einfach eine route hinzufügen!

mmm...für einen oder zwei rechner kann man das sicherlich machen.

 

 

PC1:

 

route -p add 192.168.20.0 mask 255.255.255.0 192.168.22.1

 

das ist natürlich eine gute idee, werde morgen berichten, ob der kleine trick funktioniert.

 

flexibler würde es wohl sein, wenn ich die dialer ips per dhcp zu ordne, oder ?

Share this post


Link to post
Share on other sites

Hi,

 

 

du kannst diese route natürlich auch auf dem jeweiligen default gateway hinzufügen, da brauchst du nicht jeden rechner anzufassen, die rechner lernen dann den direkten weg automatisch. man kann natürlich auch mit dhcp arbeiten, der möglichkeiten gibt es viele...

 

 

gruss

 

rob

Share this post


Link to post
Share on other sites

ich habe die lösung gefunden.

 

folgende veränderung:

!!#noch folgende einträge ergänzen

interface Dialer2

description Einwahl in PC 2

ip address 192.168.21.2 255.255.255.0

ip access-group 102 in

ip nat outside

usw.

!#noch folgende einträge ergänzen

ip route 192.168.21.0 255.255.255.0 Dialer2

ip nat inside source route-map route3 interface Dialer2 overload #das "ROUTE-Map" ist der TRICK :D

 

und natürlich noch die passende access-listen:

access-list 1 permit any

access-list 102 permit ip any any

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit #hinzufügen

route-map route3 permit 10

match ip address 1

match interface Dialer2 #ganz wichtig :cool:

 

und ...ENDE :-)

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...