Jump to content
Sign in to follow this  
othewes

Authentifizierung mit computerzertifikaten schlägt fehl

Recommended Posts

Hallo!

 

Ich verzweifel gerade. Unser WLAN authentifiziert mit EAP-TLS. Computer- und Benutzerzertifikate sind auf allen Clients verteilt. Der Haken für "Als Computer authentifizieren..." ist natürlich gesetzt.

 

Es gibt eine IAS Richtlinie mit "Drahtlos - Anderer", "Drahtlos - IEEE802.11". Dort wird unter anderem die Mitgliederschaft "Domänencomputer" oder "Domänenbenutzer" abgefragt.

 

Vista Client benutzen artig und fein ihre Computerzertifikate und können sich am WLAN authentifizieren. Windows XP Clients benutzen immer ihr Benutzerzertifikat.

 

Wird in der IAS-Richtlinie nur die Bedingung "Domänencomputer" gesetzt, dann erhalte ich bei den XP Clients folgende Fehlermeldung (VISTA funktioniert weiterhin fehlerfrei):

 

Ereignistyp: Warnung

Ereignisquelle: IAS

Ereigniskategorie: Keine

Ereigniskennung: 2

Datum: 23.07.2007

Zeit: 16:16:54

Benutzer: Nicht zutreffend

Computer: AD1 (AD und IAS)

Beschreibung:

Benutzer "user@domäne.local" wurde Zugriff verweigert.

Vollqualifizierter Benutzername = domäne\user

NAS-IP-Adresse = x.x.x.x

NAS-Kennung = name

Kennung der Anrufstation = MAC:SSID

Kennung der Empfängerstation = MAC

Clientanzeigename = Client

Client-IP-Adresse = x.x.x.x

NAS-Porttyp = Wireless - IEEE 802.11

NAS-Port = 3346

Proxyrichtlinienname = Windows-Authentifizierung für alle Benutzer verwenden

Authentifizierungsanbieter = Windows

Authentifizierungsserver = <unbestimmt>

Richtlinien-Name = <unbestimmt>

Authentifizierungstyp = EAP

EAP-Typ = <unbestimmt>

Code = 48

Ursache = Der Verbindungsversuch stimmt mit keiner RAS-Richtlinie überein.

 

Was mache ich falsch? Warum verwendet XP immer das Benutzerzertifikat, anstatt des Computerzertifikats?

Share this post


Link to post
Share on other sites

Wir haben noch ein bisschen getestet:

 

Beim Bootvorgang verwendet der XP Client zuerst das Computerzertifikat und dann das Benutzerzertifikat.

 

Ist der Rechner einmal gestartet, wird nur noch das Benutzerzertifikat verwendet.

 

Kann man den ganzen Vorgang vielleicht über Richtlinien steuern? Mit meinem Vista Client kann ich wunderschöne XP-Richtlinien mit "WPA2/AES" und "Authentifizierungsmodus: Nur Computer" auswählen. Wenn ich mir die Richtlinien jedoch auf unserem Domaincontroller ansehe, sieht die auf einmal ganz anders aus? Bedeutet das, dass ich die Vista Schemen-Erweiterungen installieren müsste?

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...