Jump to content
Sign in to follow this  
level20peon

remotedesktop error bei pulldown menü

Recommended Posts

Hallo !

 

 

Ich habe ein problem unter windows2003, dass ich jedoch auch schon bei windows2000 hatte. wenn ich von meinem pc aus über LAN auf meinen server auf dem windows2003 installiert ist per remotedesktop verbindung zugreife und dann ein pulldown menü öffne, dies dann ein paar sekunden auf lasse, friert die verbindung zum server für mehrere stunden ein, das netzwerk wird sehr (SEHR) langsam und die programme auf dem server frieren ebenfalls ein. das einzige, was dann noch funktioniert ist der gateway, der aber auch keine volle geschwindigkeit (vor allem bei den response-zeiten) mehr erreicht. das ganze passiert jedoch nur, wenn ich das menü per mausklick aufrufe, nicht, wenn ich die "menü-dropdown-taste" auf der tastatur benutze und per tastendruck navigiere. kann mir da jemand helfen, ich wäre für jeden rat SEHR dankbar...

 

 

MfG martin

Share this post


Link to post

Probiere mal die Version 5.2 von Windows 2000. liegt dort unter windows\system32\clients\tsclient.

Vielleicht hilfts. Hast du Bitmapcaching an? Wenn ja, lass es mal weg.

Wenn das alles nichts helfen sollte: hast du die Möglichkeit, testweise das Ganze einmal von einem anderen OS aus zu probieren. Wenn der Fehler bei zwei unterscheidlichen Servern auftritt, sieht nach einem Problem des Clients aus.

 

grizzly999

Share this post


Link to post

Ohja, grizzly999, war natürlich ein Typo, musste korrekterweise heissen: "Probiere mal die Version 5.2 von Windows 2003".

Hast ihn ja aber selber gefunden :)

 

grizzly999

Share this post


Link to post

also hab jetzt die version 5.2.3790.0 von win2003 drauf und habe bitmapcaching aus gemacht, das problem besteht aber weiterhin... und nochwas: du meintest doch eben, dass es am client liegen müsste, ja gut, aber dann dürfte doch der server selbst (wenn ich runterlaufe und mich normal drauf einzuloggen versuche, geht auch das nicht mehr) nicht abschmieren... außerdem besteht das problem nicht, wenn ich wie gesagt, das menü per tastatur aufrufe.

 

 

MfG martin

Share this post


Link to post
Original geschrieben von da.styla

also hab jetzt die version 5.2.3790.0 von win2003 drauf und habe bitmapcaching aus gemacht, das problem besteht aber weiterhin... und nochwas: du meintest doch eben, dass es am client liegen müsste, ja gut, aber dann dürfte doch der server selbst (wenn ich runterlaufe und mich normal drauf einzuloggen versuche, geht auch das nicht mehr) nicht abschmieren... außerdem besteht das problem nicht, wenn ich wie gesagt, das menü per tastatur aufrufe.

Nun ja, dass etwas an der Serverconsole direkt abschmiert, gehörte vorhin nicht zu meinem Informationsstand :( . Lediglich, das du dieses Problem mit deinem Client früher auf einem 2000 Server und nun auf einem 2003 Server hattest. Die einzige Konstante bis dahin war der Client.

Erste Frage: Was ist der genaue Fehler an der Konsole?

Zweite Frage: Vorher hattest du das gleiche Problem. Hast du auf 2003 upgedated, war es ein neuer 2003 Server mit neuer Hardware? Wurde Hardware übernommen? Findet sich was im ereignislog des Servers?

 

Ich hatte bisher noch nie Probleme mit dem Remote Desktop, in keiner Version, und die von dir geschilderten sehen zunächst auch nicht nach einem bekannten Problem des 2000/2003 Servers aus.

 

 

grizzly999

Share this post


Link to post

der genaue fehler ist, dass beim anklicken eines pulldown menüs mit der maus nach ein paar sekunden der rdp-bildschirm einfriert und auch die netzwerkverbindung sehr langsam wird (ich brauche dann eine minute, um einen ordner im netzwerk zu öffnen)... weiterhin werden die programme, die auf dem server laufen so gut wie gestoppt, ich fliege aus warteschlangen raus usw...

----------------

und was meinst du mit "dass etwas an der serverconsole direkt abschmiert"... wenn der von mir o.g. fehler auftritt, dann ist nicht nur die remoteverbindung hin, sondern der server selbst ist auch, wenn ich direkt davor sitze keiner anmeldung mehr fähig... und das für locker 3 bis 4 stunden.

 

ja, der client blieb die konstante, sowohl in hardware, wie auch im system und rdp client.

 

windows 2003 hab ich auf eine völlig neue hardware installiert, als ich noch einen windows 2000 server hatte, waren ganz andere komponenten im pc, ich habe nichtmal eine davon übernommen.

 

im ereignislog finde ich nur auch sehr komische sachen, die mir aber 1. nicht wirklich was sagen und 2. nicht mit dem problem des einfrierens zusammenzuhängen scheinen.

 

 

MfG martin

Share this post


Link to post

Wenn du den Server resetted hast, und er wieder läuft, dann melde dich doch mal lokal am Server am, und starte dort eine RDP-Session auf sich selber. Hängt er sich dann auch weg?

 

grizzly999

Share this post


Link to post

hey, das ist eine äußerst kreative idee der fehlersuche ;) ... bin selbst noch nicht darauf gekommen... ich habe es direkt einmal versucht, der fehler taucht aber auch dann auf, komisch oder ???

 

hinzu muss ich sagen, dass es da zwei stufen des aufhängens gibt, einmal, wenn ich genügend lange das menü offen halte, tritt der oben beschriebene stundenlange "lag" auf, wenn ich aber direkt, wenn ich das festhängen bemerke woanders hinklicke "erholt" er sich nach ein paar sekunden wieder. ich meine, das hilft nicht bei der fehlerbehebung, wollte es nur mal los werden. wie es scheint ist mein bug aber nicht zu beheben :(

 

 

MfG martin

Share this post


Link to post
hey, das ist eine äußerst kreative idee der fehlersuche

Kreative Fehlersuche gehört zu meinem Beruf... :)

 

Das wird ja immer mysteriöser. Wie gesagt, ich kenne dieses Problem selber nicht (und glaube mir, ich habe viele RDPs auf vieler unterschiedlicher Hardware mit unterschiedlichen Clients gehabt), in der KB ist auch nicht zu finden, Hardware ist komplett unterschiedlich, die RDP-Clients sind verschiedene und trotzdem hast du dieses Problem auf zwei verschiedenen Betriebssystemen.

Ich bin alles andere als ein Programmierer, aber der Beschreibung nach handelt es sich um ein Visual Basic Problem, denn soviel weiss ich, das Aufklappen eines Pulldown Menüs ruft im Hintergrund ein VB-Script auf. Und da scheint was bei dir verbogen zu sein. Da habe ich auch schon die nächste Idee (enttäusche mich nicht :cry: ): Läuft auf dem Rechner Software, die auf dem vorigen auch gelaufen ist, ist vielleicht keine Standardsoftware wie Office oder so? Möglicherweise hat eine Software an irgendwelchen RunTimeLibraries oder anderen VB-Routinen was geändert. Gewissheit würde wahrscheinlich eine saubere Installation des Servers bringen => wird mit Sicherheit nicht gelegen sein, mal eben den Server neu aufzusetzen, aber hast du vielleicht die Möglichkeit, auf einer zweiten Partition den Server parallel hochzuziehen und das Ganze dann ohne was nachzuinstallieren direkt Out of the Box zu testen?

 

Was anderes fällt mir im Augenblick nicht ein :(

 

grizzly999

Share this post


Link to post

ja, also die software ist mehr oder weniger die selbe geblieben... emule und mIRC laufen eigentlich 24 stunden am tag, ich hab zwar auch noch andere sachen installiert (ftp client und server und sachen wie microangelo), aber eigentlich ist das system noch ziemlich "jungfräulich", ausser dass ich da active directory und dns... die üblichen serversachen halt (das teil fungiert sowohl als gateway server, als auch als netzwerkserver), aber soweit ich weiß, haben die oben genannten programme keinen vb eingriff vorgenommen... ich meine, ausprobieren kostet nix, ist aber SEHR umständlich und vor allem nervenaufreibend und kann das sowieso nicht sofort machen... das alte system wiederherzustellen wäre hierbei aber das geringste problem, weil ich ein ghost image davon hab ;)...

 

btw: wieso bist du denn der einzige, der hier drauf geantwortet hat, hast du als einziger hier ahnung ? vielleicht weiß ja jemand anderes über dieses problem bescheid ?!?

 

 

MfG martin

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...