Jump to content
Sign in to follow this  
mupp

VPN Site2Site Verbindung

Recommended Posts

Hallo zusammen,

 

ich bin noch ein absoluter Neuling in Sachen PIXen.

Aber ich habe mich ein bissl in die Thematik eingelesen und habe mir ein kleines Test Szenario aufgebaut..

 

Client A

192.168.0.2/24

 

PIX_A (501)

OutsideIP 172.27.0.1/24

InsideIP 192.168.0.1/24

 

from

[...]

to

 

Client B

192.168.1.2/24

 

PIX_B (501)

OutsideIP 172.27.1.1/24

InsideIP 192.168.1.1/24

 

 

PIX-A# sh run
: Saved
:
PIX Version 6.3(5)125
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX-A
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside permit ip 172.27.0.0 255.255.255.0 any
access-list outside permit icmp any any echo-reply
access-list outside permit icmp any any unreachable
access-list outside permit icmp any any time-exceeded
access-list inside permit ip 192.168.0.0 255.255.255.0 any
access-list inside permit icmp any any echo-reply
access-list inside permit icmp any any unreachable
access-list inside permit icmp any any time-exceeded
access-list VPN_TEST_B permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
access-list VPN_TEST_B permit ip host 172.27.0.1 host 172.27.1.0
access-list NoNAT permit ip 192.168.0.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.27.0.1 255.255.255.0
ip address inside 192.168.0.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
access-group outside in interface outside
access-group inside in interface inside
route outside 0.0.0.0 0.0.0.0 172.27.1.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address VPN_TEST_B
crypto map transam 1 set peer 172.27.1.1
crypto map transam 1 set transform-set chevelle
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 172.27.1.1 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:39aba175cb40858944251cc919b67eeb
: end

Share this post


Link to post
Share on other sites

... und hier die zweite PIX!

 

PIX-B# sh run
: Saved
:
PIX Version 6.3(5)125
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname PIX-B
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside permit ip 172.27.1.0 255.255.255.0 any
access-list outside permit icmp any any echo-reply
access-list outside permit icmp any any unreachable
access-list outside permit icmp any any time-exceeded
access-list inside permit ip 192.168.1.0 255.255.255.0 any
access-list inside permit icmp any any echo-reply
access-list inside permit icmp any any unreachable
access-list inside permit icmp any any time-exceeded
access-list VPN_TEST_A permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
access-list VPN_TEST_A permit ip host 172.27.1.1 host 172.27.0.1
access-list NoNAT permit ip 192.168.1.0 255.255.255.0 192.168.0.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.27.1.1 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
pdm history enable
arp timeout 14400
access-group outside in interface outside
access-group inside in interface inside
route outside 0.0.0.0 0.0.0.0 172.27.0.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set chevelle esp-des esp-md5-hmac
crypto map transam 1 ipsec-isakmp
crypto map transam 1 match address VPN_TEST_A
crypto map transam 1 set peer 172.27.0.1
crypto map transam 1 set transform-set chevelle
crypto map transam interface outside
isakmp enable outside
isakmp key ******** address 172.27.0.1 netmask 255.255.255.255
isakmp identity address
isakmp policy 1 authentication pre-share
isakmp policy 1 encryption des
isakmp policy 1 hash md5
isakmp policy 1 group 1
isakmp policy 1 lifetime 1000
telnet timeout 5
ssh timeout 5
console timeout 0
terminal width 80
Cryptochecksum:8041c40caa30de85fad666d9bfe34980
: end

 

 

 

Ich kann die PIXen leider untereinander Outside to Outside nicht erreichen..

Auch von Client A to Client B funkt der ping nicht...

 

Was mache ich falsch?

Könnt Ihr mir ein bissl auf die Sprünge helfen, ich möchte keine fertige config, sondern nur Hilfestellung...

Share this post


Link to post
Share on other sites

ich habe jetzt ein bissl an meine ACL gebastelt.. die PIXen sind jetzt untereinander erreichbar.. PIX to PIX...

 

Ich möchte jetzt aber das Client A to PIX_B outside per ping erreichbar ist..

Wie mache ich das..

 

Hier die Config PIX_B

 

access-list outside permit ip 172.27.0.0 255.255.255.0 any
access-list outside permit icmp any any echo-reply
access-list outside permit icmp any any unreachable
access-list outside permit icmp any any time-exceeded
access-list inside permit ip 172.27.0.0 255.255.255.0 any
access-list inside permit icmp any any echo-reply
access-list inside permit icmp any any unreachable
access-list inside permit icmp any any time-exceeded
access-list inside permit ip 192.168.0.0 255.255.255.0 any

 

ip address outside 172.27.1.1 255.255.255.0
ip address inside 192.168.1.1 255.255.255.0

 

Hier die Config PIX_A

 

access-list outside permit ip 172.27.1.0 255.255.255.0 any
access-list outside permit icmp any any echo-reply
access-list outside permit icmp any any unreachable
access-list outside permit icmp any any time-exceeded
access-list inside permit ip 172.27.1.0 255.255.255.0 any
access-list inside permit icmp any any echo-reply
access-list inside permit icmp any any unreachable
access-list inside permit icmp any any time-exceeded
access-list inside permit ip 192.168.1.0 255.255.255.0 any

 

ip address outside 172.27.0.1 255.255.255.0
ip address inside 192.168.0.1 255.255.255.0

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...