Jump to content
Sign in to follow this  
hkjwj

VPN per Cisco 851 W

Recommended Posts

Hallo hallo,

 

hoffe Ihr könnt mir helfen. Habe o.a. Cisco als Router vor meinem 192.168.10/24 er Netz, auf der IP 10 ist ein w2k3 R2 als RAS/vpn eingerichtet und funzt auch innerhalb des Netztes. jedoch komm ich durch den Cisco nicht durch.

 

Kann mir bitte jemand mit der Konfig helfen. folgendes habe ich bereits eingerichtet...

Firewall habe ich das GRE freigegben (siehe Abb/link.)

 

Firewall

 

bzw. hier die config der Interfaces bzw. genauer auch noch die des GRE Tunnels

 

Interfaces / GRE Tunnel

 

SDM 2.1.1.

 

Bitte um Hilfe

 

mfg hkjwj

Share this post


Link to post

hallo,

 

hast du hitcounts auf deiner access list? wenn nein, dann zieht deine access list noch nicht!

(siehst du mit "show acces-list acceslistname - z.b.: "permit icmp 192.168.101.0 0.0.0.255 any (23136 matches)")

mir ist allerdings noch nicht ganz klar, wie deine netzwerktopologie aussieht! vielleicht kannst du es noch ein wenig genauer beschreiben (welches netz wo ist und wo du hin willst)

 

lg martin söllradl

Share this post


Link to post

Nene, du brauchst kein Tunnelinterface. Du brauchst einmal die Regel mit dem GRE (wie gepostet) und dasselbe nochmal fuer TCP/Port 1723. Mehr nicht.

Share this post


Link to post

hi, thx für die schnelle antw.

 

1.) muß leider zugeben das ich n kompletter newbie in sachen cisco bin... hab mir das teil vor 2 j zugelegt und wollte den CCNA anfangen, bin jedoch bis dato nicht mal dazu gekommen auch nur 1 buch zu lesen deswegen hab ich 0 ahnung wovon du bei der antw. redest.

 

2.) topologie: 85.16.31.40/27 -> DLINK -> 192.168.0/24 Cisco 192.168.10/24 -> LAN mit RAS/Vpn Server

 

also von 192.168.0.2 (ext. IP Cisco) zu 192.168.10.10, habe bereits probiert den DLINK mit der öff IP ans 192.168.10 zu hängen und PPTP freizugeben, das hat gefunzt, jedoch schaffe ich die Konfig im Cisco nicht

 

3.) OK thx... und ich weiß &%&/% Frage... wie mach ich das ?

Share this post


Link to post

ich geh jetzt davon aus dass du den vpn tunnel auf den windows server natten willst.

 

also wenn du über telnet auf den router gehst; sollte es so ungefähr gehen! (hoff ich hab mich da jetzt nicht vertippt:

 

router#

config terminal --- eingeben

 

dann sollte es ungefähr so aussehen

 

router(config)#

 

jetzt kannst du das teil konfigurieren,....

 

ip nat inside source static udp 192.168.0.2 GRE interface FastEthernet4 GRE

ip nat inside source static tcp 192.168.0.2 1723 interface FastEthernet4 1723

 

interface FastEthernet4

description $ES_WAN$$FW_OUTSIDE$

ip address XXXXXXXXXXXX

ip access-group 110 in

ip verify unicast reverse-path

no ip redirects

no ip unreachables

no ip proxy-arp

ip inspect DEFAULT100 out

ip nat outside

ip virtual-reassembly

ip route-cache flow

duplex auto

speed auto

no cdp enable

crypto map SDM_CMAP_1

 

access-list 110 ------- (das ist die access list die vom outside interface nach innen geht)

access-list 110 permit gre any host 192.168.0.2

access-list 110 permit tcp any host 192.168.0.2 eq 1723

 

interface vlan1

ip nat inside

 

so hatte ich damals meinen pptp vpn auf meinen windows 2003 server konfiguriert

hoffe das hilft dir

 

mfg martin söllradl

Share this post


Link to post
i

ip nat inside source static udp 192.168.0.2 GRE interface FastEthernet4 GRE

ip nat inside source static tcp 192.168.0.2 1723 interface FastEthernet4 1723

 

GRE ist nicht UDP!

 

ip nat inside source static tcp <server-ip> 1723 interface <externes IF> 1723

 

Das sollte eigentlich reichen, bei neueren IOSen wird das mit dem GRE automatisch erkannt. Sorry fuer das durcheinander, das is mir auch erst jetzt eingefallen.

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...