Jump to content
Sign in to follow this  
jussi

Routing Frage (gw of last resort)

Recommended Posts

Hallo, wie immer melde ich mich nur wenn ich was wissen will :-P

 

Router A spricht EIGRP und hat eine bestimmte Route Y nicht im Table; gw of last resort ist Router B

 

Router B spricht EIGRP und hat die betreffende Route Y auch nicht im Table, GWOLR ist Router C

 

am Router C ist die Route Y auf ein interface geroutet; der Router C spricht KEIN EIGRP, sondern OSPF** und extern bgp4 (aber egal...)

 

Die eigrp geräte distributieren natürlich nicht ihre df gws. Router A kann Geräte in der Route Y nicht erreichen. Ich dachte aufgrund der funktionierenden DF Routen müssten die Pakete irgendwann beim Router C ankommen oder geht sowas nicht über mehr als einen Hop?

 

 

[** ,...für einige weitere router (D, E, F...) das hat was mit Firmenzusammenschlüssen und IOS ständen zu tun... 2 verschiedene interne, dynamische Routing Protokolle in einem backbone kann nix, das ist aber nicht das thema...]

Share this post


Link to post
Share on other sites

wie schaut die Retourroute aus? Hat Y eine Route nach A und B?

 

Wenn der Router ein GW of last resort hat, dann schickt er es auch dorthin...

 

/#9370

Share this post


Link to post
Share on other sites

Router C hat statische Routen (weil er eben kein EIGRP kann) für C auf B, B hat zwar dynamisches Routing mit C in diesem Fall ist die Route aber sogar connected auf Serial xy

Share this post


Link to post
Share on other sites

müsste man dann eigentlich auch im traceroute sehen das ein Client Router A, dann B, dann C erreicht..und dann eben Sense weil die Antworten ab da nimmer zurück können, bzw. von Router C verworfen werden

 

und wie gehtn das das B dynamische Routen auf C hat ?

C muss natürlich auch ne statische Route auf die Netze von A haben.

 

 

Das könnte man sich natürlich alles auch erheblich vereinfachen...

Share this post


Link to post
Share on other sites

es geht aber darum, dass Y zurückfindet und nicht C (der auch, aber bei dem Problem geht es vorrangig um Y). Hast du Routing Tabellenauszüge von den betroffenen Routern und von den Y Endgeräten? Ist die Y IP Adresse am C erreichbar?

 

/#9370

Share this post


Link to post
Share on other sites

B hat zwar dynamisches Routing mit C in diesem Fall ist die Route aber sogar connected auf Serial xy

 

Sorry fetter Schreibfehler: soll heissen B hat dyn. Routing mit A., nicht mit C.

 

 

Router A: 213.164.131.58

Router B: 213.164.131.107

Router C: 213.164.131.98

 

 

Route Y: 213.164.131.152/29

 

 

Router C:

-------------

 

Zielroute Y:

 

Routing entry for 213.164.131.152/29

Known via "static", distance 1, metric 0 (connected)

Redistributing via ospf 100

Advertised by ospf 100 subnets

Routing Descriptor Blocks:

* directly connected, via ATM1/0.114

Route metric is 0, traffic share count is 1

directly connected, via ATM1/0.113

Route metric is 0, traffic share count is 1

 

Rückroute auf Router A:

 

Routing entry for 213.164.131.56/30

Known via "static", distance 1, metric 0

Redistributing via ospf 100

Advertised by ospf 100 subnets

Routing Descriptor Blocks:

* 213.164.131.107

Route metric is 0, traffic share count is 1

 

 

Router B:

 

Zielroute Y:

 

% Subnet not in table

Gateway of last resort is 213.164.131.98 to network 0.0.0.0

 

Rückroute auf Router A :

 

Routing entry for 213.164.131.56/30

Known via "connected", distance 0, metric 0 (connected, via interface)

Redistributing via eigrp 9135

Routing Descriptor Blocks:

* directly connected, via Serial1/1

Route metric is 0, traffic share count is 1

 

Router A

 

Zielroute Y

 

% Subnet not in table

Gateway of last resort is 213.164.131.98 to network 0.0.0.0

 

 

 

Traceroute von A richtung Route Y kommt keinen einzigen Hop weit.

 

Edit: Von B und C geht alles, alle hosts in Y erreichbar...

 

Edit 2wenn ich auf A ne statische Route Y auf Routr C lege gehts natürlich, aber was soll der *******?

Share this post


Link to post
Share on other sites

also die routing-tabellen wären hilfreicher...

 

Hat Router C denn überhaupt eine Route für die Netze an Router A. (die auf Router B zeigt)

Kann von Router A alles Router B erreicht werden? (Wegen dem Traceroute)

 

Ich verstehe die Struktur so

 

A--B--C-------Y

Share this post


Link to post
Share on other sites

czappb, neben den relevanten routen willst du auch alle statischen und dynamischen routen sehen die das problem nicht betreffen? das verwirrt doch nur :-P

 

Ja router C und B können ohne Probleme A erreichen und und A kann ohne probleme B und C erreichen, aber leider kann A nichts in Route Y erreichen die an B und C funktionieren... habe nun wie gesagt das problem erschlagen indem ich eine meiner meinung nach unnötige statische route von A auf C für das netz Y gelegt habe, aber ich würde es wirklich gerne verstehen...

Share this post


Link to post
Share on other sites

Ich behaupte mal der ICMP Redirect ist auf A geblockt (also eingehend), deswegen gehts von B und C aus ...

 

Hast du da irgendwelche ACLs?

Share this post


Link to post
Share on other sites

@wordo, wenn nur der Ping nicht ginge wäre ja zu verkraften aber ohne die von mir an Router A hinzugefügte statische route zum Ziel nach Router C war keine kommunikation möglich

 

Auf router A existieren folgende acls:

1. im EIGRP soll keine DF route distributiert werden, sondern nur ein Netz

access-list 23 deny   0.0.0.0
access-list 23 permit any
access-list 24 permit 213.164.137.0 0.0.0.31
access-list 24 deny   any

 

2. Über die Backupleitung (ISDN) soll niemals EIGRP distributiert werden

access-list 100 deny eigrp any any
access-list 100 permit ip any any
dialer-list 1 protocol ip list 100

 

router eigrp XXXX
redistribute connected
redistribute static
network xxx.yyy.zzz.aaa
network bbb.ccc.ddd.eee
[...]
distribute-list 24 out
distribute-list 23 in
distance eigrp 90 95
no auto-summary

 

@/#9370

 

die gesamte routingtabelle setzt sich halt aus statischen und dynamischen routen zusammen. ich denke halt dass das kommando sh ip route "route Y" schon präzise zeigt was man sehen muss, um das Problem zu debuggen. denn es zeigt ja immer die kleinste relevante route.

 

 

Von router A (dem Problembär) poste ich dir mal den konfigurierten Teil der konfig mit den statischen routen. Bevor jetzt alle schreien, das da nicht geht: das dfgw wird per eigrp übergeben, wenn EIGRP wegbricht, weil festverbindung weg greift eben die route mit der schlechten metric. Dies war nötig, da leider SFV der DTAG seit geraumer zeit auch zwischendrin als ATM Leitungen geführt werden. Das hat den Effekt, dass die Leitung down geht, das Interface aber nicht runterfällt und daher die default route auf interface sonst nie schlecht werden würde.

 

So wie es jetzt konfiguriert ist, zeitet irgendwann die eigrp route aufs df gw aus und der router wählt sich per isdn ein.

 

ich scheue mich etwas hier die komplette architektur offen zu legen, aber vielleicht bin ich auch nur paranoid. wenn ich dich/euch missverstehe und du/ihr trotzdem noch was brauch(s)t können wir auch was per PN machen.

 


no ip classless
ip route 0.0.0.0 0.0.0.0 213.164.131.107
ip route 213.164.131.96 255.255.255.240 BRI0 200
ip route 213.164.131.152 255.255.255.248 213.164.131.98
no ip http server

 

 

Wie gesagt, die letzte der 3 routen habe ich als hotfix hinzugefpgt, aber ich begreife nicht wieso das nicht per df route abgefackelt wird.

 

Danke für eure Vorschläge soweit

Share this post


Link to post
Share on other sites

Mit den Infos ist es extrem schwierig etwas genaues zu sagen. Ein "show ip route 213.164.131.98" am Router A wäre hilfreich, aber dann würde auch die Config und weitere show commands auf den Routern notendig sein.

 

/#9370

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...