Jump to content
Sign in to follow this  
123

Cisco 1760 und PPPoE

Recommended Posts

Hi,

Ich bekomme einfach auf meinem Cisco 1760 Router pppoe nicht zum laufen vielleicht seht ihr ja anhand meiner Config-Datei was ich falsch gemmacht habe.

Aufbau:

Modem------WIC-1Enet------Cisco-1760-Router------Netzwerk-Switch

 

Hier meine Config:

[ATTACH]3388[/ATTACH]

 

Danke

Share this post


Link to post

Building configuration...

 

Current configuration : 7527 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Gateway-1

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable password ........................

!

no aaa new-model

!

resource policy

!

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool 1

network 192.168.17.0 255.255.255.0

default-router 192.168.17.1

!

!

ip name-server 217.237.149.161

vpdn enable

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

description $ETH-WAN$

no ip address

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no keepalive

!

interface FastEthernet0/0

description $ETH-LAN$

ip address 192.168.17.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

speed auto

!

interface Dialer1

description connected to Internet

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 2

ppp authentication chap pap callin

ppp chap hostname ........................

ppp chap password ........................

ppp pap sent-username ........................ password........................

!

router rip

version 2

passive-interface Dialer1

network 192.168.17.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.17.0 0.0.0.255

dialer-list 2 protocol ip permit

snmp-server community public RO

!

control-plane

!

!

line con 0

exec-timeout 0 0

password ........................

login

line aux 0

line vty 0 4

password ........................

login

!

end

Share this post


Link to post

Hat dein Modem ein sync? Falls ja mach mal ein "deb pppoe er" "deb pppoe ev" "deb ppp neg" und "deb ppp auth" + "ter mon" und dann einmal den dialer auf shut und no shut und alles posten.

Share this post


Link to post

hier die ausgaben:

 

Gateway-1#deb pppoe er

PPPoE protocol errors debugging is on

Gateway-1#deb pppoe ev

PPPoE protocol events debugging is on

Gateway-1#deb ppp neg

PPP protocol negotiation debugging is on

Gateway-1#deb ppp auth

PPP authentication debugging is on

Gateway-1#

03:58:27: Vi1 PPP: Outbound cdp packet dropped

Share this post


Link to post

Hallo,

 

du hast in deiner Konfig:

 

dialer-list 2 protocol ip permit

 

stehen. Dies sollte meiner Meinung nach

 

dialer-list 1 protocol ip permit

 

heißen, weil:

 

gate(config)#dialer-list ?
 <1-128>  Dialer group number

gate(config)#

 

und die dialer-group-number bei dir die 1 ist.

In deinem Fall "sieht" die dialer-group 1 nie den "interessanten Traffic" und versucht daher auch keine Einwahl.

 

mfg

Share this post


Link to post

okay jetzt funktioniert schonmal icq und skype muss nur noch http funktionieren muss ich dafür ergendwelche access Einträge erstellen?

Building configuration...

 

Current configuration : 1643 bytes

!

version 12.4

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname Gateway-1

!

boot-start-marker

boot-end-marker

!

no logging buffered

enable password

!

no aaa new-model

!

resource policy

!

ip cef

!

!

no ip dhcp use vrf connected

!

ip dhcp pool 1

network 192.168.17.0 255.255.255.0

default-router 192.168.17.1

!

!

ip name-server 217.237.149.161

vpdn enable

!

!

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

half-duplex

pppoe enable

pppoe-client dial-pool-number 1

no keepalive

!

interface FastEthernet0/0

description $ETH-LAN$

ip address 192.168.17.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip tcp adjust-mss 1452

speed auto

!

interface Dialer1

description connected to Internet

ip address negotiated

ip access-group 103 in

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap pap callin

ppp chap hostname

ppp chap password

ppp pap sent-username password

!

router rip

version 2

passive-interface Dialer1

network 192.168.17.0

no auto-summary

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

ip http server

no ip http secure-server

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit 192.168.17.0 0.0.0.255

dialer-list 1 protocol ip permit

snmp-server community public RO

!

control-plane

!

!

line con 0

exec-timeout 0 0

password

login

line aux 0

line vty 0 4

password

login

!

end

 

Share this post


Link to post

ich habe jetzt folgenden eintrag in die access liste hinzugefügt leider funktioniert immer noch kein http oder was für ein eintrag muss ich hinzufügen damit ich mit den clients http aufrufen können?

access-list 100 permit tcp 192.168.17.0 0.0.0.255 any eq www

Share this post


Link to post

ich habe jetzt

access-list 198 permit tcp any eq www any eq www

und

ip nat inside source list 1 interface Dialer1 overload
ip nat inside source list 198 interface FastEthernet0/0 overload

zur config hinzugefügt leider funktioniert immer noch kein http oder seht ihr rnoch ein fehler in meiner config?

Share this post


Link to post

hier show interface:

Gateway-1#show inter
Ethernet0/0 is up, line protocol is up
 Hardware is PQUICC Ethernet, address is 0004.dc0c.b5a5 (bia 0004.dc0c.b5a5)
 MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive not set
 Half-duplex, 10BaseT
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:03, output 00:00:03, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    191 packets input, 25502 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 input packets with dribble condition detected
    216 packets output, 46065 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
FastEthernet0/0 is up, line protocol is up
 Hardware is PQUICC_FEC, address is 0011.92ec.bb09 (bia 0011.92ec.bb09)
 Description: $ETH-LAN$
 Internet address is 192.168.17.1/24
 MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 Keepalive set (10 sec)
 Full-duplex, 100Mb/s, 100BaseTX/FX
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input 00:00:00, output 00:00:00, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 2000 bits/sec, 5 packets/sec
 5 minute output rate 2000 bits/sec, 3 packets/sec
    503 packets input, 61185 bytes
    Received 233 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    242 packets output, 32012 bytes, 0 underruns
    0 output errors, 0 collisions, 1 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
NVI0 is up, line protocol is up
 Hardware is NVI
 Interface is unnumbered. Using address of NVI0 (0.0.0.0)
 MTU 1514 bytes, BW 10000000 Kbit, DLY 0 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation UNKNOWN, loopback not set
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    0 packets input, 0 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    0 packets output, 0 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out

Share this post


Link to post

Password:

Virtual-Access1 is up, line protocol is up
 Hardware is Virtual Access interface
 MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation PPP, LCP Open
 Listen: CDPCP
 Open: IPCP
 PPPoE vaccess, cloned from Dialer1
 Vaccess status 0x44, loopback not set
 Keepalive set (10 sec)
 DTR is pulsed for 5 seconds on reset
 Interface is bound to Di1 (Encapsulation PPP)
 Last input 00:00:31, output never, output hang never
 Last clearing of "show interface" counters 00:06:17
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    187 packets input, 21510 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    205 packets output, 38232 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions
Dialer1 is up, line protocol is up (spoofing)
 Hardware is Unknown
 Description: connected to Internet
 Internet address is 84.140.144.199/32
 MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation PPP, loopback not set
 Keepalive set (10 sec)
 DTR is pulsed for 1 seconds on reset
 Interface is bound to Vi1
 Last input never, output never, output hang never
 Last clearing of "show interface" counters 00:06:24
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: weighted fair
 Output queue: 0/1000/64/0 (size/max total/threshold/drops)
    Conversations  0/0/16 (active/max active/max total)
    Reserved Conversations 0/0 (allocated/max allocated)
    Available Bandwidth 42 kilobits/sec
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    174 packets input, 21307 bytes
    192 packets output, 38045 bytes
Bound to:
Virtual-Access1 is up, line protocol is up
 Hardware is Virtual Access interface
 MTU 1500 bytes, BW 56 Kbit, DLY 20000 usec,
    reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation PPP, LCP Open
 Listen: CDPCP
 Open: IPCP
 PPPoE vaccess, cloned from Dialer1
 Vaccess status 0x44, loopback not set
 Keepalive set (10 sec)
 DTR is pulsed for 5 seconds on reset
 Interface is bound to Di1 (Encapsulation PPP)
 Last input 00:00:34, output never, output hang never
 Last clearing of "show interface" counters 00:06:20
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
    188 packets input, 21524 bytes, 0 no buffer
    Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
    206 packets output, 38246 bytes, 0 underruns
    0 output errors, 0 collisions, 0 interface resets
    0 output buffer failures, 0 output buffers swapped out
    0 carrier transitions

Share this post


Link to post

ich habe das mal mit sdm getestet und das programm meinte die verbindung wäre erfolgreich denn skype und icq funktionieren ja cuh nur http nicht. wenns würklich an dns namen liegt wie kann ich das testen mein Provider ist t-online?

Share this post


Link to post

funktioniert jetzt lag tatsächlich an DNS Name ich hatte nur vergessen es in den DHCP Pool einzutragen.

 

Danke für eure hilfe Danke

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...