Jump to content

psychodaddy

Members
  • Gesamte Inhalte

    59
  • Registriert seit

  • Letzter Besuch

Reputation in der Community

10 Neutral

Über psychodaddy

  • Rang
    Newbie
  1. Super, danke Euch! Mit -Replace funktioniert es.
  2. Hallo, klappt leider auch nicht. Die Fehlermeldung unterscheidet sich nur um die zusätzlichen Punkte von der anderen: Set-ADObject : Multiple values were specified for an attribute that can have only one value At line:1 char:161 + Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC=mein,DC=test,DC =de" -Properties Company | % { Set-ADObject <<<< $_ -Add @{Company='CompanyName'} } + CategoryInfo : NotSpecified: (CN=Test1\, ...test,DC=de:ADObject) [set-ADObject], ADException + FullyQualifiedErrorId : Multiple values were specified for an attribute that can have only one value,Microsoft.A ctiveDirectory.Management.Commands.SetADObject Gibt es sonst noch irgendwo eine gute Hilfe? Hab schon einige Seiten gefunden, wo es aber nie um die Kontakteigenschaften geht, sondern meist nur um die AD-Benutzer.
  3. Hallo, schon mal Danke für die Hilfe, wenn ich aber Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC=mein,DC=test,DC=de" -Properties Company | Set-ADObject -Add @{Company='CompanyName'} eingebe erscheint als Fehlermeldung: Set-ADObject : Multiple values were specified for an attribute that can have only one value At line:1 char:157 + Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC=mein,DC=test,DC =de" -Properties Company | Set-ADObject <<<< -Add @{Company='CompanyName'} + CategoryInfo : NotSpecified: (CN=Test1\, ...test,DC=de:ADObject) [set-ADObject], ADException + FullyQualifiedErrorId : Multiple values were specified for an attribute that can have only one value,Microsoft.A ctiveDirectory.Management.Commands.SetADObject Hast Du noch eine Idee?
  4. Hallo, ich habe dazu noch nicht wirklich was funktonierendes gefunden. Ich möchte bei AD-Kontakten die Eigenschaften verändern, z.B. Company Mit: Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC =mein,DC=test,DC=de" -Properties Company werden mir die Kontakte wenigstens schon mal angezeigt. Nun würde ich gern die Firma durch einen neuen Namen ersetzen. Dazu hab ich schon einiges probiert, komme aber immer wieder auf Fehler. Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC =mein,DC=test,DC=de" -Properties Company | Set-ADObject -Company "neuer Wert" Als Fehler bekomme ich dann: Set-ADObject : A parameter cannot be found that matches parameter name 'Company'. Wenn ich die Beschreibung mit dem gleichen Befehl ändere: Get-ADObject -LDAPFilter '(objectClass=contact)' -SearchBase "OU=Test,OU=Benutzer,DC =mein,DC=test,DC=de" -Properties Company | Set-ADObject -Description "neuer Wert" funktioniert das aber. Es sieht irgendwie so aus, als ob er Company beim Set nicht kennt. Im Attribute Editor gibt es aber den Eintrag company (Groß-Kleinschreibung hatte ich schon versucht). Hat vielleicht jemand eine Idee wie ich das anpassen kann? Jens
  5. WSUS-Server down - Clienst rennen zu MS

    Hi, also ich habe es auf einem Client ausgeführt. Zuerst kommt eine Fehlermeldung, daß eine Datei nicht geladen werden kann - Fehler 64. Die Richtlinie die er da anmeckert ist gerade die WSUS-Richtlinie. Danach wird das Ergebnis angeziegt und es steht die WSUS-Richtlinie an der richtigen Stelle. Aber wegen der Fehlermeldung werde ich die Richtlinie jetzt löschen und eine neue für den WSUS erstellen. Vielleicht wird das Problem ja dadurch behoben. Jens
  6. WSUS-Server down - Clienst rennen zu MS

    Hi, also ich habe in der Policy die Einstellungen überprüft. Aktuell sind es folgende: Computerkonfiguration -> Administrative Vorlagen -> Windows-Komponenten -> Windows-Update Aktiviert und konfiguriert sind dort die Optionen: Automatische Updates konfigurieren: 3 - 0 - 11:00 Uhr Internen Pfad für den Microsoft Updatedienst angeben: 2x interner WSUS auf Port 80 Zeitplan für geplante Installationen neu erstellen: 5 Keinen automatischen Neustart für ....: Suchäufigkeit für automatische Updates: 1 Automatische Updates sofort installieren Erneut zu einem Neustart für geplante Installationen auffordern: 1440 Nicht-Administratoren gestatten ... Die Einstellungen auf dem WSUS kann ich aktuell nicht einsehen, da ich ihn immer noch aus haben muß. Kann es vielleicht sein, daß in einer anderen GPO noch Einstellungen liegen? Ich erhalte ja über gpresult alle Richtlinien die angewendet werden. Aber kann man vielleicht auch sehen, was dadurch gemacht wird oder muß ich die in Frage kommenden Richtlinien einzeln durchklicken? Jens
  7. Hallo, ich habe hier ein Netzwerk übernommen mit einem WSUS auf einem virtuellen W2k3. Wegen notwendigen Wartungsarbeiten hatte ich Gestern alle nicht unbedingt nötigen Server ausgeschalten. Heute Nachmittag fingen auf einmal alle Clients (ca. 160) an zu Microsoft zu rennen und Updates zu ziehen. Dies habe ich erst mal unterbunden da ziemlich schnell die Leitung dicht war. In der Gruppenrichtlinie und auch in der Registry der einzelnen Clients steht der WSUS als Server drin. Wieso gehen die Clients nun aber zu Microsoft? Mir wäre lieber die Clients würden darauf warten, daß der WSUS wieder online geht. Hat da vielleicht jemand einen Tipp für mich? Jens
  8. Benutzer aus andere Domäne einer Gruppe hinzufügen

    Da ich aber im Moment nur weiß, daß die Berechtigungen den globalen Gruppen zugeordnet sind und wie ich schon erwähnte die verschiedenen Freigaben und Berechtigungen sehr komplex aufgebaut sind wollte ich im ersten Schritt nur den Zugriff. Der Rest Bedarf einer Analyse und ich werde erst dann die Berechtigungen neu aufbauen (das meinte ich mit Schnellschuß). Ich denke zu dem Thema ist nun alles geschrieben. Danke noch mal für die Hilfe.
  9. Benutzer aus andere Domäne einer Gruppe hinzufügen

    Doch lesen kann ich schon. Nur wurde die eine Domäne bisher nicht von mir administriert. So wurden dort zwar Domänenlokale Gruppen erstellt, die NTFS-Berechtigungen aber den globalen Gruppen zugewiesen. Die lokalen wären somit überflüssig. Ich musste also die globale Gruppe zur universellen Gruppe machen, um die Mitglieder "meiner" Domäne hinzufügen zu können. Die Überarbeitung der Berechtigungen wird noch erfolgen, aber ich bin kein Freund von Schnellschüssen. Aber danke für Deinen Hinweis.
  10. Benutzer aus andere Domäne einer Gruppe hinzufügen

    Das ist nur für ein paar ausgewählte user, die standortübergreifend tätig sein müssen und dazu Netzlaufwerke vom anderen Standort eingebunden haben. In den Laufwerken ist aber eine relativ komplexe Berechtigungsstruktur hinterlegt, was eine Einzelzuweisung ziemlich aufwendig macht.
  11. Benutzer aus andere Domäne einer Gruppe hinzufügen

    Hey ich danke Euch beiden. Das waren die entschedenden Hinweise. Mit einer universalen Gruppe klappt es. Jens
  12. Hallo, ich möchte einen Benutzer von der Unterdomäne1 der Unterdomäne2 zuordnen. Beide Domänen gehören zur Hauptdomäne. Wenn ich nun in AD Benutzer und Computer die betreffende Gruppe aufrufe steht unter Objekttyp: nur "Benutzer, Gruppen oder Andere Objekte". Ich kann zwar unter Suchpfad: "unterdomäne1.hauptdomäne.de" die Unterdomäne1 auswählen, aber selbst wenn ich den kompletten Benutzernamen horst.mustermann@unterdomäne1.hauptdomäne.de eingebe kennt er den nicht. Wenn ich nun direkt ein Verzeichnis freigeben möchte, steht bei Objekttyp: "Benutzer, Gruppen oder Integrierte Sicherheitsprinzipale". Dann kennt er den Nutzer auch. Dies ist aber irgendwie nicht zielführend es für jede Freigabe so auszuwählen wenn die schon über eine Gruppenberechtigung verfügt. Wie kann ich den Nutzer aus der Unterdomäne1 einer Gruppe in der Unterdomäne2 zuordnen? Jens
  13. Problem mit Gruppenrichtlinie

    hi, also ich will das ja gerade erreichen, aber das klappt halt nicht immer. Hat noch jemand einen Tipp? Jens
  14. Problem mit Gruppenrichtlinie

    Hallo, @NorbertFe Die Systeme sind alle W2k SP4 und XP SP3 mit jeweils IE 6. Patchstand ist aktuell. @BuzzeR Ich habe ein OU "alle User". An diese habe ich die Richtlinie gehangen. Unter dieser OU liegen andere OU's wo die eigentlichen User darunter sind. Die Richtlinie wird aber laut Group Policy Management an diese vererbt. Das gpupdate bringt insoweit Erfolg, daß die Startseite nun angezeigt wird, die Zoneneinträge aber noch nicht existieren. Vielen Dank schon mal für die Hilfe. Jens
  15. Problem mit Gruppenrichtlinie

    hi, ja für die start-seite gehe ich über benutzerkonfiguration -> windows-einstellungen -> internet explorer-wartung -> urls -> wichtige urls. für die zonen gehe ich über benutzerkonfiguration -> administrative vorlagen -> windows-komponenten -> internet explorer -> internetsystemsteuerung -> sicherheitsseite -> liste der site zu zonenzuweisungen Wie soll ich es besser machen? Jens
×