Jump to content

MIC_BAC

Junior Member
  • Content Count

    94
  • Joined

  • Last visited

Community Reputation

10 Neutral

About MIC_BAC

  • Rank
    Junior Member
  • Birthday 08/17/1970
  1. Hy Dukel, ich bin Mitglied in der Gruppe Administratoren auf den Clients. mfg Michael
  2. Hallo, wir stellen Zurzeit auf Win7 Pro 64 Bit um und testen deshalb die nicht Standard Software. Bei der Installation einer Software muss ein selbst geschriebenes Script (Batch) ausgefhrt, welches Änderungen in der Datei c.\windows\system32\drivers\etc\service vornimmt. Leider funktioniert das Script unter Win7 nicht mehr, obwohl ich lokaler Admin bin. Im INet habe ich verschiedene Tipps gefunden, die aber immer händische Änderungen an den Rechten des Editors, anderen Dateien verlangen oder deaktivieren des UACs (kommt nicht in Frage) erfordern. Gibt es eventuell noch andere Möglichkeiten die service datei per Batch Script zu bearbeiten? mfg Michael
  3. Hallo Loki-123 nein hatte ich nicht. Leider musste ich die Versuche am Freitag auch einstellen. Der User brauchte das NB. Es wurde nun doch ein "Deutscher Stick" genommen. Ich finde die Lösung nicht gut, aber was soll man machen... Trotzdem Danke für Deine Antwort. Der Beitrag ist dann geschlossen. mfg Michael
  4. Hallo Board, ich habe hier ein Lenovo T61 mit WinXP Pro SP3 alle Updates & Treiber sind installiert. Der User meldet sich über den Novell Client SP5 im Netzwerk an. Der UMTS Stick ist ein T-Mobil HUAWEI Model: E122 aus Österreich Der MA soll mit dem Notebook in Österreich arbeiten. Die Firma die uns in Sachen Telekommunikation berät, hat für den MA ein UMTS Stick von T-Mobil in Österreich geliefert, da ein Stick von T-Mobil in Deutschland, aus Vertragssicht, zu teuer ist. Und damit fingen meine Probleme an: Der Stick kann installiert werden, man kann die PIN eingeben und der WebManager von T-Mobil startet. Alles klar soweit. Kein Hardwarekonflikt etc. Starte ich nun die Internetverbindung dauert es ca. 3 Sekunden und dann bekomme ich einen BlueScreen mit der Meldung: IRQL_NOT_LESS_OR_EQUAL Mit einem "deutschen" UMTS Stick von T-Mobil HUAWEI Model:E1823 passiert dies nicht. Man kann ganz normal im INet surfen. Deinstalliere ich den Novell Client, funktioniert der "Österreich" - Stick einwandfrei. Installiere ich den Novell Client wieder, hab ich nach 3 Sekunden den BlueScreen. Die Installationsreihfolge ist hierbei egal, also erst Novell dann Stick oder umgekehrt. - Ich haben den neusten Treiber zu dem "Österreich" - Stick von http://www.T-Mobil.at heruntergeladen, kein Erfolg. - Ich habe ältere Novell Clients installiert SP 3 & 4, ebenfalls kein Erfolg. - Ich habe es mit einem "Deutschen" - Treiber für dieses Model versucht, nichts... Das Problem tritt auf allen PCs/NBs auf, auf denen der Novell Client installiert ist und ich den UMTS Stick anschließe. Einen def. des "Österreich" - Sticks schließe ich aus, da er ohne Novell Client einwandfrei funktioniert. Hat vielleicht jemand eine Idee? mfg Michael
  5. Hallo @Dr. Melzer VNC wird im view-only mode betrieben. Der UHD User kann nur sehen was der User am anderen Ende tut. Hilfe erfolgt nur durch Hinweise. Es geht hier um möglichst Hohe Sicherheit vor Daten Missbrauch. @mba ja da hast Du recht. Aber Handys, usw. sind durch Verträge und Kontrolle aus zu schließen. 100 % Sicherheit gibts nun mal nicht. Es geht um den Arbeitsplatz. Durch den Fokus auf die Anwendung soll erreicht werden, dass keine andere Software (Screenshot Programme,...) gestartet werden können, bzw wenn schon gestartet eben nicht bedient werden können. mfg Michael
  6. Hallo Board, ich suche nach einer Möglichkeit beim Start einer Anwendung einen Fokus darauf zu legen. Ziel soll es sein, dass der User nur in dieser Anwendung arbeiten kann. Es soll nichts anderes möglich sein. Genau geht es um den Einsatz von RealVNC. Der User startet VNC und kann nur noch die IP / Namen des Ziels und das dazu gehörige Passwort eingeben. Dann kommt er auf den Client und kann nur noch hier arbeiten. Erst wenn VNC geschlossen wird, soll er wieder "normal" mit allen anderen Anwendungen arbeiten können. Damit soll verhindert werden, dass der User während der Sitzung andere Programme starten kann, Bildschirm abgriff, etc. sollen unterdrückt werden. Falls das so nicht geht würde es als "abgespeckte Version" auch reichen, wenn die Druck/Print Taste für die VNC Sitzung deaktiviert werden könnte. Dazu hab ich einen RegKey ausfindig gemacht, der unter [HKLM\System\CurrentControlSet\Control\Keyboard Layout] mit "Scancode Map" angelegt wird. Hier ist das Problem aber, dass es einen Neustart geben muss, damit die Einstellung übernommen wird. Das ist vom Arbeitsablauf her nicht drin. Dauerhaft abstellen geht auch nicht, weil der User nach der VNC Sitzung die Druck/Print Taste wieder benötigt. Hat jemand eine Idee? mfg Michael
  7. Hallo Zahni, also ich kann Dir nicht genau sagen wie hier die Zusammenhänge sind, dazu kenne ich mich im DHCP Bereich nicht gut genug aus. Vielleicht ist der Begriff Lokale Variablen hier auch nicht richtig angewandt. Fakt ist aber, dass bei der Installation von den Empirum Subdepo Servern auf dem DHCP Servern eine DHCP Option eingerichtet werden musste. Wir haben diese 142 genannt. Sie kann auch einen anderen Namen tragen. In dieser Option steht dann der Name des Empirum Subdepos. Beim Start des Clients, bekommt dieser dann über den DHCP Server seine IP, seine DNS Zuweisung und unsere DHCP Option142, die dann den Namen des Subdepo Servers enthält. Der Name des Servers wird in einer Variable eingetragen. Die Variable heißt Empirumserver = NamedesSubdepos Man kann diese Variable dann mit dem Befehl SET in der CMD aufrufen und prüfen ob diese da ist. Auf den PCs wo es funktioniert wird diese Variable angezeigt. empirumserver = NamedesSupdepos Auf denen wo es nicht funktioniert kommt der Hinweis Variable Empirumserver nicht gestezt Das hat zur Folge, dass das Inventory der Clients durch Empirum nicht greift. Wir die Variable von Hand gesetzt funktioniert das Inventory trotzdem nicht. Leider haben wir keine Idee mehr warum bei ca. 90% der PCs die DHCP Option greift aber bei ca. 10% nicht. Obwohl diese 10 % auch ihre IP, den DNS Eintrag und Gateway usw. bekommen wie alle anderen PCs…. mfg Michael
  8. Hallo Board, wir haben wir ein Problem mit einer Lokalen Umgebungsvariablen. Auf unserem DHCP (Novell Server) ist eine DHCP Option 142 mit dem Wert EmpirumServer gesetzt. Die Clients (XP Pro SP2 & SP3) bekommen diesen Wert beim Start zugewiesen. Bei ca. 90 % der Clients erscheint dann der Wert der Variable "EmpirumServer" wenn in der CMD "set empirumserver" eingetragen wird. Die anderen 10% schreiben dann, dass die Variable Empirumserver nicht gesetzt wurde. Bei denen wo es funktioniert ist der Regkey HLKM/software/matrix42/.... gestetzt, bei denen wo es nicht funktioniert fehlt dieser Wert. Also haben wir bei einem Client der den Eintrag hat, diesen exportiert und auf dem fehlerhaften Client importiert. Hat leider nicht funktioniert. Nach einem Neustart war der Regkey noch da, aber unter CMD set "Empirumserver" hieß es wieder nicht gesetzt. Im Internet gab es einen ähnlichen Beitrag, der mit der DHCP Option43 zutun hatte. Bei MS gibt es eine Hotfix das dieses Problem beheben soll. Leider funktionierte auch dies nicht. Wir haben nun keine richtige Idee mehr und kommen nicht recht weiter. Die Frage lautet: Warum übernimmt der Client die DHCP Option nicht so wie alle anderen Clients? mfg Michael
  9. Hallo Board, ich versuche mit diesem Script per PSexec.exe auf einem RemotePC eine Bat zu starten. Die Bat soll in einem bestimmt Verzeichnis prüfen ob eine TXT vorhanden ist oder nicht. Das Kopieren usw. funktioniert einwandfrei. Nur das Ergebnis was mir die PSexec.exe wiedergibt verstehe ich nicht ganz. Pruef.bat: FOR /F %%a IN (c:\hosts.txt) DO ( net use K: \\%%a\C$ "Passwort" /user:administrator XCOPY \\192.168.xx.xx\vol1\......\Test.bat K:\Windows\Temp /S /Y "%cd%\psexec.exe" \\%%a -u Administrator -p "Passwort" -c c:\windows\Temp\Test.bat >> Test.log ) net use k: /delete Die Test.bat die ausgeführt werden soll lautet: @echo off cls IF not EXIST C:\temp\AAA.txt echo %computername% YES >> Test.log Die Test.log wird wie erwartet auf dem PC abgelegt, auf dem die Pruef.bat gestartet wird. Der Inhalt in der Test.log lautet: 192.168.xx.xx ok Dies Ergebnis bekomme ich immer, auch wenn die Test.bat etwas ganz anderes machen soll zb. kopieren einer anderen Datei. Ich vermute das Ergebnis "OK" bezieht sich auf den Start der Test.bat und wird von der PSexec.exe wieder gegeben. Ändere ich die Die Test.bat die ausgeführt werden soll auf: @echo off cls IF not EXIST C:\temp\AAA.txt echo %computername% YES >> c:\Test.log bekomme ich das gleiche Ergebnis wie oben, aber die Test.log wird nicht auf dem Remote PC unter c:\ erstellt. Starte ich die TEST.bat auf dem Remote PC von Hand dann funktioniert alles bestens. Meine Frage ist nun: Wie bekomme ich das Script dazu, dass es die Test.bat auf dem Remote PC auch wirklich ausführt? Ich hoffe ich konnte mein Problem darstellen. mfg Michael
  10. Das nur macht mir sorgen... Gibts hier ein paar Beispiele zu? In Google gibts jedemenge aber da das total neu ist für mich, liest sich das alles sehr kryptisch... mfg Michael
  11. Hallo wannabee ich habe ein Script das über das LogIn Script (Novell) der User auf deren PC (WinXP Pro) verteilt werden soll. Einfache Sache.... dachte ich... In den Vorgesprächen mit meinem Server Menschen war alles klar. Bei den Tests lief alles bestens und dann trat das Problem auf. Ein anderes Script tauchte plötzlich auf den Servern auf. So soll das natürlich nicht sein. Da in den Vorgesprächen hier niemand was gesagt hat, bin ich bis jetzt davon ausgegangen das durch Administrativeabläufe im Anmeldevorgang (Gruppen, etc) sichergestellt ist das die Scripts nicht auf den Servern landen... Dem ist nun leider nicht so... Nun brauche ich ASAPs eine Lösung um die Verteilung auf Server zu unterbinden. Denn das Script ist recht wichtig. Ich denke man kann unter Novell im LogIn Script prüfen wo der User sich anmeldet aber da kenn ich mich Null aus... mfg Michael
  12. Hallo Board, kann ich per Batch Script abfragen ob es sich bei dem System, auf dem die Batch ausgeführt wird, um ein Server oder um eine Worckstation handelt? Also welches Betriebssystem installiert? Ich wollte das so lösen: if exit %windir%\system32\dcpromo.exe goto end und das Script startet nicht. Meine Frage nun hierzu lautet: Die Datei DCPROMO.exe ist die immer da wenn ein Server installiert wird oder ist das eine Option auf man sich nicht verlassen sollte. mfg Michael
  13. Hallo auch, so im Grunde habe ich mein Problem "fast" gelöst. Mein Ergebnis sieht erstmal so aus: Es wir per batch das PSTool PSlogList.exe auf den PC kopiert und mit der Befehlszeile: eventriggers /creat /tr VNCaccess /l application /so winvnc4 /tk c:\vncaccess.bat ein eventtrigger gesetzt. Die VNCaccess.bat sieht dann so aus: c:\psloglist.exe -m 60 -o win* application >> c:\vncaccess.txt Soweit so gut. Starte ich die vncaccess.bat von Hand funktioniert alles einwandfrei, vorraus gesetzt das Ereignis ist im Eventlog eingetreten. Wird die Bat durch den Eventtrigger gestartet, durch den eintritt des Ereignis "Winvnc4" im eventlog, startet die Bat auch, aber wenn ich die TXT dann öffne steht nichts drin. Die erstellte txt kann auch nicht gelöscht werden, weil die "psloglist.exe" die txt noch im Zugriff hat. Das bleibt auch so. Im Taskmanager ist zusehen das die "psloglist.exe" läuft und läuft und läuft.... erst wenn ich die abschieße, kann ich die txt löschen. Es wurde aber nichts reingeschrieben. Den Befehl "taskkill /F /im pslogfile.exe" mit in die Batch aufzunehmen bringt leider auch nichts. Die exe wird dann abgeschossen bevor sie ihre Arbeit ausführen kann. Meine Vermutung ist, dass der Eventtrigger die Bat immer wieder anstartet und dadurch natürlich auch die "psloglist.exe" immer wieder gestartet wird und ihre Arbeit nicht zu ende bringen kann. Also meine Frage ist: Wie prüfe ich ob der Task "PSloglist.exe" da ist? Ich würde das dann so versuchen: is exit "TASK" PSlogList.exe goto end c:\psloglist.exe -m 60 -o win* application >> c:\vncaccess.txt :end Das sollte dann, selbst wenn der Eventtrigger die Bat immer wieder anstartet, der PSlogList.exe soviel Luft geben, dass sie ihren job beenden kann. Notfalls baue ich das auch so auf: is exit "TASK" PSlogList.exe goto end c:\psloglist.exe -m 60 -o win* application >> c:\vncaccess.txt eventtriggers /delete /tid 1 eventtriggers /creat /tr VNCaccess /l application /so winvnc4 /tk c:\vncaccess.bat :end Damit würde der Eventtrigger gelöscht und gleich wieder neugesetzt werden und die Schleife damit unterbrechen. mfg Michael
  14. Moin Dukel, das hab ich mir schon gedacht... Mein Prob ist die sehr enge Finanzlage in dem Projekt... und die Vorgabe das VNC Enterprice benutzt werden muss, weil hier schon x Tausend Lizenzen gehalten werden... Ich weiß .. das eine was man will, dass andere was man muss... Würde dies Problem aber trotzdem gerne lösen. Aber danke für den Hinweis. mfg Michael
  15. Hallo auch, bin nun ein Stück weiter gekommen. Im Ereignisprotokoll steht unter Anwendung beim Ereignis "WinVnc4" der User anonymus, wenn im VNC Server nur der default user zugriffsrechte hat. Trägt man User oder Gruppen ein werden diese im Ereignisprotokoll namentlich erwähnt. Selbst wenn nur eine Gruppe eingetragen ist wird der Name des Users aus der Gruppe angezeigt der zugreift. Zum auslesen des eventlogs habe ich das Windows Boardmittel "eventtriggers" gefunden. Leider funktioniert das nicht so ganz. Unter CMD habe ich folgendes angelegt: eventriggers /creat /tr VNCaccess /l application /so winvnc4 /tk c:\test.bat Anstelle der test.bat soll dann irgendwie das Ereignis winvnc4 das der eventriggers festgestellt hat in eine txt kopiert werden... Leider startet schon meine Test.bat nicht, geschweige denn weiß ich wie ich das Ereignis in eine txt bekomme... Hoffe auf einen Gedankenanstoß von Euch. mfg Michael
×
×
  • Create New...