Zum Inhalt wechseln


Foto

Entweder oder, aber nicht gleichzeitig (Callback, Telefonieren)


  • Bitte melde dich an um zu Antworten
57 Antworten in diesem Thema

#1 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 30. Mai 2005 - 09:39

Hallo,

mir ist aufgefallen, dass man bei dem eingerichteten Callback mit dem Router nicht gleichzeitig telefonieren (Telefonanlage, ISDN) kann, obwohl es möglich sein müsste.
Kann es sein, dass der Router die B-Kanäle belegt?

Liebe Grüße

#2 edv-olaf

edv-olaf

    Expert Member

  • 4.610 Beiträge

 

Geschrieben 30. Mai 2005 - 10:29

Hi,

welcher Router? :confused:

Grüße
Olaf
:suspect: Du musst schon alle Infos zum Problem posten, wir sind keine Hellseher und Glaskugeln sind gerade ausverkauft.
;) Zertifiziert für NetWare, Linux und Microsoft
:cool: NetWare hieße nicht NetWare, wenn es nicht nett wär'.

#3 rob_67

rob_67

    Board Veteran

  • 955 Beiträge

 

Geschrieben 30. Mai 2005 - 12:38

Hi Stadt Tiger, normalerweise ist das möglich, es kann jedoch sein, dass das callback nicht funktioniert, wenn ein Kanal belegt ist, dann besser ppp callback einrichten,

Viele Grüsse

#4 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 30. Mai 2005 - 12:39

Hallo,

entschuldige, habe ich glatt vergessen...Ist ein Cisco 2610 mit 4 Bri-Ports.

Liebe Grüße

#5 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 30. Mai 2005 - 12:41

Hallo Rob,

so etwas ist mir auch in den Sinn gekommen und ich habe beim Dialer jetzt noch "ppp callback permit" eingetragen. Meintest du das damit?

Liebe Grüße

#6 rob_67

rob_67

    Board Veteran

  • 955 Beiträge

 

Geschrieben 30. Mai 2005 - 12:46

Hi stadt tiger, trag auf dem dialer und auf den jeweiligen bri interfaces ppp callback accept ein, hinter den dialer string schreibst du class callback, dann legst du eine map-class callback an mit dem inhalt dialer callback-server username, der router ruft dann authentifizierte lokale user zurück, in dem falle die user die mit dem dialer-remote name verknüpft sind.

Gruß

Rob

#7 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 30. Mai 2005 - 13:18

Hallo Rob,

jetzt nimmt der Router keine Einwahlanfrage mehr an...

Liebe Grüße

#8 rob_67

rob_67

    Board Veteran

  • 955 Beiträge

 

Geschrieben 30. Mai 2005 - 13:31

Hallo Stadt Tiger, dann schick bitte nochmal die config + debug dialer events, wenn du versuchst, dich von einem pc aus einzuwählen, und vor allem mal die genaue! ios Version

#9 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 31. Mai 2005 - 05:26

guten Morgen Rob,

hab gerade den Router neu gestartet, so dass die letzte Konfiguration wiederhergestellt wurde...

[B]version 12.3[/B]
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 16000 debugging
enable password 7 xxx
!
username xxx password 7 xxx
username xxx privilege 0 password 7 xxx
username xxx privilege 0 password 7 xxx
username xxx privilege 0 password 7 xxx
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
aaa authentication ppp default local
aaa authorization network default if-authenticated
aaa session-id common
ip subnet-zero
ip cef
!
no ip domain lookup
!
ip audit po max-events 100
no ftp-server write-enable
isdn switch-type basic-net3
!
!
interface FastEthernet0/0
 description Verbindung zum LAN
 ip address 192.168.2.2 255.255.254.0
 duplex auto
 speed auto
!
interface BRI1/0
 description Verbindung Dialer 1
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type basic-net3
 ppp callback accept
!
interface BRI1/1
 description Verbindung Dialer 1
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type basic-net3
 ppp callback accept
!
interface BRI1/2
 description Verbindung Dialer 1
 no ip address
 encapsulation ppp
 dialer rotary-group 1
 dialer-group 1
 isdn switch-type basic-net3
 ppp callback accept
!
interface BRI1/3
 description noch keine Verbindung
 no ip address
 shutdown
 isdn switch-type basic-net3
!
interface Dialer1
 description Verbindung von Außen
 ip address 192.168.1.2 255.255.255.0
 encapsulation ppp
 no ip split-horizon
 dialer in-band
 dialer caller 0123 callback
 dialer caller 0234 callback
 dialer map ip 192.168.1.11 name xxx 0123
 dialer map ip 192.168.1.12 name xxx 0234
 dialer-group 1
 ppp authentication chap
!
ip http server
ip http access-class 1
ip http authentication local
no ip classless
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
end

Liebe Grüße

#10 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 31. Mai 2005 - 05:43

Debug von ISDN events, q931 und Dialer events:

*Mar  1 00:13:23.404: ISDN BR1/0 Q931: RX <- BAD PACKET()
*Mar  1 00:13:23.424: ISDN BR1/0 Q931: RX <- SETUP pd = 8  callref = 0x4D
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x8A
        Calling Party Number i = 0x0080, '0123'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x81, '3'
                Plan:ISDN, Type:Unknown
        Sending Complete
*Mar  1 00:13:23.432: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x4 callty
pe 1 HOST_INCOMING_CALL
*Mar  1 00:13:23.432: Di1 DDR: Caller id: Callback server starting to xxx 0123
*Mar  1 00:13:23.432:  Could not obtain author data from the previous call
*Mar  1 00:13:23.436: ISDN BR1/0 **ERROR**: host_incoming_call: DIALER ERROR 0x1
: b channel 1, call id 0x4
*Mar  1 00:13:23.440: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x4 callty
pe 1 HOST_DISCONNECT_ACK
*Mar  1 00:13:23.440: ISDN BR1/0 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xCD
 
        Cause i = 0x8095 - Call rejected
*Mar  1 00:13:24.886: ISDN BR1/0 Q931: RX <- BAD PACKET()
*Mar  1 00:13:26.389: ISDN BR1/0 Q931: RX <- BAD PACKET()
*Mar  1 00:13:28.236: ISDN BR1/2 Q931: RX <- BAD PACKET()
*Mar  1 00:13:28.256: ISDN BR1/2 Q931: RX <- SETUP pd = 8  callref = 0x4E
        Bearer Capability i = 0x8890
                Standard = CCITT
                Transfer Capability = Unrestricted Digital
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0x89
        Calling Party Number i = 0x0080, '0123'
                Plan:Unknown, Type:Unknown
        Called Party Number i = 0x81, '2'
                Plan:ISDN, Type:Unknown
        Sending Complete
*Mar  1 00:13:28.260: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x5 callty
pe 1 HOST_INCOMING_CALL
*Mar  1 00:13:28.264: Di1 DDR: callback to xxx already started
*Mar  1 00:13:28.264:  Could not obtain author data from the previous call
*Mar  1 00:13:28.268: ISDN BR1/2 **ERROR**: host_incoming_call: DIALER ERROR 0x1
: b channel 0, call id 0x5
*Mar  1 00:13:28.268: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x5 callty
pe 1 HOST_DISCONNECT_ACK
*Mar  1 00:13:28.272: ISDN BR1/2 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xCE


#11 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 31. Mai 2005 - 05:44

Cause i = 0x8095 - Call rejected

*Mar  1 00:13:29.726: ISDN BR1/2 Q931: RX <- BAD PACKET()

*Mar  1 00:13:31.225: ISDN BR1/2 Q931: RX <- BAD PACKET()

*Mar  1 00:13:33.072: ISDN BR1/2 Q931: RX <- BAD PACKET()

*Mar  1 00:13:33.092: ISDN BR1/2 Q931: RX <- SETUP pd = 8  callref = 0x4D

        Bearer Capability i = 0x8890

                Standard = CCITT

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x8A

        Calling Party Number i = 0x0080, '0123'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x81, '3'

                Plan:ISDN, Type:Unknown

        Sending Complete

*Mar  1 00:13:33.096: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x6 callty

pe 1 HOST_INCOMING_CALL

*Mar  1 00:13:33.100: Di1 DDR: callback to xxx already started

*Mar  1 00:13:33.100:  Could not obtain author data from the previous call

*Mar  1 00:13:33.100: ISDN BR1/2 **ERROR**: host_incoming_call: DIALER ERROR 0x1

: b channel 1, call id 0x6

*Mar  1 00:13:33.104: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x6 callty

pe 1 HOST_DISCONNECT_ACK

*Mar  1 00:13:33.108: ISDN BR1/2 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xCD

 

        Cause i = 0x8095 - Call rejected

*Mar  1 00:13:34.558: ISDN BR1/2 Q931: RX <- BAD PACKET()

*Mar  1 00:13:36.057: ISDN BR1/2 Q931: RX <- BAD PACKET()

*Mar  1 00:13:37.904: ISDN BR1/1 Q931: RX <- BAD PACKET()

*Mar  1 00:13:37.924: ISDN BR1/1 Q931: RX <- SETUP pd = 8  callref = 0x4E

        Bearer Capability i = 0x8890

                Standard = CCITT

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x89

        Calling Party Number i = 0x0080, '0123'

                Plan:Unknown, Type:Unknown

        Called Party Number i = 0x81, '2'

                Plan:ISDN, Type:Unknown

        Sending Complete

*Mar  1 00:13:37.928: ISDN BR1/1 EVENT: process_rxstate: ces/callid 1/0x7 callty

pe 1 HOST_INCOMING_CALL

*Mar  1 00:13:37.932: Di1 DDR: callback to xxx already started

*Mar  1 00:13:37.932:  Could not obtain author data from the previous call

*Mar  1 00:13:37.932: ISDN BR1/1 **ERROR**: host_incoming_call: DIALER ERROR 0x1

: b channel 0, call id 0x7

*Mar  1 00:13:37.936: ISDN BR1/1 EVENT: process_rxstate: ces/callid 1/0x7 callty

pe 1 HOST_DISCONNECT_ACK

*Mar  1 00:13:37.940: ISDN BR1/1 Q931: TX -> RELEASE_COMP pd = 8  callref = 0xCE


#12 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 31. Mai 2005 - 05:44

Cause i = 0x8095 - Call rejected

*Mar  1 00:13:38.433: DDR: Callback timer expired

*Mar  1 00:13:38.433: Di1 DDR: beginning callback to xxx 0123

*Mar  1 00:13:38.433: BR1/2 DDR: rotor dialout [best] least recent failure is al

so most recent failure

*Mar  1 00:13:38.433: BR1/2 DDR: rotor dialout [best] trying untried dialout

*Mar  1 00:13:38.433: BR1/2 DDR: rotor dialout [best] also has most recent failu

re

*Mar  1 00:13:38.433: BR1/2 DDR: rotor dialout [best]

*Mar  1 00:13:38.433: BR1/2 DDR: Attempting to dial 0123

*Mar  1 00:13:38.433: ISDN BR1/2 EVENT: UserIdle: callid 0x8001 received ISDN_CA

LL (0x0)

*Mar  1 00:13:38.441: ISDN BR1/2 Q931: TX -> SETUP pd = 8  callref = 0x01

        Bearer Capability i = 0x8890

                Standard = CCITT

                Transfer Capability = Unrestricted Digital

                Transfer Mode = Circuit

                Transfer Rate = 64 kbit/s

        Channel ID i = 0x83

        Called Party Number i = 0x80, '0123'

                Plan:Unknown, Type:Unknown

*Mar  1 00:13:38.709: ISDN BR1/2 Q931: RX <- SETUP_ACK pd = 8  callref = 0x81

        Channel ID i = 0x89

*Mar  1 00:13:38.713: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x8001 cal

ltype 1 HOST_INFORMATION

*Mar  1 00:13:39.386: ISDN BR1/1 Q931: RX <- BAD PACKET()

*Mar  1 00:13:39.707: ISDN BR1/2 Q931: RX <- CONNECT pd = 8  callref = 0x81

        Date/Time i = 0x05051F071F

*Mar  1 00:13:39.711: ISDN BR1/2 EVENT: process_rxstate: ces/callid 1/0x8001 cal

ltype 1 HOST_CONNECT

*Mar  1 00:13:39.711: %LINK-3-UPDOWN: Interface BRI1/2:1, changed state to up

*Mar  1 00:13:39.715: DDR: Freeing callback to xxx 0123

*Mar  1 00:13:39.715: %ISDN-6-CONNECT: Interface BRI1/2:1 is now connected to 0123

 N/A

*Mar  1 00:13:39.747: ISDN BR1/2 Q931: TX -> CONNECT_ACK pd = 8  callref = 0x01

*Mar  1 00:13:39.791: BR1/2:1 DDR: Remote name for xxx

*Mar  1 00:13:39.839: BR1/2:1 DDR: dialer protocol up

*Mar  1 00:13:40.800: %LINEPROTO-5-UPDOWN: Line protocol on Interface BRI1/2:1,

changed state to up

*Mar  1 00:13:45.717: %ISDN-6-CONNECT: Interface BRI1/2:1 is now connected to 0123

xxx

*Mar  1 00:13:45.717: %ISDN-6-CONNECT: Interface BRI1/2:1 is now connected to 0123

xxx

--------------------------------------------------------------------------------

                                ISDN ACTIVE CALLS

--------------------------------------------------------------------------------

Call    Calling      Called       Remote  Seconds Seconds Seconds Charges

Type    Number       Number       Name    Used    Left    Idle    Units/Currency

--------------------------------------------------------------------------------

Out   ---N/A---    0123  +xxx       11     119       0      0

--------------------------------------------------------------------------------

 

router#sh us

    Line       User       Host(s)              Idle       Location

* 66 vty 0     xxx      idle                 00:00:00 192.168.3.13

 

  Interface    User               Mode         Idle     Peer Address

  BR1/2:1      xxx        Sync PPP     00:00:00 PPP: 192.168.1.11


#13 rob_67

rob_67

    Board Veteran

  • 955 Beiträge

 

Geschrieben 31. Mai 2005 - 06:27

Hallo Stadt Tiger,

es sieht so aus, als hätte doch das ios ein problem

*Mar 1 00:13:23.432: ISDN BR1/0 EVENT: process_rxstate: ces/callid 1/0x4 callty
pe 1 HOST_INCOMING_CALL
*Mar 1 00:13:23.432: Di1 DDR: Caller id: Callback server starting to xxx 0123
*Mar 1 00:13:23.432: Could not obtain author data from the previous call :confused:
*Mar 1 00:13:23.436: ISDN BR1/0 **ERROR**: host_incoming_call: DIALER ERROR 0x1
: b channel 1, call id 0x4

der router sieht den call und bingt dialer error, laut config sind 3 bri's in Benutzung, sind alle drei auch up und auf spoofing, mach doch mal nen sh isdn status

was du konfiguriert hast, ist immer noch d-kanal callback, ein ppp callback accept allein reicht nicht,

#14 Stadt-Tiger

Stadt-Tiger

    Registered User

  • 134 Beiträge

 

Geschrieben 31. Mai 2005 - 12:30

Hallo Rob,

in der Zwischenzeit hatte ich alles mal auf Dialer Strings usw. umgestellt, aber das läuft garnicht und deswegen habe ich das gerade nochmal zurück geändert.
Ich habe jetzt überlegt, für jede externe Stelle einen Dialer zuzuordnen, wie du mir das in einem anderen Bereich schon mal vorgeschlagen hast und dann die externe Stelle nur einem Bri-Port zuzuweisen. Was hälst du davon?

Liebe Grüße

#15 rob_67

rob_67

    Board Veteran

  • 955 Beiträge

 

Geschrieben 31. Mai 2005 - 13:03

Hallo Stadt Tiger, du kannst das schon probieren, ein dialer pro bri, aber normalerweise müsste das auch so gehen, du kannst ja auch erstmal nur ein bri nehmen, legst das in den pool 1 und legst einen neuen dialer an, ebenfalls im pool 1 und hier setzt du den dialer string, dann kannst du erstmal die funktionierende config lassen (eine rotary group verträgt sich nicht mit dialer pools) in der Art(mit multilink):

interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
load-interval 30
dialer remote-name xxx
dialer pool 1
dialer idle-timeout 30
dialer enable-timeout 2
dialer string xxx class callback
dialer load-threshold 50 either
dialer-group 1
ppp authentication chap
ppp multilink
ppp callback accept

interface BRI1/3
bandwidth 64
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
ppp authentication chap
ppp multilink
ppp callback accept


!
map-class dialer callback
dialer callback-server username


viele grüße