Jump to content
Melde dich an, um diesen Inhalt zu abonnieren  
Stadt-Tiger

Callout?

Empfohlene Beiträge

was heisst du hast nur die nummer zur einwahl, du musst doch wissen, was du dort machst?

 

PC-LAN-Router-ISDN-Router?-LAN-Server? funktioniert ebenfalls, wenn du einen deiner pcs als router missbrauchst, geht es theoretisch auch über diese, falls routing aktivierbar ist.

 

 

was ist das für ein server, den du erreichen willst und welches programm nutzt du für die verbindung?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo Rob,

 

an dem Arbeitsplatz werden Daten in das andere Netzwerk versendet und Daten kommen auch zurück.

Wie ich jetzt erfahren habe, bei dem anderen Netz ein Router, der nach Rufnummern sortiert und dem Einwählenden eine IP mitteilt. Mehr habe ich mit dem Netz nicht zu tun.

An den Arbeitsplatzrechner ist überall Windows NT 4.0 installiert, also noch eine kleine Schwierigkeit.

Bislang wird für das CAPI NDC verwendet und für die Einwahl DFÜ.

 

Liebe Grüße

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

wenn du dich mittels capi bei einem router einwählst und eine ip zugewiesen bekommst, ist das gar kein problem, leg einfach auf dem router einen weiteren dialer an, der bekommt die nummer von dem anderen router und ip address negotiated, dann brät der gegenüberliegende router auch eine ip drüber, es wäre nur noch eine route auf den dialer zu legen und der gegenüberliegende router ist anzupassen

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

 

das ist alles garnicht so einfach. Mittlerweile habe ich es geschafft, dass der Router eine Testverbindung aufbaut.

Aber wie kann ich jetzt von einem Arbeitsplatzrechner aus dem Router mitteilen, er soll zu einem bestimmten Netz eine Verbindung aufbauen?

Capi fällt ja raus. Jetzt suche ich nach einem anderem Programm...

 

Liebe Grüße

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Stadt Tiger, du machst das ganz normal über routing, der quellrechner bekommt den router als gateway, der router bekommt eine route zum zielnetz über den dialer und schon geht es.

 

Viele grüße

 

Rob

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

was klappt nicht, versuch doch mal den trace vom recher zum zielnetz, siehst du darin den router, wenn ja ists bis dahin OK. dann schau, ob der router rauswählt, wenn nicht, mach mal ein debug dialer packets an, da siehst du den traffic, der ein wählen veranlasst, du kannst auch schauen, ob deine dialer list bei dem traffic zieht, wenns gar nicht geht, könen wir auch mal zusammen schauen

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

nach einem ausgiebigen Debug und Testreihen, habe ich festgestellt, dass der Router jetzt versucht sich in ein anderes Netz zu wählen, nimmt dazu aber die Callback-Verbindungen...

 

Ich werde später mal die momentane Konfiguration reinstellen.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 16000 debugging
enable password 7 
!
username xxx password 7 
username xxx privilege 15 password 7 
username xxx privilege 0 password 7 
username xxx privilege 0 password 7 
no network-clock-participate slot 1
no network-clock-participate wic 0
aaa new-model
!
aaa authentication ppp default local
aaa authorization network default if-authenticated
aaa session-id common
ip subnet-zero
ip cef
!
ip audit po max-events 100
no ftp-server write-enable
isdn switch-type basic-net3
!
interface FastEthernet0/0
description Verbindung zum LAN
ip address 192.168.2.2 255.255.254.0
ip nat inside
duplex auto
speed auto
!
interface BRI1/0
description Verbindung Dialer
bandwidth 64
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 3
isdn switch-type basic-net3
isdn calling-number 987
no cdp enable
ppp callback accept
ppp authentication chap
!
interface BRI1/1
description Verbindung Dialer
bandwidth 64
no ip address
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
isdn calling-number 987
no cdp enable
ppp callback accept
ppp authentication chap
!
interface BRI1/2
description Verbindung Dialer
bandwidth 64
no ip address
encapsulation ppp
dialer pool-member 1
dialer pool-member 3
isdn switch-type basic-net3
isdn calling-number 987
no cdp enable
ppp callback accept
ppp authentication chap
!
interface BRI1/3
description noch keine
no ip address
encapsulation ppp
shutdown
dialer pool-member 1
isdn switch-type basic-net3
no cdp enable
!
interface Dialer1
description Verbindung mit extern1
ip address 192.168.1.2 255.255.255.0
ip nat outside
encapsulation ppp
no ip split-horizon
load-interval 30
dialer pool 1
dialer remote-name xxx
dialer idle-timeout 80
dialer enable-timeout 2
dialer string 0123 class callback
dialer caller 0123
dialer-group 1
peer default ip address pool extern1
ppp callback accept
ppp authentication chap
!
interface Dialer2
description Verbindung mit extern2
ip address 192.168.1.2 255.255.255.0
ip nat outside
encapsulation ppp
no ip split-horizon
load-interval 30
dialer pool 1
dialer remote-name xxx
dialer idle-timeout 80
dialer enable-timeout 2
dialer string 0234 class callback
dialer caller 0234
dialer-group 1
peer default ip address pool extern2
ppp callback accept
ppp authentication chap
!
interface Dialer3
description test
ip address negotiated
ip access-group 121 in
no ip proxy-arp
ip mtu 1492
ip nat outside
encapsulation ppp
no ip split-horizon
dialer pool 3
dialer remote-name xxx
dialer idle-timeout 60
dialer string 654
dialer hold-queue 10
dialer load-threshold 10 either
dialer-group 3
ppp authentication chap pap callin
ppp chap hostname xxx
ppp chap password 7 
ppp pap sent-username xxx password 7 
ppp ipcp dns request
ppp ipcp wins request
ppp multilink
!
ip local pool extern1 192.168.1.11
ip local pool extern2 192.168.1.12
ip nat pool NAT 192.168.0.1 192.168.0.100 netmask 255.255.255.0
ip nat inside source list 1 interface Dialer3 overload
ip http server
ip http access-class 1
ip http authentication local
no ip classless
ip route 192.168.1.0 255.255.0.0 Dialer3
ip route 192.168.0.0 255.255.0.0 Dialer3
!
map-class dialer callback
dialer callback-server username
access-list 1 permit any
dialer-list 1 protocol ip permit
!
line con 0
line aux 0
line vty 0 4
!
!
end

 

Das wird alles langsam unübersichtlich...Auch gedanklich bei mir...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

welche ip hat der rechner im lan und welches netz will er erreichen? 192.168.0.0 /16 ist ein relativ grosses Netz das du auf den dialer 3 routest, dieses beinhaltet sowohl dein lokales Netz und auch die IPs der über die anderen dialer angeschlossenen pcs, die Route 192.168.1.0 / 16 kannst du weglassen...

beim nat nur ein permit any reinzuschreiben ist sehr ungünstig, ich würde hier immer mit erweiterten access-listen mit quelle und ziel arbeiten

 

die externen pools kannst du sparen, schreib doch gleich die default ip address auf den dialer

 

die config hast du doch sicher von ner internetanbindung kopiert (ip mtu usw.)?

 

wo ist deine access-list 121 ?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Mein Rechner im Lan hat 192.168.3.20. Gut, die Route habe wirklich schlecht ausgewählt, da muss ich mir was besseres einfallen lassen, weil ja das lokale nicht mit rein soll. Bei den Access-Listen habe ich noch nichts gemacht und den Dialer 3 wie du schon bemerkt hast, einfach mal abgekupfert und angepasst. Beim NAT war ich mir etwas unsicher, dachte mir aber, das wäre soweit okay.

Ich denke mal, wenn das mit dem Verbinden und Routen klappt mit allen Rechern (intern/extern), dann werde ich mich an die Access-Listen machen. :)

Du hast noch gemeint, dass ich bei den Dialern gleich die anstatt der Pools die Adressen fest eintragen soll. Bei mir stellt sich nämlich die Frage, ob sich die Dialer untereinander stören, wenn sie die gleiche IP haben und im gleichen Netz sind. Ist das gleich oder muss wirklich jeder Dialer ein anderes Subnetz haben?

 

Am liebsten würde ich den Router im Moment würgen, aber er kann ja auch nichts dafür, dass ich da nicht so vom Blitz getroffen bin. :D

 

Liebe Grüße

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden
Melde dich an, um diesen Inhalt zu abonnieren  

×