Jump to content
Sign in to follow this  
Maik

Subnetting - wieso klappts nicht?

Recommended Posts

Hallo ans Board,

 

ich sitze gerade an einem Problem in Bezug auf das Subnetting. 5 Kabinette, 1 Server 2003,

120 XP Rechner über die Kabinette verteilt. Es sollen die Kabinette NUR mit dem Server kommunizieren, nicht untereinander. Jedes Kabinett also in ein eigenes Subnetz. Der Server muss nun in jedem Subnetz mit einem Bein stehen. 5 Lankarten wäre die Lösung, ist nicht machbar.

Vorschlag: Subnetting

172.16.0.0/255.255.254.0 ergäbe

255.255.254.0 172.16.0.1 bis 172.16.1.254

255.255.254.0 172.16.2.1 bis 172.16.3.254

usw.

Für den Server habe ich

172.16.0.254/255.255.255.240 172.16.0.1 to 172.16.0.14

Dieser steht doch nun überall drin.. kann aber per ping vom Client nicht erreicht werden.

 

Wo liegt mein Denkfehler?

Dank an alle

Share this post


Link to post

die Backroute von den Clients zum Server fehlt

 

Du könntest dem Server pro Subnetz eine zusätzliche IP (auf dem normalen LAN Interface) aus dem Client IP Bereich geben - dann erreichen ihn die Clients auch

Share this post


Link to post

warum sollte es? Einfach die IPs mit auf das Laninterface binden. Wenn Dein DNS sauber läuft gibt es keine Probleme!

 

hab ich hier beim meiner Mühle auch ... zu Testzwecken einen weiteren IMAP Server neben Exchange

 

U:\>nslookup
Standardserver:  locutus.unimatrix.local
Address:  10.0.0.1

> locutus
Server:  locutus.unimatrix.local
Address:  10.0.0.1

Name:    locutus.unimatrix.local
Addresses:  10.0.0.1, 10.100.100.100

Share this post


Link to post

Wenn der Server alle Adressen registriert und die Netzwerkmaskenanforderung im DNS aktiviert ist (Default), dann sollten die Clients immer die passenden Adressen aus ihrme Bereich bekommen. Aber gründlich testen würde ich es trotzdem ...

Share this post


Link to post

Aber ich habe von MS aml gehört, dass es Supernetting gibt, so um bspw. die Routingtabellen klein zu halten. Ich wollte in diese Richtung, so dass die Kabinette jeweils über die Subnetmask voneinander getrennt sind, der Server aber eine Subnetmaske besitzt, die sind in jedem Teilnetz der Clients befindet und darum funktioniert..

Geht so etwas überhaupt

Share this post


Link to post

ja das geht allerdings muss dann auf jedem Client eine manuelle statische Route hinzugefügt werden.

 

Ist doch eigentlich ganz einfach: Die Clients sehen in ihrem Subnetzbereich ja den Server überhaupt nicht, da er für sie in einem anderen Subnetz liegt - der Server sieht zwar die Clients aber das nützt Dir nichts. Damit fehlt Dir die Route vom Client zum Server!

Share this post


Link to post

Ja, die Idee mit der Route ist richtig, hatte ich mir auch schon gedacht. Der Ping geht vom Client nicht weg bzw. der Server erhält keine Antwort..

Wie kann ich aber nun auf jedem Rechner die statische route mit route add 172.16.0.254 mask 255.255.240.0 per script hinzufügen? Ich muss ja immer das GW manuell auf dem PC auf die eigene Netzwerkkarte setzen.. Heisst dass: eine batch datei mit dem route add Befehl, welches die aktuelle IP-Adresse des Hosts in dem Script als Variable ablegt und für diesen speziellen Fall in der route add Syntax als Gateway zum Server ablegt???

Share this post


Link to post

Ich versteh´s grad nicht, auf welches Gateway soll die Route auf den Clients denn zeigen ? Da ist doch gar kein Router zwischen . Und wenn der Server mehrere Adressen gebunden hat, befinden sich alle sowieso am selben Switch oder zumindest im selben physikalischen Subnetz, wozu dann eine Rückroute ?

Helft mir mal bitte auf die Sprünge ...

Share this post


Link to post

Nein, habe ich vielleicht SCHLECHT ausgedrückt..

route add 172.16.0.0 mask 255.255.240.0 gw (!!! lokale Netzwerkkarte!!!) -p. Da sich dies bei jedem PC ändern, muss ich diesen Befehl 120 Mal eingeben...

Ich dachte an ein script, dass die lokale IP ausliest und als Variable in das script zur Laufzeit einfügt...

Share this post


Link to post

nochmal ... wenn der Server auf dem LAN-Interface jeweils eine Adresse aus dem jeweiligen Clientsubnetz hat brauchst Du am Client keine Route hinzufügen.

 

Die Route wäre in der jetzigen Konstellation notwendig in der der Server alleine in einem eigenen Subnetz steht.

Share this post


Link to post

@ITHome: es dreht sich um seine aktuelle Konfig.

 

Server 172.16.0.254/20

Clients 172.16.0.0/23 etc ...

 

damit die Clients den Server erreichen brauchen sie eine Route in das 0.254er Netz

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...