Jump to content
Sign in to follow this  
defcon3

Clients registrieren sich nicht am WSUS Server

Recommended Posts

Hallo,

 

wir haben seit gestern den WSUS Server im Einsatz. Unser Netzwerk besteht ausschließlich aus Windows XP SP2 Client, einigen Windows 2000 Server (alle SP4) sowie einigen Windows 2003 Servern (alle SP1). Nicht verschweigen möchte ich natürlich unsere beiden NT 4.0- Domänencontroller, da wir noch kein ActiveDirectory haben. Das nicht vorhandene ActiveDirectory macht das Handling des WSUS Servers nicht einfacher, aber eigentlich sollte es trotzdem funktionieren, denn per Anmeldeskript wird Folgendes in die Registry jedes Clients importiert:

 

Windows Registry Editor Version 5.00

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]

"WUServer"="http://wsusserver:8530"

"WUStatusServer"="http://wsusserver:8530"

"TargetGroupEnabled"=dword:00000001

"TargetGroup"="Clients"

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]

"NoAutoUpdate"=dword:00000000

"RescheduleWaitTimeEnabled"=dword:00000001

"RescheduleWaitTime"=dword:00000001

"ScheduledInstallDay"=dword:00000000

"ScheduledInstallTime"=dword:0000000c

"UseWUServer"=dword:00000001

"AutoInstallMinorUpdates"=dword:00000001

"DetectionFrequency"=dword:00000001

"DetectionFrequencyEnabled"=dword:00000001

"NoAUShutdownOption"=dword:00000000

"AUOptions"=dword:00000004

 

Unter WSUS habe ich auch die entsprechende Computergruppe "Clients" angelegt, die Einstellungen wurden auch erfolgreich in die regsitry importiert, das habe ich manuell als auch mit dem Tool von wsus.de überprüft. Trotzdem nehmen die Clients keine Verbindung mit dem WSUS auf, bzw. der Server nimmt sie nicht an. Gibt es irgendwelche besonderen Berechtigungen, die gesetzt werden müssen? Berechtigungen auf den Clients können wir, glaube ich, ausschließen, denn wir haben es sowohl an Clients ausprobiert, die lokale Adminrechte haben, als auch an Clients, die nur Standardbenutzer sind...... no way!

 

Freue mich auf alle Ideen.

 

Gruss

 

defcon3

Share this post


Link to post
Share on other sites

Hi,

 

neee habe ich noch nicht. Brauche ich das denn? ich würde mir gerne die Installation von zusätzlicher Software auf 100 Clients ersparen. Ausprobieren werde ich das aber trotzdem..... ansonsten wirst Du mir doch aber sicher zustimmen, dass es auch so funktionieren müsste, oder? Die Frage ist, wann die Clients denn auf den WSUS zugreifen und wann sie auf dem Server angezeigt werden? Sobald der Zeitpunkt der Aktualisierung gekommen ist, sollten die Clients doch Ihre registrty auslesen und dort die Anweisung vorfinden auf den WSUS Server zuzugreifen... dann werden sie dort auch zu sehen sein und ich kann sie dann von von "nicht zugeordnete Computer" in die Computergruppe "Clients" verschieben. Oder sind die automatisch durch die reg- Datei in der Gruppe "Clients"?

 

Schwierig, schwierig......

 

Bin für weitere Ideen sehr dankbar.

 

Danke

 

defcon3

Share this post


Link to post
Share on other sites

Also ich habe den WSUS am WE bei uns installiert. Die Clients bekommen ihre Einstellungen per GPO da wir eine AD-Domäne haben.

Die XP-Clients haben sich innerhalb von einer Stunde beim WSUS gemeldet, die 2k-Clients brauchten einen Neustart und danach ein paar Minuten.

 

Ich würde sagen, deine Einstellungen sind soweit korrekt.

Versuche doch mal bei einem Client die lokale Ricktlinie entsprechend zu modifizieren. Der Client sollte sich spätestens nach dem Neustart beim WSUS melden.

Tut er das nicht, hast du ein Kommunikationsproblem. Andernfalls liegt es wohl doch an deinen Einstellungen.

Share this post


Link to post
Share on other sites

Hai,

 

ist klar, 100 clients nach zuinstallieren, das ist schlecht... vielleicht bekommt man es ja über eine netlogon.bat hin...

erst die Datei aus der windowsupdateagenten20.exe hinschieben dann diesen Befehl "regsvr32 -u wuaueng.dll" und dann mal schauen ob er im WSUS angezeigt wird..

evtl. lädst Du Dir mal die Tools von http://www.wsus.de/cgi-bin/yabb/YaBB.pl?board=ToolsWSUS

 

zu der Zuordnung:

Man kan im WSUS einstellen, ob die Zuordnung automatisch oder manuell geschehen soll

Share this post


Link to post
Share on other sites

Kurzer Zwischenstand:

 

WindowsUpdateAgent20-x86.exe habe ich installiert, die Installation endete mit "Brauchste nicht, ist schon installiert" ;) Bin mir sicher, dass das mit SP2 mitkam.

 

Ansonsten denke, ich dass wir morgen sowieo mehr wissen, dann jeder Boot tut ja bekanntlich gut. Mal schauen, ob nicht morgen einige meiner Testkandidaten beim WSUS angezeigt werden.

 

Bis dahin werde ich die anderen Ideen nochmal ausprobieren.

 

Danke vielmals und wer noch input geben kann, immer her damit.

 

Grüsse

 

defcon3

Share this post


Link to post
Share on other sites

Hi,

 

ich habe genau das gleiche Problem. Habe den WSUS installiert und bekomme nur einen Client angezeigt. Habe das ****e Gefühl das irgendeine Einstellung im IIS nicht passt. Wenn ich nicht ganz **** bin habe ich am Client wie auch am Server das Problem http: 404 Fehler.

Kann mir noch einer sagen wie die Einstellungen am Server sein müssen in der Gruppenrichtlinie. Bsp.http://server001/WSUSAdmin/

http://server001/WSUSAdmin/

 

ist die Einstellung so richtig oder muss ich die ändern. Da kommt mir noch eine Frage. Müssen den die Clients Adminrechte haben und spielt es eine Rolle ob die Clients Rechte haben ins Internet zu gehen oder nicht???

 

Für eure Hilfe bin ich euch jetzt schon dankbar.

 

Grüsse

Chris

Share this post


Link to post
Share on other sites

Hi,

 

es reicht, den Servernamen anzugeben, das /Wsusadmin/ ist nur für die Verwaltung des WSUS via Web erforderlich.

 

Natürlich muß die Website korrekt konfiguriert sein, d.h. :

chrismuc muß die über Port 80 ansprechen (default),

defcon3 sollte im IIS für die WSUS Website den Port 8530 eingetragen haben.

 

Namensauflösung sollte natürlich auch funktionieren, wenn man nicht die IP Adresse des WSUS Servers übergibt.

 

@Defcon3: warum trägst du die wsus settings via login-script ein? Es sollte doch reichen, die einmalig in die Registry zu schreiben?!

 

Christoph

Share this post


Link to post
Share on other sites

Hi,

 

leider gibt es keine Neuigkeiten... die Clients melden sich immer noch nicht beim WSUS. Die Frage ist doch durch was der Client dazu veranlasst wird, sich entsprechend beim WSUS blicken zu lassen. Diesen Auslösemechanismus muss man doch nur entsprechend aktivieren, die Frage ist nur: wie zum Henker geht das?!?!

 

Eventuelle Fehlerquelle ist ausserdem die Computergruppe. Im Registry- Eintrag steht ja, dass der Rechner der Gruppe Clients angehören soll. Diese Gruppe besteht auch, aber normalerweise landen die Clients, wenn sie sich das erste Mal beim WSUS melden, in der Gruppe nicht zugeordnete Computer. Vielleicht führt das zu einem Fehler?

 

Ansonsten stellt sich mir immer noch die Frage nach der Berechtigung. Kann einfach jeder Domänen- Client ohne Probleme auf den WSUS zugreifen? Oder erteilt man nicht erst die Berechtigung durch das Verschieben des Clients von nicht zugeordnete Computer in die entsprechende Computergruppe?

 

@danryker:

"regsvr32 -u wuaueng.dll" habe ich ausgeführt, hat aber leider nicht geholfen. Den von Dir erwähnten Client habe ich versucht zu installieren, aber der war schon drauf

 

@Christoph35

 

Du hast Recht, es reicht absolut, die reg- Datei einmalig zu importieren. Allerdings sollte es auch nichts ausmachen, das Ganze per Anmeldeskript immer wieder zu importieren, da die Einstellungen ja nur überschrieben werden. Solange wir uns uns hier im Test befinden ist diese Art der Verteilung die, die am wenigsten Aufwand macht.

 

Bin ja mal gespannt, ob wir das noch zusammen hinbekommen. Freue mich auf Euer weiteres input.

 

Gruss

 

defcon3

Share this post


Link to post
Share on other sites

Hallo,

an den Clients mußt Du nichts machen, außer sie in die ou zu verschieben, auf die die Gruppenrichtlinie angewendet wird.

Du kannst ja mal mit gpresult überprüfen, ob die gpo für die Clients gilt.

 

Mit dem Check WSUS-Skript (von http://www.wsus.de) kannst Du überprüfen, ob er den WSUS-Server überhaupt kennt.

 

Gibt es bei den Clients im winnt-Verzeichnis eine Datei windowsupdate.log? Poste mal, was darin steht.

 

Adminrechte müssen auf den Clients nicht vorhanden sein.

 

Viele Grüße,

Frauke

Share this post


Link to post
Share on other sites

@Frauke

 

Hallo Frauke,

 

unten findest Du einen aktuellen Ausschnitt von einem der Clients. Aber erst noch eines: das Tool von WSUS gibt grünes Licht, alle Einträge stimmen! Hier nun der Ausschnitt aus dem WindowsUpdate.log

 

2005-12-21 15:29:23 864 430 PT WARNING: GetConfig failure, error = 0x80072EFD, soap client error = 5, soap error code = 0, HTTP status code = 200

2005-12-21 15:29:23 864 430 Report WARNING: Reporter failed to upload events with hr = 80072efd.

2005-12-21 15:31:06 864 658 Service *********

2005-12-21 15:31:06 864 658 Service ** END ** Service: Service exit [Exit code = 0x240001]

2005-12-21 15:31:06 864 658 Service *************

2005-12-21 15:31:31 168 e0 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-21 15:31:31 168 e0 Misc = Process: C:\WINDOWS\Explorer.EXE

2005-12-21 15:31:31 168 e0 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-21 15:31:31 168 e0 Shutdwn Install at shutdown: no updates to install

2005-12-21 15:50:15 168 e0 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-21 15:50:15 168 e0 Misc = Process: C:\WINDOWS\Explorer.EXE

2005-12-21 15:50:15 168 e0 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-21 15:50:15 168 e0 Shutdwn Install at shutdown: no updates to install

2005-12-21 15:50:19 528 1a8 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-21 15:50:19 528 1a8 Misc = Process: \??\C:\WINDOWS\system32\winlogon.exe

2005-12-21 15:50:19 528 1a8 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-21 15:50:19 528 1a8 Shutdwn FATAL: WUAutoUpdateAtShutdown failed, hr=8024000C

2005-12-22 10:33:44 888 118 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-22 10:33:44 888 118 Misc = Process: C:\WINDOWS\Explorer.EXE

2005-12-22 10:33:44 888 118 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-22 10:33:44 888 118 Shutdwn Install at shutdown: no updates to install

2005-12-22 10:37:15 1460 454 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-22 10:37:15 1460 454 Misc = Process: C:\WINDOWS\Explorer.EXE

2005-12-22 10:37:15 1460 454 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-22 10:37:15 1460 454 Shutdwn Install at shutdown: no updates to install

2005-12-22 10:37:19 532 14c Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-22 10:37:19 532 14c Misc = Process: \??\C:\WINDOWS\system32\winlogon.exe

2005-12-22 10:37:19 532 14c Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-22 10:37:19 532 14c Shutdwn FATAL: WUAutoUpdateAtShutdown failed, hr=8024000C

2005-12-22 13:07:40 1036 700 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-22 13:07:40 1036 700 Misc = Process: C:\WINDOWS\Explorer.EXE

2005-12-22 13:07:40 1036 700 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-22 13:07:40 1036 700 Shutdwn Install at shutdown: no updates to install

2005-12-22 13:07:44 532 3a4 Misc =========== Logging initialized (build: 5.8.0.2469, tz: +0100) ===========

2005-12-22 13:07:44 532 3a4 Misc = Process: \??\C:\WINDOWS\system32\winlogon.exe

2005-12-22 13:07:44 532 3a4 Misc = Module: C:\WINDOWS\system32\wuaueng.dll

2005-12-22 13:07:44 532 3a4 Shutdwn FATAL: WUAutoUpdateAtShutdown failed, hr=8024000C

[/i]

 

Danke im voraus. Ach ja: Eines habe ich noch ausprobiert: ich habe den Eintrag TargetGroup, der bisher auf Clients stand mal komplett rausgeschmissen. War / ist nur ein Versuch... wenn Du also solch eine Meldung oben siehst, wundere Dich nicht.

 

Gruss

defcon3

Share this post


Link to post
Share on other sites

Also bei mir reichts immer wenn ich nach der Einstellung des Clients (ohne AD) der GPO

einmal gpupdate /force und dann noch wuauclt.exe /detectnow evtl 2-3 mal eingebe.

Share this post


Link to post
Share on other sites

Soso..... hmmmm.... und was genau gibst Du den Clients als Info? Machst Du das manuell per Anmeldeskript oder gehst Du an jeden Client und trägst die Einstellung manuell ein?

 

Danke schon mal für die Info.

 

Gruss defcon3

Share this post


Link to post
Share on other sites
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

Werbepartner:



×
×
  • Create New...