Jump to content

Problem mit NTFS-Verschlüsselung


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo zusammen!

 

Ich brauche dringend Hilfe! Folgendes Problem:

 

Die Daten eines Ordners, der unter meiner alten Win2k-Installation mit der NTFS-Verschlüsselung verschlüsselt wurde, sind unter der neuen Installation nicht mehr lesbar. Auch läßt sich die Verschlüsselung nicht aufheben.

 

Ich habe zwar noch die Partition mit der alten Installation, aber die läßt sich nicht mehr booten (auch nicht im abges. Modus).

 

Kann mir da jemand aus der geneigten Leserschaft helfen??

 

CU, Tom

 

ICQ: 109741791

Link to comment
Guest BamBam

Wenn Du nicht den Zertifikatsschlüßel gespeichert hast, kannst Du nicht mehr von einer neuen Installation aus auf diese Verzeichnisse zugreifen! Nur die alte Installation!

 

Sonst gibts nichts!

 

Falls jemand doch nen Weg weiß, gleich zu MS schicken, als neuen Security Bug!

Link to comment

Hallo!

 

@Dr.Melzer:

 

Der Bootvorgang bricht ab, nachdem der Fortschrittsbalken auf dem "Windows2000" Splashscreen voll ist. Dann kommt ein BlueScreen mit der Meldung

Stop 0x0000001E (...) - KMODE_EXCEPTION_NOT_HANDLED.

 

Als Fehlerquelle wird "ntoskrnl.exe" angegeben.

 

@all:

 

... und man kann den Schlüssel auch nicht aus der alten Installation extrahieren? Das müßte doch möglich sein, auch wenn sie sich nicht booten läßt.

Wo werden denn unter W2K die Zertifikate/Schlüssel gespeichert? Gibt es eventuell die Möglichkeit, diese Daten in die neue Installation zu kopieren?

 

Vielen Dank,

 

Tom

Link to comment

Uuups,

bin ich eben auf die falsche Taste gekommen.

 

An den privaten Schlüssel kommst Du nicht mehr heran. Du könntest vielleicht noch das Zertifikat selbst finden, aber damit hast Du nur den öffentlichen Schlüssel und der nutzt Dir nur etwas um den EK (File Encryption Key) zu verschlüsseln. Ohne privaten Schlüssel hast Du keine Chance an die Daten heranzukommen.

 

Die einzige Möglichkeit die Dir bleibt ist die, die alte Installation wieder zum laufen zu bringen.

 

Ulli

Link to comment

Ich denke, der einzige Weg an deine daten zu kommen ist, die alte Installation wieder zum Laufen zu bekommen.

Der von Dir genannte Stop-Fehler ist nicht eindeutig zu interpretieren, es fehlen zu viele Parameter.

 

Aber unter: http://search.microsoft.com/default.asp?qu=0x0000001E&boolean=ALL&nq=NEW&so=RECCNT&ig=01&ig=02&ig=03&ig=04&ig=05&ig=06&ig=07&ig=08&ig=09&ig=10&i=00&i=01&i=02&i=03&i=04&i=05&i=06&i=07&i=08&i=09&siteid=us findest du Erklärungen und Lösungsansätze zu dem Fehler

Link to comment

Hallo zusammen!

 

Gleich vorweg: Ich hab's wieder zum Laufen gebracht!! Yeeeha!! :D

 

 

Meine Methode: Ich habe einfach das Verzeichnis <winnt\system32\drivers> von der neuen Installation in die alte kopiert und dann sukzessive die in der alten Installation zusätzlich vorhandenen Treiber 'rausgelöscht bis die Installation schließlich wieder startete. War also einer der gelöschten Treiber, wahrscheinlich einer von VMWare.

Dann hatte ich zwar das System laufen, hatte aber trotzdem keinen Zugriff auf die verschlüsselten Dateien. Man stelle sich mein langes Gesicht vor ... :eek:

Langer Rede kurzer Sinn: Nach einer Neuinstallation des SP2 ging's dann und ich bin wieder glücklicher Besitzer meiner Buchhaltungsdaten der letzten 4 Jahre :D

 

Und die Moral: BrutForce-Methoden sind eben doch nicht immer schlecht ;)

 

Vielen Dank Euch allen für die Hilfe!

 

Tom

 

P.S.: Was mich gewundert (und geärgert) hat, ist, daß Win2k auch auf Aufforderung kein Bootlog geschrieben hat!!

Link to comment
Original geschrieben von Dr.Melzer

 

Frage am Rande:

hast du dir schon mal Gedanken über eine Datensicherung gemacht??? :confused:

 

Klar hab' ich ein Backup. Leider ist (nein - war ;) ) das auch verschlüsselt.

 

Ich hätte halt Zertifikat und Schlüssel sichern müssen. Dann wär's alles kein Problem gewesen.

 

Jetzt nehme ich BestCrypt, da habe ich diese Probleme nicht mehr (und Datensicherung geht auch mit "normalen" Tools).

 

CU,

 

Tom

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...