Jump to content

Exchange 2000 Installation nicht möglich - findet Domäne und AD nicht


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

 

versuche seit 2 Tagen Exchange 2000 auf dem einzigen Server in einer kleinen Firma zu installieren. Dieser Server ist PDC, und ist mit AD, DNS, WINS ... konfiguriert.

Bei der Installation von Exchange (egal ob ich /forestprep, oder /schemaonly oder normal starte) kommt bei der Auswahl von der Installationsmethode (Typical, Minimal, Custom ...)

die Fehlermeldung

"setup is unable to access the windows 2000 active directory

failed to contact the schema master server for this active directory forest"

auch das ADC Setup beendet mit der Meldung, dass kein RPC Server gefunden werden kann.

In der Knowledge Base von Microsoft heisst es bei diesem Fehler, dass es ein DNS Problem ist.

nslookup funktioniert aber einwandfrei, und die vorgeschlagenen Häkchen hab ich in der DNS Registerkarte bei den TCP/IP Einstellungen schon gesetzt. ... ohne Erfolg.

Hab auch DNS schon neuinstalliert ... gleicher Fehler wieder.

Irgendwo hab ich noch gelesen, dass Exchange nur installierbar ist, wenn der Befehl

 

nltest /dsgetdc:xg

 

ohne Fehler ausführt wird.

Bei mir kommt aber:

DSGetDcName failed: Status = 1355 0x54b ERROR_NO_SUCH_DOMAIN

 

und wenn ich

dcdiag /test:knowsofroleholders /v

ausführe, bringt er auch einige Fehler dass er die Domain nicht finden kann...

Sonst funktioniert aber alles im Netz (Benutzeranmeldung...)

Weiss nicht mehr weiter ... vielen Dank für eure Hilfe

 

gruss Birgit

Link to comment

w2ksrv, hab ich vergessen ;)

ja, in der forwardlookup zone sind _msdcs,_sites,_tcp,_udp einträge drin

die netzwerkkarte is auch aktiv

der dc heisst servername.firma-standort.local

aber bei nslookup _msdcs kommt

Server: servername.firma-standort.local

Adress: 192.168.31.1

*** _msdcs wurde von servername.firma-standort.local nicht gefunden: non-existent domain

Link to comment

also reverselookup scheint zu funktionieren.

aber _msdcs sollte er finden.

funktioniert "nslookup servername" (WICHTIG: ohne domäne) ?

wenn ja :

lösche einmal die firma-standort.local zone raus. lege sie neu an. ad-integriert. starte den anmeldedienst neu und warte bis die _... zonen eingetragen wurden.

wenn nein :

ist dein zonen-name wirklich der gleiche wie der domänenname ?

 

 

lars

Link to comment

nslookup servername funktioniert:

Server: servername.firma-standort.local

Adress: 192.168.31.1

 

Server: servername.firma-standort.local

Adress: 192.168.31.1

 

wundert mich nur warum er das zweimal bringt

hab die forward zone auch neu angelegt (AD integriert mit namen firma-standort.local)

nach neustart des anmeldedienstes sind alle einträge drin (_msdcs ...),

aber immer noch der gleiche fehler bei nslookup _msdcs...

Link to comment

er bringt es zweimal weil nslookup erst ein reverselookup auf die ip-adresse des primären dns macht.

danach kommt die eigentliche anfrage.

 

tut mir leid. mein fehler nslookup funktioniert nicht, weil _msdcs bei dir ein einfacher ordner ist. ich habe hier _msdcs deligiert und kann es daher auch auflösen.

 

schaue mal in %systemroot%\system32\config\netlogon.dns nach. ist dort die guid des dc zu sehen.

 

sind irgendwelche einträge im ereignisprotokoll, die auf fehler im ad hinweisen ?

Link to comment

hier die netlogon.dns:

_gc._tcp.firma-standort.local. 600 IN SRV 0 100 3268 SERVERNAME.firma-standort.local.

_kerberos._udp.firma-standort.local. 600 IN SRV 0 100 88 SERVERNAME.firma-standort.local.

_ldap._tcp.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

_ldap._tcp.Standardname-des-ersten-Standorts._sites.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

_ldap._tcp.pdc._msdcs.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

_ldap._tcp.gc._msdcs.firma-standort.local. 600 IN SRV 0 100 3268 SERVERNAME.firma-standort.local.

_ldap._tcp.Standardname-des-ersten-Standorts._sites.gc._msdcs.firma-standort.local. 600 IN SRV 0 100 3268 SERVERNAME.firma-standort.local.

_ldap._tcp.59f17838-1596-44ec-b430-6ccb63298c0c.domains._msdcs.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

40869bc6-e4d5-4118-ba8b-23f3cefcf121._msdcs.firma-standort.local. 600 IN CNAME SERVERNAME.firma-standort.local.

_kerberos._tcp.dc._msdcs.firma-standort.local. 600 IN SRV 0 100 88 SERVERNAME.firma-standort.local.

_kerberos._tcp.Standardname-des-ersten-Standorts._sites.dc._msdcs.firma-standort.local. 600 IN SRV 0 100 88 SERVERNAME.firma-standort.local.

_ldap._tcp.dc._msdcs.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

_ldap._tcp.Standardname-des-ersten-Standorts._sites.dc._msdcs.firma-standort.local. 600 IN SRV 0 100 389 SERVERNAME.firma-standort.local.

_kerberos._tcp.firma-standort.local. 600 IN SRV 0 100 88 SERVERNAME.firma-standort.local.

_kerberos._tcp.Standardname-des-ersten-Standorts._sites.firma-standort.local. 600 IN SRV 0 100 88 SERVERNAME.firma-standort.local.

_gc._tcp.Standardname-des-ersten-Standorts._sites.firma-standort.local. 600 IN SRV 0 100 3268 SERVERNAME.firma-standort.local.

_kpasswd._tcp.firma-standort.local. 600 IN SRV 0 100 464 SERVERNAME.firma-standort.local.

_kpasswd._udp.firma-standort.local. 600 IN SRV 0 100 464 SERVERNAME.firma-standort.local.

firma-standort.local. 600 IN A 192.168.31.1

gc._msdcs.firma-standort.local. 600 IN A 192.168.31.1

 

... kann damit ned viel anfangen..

np wegen dem nslookup, mir is auch grad n fehler von mir aufgefallen:

nltest /dsgetdc:xg

muss bei mir heissen

nltest /dsgetdc:firma-standort.local

... dann gehts auch ...

dcdiag /test:knowsofroleholders /v

bringt jetzt auch keine fehler mehr...

ansonsten alles beim alten

 

im dateireplikationsdienst steht eine warnung die damit zu tun haben könnte:

 

Das nTDSConnection-Objekt cn=14eaa427-17ba-47fe-b9ab-880b1fc3aca9,cn=ntds settings,cn=fps-muc,cn=servers,cn=standardname-des-ersten-standorts,cn=sites,cn=configuration,dc=fps-muc,dc=local steht in Konflikt mit cn=396ec259-985d-4ff8-a3a9-af7872b6cee9,cn=ntds settings,cn=fps-muc,cn=servers,cn=standardname-des-ersten-standorts,cn=sites,cn=configuration,dc=fps-muc,dc=local. cn=14eaa427-17ba-47fe-b9ab-880b1fc3aca9,cn=ntds settings,cn=fps-muc,cn=servers,cn=standardname-des-ersten-standorts,cn=sites,cn=configuration,dc=fps-muc,dc=local wird verwendet.

 

Und das im Directory Service:

 

Das "ntdsConnection"-Objekt CN=14eaa427-17ba-47fe-b9ab-880b1fc3aca9,CN=NTDS Settings,CN=FPS-MUC,CN=Servers,CN=Standardname-des-ersten-Standorts,CN=Sites,CN=Configuration,DC=fps-muc,DC=local schreibt vor, dass der lokale Server von sich selbst replizieren soll. Diese Konfiguration ist ungültig und wird ignoriert. Verwenden Sie die Active Directory Standort- und Dienstverwaltung, um dieses Objekt zu ändern oder zu löschen.

 

sorry für den vielen text ... werd etz mal versuchen die domäne auf den "native" modus umzustellen..

danke

Link to comment

... native mode umstellung hats nicht gebracht

 

wenn ich dcdiag ausführe kommen auch einige fehler:

DC Diagnosis

 

Performing initial setup:

Done gathering initial info.

 

Doing initial non skippeable tests

 

Testing server: Standardname-des-ersten-Standorts\FIRMA-STANDORT

Starting test: Connectivity

......................... FIRMA-STANDORT passed test Connectivity

 

Doing primary tests

 

Testing server: Standardname-des-ersten-Standorts\FIRMA-STANDORT

Starting test: Replications

......................... FIRMA-STANDORT passed test Replications

Starting test: NCSecDesc

......................... FIRMA-STANDORT passed test NCSecDesc

Starting test: NetLogons

[FIRMA-STANDORT] An net use or LsaPolicy operation failed with error 5

etzwerkpfad wurde nicht gefunden..

......................... FIRMA-STANDORT failed test NetLogons

Starting test: Advertising

Fatal Error:DsGetDcName (FIRMA-STANDORT) call failed, error 1722

The Locator could not find the server.

......................... FIRMA-STANDORT failed test Advertising

Starting test: KnowsOfRoleHolders

......................... FIRMA-STANDORT passed test KnowsOfRoleHolder

Starting test: RidManager

Failed with 8481: Bei der Suche konnten keine Attribute aus der

nk abgerufen werden.

Could not get Rid set Reference :failed with 8481: Bei der Such

n keine Attribute aus der Datenbank abgerufen werden.

......................... FIRMA-STANDORT failed test RidManager

Starting test: MachineAccount

***Error: The server FIRMA-STANDORT is missing its machine account. T

running with the /repairmachineaccount option.

* The current DC is not in the domain controller's OU

* FIRMA-STANDORT does not have computer as its objectClass

Failed with 8481: Bei der Suche konnten keine Attribute aus der

nk abgerufen werden.

Could not open pipe with [FIRMA-STANDORT]:failed with 53: Der Netzwerk

de nicht gefunden.

Could not get NetBIOSDomainName

Failed can not test for HOST SPN

Failed can not test for HOST SPN

Failed with 8481: Bei der Suche konnten keine Attribute aus der

nk abgerufen werden.

......................... FIRMA-STANDORT failed test MachineAccount

Starting test: Services

Could not open Remote ipc to [FIRMA-STANDORT]:failed with 53: Der Netz

wurde nicht gefunden.

......................... FIRMA-STANDORT failed test Services

Starting test: ObjectsReplicated

......................... FIRMA-STANDORT passed test ObjectsReplicated

Starting test: frssysvol

[FIRMA-STANDORT] An net use or LsaPolicy operation failed with error 5

etzwerkpfad wurde nicht gefunden..

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...