Jump to content

LAN-Problem - Konfiguration?


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Hallo,

ich habe ein Problem mit meiner Netzwerkinstallation (kleines LAN mit 2x XP Pro und 2x XP Home). Manchmal funktioniert alles bestens, alle Rechner sehen sich und können auf die freigegebenen Laufwerke zugreifen. Dann gibt es wieder Tage, wo gar nichts geht. Schon beim Zugriff auf die Arbeitsgruppe (unter "Netzwerkumgebung" im Windows Explorer) gibt's Probleme: wenn ich die Arbeitsgruppe anklicke, kommt nach endlos langer Zeit die Meldung "Auf <Arbeitsgruppe> kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung [...] Die Liste der Server in dieser Arbeitsgruppe ist zurzeit nicht verfügbar."

Was mich irritiert, ist die Tatsache, dass ich nicht einmal meinen eigenen Rechner, auf dem ich mich gerade befinde (XP Pro), angezeigt bekomme. Selbst wenn alle anderen Rechner physikalisch ausgeschaltet sind. Irgendwie scheint es damit zusammenzuhängen, wie viele oder welche Rechner im Netz gerade eingeschaltet sind und laufen. Möglich wäre auch, dass der XP-"Bildschirmschoner" (mit Passwortabfrage beim Reaktivieren) auf dem zweiten XP Pro Probleme macht.

Es gibt auch noch die Variante, dass nach endlos langer Zeit die Rechner der Arbeitsgruppe angezeigt werde. Zur allgemeinen Überraschung aber oftmals auch die Rechner, die bereits abgeschaltet sind.

Fakten:

Die Rechner sind völlig unterschiedlich in Betrieb; mal sind alle 4 an, mal nur einer oder zwei.

Die beiden XP Pro laufen NICHT unter Administrator-Rechten; bei den beiden XP Home gibt es nur Admin-User.

Firewalls sind deaktiviert (XP -3x) bzw. werden bei Problemen als erstes ausgeschaltet (Keerio -1x).

IP-Adressen sind fix, DHCP ist aus. LMHOSTS wird nicht verwendet. NetBIOS over TCP/IP = Standard.

Internet funktioniert, läuft über Hardware-Router (als Gateway eingetragen, ist gleichzeitig Switch).

 

Hat irgendjemand eine Idee? Vielleicht gibt's auch irgendwo eine Doku, in der die LAN-Konfiguration mit allen Tücken und Fallen gut beschrieben ist. Was ist z.B. das Primäre und das Verbindungsspezifische DNS-Suffix? (auf meinem Rechner leer) Wozu brauche ich das, wo stelle ich es ein? Was ist der Knotentyp? (auf meinem Rechner "unbekannt") Was sollte da drinstehen? (Alle Angaben aus ipconfig) Welche Häkchen sollte ich in der TCP/IP-Einstellung setzen und welche Auswirkungen hat das? Was ist der QoS-Paketplaner? Brauche ich den? Und so weiter und so fort ....

Ich weiss, das sind ziemlich viele Fragen auf einmal. Vielleicht fängt irgendwer einfach mal irgendwo an .... ich wäre echt dankbar!

Link to comment

Hi szech

 

ich tippe auf eine deffekte Netzwerkkarte oder Kabel

 

Primäre und das Verbindungsspezifische DNS-Suffix brauchst Du nicht.

 

Schau doch mal bei:

http://www.elektronik-kompendium.de/sites/net/0901051.htm

dort die suche benutzen (QOS)

oder bei

http://www.netzmafia.de/skripten/index.html

dort die Glossare, RFCs bzw einfürung in computernetze

(haben leider keine vernünftige suche

 

gruß fossib

Link to comment

Ich würde darauf tippen, dass dieses Verhalten mit dem Masterbrowser zusammenhängt. In einem Windows-Netzwerk wird ein Rechner zum Masterbrowser erkoren, der dann die Infos über derzeit im Netz vorhandene Rechner vorhält und aktualisiert. Dies ist in der Regel der Rechner mit der neuesten Windows-Version und der besten Hardware-Ausstattung.

 

Wenn der Masterbrowser abgeschaltet wird, wird ein neuer Masterbrowser gesucht und dann kann es einige Zeit lang zu Problemen mit den Anzeigen in der Netzwerkumgebung kommen. Direkter Zugriff auf Ressourcen angeschalteter Rechner sollte aber unabhängig vom Masterbrowser möglich sein, z. B. über UNC-Pfade.

 

Es muss wohl auch eine Möglichkeit geben, einen Rechner über einen Registry-Eintrag dauerhaft zum Masterbrowser zu machen. Vielleicht weiss hier jemand Rat.

Link to comment

Hallo und fröhliche Weihnachten,

 

Masterbrowser einer Arbeitsgruppe wird ein Rechner aufgrund eigener Erklärung, wenn er nach dem Starten der Netzwerkverbindung im Netzwerk keinen anderen Masterbrowser findet.

Der Masterbrowser ist also ein Dienst, der normalerweise aufgrund einer Prüfung automatisch startet. Nun gibt es Programme, die dafür gedacht sind, Rechner weniger angreifbar zu machen und sogenannte überflüssige Dienste abschalten.

 

Benutze doch die Boardsuche! Das Thema wird x-mal behandelt worden sein.

 

Gruß

Edgar

Link to comment

Hallo,

 

danke erstmal für euere Antworten! Die Sache mit dem masterbrowser scheint mir schon irgendwie problematisch: wir brauchen hier ein Netzwerk, in dem völlig unverhersehbar und in beliebiger Reihenfolge mal z.B. nur Computer A an ist, dann Computer B dazukommt, dann B und C und D an sind, dann nur D undsoweiterundsofort - ihr versteht was ich meine? Der masterbrowser bzw. die Suche danach würden das Ganze doch von vorneherein zum Scheitern verurteilen, denn diese Rolle würde ja ständig wechseln bzw. der einmal "erkorene" masterbrowser wäre plötzlich nicht mehr da, weil abgeschaltet - oder sehe ich das falsch? Ist dann nicht vielleicht doch die Verwendung von lmhosts angebracht? Welche Konsequenzen hätte das dann? Müsste/könnte/sollte ich dann WINS und DNS abschalten? Was ist (oder war?) überhaupt der Unterschied zwischen hosts und lmhosts?

 

Weihnachtliche Grüsse

szech

 

PS Wie erkenne ich, ob auf einem Rechner dieser masterbrowser-Dienst läuft?

Link to comment

Der Masterbrowser ist kein eigenständiger Dienst den man an- und abschalten kann. Er hängt zusammen mit dem Arbeitsstation- und Serverdienst von Windows.

 

Um herauszufinden auf welchem Rechner der Masterbrowser läuft kann man das Kommando nbtstat -a <i>hostname</i> verwenden. Wenn der Masterbrowser auf dem Rechner <i>hostname<i/> läuft ist ein Eintrag in der Form ..__MSBROWSE__. zu sehen.

 

hosts ist für DNS-Auflösung zuständig, lmhosts für Netbios-Auflösung. DNS oder WINS muss bei Verwendung von hosts oder lmhosts nicht abgeschaltet werden, da diese Dateien zuerst ausgewertet werden. Allerdings dürfte es in dem geschilderten Netzwerk ohnehin keinen DNS- oder WINS-Server geben?

 

Wenn kein Computer dauerhaft angeschaltet ist, wird es wahrscheinlich immer Phasen geben in denen es Probleme mit dem Masterbrowser gibt.

 

Aber wie bereits erwähnt sollte der Zugriff auf Ressourcen (Netzlaufwerke, Drucker, etc.) unabhängig vom Masterbrowserdienst funktionieren, wenn die Ressouren verfügbar sind. Warum also nicht einfach per Verknüpfung oder Batch-Datei diese Ressourcen bei Bedarf einbinden?

Link to comment

Hallo,

 

wie kann man Abhilfe schaffen? Ranger beschrieb schon , dass Verwenden von Verknüpfungen und Netzlaufwerken ist möglich. Weiter könnte Suchen Computer benutzt werden. Beides hat natürlich seine Grenzen; die Benutzer werden bei der produktiven Arbeit behindert. Letztendlich ist in solch einer Umgebung doch das Einrichten eines Servers anzudenken.

 

Gruß

Edgar

Link to comment

Hallo und ein gesegnetes neues Jahr miteinander,

 

@ pdietrich:

was hat NAV damit zu tun? Ich habe auf einem Rechner den Anti-Virus von Kasperkski laufen, auf den anderen den NAV.

Fehlender Masterbrowser kein Problem: könntest du das bitte mal näher erklären? Was meinst du mit "fehlend" - momentan oder generell? Kein Problem wofür? Wie hast du dein LAN konfiguriert?

 

Trotz einiger Rumleserei habe ich immer noch ein paar Probleme mit dem "Gesamtüberblick". Sind folgende Aussagen richtig:

1) Für ein Netzwerk mit Domänenserver ist DNS zuständig. Habe ich kein solches, brauche ich bei TCP/IP-Konfiguration keinen Eintrag unter DNS (im Moment steht dort mein Router, und zwar sowohl unter "allgemein" als bevorzugter DNS-Server als auch unter "erweitert", Reiter "DNS" - das sollte ich wohl löschen, oder?). Auch die Pflege der Datei hosts ist dann auf jeden Fall überflüssig.

Der DNS meines Internet-Providers spielt in einer anderen Liga und hat hiermit nix zu tun.

2) Für ein Netzwerk mit Arbeitsgruppen ist NetBios zuständig - wofür ist dann WINS da?? Ich dachte bisher, ebendafür! Logo brauche ich dann auch NetBios over TCP/IP - das sollte nicht deaktiviert sein. Falls gewünscht, kann ich die Datei lmhosts verwenden. (Stimmt der Pfad: C:\WINDOWS\system32\drivers\etc ?)

3) Es geht aber doch irgendwie auch ohne NetBios, oder? Wie?

4) Welche Rolle spielt active directory in diesem Zusammenhang?

 

Übrigens: nbtstat bringt auf meinem Rechner eine Fehlermeldung: "Fehler beim Zugriff auf NetBT-Treiber - NetBT ist möglicherweise nicht geladen".

Im Augenblick sind drei Rechner im LAN, auf alle drei besteht Zugriff. So sollte es immer sein!

 

Vielen Dank für eure Hilfe!

Link to comment

Hallo szech,

 

NAV war in meinem Netz die Ursache dafür das ich hin und wieder keinen Zugriff auf Rechner hatte. Komischerweise war aber fast immer nachdem mein Rechner neu gestartet war mindestens 1 einwandfreier Zugriff möglich.

"... Sie haben eventuell keine Berechtigung ..." dies war ansonsten die Standardfehlermeldung. Nach vielen Versuchen hat sich dann NAV2005 als Ursache herausgestellt. Da ich seit der Installation von NAV2005 schon andere Problem z.B. mit großen ZIP-Files hatte die den Scanner zum Absturz brachten war der Umstieg auf einen anderen Scanner schon geplant. Ich habe also Umgestellt und nicht lange eruiert was die Ursache hierfür war. Nach Deinstallation von NAV war jedenfalls sofort alles i.O. und auch der neue Scanner macht keinen Ärger.

 

Masterbrowser, hier wechselt auch im normalen Betrieb evtl. der Rechner der diese Liste führt. Das hat aber keine Auswirkung darauf mit anderen Rechnern in Kontakt treten zu können. Vielleicht dauert es etwas länger, aber in einem Heimnetz wird das wohl niemand spüren. Die "alten" Rechner die im Netzwerk angezeigt werden, aber schon ausgeschaltet sind, kommen von dieser Liste. Ist aber ganz normal. Die Aktualisierungszeit beträgt mehrere Minuten (? 12 ?).

 

Mein Netz:

 

Router

- XP Pro 1

- XP Pro 2

- XP Pro 3

- Switch

- - Accesspoint

- - - Laptop

- - sporadisch verschiedene Rechner

 

An einem Router mit DHCP und integriertem 4fach Switch hängen 3 XP Pro Rechner und es geht weiter zu einem weiteren Switch an dem ich per WLAN mein Laptop ins Netz bringe und hin und wieder einen Testrechner anschließe. Alle beziehen ihre Adressen per DHCP und haben eine gemeinsame Arbeitsgruppe. Firewall ist die Agnitum Outpost V2.5, neuer Virenscanner ist der Bitdefender V8. Das wars. Ganz primitiv und dennoch funktioniert alles immer einwandfrei seit NAV weg ist. Hat allerdings auch mit einer alten Version von NAV (2003) problemlos funktioniert.

Meine Rechner sind ebenfalls wie bei Dir nicht ständig in Betrieb, es ist mehr oder weniger ein ständiges kommen und gehen.

 

:-)

Peter

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...