Jump to content
Sign in to follow this  
domi974

Verständnisfrage zu Gruppenrichtlinien

Recommended Posts

Hallo @all,

 

ich hab eine Verständnisfrage zu GPOs im Allgemeinen.

 

Wenn ich Richtlinien für beispielsweise die OU Benutzer anlegen will, soll ich für jede Richtlinie eine eigene GPO erstellen, oder die ganzen Einstellungen in EINER GPO machen, wenn diese für ALLE User in der OU gelten sollen?

 

Ich kann mich noch sehr genau an die Worte meines Trainers für den MCP erinnern. Er mahnte uns eindringlich für jede Gruppenrichtlinie eine eigene GPO zu erstellen und diese entsprechend den Pfad zu benennen, damit man die Richtlinien auch wieder finden kann. Nun... ich finde diese Vorgehensweise eher umständlich und unübersichtlich. Je mehr Richtlinien man erstellt, desto mehr GPOs hat man und dann ich welcher Reihenfolge etc.

 

Eine weitere Frage: Wenn ich mehrere Software für Computer verteilen will (OU in der die Rechner drin sind, klar) muss / soll ich für jede Softwareverteilung eine eigene GPO erstellen, oder alle in eine GPO packen? Ich habe eine kleine Domäne mit 11 Clients und die Software kriegen entweder alle, oder keiner.

 

Nun zu meinem Problem und der daraus resultierenden Fragestellung:

 

Testumgebung mit W2K AD, DNS, DHCP, etc. und XP Clients. Die adm Dateien habe ich von einem W2K3 Server.

 

Ich wollte ursprünglich nächste Woche ein XP Rollout auf neue Rechner durchführen. Mein Ziel: Die Clients werden per RIS mit XP installiert und die restliche Software wird dann per GPO und Scripten installiert. Einfach alles automatisiert. An RIS anmelden, Installation auswählen und Käffsche trinken gehen. Nach einer halben Stunde ist der Rechner einsatzbereit.

 

Die Installation per GPO und Scripten hat auch einwandfrei funktioniert. Ich habe einen XP Client der in der OU WKS ist und habe nacheinander eine GPO mit einer Softwareverteilung eingerichtet. Hat funktioniert. Danach wollte ich einen Testlauf machen und habe den Client per RIS neu aufgesetzt. Als er mit der XP Installation fertig war und XP das erste mal normal gestartet ist, haben die Probleme angefangen. Keine einzige Software wurde installiert, alle abgebrochen mit der Fehlermeldung: Schwerwiegender Fehler. Die Meldung kenn ich. Keine Zugriffsberechtigung auf die Installationsresourcen. Allerdings habe ich nichts an den Berechtigungen des Installationsordners geändert! :confused::confused::confused:

 

Ich wie bl... wieder gegoogelt, aber nix gefunden, was ich nicht schon wusste... der Client lief weiter. Nach ca. 10-15 Minuten hab ich die Kiste durchgebootet (Client) und siehe da plötzlich installiert er die komplette Software..... :confused:

 

Ich peil das einfach nicht... das einzige was ich geändert hatte, war das ich die OU in eine andere OU verschoben hatte (die hat keine GPOs), aber BEVOR ich RIS gestartet habe. Die GPOs wurden auch alle "mitgenommen" (vorher überprüft).

 

Hab ich was übersehen, hab ich die Richtlinien falsch erstellt, soll ich alle Richtlinien und alle Software in jeweils einer eigenen GPO reinpacken?

 

Bin so ziemlich verzweifelt... wenn das so weitergeht wird das nix mit nächster Woche und ich steh mit dem Rücken an der Wand *verzweifelsei :cry::cry::cry:

 

Bin für jede Antwort dankbar!!

 

PS: http://www.gruppenrichtlinen.de hab ich mir aufmerksam aber ohne Erfolg durchgelesen...

Share this post


Link to post

Hallo,

Wenn ich Dich richtig verstehe hat die Installation mit Ris geklappt und nach einem erneuten booten auch die Softwareinstallation. Wenn dies bei mehreren Rechnern der Fall ist, finde ich es nicht so problematisch.

Alternativ könntest Du ja auch einen Rechner ausetztn, dann die Software drauf installieren und dann ein Risimage machen und Os plus Sotware installieren.

Die Fragen zu den Gruppenrichtlinien finde ich sind Geschmacksfragen. Wenn alle Clients die gleichen Einstellungen bekommen spricht nichts dagegen das in einer Richtlinie zu tun.

Gruss

MaTzu

Share this post


Link to post

Hallo,

 

erstmal danke für die schnelle Antwort :)

 

Jain... Nach dem ersten Starten des Clients gleich nachdem RIS fertig ist, wird die Software nicht installiert und bricht mit o.g. Fehlermeldung ab. Die Clients werden gleich in die OU WKS gepackt, wo die Softwareverteilung ist, ergo greifen die Richtlinien auch sofort. Die Software wird aber erst nach ca. 10 Minuten installiert... Anfangs scheint es so, als habe der PC keine Berechtigung auf das Installationsverzeichnis zuzugreifen.... Die "Authentifizierten Benutzer", welche ja auch die Rechner beinhalten haben allerdings Leserecht auf das Verzeichnis, was ja auch ausreicht.

 

Das mit dem RIS Image wollte ich nicht machen, weil Images nicht wirklich eine lange Lebensdauer (von der Aktualität her) haben. Das Problem haben wir mit Ghost beispielsweise. Ich wollte saubere OS haben, die ich dann in Zukunft mit neuerer Software installieren kann. (Rechner putt, z.B.)

 

Wenn nichts dagegen spricht (GPOs), werde ich das wohl so machen, danke :)

 

Eine Frage hab ich noch: Die GPOs werden doch der Reihe nach, also von oben nach unten ausgeführt, richtig? Ich meine jetzt in der OU nix mit Vererbung, oder so. Was mir nämlich aufgefallen ist, der Client wollte die Software in umgekehrter Reihenfolge installieren. Also unter OU --> Eigenschaften --> Richtlinie habe ich Installation Adobe, Installation Java2, Installation O2K3, aber er hat als erstes mit der Office Installation angefangen. Hat das seine Richtigkeit? Das Startscript, was ganz oben steht, wurde beispielsweise als letztes ausgeführt?

 

Hoffe ich hab mich klar ausgedrückt :)

Share this post


Link to post
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte überlege Dir, ob es nicht sinnvoller ist ein neues Thema zu erstellen.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...