Jump to content

DVD-ROm nur im PIO-Modus


Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Recommended Posts

Also, ich habe da folgendes Problem. Ich habe seit geraumer Zeit Windows XP installiert und es lief eigentlich alles einwandfrei.

 

Ich war dann jedoch so mutig ein etwas altertümliches Spiel zu installieren, welches wohl mit Win XP nicht so richtig gut konnte. Es kam nicht häufiger zu gnadenlosen Systemabstürzen.

 

Seit dieser Zeit erkennt Win XP nicht mehr, dass bei dem Gerät 1 (DVD-Rom) an meinen primären ÍDE-Kanal DMA als Übertragunsmodus möglich ist. Stattdessen wird lediglich der PIO-Modus akzeptiert.

 

Der Spass am DVD gucken ist doch erheblich vermindert, wenn die Akteure nur noch durch das Bild "rappen" und man ständig einsekündige Standbilder hat.

 

Ich hoffe irgendjemand hier kann mir eine Möglichkeit nennen das Probelm zu beheben ohne gleich sämtliche Geräte an den IDE-Kanälen zu tauschen.

 

Ein Freund meinte, dass man durch das Löschen eines "falschen" Eintrags in der Win XP Reg. dies reparieren könnte. Wäre nett, wenn mir nun noch jemand veraten würde wie man das macht .

 

Danke schonmal im vorau.

 

Kozolov

Link to comment

Das mit dem Gerätemanager habe ich schon probiert. E lässt sich dort zwar einstellen, dass DMA (wenn möglich) benutzt werden soll, jedoch wird nur der PIO-Modus aktiviert.

Allerdings funktionierte DMA vor den Abstürzen noch. Es sieht so aus, als hätte WIN XP irgendwo irgendetwas falsches intern abgespeichert.

Link to comment

Gut, dann sind wir schon ein stückchen weiter.

 

Windows xp hat da ein tooles neues feature ;)

Wenn auf einem dma-gerät über einige zeit lesefehler passieren, dann schaltet es auf pio runter :rolleyes:

 

For repeated DMA errors.

Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.

In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.

Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).

If the mini-IDE driver for the device does not support stepping down transfer modes, or if the device is running UDMA mode 0, Windows XP will step down to PIO mode after encountering six or more CRC errors. In this case, a system reboot should restore the original DMA mode settings.

All CRC and timeout errors are logged in the system event log. These types of errors could be caused by improper mounting or improper cabling (for example, 40-pin instead of 80-pin cable). Or such errors could indicate imminent hardware failure, for example, in a hard drive or chipset.

 

http://www.microsoft.com/hwdev/tech/storage/IDE-DMA.asp

 

Wenn Du das Laufwerk kurzzeitig abklemmst, bootest und danach wieder einsteckst und hochfährst, könnte es wieder klappen.

 

Falls nicht, kannst Du den ide kanal deinsten, dann wird er beim neustarten wieder erkannt und installiert.

 

Hier die Quelle zu der info: http://www.overclockers.com/tips839/

 

Mag lästig sein, aber XP versucht sicherzustellen, daß keine korrupte daten entstehen.

 

Hoffe Dir geholfen zu haben :)

Link to comment
  • 2 months later...
  • 2 weeks later...

@Zapnduster

 

Hallo,

habe ähnliches Problem, nur habe ich im Gerätemanager gar keine Auswahl ob DMA oder PIO.

Habe Primären IDE deinstalliert und neu gebootet, aber nichts passiert.

Wie ist das mit dem "Gerät abklemmen", es betrifft bei mir die Festplatte, unnter laufenden Betrieb oder wie ?

Problem tauchte nach diesem crash auf

http://www.mcseboard.de/showthread.php?threadid=4419&perpage=10&pagenumber=1

Danke

Link to comment
Der letzte Beitrag zu diesem Thema ist mehr als 180 Tage alt. Bitte erstelle einen neuen Beitrag zu Deiner Anfrage!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...