Jump to content

RDP Verbindung wird immer erst beim zweiten Mal aufgebaut


Recommended Posts

Moin,

ich folgendes Phänomen bei einigen Sprungservern, wo ich mich mit RDP raufwähle um mich von dort auf andere Server zu verbinden.

Korrektur: es sind 2 verschiedene Fehler, die auftreten. Bei einem 2012 der zweite, bei 2 2019 der erste.

 

Fehler 1:

Die RDP Connection wird initiiert und ich gebe die Login Daten ein

Nach ca. 90 Sekunden kommt die Meldung "an internal error has occured"

Wenn man dann erneut Verbinden drückt funktioniert es wunderbar.

 

Fehler 2:

Die RDP Connection wird initiiert und ich gebe die Login Daten ein

Nach ca. 90 Sekunden kommt die Meldung der Computer kann keine Verbindung zum Remote Computer aufbauen

Wenn man dann erneut Verbinden drückt funktioniert es wunderbar.

 

Jemand eine Idee dazu?

Gruß DO

Edited by Dutch_OnE
Link to post

Das kommt mir bekannt vor. Gibt wohl verschiedene Ursachen. Ich tippe auf inkompatible  Sicherheitshandles oder ähnliches. Beim zweiten Versuch wird dann wohl eine andere Variante genommen oder die Handles zwischen den Maschinen bestehen schon. Habe ich vermehrt in eher stärker gesicherten Maschinen bemerkt, also z.Bsp. mit durchkonfigurierten Windows-Firewalls (Out). Da es mit dem zweiten Versuch immer klappt und eigentlich nur Admin-Konsolen und keine User-Konsolen betraf, hatte ich noch nicht die Lust das wirklich im Detail genauer anzuschauen.

Oft klappts übrigens wenn man selber abbricht und wieder versucht zu verbinden. Auch schon konnte ich es mit dem aktualisieren von Zertifikaten oder RDP-Clients lösen. =)

 

Ansonsten aktiviere ich bei Verbindungsprolemen jeweils das Securitiy-Auditing der Windows-Filter-Engine. Da kommt man dem Ärger sehr oft auf die Schliche. Zusammen mit tasklist / netstat kriegt man die jeweiligen Prozesse raus. Damit kann man dann weitergraben.

 

Deutsch: auditpol.exe /set /category:"Objektzugriff" /subcategory:"Filterplattform: verworfene Pakete" /success:enable /failure:enable

Sprachübergreifend: auditpol.exe /set /category:"{6997984A-797A-11D9-BED3-505054503030}" /subcategory:"{0CCE9225-69AE-11D9-BED3-505054503030}" /success:enable /failure:enable

 

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...