Jump to content
Agrarstudent

selber vom RDS ausgesperrt

Recommended Posts

Hallo zusammen,

 

eben ist mir wieder mal so etwas dämliches passiert. Ich war als Admin am RDS meinens Windows Server 2012 R2 angemeldet und habe in der Eingabeaufforderung die Befehle "change logon /disable" und change user /install" ausgeführt. Dann habe ich versucht Visio 2016 Pro zu installieren was eine Katastrophe ist weil ich schon mein bestehendes Office deinstallieren soll... Habe da rumgeeiert um das mit entsprechenden Microsoft Tools zu umgehen und plötzlich wurde die RDS-Verbindung unterbrochen. Jetzt kann ich mich nicht mehr am RDS anmelden und bekommen die nette Info "remoteanmeldungen sind momentan nicht möglich". Habe schon einiges probiert wie Logon auf dem DC und auf dem HyperV zu aktivieren selbst ein kompletter Neustart des Server, aber nichts hilft.

 

Kann mir jemand erklären, wie ich mich wieder als Admin auf den RDS anmelden kann.  Wäre wichtig, da sonst keiner mehr in der Firma arbeiten kann.

Danke für schnelle Hilfe und bleibt gesund.

 

Gruss

Share this post


Link to post

Hi,

 

wenn der RDS als VM auf dem HyperV Host läuft, dann kannst du dich doch im HyperV Manager am RDS anmelden. Ggfs. musst du dann aber den erweiterten Sitzungsmodus deaktivieren bzw. nicht nutzen.

 

Wenn der RDS auf einem physikalischem Host läuft dann wirst du über KVM over IP / iDRAC / iLO / o.ä. auf die Konsole kommen. Eine weitere Möglichkeit könnte Teamviewer und Co. sein, sofern installiert. Notfalls bleibt hinfahren. ;)

 

Gruß

Jan

Share this post


Link to post
vor 16 Minuten schrieb testperson:

wenn der RDS als VM auf dem HyperV Host läuft, dann kannst du dich doch im HyperV Manager am RDS anmelden. Ggfs. musst du dann aber den erweiterten Sitzungsmodus deaktivieren bzw. nicht nutzen.

 

Fernwartung geht nicht und über den HyperV am RDS anmelden führt zur gleichen netten Info. Wo kann ich den erweiterten sitzungsmodus deaktivieren?

 

vor 21 Minuten schrieb Agrarstudent:

Fernwartung geht nicht und über den HyperV am RDS anmelden führt zur gleichen netten Info. Wo kann ich den erweiterten sitzungsmodus deaktivieren? 

ok gerade mal Dr. GOOGLE gefragt! Fündig geworden im HyperV Manager siehe Bild im Anhang, Haken aus --> rechtsklick auf den RDS und neustarten --> dann über Remotedesktopverbindung als Admin anmelden und in der Eingabeaufforderung "Change logon /enable" --> abmelden --> im HyperV Manager siehe Bild im Anhang, Haken wieder rein --> rechtsklick auf den RDS und neustarten

 

Problem mit dem Aussperren gelöst. Danke @testperson

Schöne Feiertage, trotz Corona.

 

HyperV Manager.JPG

Share this post


Link to post

Tipp für die Zukunft: verwende change logon /drain - so sperrst du dich nicht selber aus, aber neue Anmeldungen werden abgelehnt :-)

Share this post


Link to post
vor 56 Minuten schrieb Nobbyaushb:

Tipp für die Zukunft: verwende change logon /drain - so sperrst du dich nicht selber aus, aber neue Anmeldungen werden abgelehnt :-)

Hilft aber nur wenn man die Sitzung trennt. Sollte man sich abmelden hilft auch bei "/drain" nur die Konsole (und kein Reboot). Mit "/drainuntilrestart" würde auch ein Reboot helfen. :)

  • Like 1

Share this post


Link to post
vor 1 Stunde schrieb testperson:

Hilft aber nur wenn man die Sitzung trennt. Sollte man sich abmelden hilft auch bei "/drain" nur die Konsole (und kein Reboot). Mit "/drainuntilrestart" würde auch ein Reboot helfen. :)

Danke Jan!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...