Jump to content
Seppim

[gelöst] WireGuard einrichten

Recommended Posts

Hallo,

 

nach einem Tipp hier im Forum beschäftige ich mich mit WireGuard. Eigentlich würde es funktionieren, aber die Clients sehen sich untereinander nicht.

Ich habe einen Server und 2 Clients:

Server:

[Interface]
PrivateKey = ***
Address = 10.11.12.254/32
ListenPort = 8999

[Peer]
PublicKey = ***
AllowedIPs = 10.11.12.1/32

[Peer]
PublicKey = ***
AllowedIPs = 10.11.12.2/32

Client 1:

[Interface]
PrivateKey = ***
Address = 10.11.12.1/32

[Peer]
PublicKey = ***
AllowedIPs = 10.11.12.0/24
Endpoint = 192.168.0.189:8999
PersistentKeepalive = 25

Clilent 2:

[Interface]
PrivateKey = ***
Address = 10.11.12.2/32

[Peer]
PublicKey = ***
AllowedIPs = 10.11.12.0/24
Endpoint = 192.168.0.189:8999
PersistentKeepalive = 25

 

Ausgabe von wg:

Warning: one or more unrecognized netlink attributes
interface: wg0
  public key: ***
  private key: (hidden)
  listening port: 8999

peer: ***
  endpoint: 192.168.0.217:59618
  allowed ips: 10.11.12.1/32
  transfer: 308 B received, 92 B sent

peer: ***
  endpoint: 192.168.0.38:50129
  allowed ips: 10.11.12.2/32
  transfer: 2.61 KiB received, 188 B sent

 

Zum testen sind alle 3 am selben Switch im lokalen Lan.

 

Ich kann vom Server alle 2 Clients pingen

Auch kann ich von den Clients den Server pingen

 

Abe die Clients haben unter einander keine Verbindung

edit:

 

klappt nun ... net.ipv4.ip_forward=1 war nicht aktiv

Edited by Seppim
  • Thanks 1

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...