Jump to content
J.P.Endress

Windows Server 2019 Terminalserver hängt zeitweise

Recommended Posts

Hallo miteinander,

ich habe ein Problem mit einem Windows Server 2019 der als Terminalserver läuft. Kein AD aber hängt in einer Domäne.

 

in unregelmässigen Abständen hängt der Server regelrecht, Arbeiten ist fast nicht mehr möglich. Leider konnte ich das Problem noch nicht live erleben, deswegen kann ich nichts zu Prozessen sagen, die vielleicht das Problem verursachen.

 

Den Windows Defender habe ich deaktiviert aber das Problem tritt trotzdem noch auf. 

 

Im Ereignisprotokoll kann ich keine Fehlermeldungen entdecken.

 

Hat jemand irgendeine Idee, was ich noch versuchen könnte ?

 

Share this post


Link to post
Share on other sites

Ich durfte heute dieses Verhalten live beobachten:

 

Die Remotesitzung friert komplett ein. Eine gleichzeitig etablierte Sitzung als Admin zeigte keine Prozessor / Speicher / etc etc Last an und läuft einwandfrei.

 

Ich kann so nichts diagnostizieren und weiss langsam nicht mehr weiter.

Der User Input Delay bringt mich bei dem Problem überhauptnicht weiter, weil einfach kein Input mehr möglich ist...

Share this post


Link to post
Share on other sites

Hi,

 

wo steht denn der Server, wo der Client und was ist alles dazwischen?

Was ist das für ein Client? Läuft auf dem Client etwas, was evtl. den Client auslastet?

 

Gruß

Jan

Share this post


Link to post
Share on other sites

Wieviele Sessions verarbeitet denn der Server zum Zeitpunkt des  Lag's ? 

Wie hoch ist die RAM-Auslastung innerhalb der virtuellen Maschine - und: hat der ESX die Ressourcen (incl. Storage), den TS performant im Netz bereitzustellen?

 

 Wenn der Lag aufschlägt, sind dann weitere User betroffen - oder nur Einzelne? 

Zitat

Die Remotesitzung friert komplett ein. Eine gleichzeitig etablierte Sitzung als Admin zeigte keine Prozessor / Speicher / etc etc Last an und läuft einwandfrei.

 

Wurden, bevor es zu den Störzeiten kam, evtl. Updates, Druckertreiber oder Software installiert?

 

So auf die Schnelle wären das mal meine ersten Ansatzpunkte, um die Ursache für den sporadischen Lag zu finden.

Als Nächstes wäre dann das Monitoren angesagt: Server, betroffene User, Zeitpunkte der Lag's.

 

Viel Erfolg!

Share this post


Link to post
Share on other sites

1 Session, es arbeitet derzeit nur ein User auf der Maschine

Der Server hat 32 GB zur Verfügung, nagelneuer Dell Server, Raid Controller kann ich gerne nachsehen, aber das ist in meinen Augen nicht das Problem, weil:

Es laufen 3 virtuelle Maschinen auf dem ESXi, und die laufen alle perfekt.

Es liegt nicht an der Performance, oder dem Speicher etc. Ansonsten würde eine zweite Sitzung auf dem selben Server nicht laufen wie geschmiert.

 

Das Monitoring ist entweder nicht sehr hilfreich, das Microsoft verbaut hat, oder ich kann es nicht bedienen. DIese Leistungsaufzeichnung zeichnet immer genau 60 Sekunden auf, davon hab ich natürlich garnichts.

 

Die Maschine ist frisch installiert worden und bei den ersten Tests traten diese Probleme auf, sporadisch, unabhängig von Updates nicht reproduzierbar.

 

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...