Jump to content
Gu4rdi4n

Windows 10 Iso ohne .net 4.8

Recommended Posts

Hi,

 

das kannst du mit DISM erledigen.

  1. Mounten
  2. Paket entfernen
  3. Dismount mit Übernahme der Änderungen
  4. Als "install.wim" umbenennen und in das Installationsmedium packen
  5. Fertig

Share this post


Link to post
Share on other sites

So sah das bei mir aus. Es geht.

PS C:\_DEV> dism /image:"C:\_DEV\Win10Mount" /disable-feature /featurename:NetFx4-AdvSrvs

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.18362.1

Abbildversion: 10.0.18362.30

Features werden deaktiviert
[==========================100.0%==========================]
Der Vorgang wurde erfolgreich beendet.

 

Share this post


Link to post
Share on other sites

Also ich hab Windows 10 auf einem Stick

dism /image:"Q:\" /disable-feature /featurename:NetFx4-AdvSrvs

 

 

Da kommt das:

C:\Windows\system32>PowerShell -Command  Mount-DiskImage  -ImagePath  "Q:\Windows.iso"

C:\Windows\system32>dism /image:"I:\" /disable-feature /featurename:NetFx4-AdvSrvs

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.17134.1


Fehler: 1639

In der Befehlszeile fehlt ein erforderlicher Wartungsbefehl.
Weitere Informationen finden Sie in der Hilfe, indem Sie den Befehl "DISM.exe /Image=<Pfad_zum_Offlineimage> /?" ausführen, wobei <Pfad_zum_Offlineimage> der vollständige Pfad zu einem Windows-Offlineimage ist.

Die DISM-Protokolldatei befindet sich unter "C:\Windows\Logs\DISM\dism.log".

 

Share this post


Link to post
Share on other sites

Machs bitte mit Dism. Dir fehlt auch in der Powershell der Parameter des Index. Des Weiteren kann ich nicht erkennen auf welches Verzeichnis du die WIM (nicht ISO) gemountet hast.

Share this post


Link to post
Share on other sites

Ah ok, ich hatte die Iso gemounted

 

 

C:\Windows\system32>dism.exe /Mount-Wim /MountDir:C:\Temp\wim /wimfile:Q:\sources\boot.wim /index:1

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.17134.1

Abbild wird bereitgestellt
[==========================100.0%==========================]
Der Vorgang wurde erfolgreich beendet.

C:\Windows\system32>dism /image:"C:\Temp\wim" /disable-feature /featurename:NetFx4-AdvSrvs

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.17134.1

Abbildversion: 10.0.18362.239


Fehler: 0x800f080c

Der Featurename "NetFx4-AdvSrvs" ist unbekannt.
Ein Windows-Funktionsname wurde nicht erkannt.
Verwenden Sie die Option "/Get-Features", um den Namen der Funktion im Abbild zu suchen und den Befehl erneut auszuführen.

Die DISM-Protokolldatei befindet sich unter "C:\Windows\Logs\DISM\dism.log".

 

Edited by Gu4rdi4n

Share this post


Link to post
Share on other sites

Ups, der befehl geht wohl anders - moment

 

PS C:\Windows\system32> dism /get-wiminfo /wimfile:Q:\sources\boot.wim

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.17134.1

Details für Abbild: "Q:\sources\boot.wim"

Index: "1"
Name: "Microsoft Windows PE (x64)"
Beschreibung: "Microsoft Windows PE (x64)"
Größe: 1.746.981.055 Bytes

Index: "2"
Name: "Microsoft Windows Setup (x64)"
Beschreibung: "Microsoft Windows Setup (x64)"
Größe: 1.906.681.001 Bytes

Der Vorgang wurde erfolgreich beendet.
PS C:\Windows\system32> dism /image:c:\temp\wim /Get-Features

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.17134.1

Abbildversion: 10.0.18362.239

Featureauflistung für das Paket : Microsoft-Windows-WinPE-Package~31bf3856ad364e35~amd64~~10.0.18362.239

Featurename : SMB1Protocol
Status : Deaktiviert

Featurename : SMB1Protocol-Client
Status : Deaktiviert

Featurename : SMB1Protocol-Server
Status : Deaktiviert

Featurename : WinPE-EnhancedStorage
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-Narrator-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-Narrator-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-ATBroker-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-ATBroker-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-Speech-TTS-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-Speech-TTS-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-Speech-TTS-de-DE-Package
Status : Aktiviert

Featurename : WinPE-SRT
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-AudioCore-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-AudioCore-Package
Status : Aktiviert

Featurename : WinPE-Scripting
Status : Aktiviert

Featurename : WinPE-WDS-Tools
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-AudioDrivers-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-AudioDrivers-Package
Status : Aktiviert

Featurename : WinPE-WMI
Status : Aktiviert

Featurename : WinPE-SecureStartup
Status : Aktiviert

Featurename : WinPE-TPM
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-SRH-Package
Status : Aktiviert

Featurename : Microsoft-Windows-WinPE-SRH-Package
Status : Aktiviert

Der Vorgang wurde erfolgreich beendet.

 

Edited by Gu4rdi4n

Share this post


Link to post
Share on other sites

Dann die ESD mounten. Gleiches Spiel wie mit der WIM-Datei.

 

Das Windows Setup (WinPe - Boot.wim) enthält kein NetFramework 4.8 ;-) Außer du möchtest das als Betriebssystem nutzen :D 

 

PS: Man darf auch Google verwenden und mitarbeiten :aetsch2:

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...