Jump to content
kosta88

SSO O365 mit Azure AD Connect

Recommended Posts

Hallo,

 

ich bin soeben dabei mich bei Azure AD Connect zu informieren, und möchte grundsätzlich bei uns wegen SSO bei Office 365 implementieren.

Unsere interne Domäne (AD) ist internal.company.com, und unsere Office 365 Domäne ist office.company.com. Der einfachste Weg soweit ich gesehen habe, ist den UPN Suffix (office.company.com) in AD einzutragen.

Ich möchte die Umstellung vorerst mit einem Test-Benutzer probieren, daher habe ich den UPN des Benutzer auf office.company.com umgestellt, und bin dabei Azure AD Connect zu installieren.

Ich lese bei MS dass nur die gleichen UPNs gesynct werden, und non-routable mit onmicrosoft-Benutzern (gibts eh keine bei uns). Aber sicherheitshalber die Frage...

 

Kann die Installation von Azure AD Connect bei den normalen Benutzern die noch nicht auf UPN Suffix office.company.com umgestellt wurden Probleme verursachen?

 

Danke

Edited by kosta88

Share this post


Link to post
Share on other sites

Hallo

 

welcher UPN in welchem Format ist aktuell bei den Benutzern eingetragen?

 

Am 13.5.2019 um 07:13 schrieb kosta88:

Kann die Installation von Azure AD Connect bei den normalen Benutzern die noch nicht auf UPN Suffix office.company.com umgestellt wurden Probleme verursachen?

Das und vieles mehr kannst Du mit IdFix prüfen: https://docs.microsoft.com/de-de/office365/enterprise/install-and-run-idfix

Lade das herunter und führe eine Query aus ohne Änderungen durchzuführen.

Share this post


Link to post
Share on other sites

Ich habe die benutzerdefinierte Installation gemacht, nachdem ich bisschen erkundigt habe, was die Sachen tun...

UPN ist (bei Testusern in einer Unter-OU, die gesynct wurde) als vorname.nachname@office.company.com.

Nun ist es zuerst falsch gelaufen, es wurde ein neuer Benutzer in AAD erstellt. Der Grund dafür war, dass der Testuser in O365 Admin war. Den neuen Benutzer gelöscht, heruntergestuft, und nochmal gesynct. Damit hat's dann funktioniert. Im AAD steht auch gesynct aus AD.

 

Aber ich habe jetzt ein weiteres Problem. Alles das habe ich gemacht um Seamless SSO zu haben. Es ist mein Verständnis, dass jede App, bzw. Seite, die die Login-Maske von MS aufruft (das weiße Popup-Fenster mit Microsoft Logindaten), eigentlich sich automatisch einloggen sollte.

Ich habe nach Vorgabe die GP-Einträge, die Benutzer bekommen die GPO, im IE sieht man auch die Einträge, AAD zeigt auch dass SSO aktiv ist, Pass-Through ist aktiv, Pass-Hash ist inaktiv... und es popt auf, und es tut sich nix.

 

Ideen, wie troubleshoote ich das weiter?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


Werbepartner:



×
×
  • Create New...