Jump to content
mus.zah

Windwos SRV16 + NAS Aktualisierung der Domäne möglich?

Recommended Posts

Hallo Allerseits,

 

mein erster Beitrag hier, hoffe Ihr könnt mir weiterhelfen! :)

Ich bin noch am Netzwerk Aufbauen und am Tüfteln, der Server

ist jetzt nur Testseitig und wird noch konfiguriert.

Ich weiß es gibt bessere Lösungen, jedoch möchte ich dies

erstmal alles über den NAS laufen lassen :)

 

Kurz zu meiner Systemumgebung:

-NAS --> Angemeldet in Domäne von Server, Virtualisiert gleichzeitig den Server (sofortiger Start nach Neustart des NAS)

-Windwos Server 2016 --> DC und DNS Server vorerst

-Windows 10 --> Client

 

Mein Problem:

Es läuft alles super, der QNAP hat Zugriff auf den DC und die jeweiligen Nutzer. Wenn ich jedoch

einen Neustart des QNAP mache, dann verliert er die Anbindung zum DC, in den Einstellungen werden

die Computer des Netzwerks erkannt, jedoch keine Benutzer oder Benutzergruppen.

Auch wird der DC in den redundanten DC Einstellungen angezeigt, jedoch ist dieser auf Standby gesetzt. 

(Liegt wohl daran, dass der Server erst nach dem Hochfahren des NAS verfügbar ist)

 

Wenn ich jedoch eine gewisse Zeit warte, ca 1-2 Stunden, dann ist die Verbindung wieder aufgebaut

und es werden alle Benutzer, Gruppen etc angezeigt.

Jetzt ist die Frage welche Einstellungen ich am Server vornehmen muss, um die Aktualisierung der

AD bzw die Verbindung wesentlich schneller zu erneuern?

 

Ich hoffe dass ist alles verständlich :)

 

-Mus.Zah

Edited by mus.zah

Share this post


Link to post
Share on other sites

Hi,

 

was für eine NAS ist das denn? Vermutlich wird der Server einfach nur 1-2 Stunden zum Hochfahren brauchen.

Was möchtest du denn testen bzw. was willst du später erreichen?

 

Gruß

Jan

Share this post


Link to post
Share on other sites

Moin,

wenn der Host Member der Domäne ist, diese aber erst vom Host als VM gestarted werden muss ist das Verhalten völlig korrekt.

(Zum lernen?)

Wenn man sowas produktiv betreiben würde/sollte, empfehle ich einen weiteren DC (oder die VM moven) auf Physik - kann u.U. sogar ein Intel NUC sein.

 

My2Cents

Edited by Nobbyaushb
Typo

Share this post


Link to post
Share on other sites

@testperson 

Es ist ein qnap ts473, der Server hat noch sehr wenig Aufgaben und braucht nicht so lange zum hochfahren. Wenn ich im qnap den domanenzugriff neu einrichte ist ja auch wieder alles okay.. 

 

Möchte im Grund nur paar Sachen für bestimmte Nutzer in unserem KMU einstellen, z.b. Druckserver, bestimmte netzfreugaben und Zugriff auf bestimmte Programme. Der Server macht im Grunde nur die AD und ggf noch dhcp. 

 

@Nobbyaushb

Ja das weiß ich, wäre auch ne Lösung. 

Was mir aufgefallen ist, das oben beschriebene verhalten passiert nur wenn ich dem NAS die GP eines DC gebe. Sonst passiert das nicht...

 

 

Share this post


Link to post
Share on other sites
vor 23 Minuten schrieb mus.zah:

Möchte im Grund nur paar Sachen für bestimmte Nutzer in unserem KMU einstellen, z.b. Druckserver, bestimmte netzfreugaben und Zugriff auf bestimmte Programme. Der Server macht im Grunde nur die AD und ggf noch dhcp. 

Wenn mich nicht alles täuscht, sollte die QNAP diese Dienste (Samba AD, Druckserver, DHCP, Shares, ...) auch ohne virtualisiertes Windows hinbekommen. Dann brauchst du nichtmal Lizenzen und CALs.

Wenn du unbedingt einen Windows Server dafür möchtest, dann mach es doch direkt von Anfang an richtig und nicht so (und produktiv auch nicht mit einem NUC).

Share this post


Link to post
Share on other sites
vor 2 Stunden schrieb mus.zah:
 

Wenn ich jedocheinen Neustart des QNAP mache, dann verliert er die Anbindung zum DC, in den Einstellungen werdendie Computer des Netzwerks erkannt, jedoch keine Benutzer oder Benutzergruppen. Auch wird der DC in den redundanten DC Einstellungen angezeigt, jedoch ist dieser auf Standby gesetzt. 

(Liegt wohl daran, dass der Server erst nach dem Hochfahren des NAS verfügbar ist)

 

Wenn ich jedoch eine gewisse Zeit warte, ca 1-2 Stunden, dann ist die Verbindung wieder aufgebaut und es werden alle Benutzer, Gruppen etc angezeigt.

 

Auf dem QNap muß ein User Mapper laufen, der die Pinguin-UIDs und GUIDs in Windows-SIDs übersetzt und umgekehrt. Damit das klappt, muß der User Mapper beim Start natürlich einen DC erreichen. Wie oft der Mapper das dann erneut versucht, das mußt Du bei QNap herausfinden.

 

Ansonsten wurde alles gesagt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Werbepartner:



×
×
  • Create New...