Jump to content

Empfohlene Beiträge

Hallo zusammen,

 

wir setzen bei uns im internen LAN einen Win Server 2012R2 mit IIS ein. Über diesen wird eine Software für die Fertigung realisiert.

Nun ist diese Software im Moment über die URL http://<Server-Name/Anwendungsname> aufrufbar. Ich möchte aber die Webseite über http://<Anwendungsname> erreichbar machen.

 

Irgendwie stehe ich auf dem Schlauch und ich bin auch kein großer IIS Experte. Ich komme einfach nicht dahinter wie ich das ändern kann (muss man hier über die Bindungen im IIS arbeiten?).

Ein DNS Eintrag (CNAME) von <Anwendungsname> -> <IP des Servers> funktioniert nicht, da dort nur die IIS Seite erscheint. Ich muss die Webseite zwingenden über <Server-Name>/Anwendungsname aufrufen.

 

Kann mir jemand einen Tipp geben, wie ich es hinbekommen?

Im Moment sieht es so aus http://server/meine-Anwendung funktioniert. Ich möchte aber die Seite über http://meine-Anwendung aufrufen können.

 

Vielen Dank schon mal.

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Du kannst eine neue Website erstellen, welche auf das Verzeichnis der Anwendung zeigt und bei den Bindungen den Name der Anwendung enthält. Den CNAME-Eintrag im DNS benötigst Du zusätzlich.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi mwiederkehr,

 

danke dir. Das Problem ist, die Webseite besteht aus 2 Anwendungspools  - kann ich da genau so verfahren?

  • Eine neue Webseite erstellen (die benenne ich wie ich möchte)
  • Dieser Webseite beide Anwendungspools anhängen 
  • Bindung für die neue Webseite erstellen und den gewünschten Namen verwenden
  • DNS Eintrag erstellen

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hi Dukel,

 

danke für den Tip. Ich habe nun für die Default Web Site eine Umleitung festgelegt. Nach einigen Tests funktioniert es jetzt auch.

Ich musste beim Umleitungsverhalten die Option "Anforderungen zu Inhalt in diesem Verzeichnis (nicht in Unterverzeichnissen) umleiten" aktivieren und den Statuscode auf Dauerhaft(301) setzen.

 

Wenn ich den Haken bei der "Anforderungen zu Inhalt in diesem Verzeichnis (nicht in Unterverzeichnissen) umleiten" nicht setze wird die URL mehrmals hinten angehängt und nichts funktioniert.

Aus http://Anwendung wird dann http://server/Anwendung/Anwendung/Anwendung/Anwendung usw.

 

Wenn ich die Hilfe zu der Option richtig versehe, wird die Umleitung dann auch für jede Unterordner angewendet.

 

Verstehe ich jetzt irgendwas komplett falsch oder kann man die Konfig so umsetzen?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

Werbepartner:



×