Jump to content

Empfohlene Beiträge

Hallo zusammen,

 

habe ein Problem mit einem TS Server unter 2016.

Dieser ist als Gateway Server, Connection Broker und RemoteAPPs konfiguriert. Also alle Rollen hat der Server

 

Updates sind alle installiert. Habe im Netz gefunden das solche Probleme bei 2008R2 und 2012R2 aufgetreten sind aber dies durch ein Update behoben werden konnte.

Leider weiß ich gerade nicht weiter und hoffe jemand kennt dieses Problem und hat einen Rat:)

 

Gruß

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

wir haben das gleiche Problem haben den Fehler aber leider auch noch nicht gefunden. Zusätzlich ist uns aufgefallen das "unbekannte Konten" angemeldet sind diese werden als (4) dargestellt. Wenn die Fehlermeldung auftaucht "RDS is busy" können die Leute die angemeldet sind weiterarbeiten jedoch lässt der Fehler keine neuen Anmeldungen zu. Wenn versucht wird den Remotedsektopdienst neuzustarten bleibt er im Status "wird beendet" und anschließend muss der Server neugestartet werden.

 

Leider ist zur Zeit unser Workaround ein Server Neustart.

 

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Auf unserer Umgebung ist kein Mozilla Firefox installiert. Der Server ist aktuell gepatched (Patchstand - 1 Monat). Im Eventlog gibt es keine entsprechenden Meldungen die auf den Fehler hindeuten. Folgende Klassifizierungen werden über einen WSUS abgedeckt (Feature Packs, Sicherheitsupdates, Wichtige Updates).

bearbeitet von Rhyme

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

wieviele Netzwerkkarten haben die Server der beiden TOs bitte?

die Fehlermeldung "RDP is busy" ist bisher alles an Daten?

Irgendwie ein daja vu-thread, gabs dasselbe nicht vor einer Woche oder so?

kenne die Meldung bei Servern mit zuwenig Resourcen, z.B. das Laden eines Profils vom Filer dauert zu lange, diese Richtung

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Standardüberprüfung schon mal durchgeführt?

Dism /online /cleanup-image /scanhealth
	-> Bei gefundenen Fehlern 
	Dism /online /cleanup-image /restorehealth

sfc /scannow

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
Am 7.12.2018 um 21:06 schrieb Jim di Griz:

Moin,

wieviele Netzwerkkarten haben die Server der beiden TOs bitte?

die Fehlermeldung "RDP is busy" ist bisher alles an Daten?

Irgendwie ein daja vu-thread, gabs dasselbe nicht vor einer Woche oder so?

kenne die Meldung bei Servern mit zuwenig Resourcen, z.B. das Laden eines Profils vom Filer dauert zu lange, diese Richtung

Die Server haben 1 virtuellen Netzwerkadapter. Bis jetzt gibt es nur sporadisch die Fehlermeldung "RDP is busy" bzw. die RDP Dienste sind ausgelastet. Es gibt dann keine Möglichkeit über RDP anzumelden. Wir haben uns dann testweise über VMware Konsole angemeldet und haben uns die Logs bzw. Auslastung angeschaut. Die Auslastung (CPU, RAM) war alles im grünen Bereich. In den Ereignis Logs gab es auch keine Aufälligkeiten. Die Standardüberprüfung wurde schon durchgeführt leider gab es keine Fehler.

 

Meine Vermutung ist das eventuell Windows Updates installiert wurden die diesen Fehler verursachen. Da das Fehlerbild nur sporadisch auftaucht und sich über mehrere Terminalserver (Win 2016) streckt können wir auch keine Windows Updates deinstallieren. Gibt es zur Zeit Informationen über defekte Windows Updates die auf ein derartiges Fehlerbild zurückschließen?

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

evtl. deadlock wie bei 2008? weiss aber nicht wie ma das feststellt. https://support.microsoft.com/de-de/help/2571388/a-remote-desktop-services-session-stops-responding-during-the-logoff-p

oder eine ähnliche Schilderung zu 2016 mit "Handarbeits-Lösung" https://serverfault.com/questions/870052/windows-server-2016-cant-rdp-with-one-specific-user

auf 2008 R2 kenne ich etwas ähnliches, über 25 TS gibt es im Monat 2 Sessions in die sich User nicht wieder connecten koennen, desktop bleibt leer nach Anmeldung. keine Idee keine Lösung, user abmelen ueber TM hilft.

Als mögliche Ideen : Profile werden beim Abmelden gelöscht? lokale Profile? Evtl. Profilreste älterer Anmeldungen die einen Hinweis geben?

Sind schon user auf dem Ts wenn das passiert? Kannst du evtl. auf dem TS zuschauen was passiert? halbes Profil nleint liegen oder so?

bearbeitet von Jim di Griz
fehler korrigiert

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 22 Stunden schrieb Jim di Griz:

Moin,

evtl. deadlock wie bei 2008? weiss aber nicht wie ma das feststellt. https://support.microsoft.com/de-de/help/2571388/a-remote-desktop-services-session-stops-responding-during-the-logoff-p

oder eine ähnliche Schilderung zu 2016 mit "Handarbeits-Lösung" https://serverfault.com/questions/870052/windows-server-2016-cant-rdp-with-one-specific-user

auf 2008 R2 kenne ich etwas ähnliches, über 25 TS gibt es im Monat 2 Sessions in die sich User nicht wieder connecten koennen, desktop bleibt leer nach Anmeldung. keine Idee keine Lösung, user abmelen ueber TM hilft.

Als mögliche Ideen : Profile werden beim Abmelden gelöscht? lokale Profile? Evtl. Profilreste älterer Anmeldungen die einen Hinweis geben?

Sind schon user auf dem Ts wenn das passiert? Kannst du evtl. auf dem TS zuschauen was passiert? halbes Profil nleint liegen oder so?

Moin,

gerade eben ist das Problem erneut aufgetreten. Die "Handarbeits-Lösung" funktioniert nicht da sobald der User sich versucht anzumelden bekommt er die Fehlermeldung "RDP is busy" und der Benutzer wird nicht im Task-Manager unter den Benutzern gelistet. Die Profile werden nicht beim abmelden gelöscht und die werden auch sauber zurückkopiert. Die Benutzerprofile sind lokale Profile. Es sind User angemeldet diese können auch wie gewöhnt weiter arbeiten und bekommen von der Anmeldeproblematik meistens nichts mit. Sobald sich ein User abmeldet und wieder neu anmeldet bekommt er die Fehlermeldung obwohl er vorher schon angemeldet war. Die Profile sind von der Größe fast alle identisch. Auf den Terminalservern ist McAfee als Antivirus installiert. In den McAfee Logs gibt es auch keine Aufälligkeiten. Als die Problematik auftrat bin ich nochmal folgende Schritte durchgegangen:

1. Dism /online /cleanup-image /scanhealth Ergebnis: Keine Fehler gefunden.

2. sfc /scannow Ergebnis: Vom Windows-Ressourcenschutz wurden beschädigte Dateien gefunden und erfolgreich repariert Weitere Infos finden Sie in der Datei "CBS.Log". Ich habe die Datei mit dem Ergebnis als Anhang hinzugefügt (Habe die Datei als .txt abgespeichert).

3. Zusätzlich habe ich eine Abbildatei vom Prozess termsvcs "Remotedesktopdienste" erstellt. Ergebnis: Siehe Anhang "svchost.tcxt". Ich werde aus diesen DMP Dateien nicht schlauer, vielleicht kennt sich einer mit der Analyse eines DMPs besser aus.

 

Was mir aufgefallen ist was ich sehr ungewöhnlich finde ist das viele Benutzerkonten als unbekannt "(4)" dargestellt werden (siehe Screenshot). Trotzdem gibt es auch Benutzer die Angemeldet sind die auch wie gewohnt arbeiten können und auch korrekt dargestellt werden (Benutzernamen). Ich vermute das die Benutzer die als "(4)" dargestellt werden die Benutzer sind die sich nicht verbinden können über RDP.

Benutzerunbekannt.JPG.6dab2b679718ff38679446a7b8c4a2b2.JPG

 

Was mir noch ungewöhnlich erscheint ist das anscheind auf dem Win2016 Dienste pro User gestartet werden. Sind die Dienste normal bei einem Windows Server 2016 RDS?

 

image.thumb.png.f23a163e343acf2526e7b6c4833d77fe.png

 

Vielen Dank vorab für die Unterstützung.

 

 

 

 

CBS.txt

svchost.txt

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo zusammen,

 

Rhyme, genau das gleiche habe ich auch gerade bei mir gesehen.

War ein paar Tage nicht im Büro daher konnte ich erst jetzt die Nachrichten lesen.


Also gleiches Verhalten. Die Serevr sind auch bei mir auf dem aktuellen Stand.

Die Befehle habe ich auch getestet leider auch ohne Erfolg.

 

Schon Komisch das phänomen. 

 

Gruß

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Moin,

im 2ten Screenshot ganz unten sind "Felger bei " geloggt, danach würde ich suchen.

haben andere server auch scannow fehler? Es ging um einen Server, während andere komplett ok sind?

sfc ruhig mehrfach ausführen, es findet gern weitere Fehler nach Reparaturen,

Könntest die Profile betroffener User mal löschen/resetten.

Wegen des sfc bei ansonstem normalem betrieb glaube ich jetzt schon an Hardware.

sorry wegen Grossschreibung, brauche ne neue Tastatur

Evtl. ein Virus welcher haengt beim Kapern? wegen der vielen Prozesse, local system hat probleme beim zugriff? das ist schlecht.

bearbeitet von Jim di Griz
...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen
vor 27 Minuten schrieb Jim di Griz:

Moin,

im 2ten Screenshot ganz unten sind "Felger bei " geloggt, danach würde ich suchen.

haben andere server auch scannow fehler? Es ging um einen Server, während andere komplett ok sind?

sfc ruhig mehrfach ausführen, es findet gern weitere Fehler nach Reparaturen,

Könntest die Profile betroffener User mal löschen/resetten.

Wegen des sfc bei ansonstem normalem betrieb glaube ich jetzt schon an Hardware.

sorry wegen Grossschreibung, brauche ne neue Tastatur

Evtl. ein Virus welcher haengt beim Kapern? wegen der vielen Prozesse, local system hat probleme beim zugriff? das ist schlecht.

Moin,

vielen Dank für den Ratschlag ich werde Morgen nach den Fehlermeldungen suchen. An der Hardware kann es nicht liegen da es virtuelle Maschinen sind und mehrere RDS (Server 2016, Server 2012 R2, Server 2008) auf der Hardware laufen. 

Ich frage mich nur ist das normal das für gefühlt jeden User ein Dienst gestartet bzw. erstellt auf dem Server 2016 erstellt ist?

 

 Es geht um mehrere RDS Server 2016. Von dem Fehler ist nicht nur einer betroffen sondern mehrere. Wie viele genau kann ich nicht abschätzen da nur sporadisch verschiedene Server (nicht zur selben Uhrzeit) von der Fehlermeldung "RDP is Busy" betroffen sind. 

bearbeitet von Rhyme

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×