Jump to content
MiLLHouSe

Umstellung auf 23er Netzwerk - Frage zu DHCP-Bereichsumstellung

Recommended Posts

Hallo,

wir haben hier einen Windows 2008 R2 Server der bislang ein 24er Netz verwaltet hat. Nun reichen mir aber die IP-Adressen nicht mehr aus und so habe ich die Subnetzmaske auf 255.255.254.0 umgestellt, so auch schon bei fast allen Geräten, die eine feste IP-Adresse haben.

 

Ziel ist es, dass ich künftig das 16er und das 17er Netz (192.168.16.xxx u. 192.168.17.xxx) nutzen kann.

Ich bin jetzt an dem Punkt, dass ich den bisherigen Bereich am DHCP löschen und den neuen 17er Bereich eintragen könnte. Muss ich mit irgendwelchen Problemen rechnen, wenn ich den IP-Bereich neu definiere und den alten Bereich lösche?

 

Die Clients sollten sich doch beim nächsten Start dann eine Adresse aus dem neu definierten Bereich abholen oder?

 

Habe ich noch was vergessen? Umgestellt sind alle Server, Firewall, Drucker, ...

 

Danke und Gruß

Alex

Share this post


Link to post
Share on other sites

Hmm, das ist bislang auch noch gar nicht aktiviert. Sollte ich das also besser aktivieren?

 

Der Wert steht auf 0, wir hatten hier aber auch noch keine Probleme in der Vergangenheit.

Share this post


Link to post
Share on other sites

Was soll ich dir denn jetzt dazu sagen? Ich hatte noch nie nen Unfall und trotzdem stand der Baum im Weg. :/

 

Lies dir durch, wofür die Konflikterkennung da ist, und überleg kurz, was passiert, wenn du den Bereich löschst und einen neuen überlappenden anlegst. Was werden wohl die Clients tun? Im Idealfall behalten Sie alle ihre zugeteilte IP, aber sicher sein kannst du dir eben nicht und dann wärs sinnvoller, wenn man die Konflikterkennung aktiviert hat, meinst du nicht?

Share this post


Link to post
Share on other sites

Ne, es ist ja kein überlappender Bereich. Bislang habe ich 192.168.16.xxx und dann habe ich 192.168.17.xxx

Es ändert sich der komplette DHCP-Bereich, von daher wäre das zumindest kein Problem.

 

Verstanden habe ich das mit der Konflikterkennung schon, nur in dem Fall habe ich ja keine doppelten Bereiche...

Share this post


Link to post
Share on other sites

Stehe ich jetzt auf dem Schlauch oder wie meinst du das?

Ich habe jetzt einen Bereich von 192.168.16.150 - 192.168.16.250.

 

Künftig soll der von 192.168.17.100 - 192.168.17.254 gehen. Da wird doch nichts überlappt o.ä.

Der komplette Bereich 192.168.16.xxx wird nicht mehr per DHCP vergeben sondern beinhaltet ausschließlich fest vergebene IP-Adressen (wie von 192.168.17.1 - 192.168.17.99).

Aber prinzipiell kann ich das ja anschalten, es ist ja kein Schaden...

Edited by MiLLHouSe

Share this post


Link to post
Share on other sites

OK, sehe auch jetzt, dass ich das im Eingangspost etwas unglücklich dargestellt habe... Stimmt schon ;)

Danke dir jedenfalls, ich werde morgen früh die Umstellung vornehmen.

Share this post


Link to post
Share on other sites

Jetzt habe ich mal noch eine Frage, vielleicht weiß das jemand...

 

Ich habe gestern früh umgestellt, alles hat auch soweit geklappt. Jetzt ist es aber so, dass viele Clients gar keine neue IP-Adresse beziehen. Ich habe mir das mal angeschaut und festgestellt, dass die Releases einfach nach dem Hochfahren des Rechners verlängert wurden und die IP-Adresse beibehalten wurde.

 

Ein paar wenige Clients haben sich eine neue Adresse geholt, aber das müssten doch deutlich mehr sein oder? Von rund 90 Clients sind es gerade mal 10...

 

Sollte ich vielleicht im Login-Skript die Befehle für release und renew einbauen?

Edited by MiLLHouSe

Share this post


Link to post
Share on other sites

Nein, da hat sich nichts geändert.

Ich habe nur deshalb nachgefragt, weil ich gestern Nachmittag bei einem Rechner mal explizit nachgeschaut habe und dort die leasetime wieder neu 3 Tage (so habe ich es voreingestellt) betragen hat. Und er hat sich dann wieder die bisherige (reservierte) Adresse genommen, die aber ja eigentlich im DHCP keine Gültigkeit mehr besitzt, weil gar nicht mehr vorhanden.

 

Habe das gerade an meinem Surface-Tablet auch gehabt. Neu gestartet und mal nachgesehen, was das Ding über den Ethernet-USB-Adapter für ne IP-Adresse bekommen hat. Da steht die 16er IP drin und bei Lease erhalten das heutige Datum mit der Uhrzeit der aktuellen Uhrzeit - Leaseablauf in 3 Tagen.

 

Kann das mit dieser Meldung im Ereignisprotokoll zu tun haben:

 

Protokollname: System
Quelle:        NETLOGON
Datum:         14.11.2018 08:42:12
Ereignis-ID:   5719
Aufgabenkategorie:Keine
Ebene:         Fehler
Schlüsselwörter:Klassisch
Benutzer:      Nicht zutreffend
Computer:      xxx
Beschreibung:
Der Computer konnte eine sichere Sitzung mit einem Domänencontroller in der Domäne xxx aufgrund der folgenden Ursache nicht einrichten:
Sie können mit diesen Anmeldeinformationen nicht angemeldet werden, weil Ihre Domäne nicht verfügbar ist. Stellen Sie sicher, dass Ihr Gerät mit dem Netzwerk Ihrer Organisation verbunden ist, und versuchen Sie es erneut. Wenn Sie sich auf diesem Gerät zuvor mit anderen Anmeldeinformationen angemeldet haben, können Sie sich mit diesen Anmeldeinformationen anmelden.
Dies kann zu Authentifizierungsproblemen führen. Stellen Sie sicher, dass der Computer mit dem Netzwerk verbunden ist. Wenden Sie sich an den Domänenadministrator, wenn das Problem weiterhin besteht.  

ZUSÄTZLICHE INFORMATIONEN
Wenn dieser Computer ein Domänencontroller der bestimmten Domäne ist, wird eine sichere Sitzung zum primären Domänencontrolleremulator in der bestimmten Domäne eingerichtet. Andernfalls richtet dieser Computer eine sichere Sitzung zu einem beliebigen Domänencontroller in der bestimmten Domäne ein.

 

Edited by MiLLHouSe

Share this post


Link to post
Share on other sites

Jetzt muss ich nochmal auf Unterstützung hoffen...

 

Ich habe bis jetzt einige Clients gehabt, die ihre IP-Adresseeinstellungen aus dem 16er Netz behalten haben. Die habe ich nun manuell mit ipconfig /release und ipconfig /renew umgestellt.

Aber es gibt ein Gerät, vermutlich ein älterer Fujitsu Rechner, der auf einen Ping reagiert.

Es ist aber eher nicht das Betriebssystem sondern irgendeine "Wartungsschnittstelle" o.ä., die ich nicht erreichen kann.

Das Thema hatte ich vor vielen Jahren mal hier https://www.mcseboard.de/topic/182091-frage-zu-dhcp-dashdomainlocal/ eingestellt, damals habe ich mir beholfen indem ich die Adressen einfach in den Sperrfilter beim DHCP eingestellt habe. Aber das geht ja jetzt nicht mehr, da ich nur den 17er Bereich im DCHP habe.

 

Hat irgendjemand eine Idee, wie ich entweder dem Teil sagen kann, dass es eine neue Adresse beziehen soll oder wie ich die Adresse frei bekomme?

 

Vielen Dank...

 

Share this post


Link to post
Share on other sites

Manuell über:

# Release the IPv4 address for the specified adapter.
ipconfig /release

# Renew the IPv4 address for the specified adapter.
ipconfig /renew

Tipp für nächstes Mal: Stelle die Lease in der Übergangszeit einfach auf 30 Minuten, dann hast du nächstes Mal die Probleme nicht. :-) 

Share this post


Link to post
Share on other sites

Gibt es denn ein wirkliches Problem? Ob man nicht abwarten kann bis sich das von selbst einrenkt?

 

Wurde die Mask am Server auch auf 23 umgestellt?

Edited by lefg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...