Jump to content
hson

Updates installieren sich nicht automatisch

Empfohlene Beiträge

Hallo,

 

ich habe per Registry eingestellt, dass Updates automatisch installiert werden, aber kein automatischer Neustart erfolgt.

Dachte ich zumindest. Nun haben sich aber seit 20 Tage keine Update mehr installiert, obwohl einige runtergeladen wurden und die Meldung "Updates werden automatisch installiert, wenn das Gerät nicht in Gebrauch ist. Sie können Updates auch sofort installieren." darunter steht.

 

Habe ich hier irgendwas falsch eingestellt?  Ich möchte, dass Updates jeden Tag automatisch um 3 Uhr installiert werden, bzw. dann, wenn der PC das nächste Mal nach 3 Uhr eingeschaltet wird. Oder geht das so gar nicht?

 

Hier meine Einstellungen:

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"DeferFeatureUpdates"=dword:00000001
"BranchReadinessLevel"=dword:00000020
"DeferFeatureUpdatesPeriodInDays"=dword:0000003c
"PauseFeatureUpdatesStartTime"=""
"DeferQualityUpdates"=dword:00000001
"DeferQualityUpdatesPeriodInDays"=dword:00000007
"PauseQualityUpdatesStartTime"=""
"SetAutoRestartRequiredNotificationDismissal"=dword:00000001
"AutoRestartRequiredNotificationDismissal"=dword:00000002
"SetAutoRestartNotificationConfig"=dword:00000001
"AutoRestartNotificationSchedule"=dword:0000000f
"SetRestartWarningSchd"=dword:00000001
"ScheduleRestartWarning"=dword:00000004
"ScheduleImminentRestartWarning"=dword:0000000f
"SetAutoRestartNotificationDisable"=dword:00000000
"AllowAutoWindowsUpdateDownloadOverMeteredNetwork"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000000
"AUOptions"=dword:00000004
"ScheduledInstallDay"=dword:00000000
"ScheduledInstallTime"=dword:00000003
"ScheduledInstallEveryWeek"=dword:00000001
"AllowMUUpdateService"=dword:00000001
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings]
"RestartNotificationsAllowed2"=dword:00000001
"RestartNotificationsAllowed"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeliveryOptimization]
"DODownloadMode"=dword:00000001

 

Hoffentlich kann mir jemand helfen, finde einfach keine Lösung.

 

Danke

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo,

 

ich möchte das gern ohne Zusatzprodukte realisieren.

Ein Einstellung einer Uhrzeit, zu der der PC an ist, als ScheduledInstallTime hat keine Änderung gebracht. Updates wurden trotzdem nicht installiert.

 

Angenommen mir ist die Uhrzeit egal, wann Updates installiert werden, lediglich soll nicht ohne Abfrage neu gestartet werden, dann müsste es doch so gehen, oder?

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"DeferFeatureUpdates"=dword:00000001
"BranchReadinessLevel"=dword:00000020
"DeferFeatureUpdatesPeriodInDays"=dword:0000003c
"PauseFeatureUpdatesStartTime"=""
"DeferQualityUpdates"=dword:00000001
"DeferQualityUpdatesPeriodInDays"=dword:00000007
"PauseQualityUpdatesStartTime"=""
"SetAutoRestartRequiredNotificationDismissal"=dword:00000001
"AutoRestartRequiredNotificationDismissal"=dword:00000002
"SetAutoRestartNotificationConfig"=dword:00000001
"AutoRestartNotificationSchedule"=dword:0000000f
"SetRestartWarningSchd"=dword:00000001
"ScheduleRestartWarning"=dword:00000004
"ScheduleImminentRestartWarning"=dword:0000000f
"SetAutoRestartNotificationDisable"=dword:00000000
"AllowAutoWindowsUpdateDownloadOverMeteredNetwork"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000000
"AUOptions"=dword:00000004
"ScheduledInstallDay"=-
"ScheduledInstallTime"=-
"ScheduledInstallEveryWeek"=-
"ScheduledInstallFirstWeek"=-
"ScheduledInstallSecondWeek"=-
"ScheduledInstallThirdWeek"=-
"ScheduledInstallFourthWeek"=-
"AllowMUUpdateService"=dword:00000001
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings]
"RestartNotificationsAllowed2"=dword:00000001
"RestartNotificationsAllowed"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeliveryOptimization]
"DODownloadMode"=dword:00000001

Aber auch so passiert bisher nichts. Die runtergeladenen Updates werden nicht automatisch installiert.

Wer kann mir sagen, was zusätzlich gesetzt werden muss, bei AUOptions=4, damit alles immer automatisch installiert wird?

Danke

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Fang doch einfach mal frisch an. Alles weg außer Option 4, täglich und eine Uhrzeit. Test. Und dann langsam weiter vorantasten.

 

BTW: Kein WSUS?

bearbeitet von Sunny61

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich habe nun den Wert bei AUoptions mal ganz gelöscht und neu gestartet.

Danach hat er einige Updates installiert, aber dieses Update bleibt auf allen PCs "ausstehend":

 

2018-10 Kumulatives Update für Windows 10 Version 1803 für x64-basierte Systeme (KB4462919)

Status: Installation ausstehend

Updates werden automatisch installiert, wenn das Gerät nicht in Gebrauch ist. Sie können Updates auch sofort installieren.

 

Ist es normal, dass da steht "werden installiert, wenn das Gerät nicht in Gebraucht ist"?

Das habe ich doch nirgends eingestellt, oder?

Die Einstellungen sind jetzt so:

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate]
"DeferFeatureUpdates"=dword:00000001
"BranchReadinessLevel"=dword:00000020
"DeferFeatureUpdatesPeriodInDays"=dword:0000003c
"DeferQualityUpdates"=dword:00000001
"DeferQualityUpdatesPeriodInDays"=dword:00000007
"SetAutoRestartRequiredNotificationDismissal"=dword:00000001
"AutoRestartRequiredNotificationDismissal"=dword:00000002
"SetAutoRestartNotificationConfig"=dword:00000001
"AutoRestartNotificationSchedule"=dword:0000000f
"SetRestartWarningSchd"=dword:00000001
"ScheduleRestartWarning"=dword:00000004
"ScheduleImminentRestartWarning"=dword:0000000f
"SetAutoRestartNotificationDisable"=dword:00000000
"AllowAutoWindowsUpdateDownloadOverMeteredNetwork"=dword:00000000

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate\AU]
"NoAutoUpdate"=dword:00000000
"AUOptions"=-
"ScheduledInstallDay"=-
"ScheduledInstallTime"=-
"ScheduledInstallEveryWeek"=-
"ScheduledInstallFirstWeek"=-
"ScheduledInstallSecondWeek"=-
"ScheduledInstallThirdWeek"=-
"ScheduledInstallFourthWeek"=-
"AllowMUUpdateService"=dword:00000001
"NoAutoRebootWithLoggedOnUsers"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WindowsUpdate\UX\Settings]
"RestartNotificationsAllowed2"=dword:00000001
"RestartNotificationsAllowed"=dword:00000001

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\DeliveryOptimization]
"DODownloadMode"=dword:00000001

 

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Fang doch einfach mal frisch an. Alles weg außer Option 4, täglich und eine Uhrzeit. Test. Und dann langsam weiter vorantasten.

 

BTW: Kein WSUS?

 

bearbeitet von Sunny61

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Hallo erstmal, aber ich muss den Thread mal wiederbeleben.

 

Schon irgendwelche Erkenntnisse diesbezüglich?

 

Windows 10 1709 Clients. Das Verhalten ist ähnlich bzw. gleich.

 

Eingestellt ist, das Updates heruntergeladen und beispielsweise um 8 Uhr installiert werden sollen.

Die Updates werden zwar alle schön heruntergeladen, aber stehen dann auf:

 

"Updates werden automatisch installiert, wenn das Gerät nicht in Gebrauch ist. Sie können Updates auch sofort installieren"

 

Ich bin mir ziemlich sicher, dass die Updates auch schon zu Windows 10 Zeiten während der üblichen Gebrauchszeiten installiert worden sind und der Neustart auf ausstehend stand.

 

Probeweise habe ich einen PC über Nacht angelassen, in der dann auch scheinbar außerhalb der Gebrauchszeiten (8-20Uhr) die Updates installiert worden sind, den Neustart aber kurioserweise nicht vollführt hat. (Option Keinen Neustart bei angemeldeten Benutzer durchführen ist deaktiviert bzw. nicht konfiguriert).

 

In den ganzen GPO Einstellungen bezieht sich doch alles auf einen Neustart, NACHDEM Updates installiert worden sind und einen Neustart brauchen. Ich kann nirgendwo in den Beschreibungen lesen, das sich Updates auch nur noch außerhalb der üblichen Geschäftszeiten installieren.

 

Sorry fürs kapern, aber das Updateverhalten unter Win 10 ist leider kein "Selbstläufer" mehr, wie noch zu Win 7 und das nervt gewaltig.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ist den der PC um 8 Uhr eingeschaltet und hat  er zu diesem Zeitpunkt schon die Updates heruntergeladen gehabt? Wie ich weiter oben schrieb, muss der PC zu der Zeit eingeschaltet sein. Bei Windows 10 wird leider nichts "nachgeholt".

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

In dem Fall war er nicht eingeschaltet.

 

Ich habe die Zeiten gestern mal geändert - ich bin gespannt.

 

Aber das kann doch nicht die Lösung sein... hat ein User warum auch immer nicht um exakt die Uhrzeit den Rechner an (Teilzeitarbeit, Neustart wegen Installation anderer Software, etc etc) werden die Updates nicht (mehr) nachgeholt?! Das ist doch absolutes Fehldesign..

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das musst Du MS fragen. Wir  wissen auch nicht, warum Windows 10 die Installation nicht mehr nachholt oder warum man Updates nicht mehr beim Shutdown installieren kann.

Wir haben hier 12:00 Uhr eingestellt. Klappt ganz gut.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Würde ich gerne nachfragen ;).

 

Fortschrittsmeldung:

 

Habe die GPO Einstellung "Nutzungszeitbereich für automatische Neustarts angeben" wieder auf "nicht konfiguriert" gestellt (vorher auf 12) - nun fangen die Clients auch sukzessive an, die Updates zu installieren.

Ich verstehs einfach nicht ...

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Ich stehe gerade auf dem Schlauch: Stellt man bei neueren Windows-10-Versionen nicht ein Zeitfenster ein, bei dem kein automatischer  Neustart erfolgen soll? 

Ich meine, das Fenster darf max. 12h lang sein. Der GPO-Editor lässt auch nichts Anders zu. Der Installationszeitpunkt ist aber eine andere Einstellung.

Verwende bitte aktuelle ADMX-Dateien.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Das sind die Vorlagen von 1803 - 1809 gibts ja auch erst seit 2 Tagen..

 

Einerseits kann man die Zeiten einstellen von .. bis ..  - maximal 18h 

 

Aber auch ein Zeitfenster .. dessen Default Wert selbst bei den maximalen 18h liegt, wenn nicht konfiguriert.

 

Wie dem auch sei, bezieht sich das aus meiner Sicht alles auf den Neustart nach erfolgter Installation der Updates und nicht auf die Installation der Updates ansich - ansonsten sind die Beschreibungen irreführend.

Diesen Beitrag teilen


Link zum Beitrag
Auf anderen Seiten teilen

Erstelle ein Benutzerkonto oder melde dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde dich hier an.

Jetzt anmelden

×